Update to 1.0.15

Fix tarball url
Disable experimental DBUILD_WITH_STD_FILESYSTEM due to failure
Resolves: #1921848
This commit is contained in:
Luya Tshimbalanga 2021-04-19 02:16:44 -07:00
parent 8949939582
commit 1a76a01125
No known key found for this signature in database
GPG Key ID: 5E528174D8A2609A
5 changed files with 23 additions and 26 deletions

2
.gitignore vendored
View File

@ -1,3 +1,5 @@
/OpenXR-SDK-Source-release-1.0.12.tar.gz
/OpenXR-SDK-Source-release-1.0.13.tar.gz
/OpenXR-SDK-Source-release-1.0.14.tar.gz
/release-1.0.14.tar.gz
/release-1.0.15.tar.gz

View File

@ -1,3 +1,5 @@
# openxr
The openxr package
This repository contains source code and build scripts for implementations of the OpenXR loader, validation layers, and code samples.
For more details about OpenXR, visit https://www.khronos.org/openxr/

View File

@ -1,16 +0,0 @@
--- OpenXR-SDK-Source-release-1.0.12/src/api_layers/CMakeLists.txt.orig 2020-09-25 19:21:55.000000000 -0700
+++ OpenXR-SDK-Source-release-1.0.12/src/api_layers/CMakeLists.txt 2020-11-08 11:41:38.471517626 -0800
@@ -198,9 +198,12 @@ elseif(APPLE)
else()
# Linux api_dump-specific information
set_target_properties(XrApiLayer_api_dump PROPERTIES LINK_FLAGS "-Wl,-Bsymbolic,--exclude-libs,ALL")
-
+ set_target_properties(XrApiLayer_api_dump PROPERTIES OUTPUT_NAME XrApiLayer_api_dump
+ SOVERSION 1)
# Linux core_validation-specific information
set_target_properties(XrApiLayer_core_validation PROPERTIES LINK_FLAGS "-Wl,-Bsymbolic,--exclude-libs,ALL")
+ set_target_properties(XrApiLayer_core_validation PROPERTIES OUTPUT_NAME XrApiLayer_core_validation
+ SOVERSION 1)
endif()
# Install explicit layers on Linux

View File

@ -2,16 +2,12 @@
%global libmajor 1
Name: openxr
Version: 1.0.14
Version: 1.0.15
Release: 1%{?dist}
Summary: An API for writing VR and AR software
License: ASL 2.0
URL: https://github.com/KhronosGroup/%{pkgname}
Source: https://github.com/KhronosGroup/%{pkgname}/archive/%{pkgname}-release-%{version}.tar.gz
# Patch addressing .so versioning
# https://github.com/KhronosGroup/OpenXR-SDK-Source/issues/221
# Patch: %%{name}-1.0.14-soversion.patch
Source: https://github.com/KhronosGroup/%{pkgname}/archive/refs/tags/release-%{version}.tar.gz
BuildRequires: cmake
BuildRequires: gcc-c++
@ -61,17 +57,24 @@ want to compile applications using the OpenXR library.
-DBUILD_ALL_EXTENSIONS=ON \
-DBUILD_LOADER=ON \
-DBUILD_TESTS=ON \
-DBUILD_WITH_STD_FILESYSTEM=OFF \
-DBUILD_WITH_WAYLAND_HEADERS=ON \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_C_FLAGS="%{optflags} -Wl,--as-needed" \
-DCMAKE_CXX_FLAGS="%{optflags} -Wl,--as-needed" \
-DCMAKE_CXX_STANDARD=14 \
-DDYNAMIC_LOADER=ON
-DCMAKE_CXX_STANDARD=17 \
-DDYNAMIC_LOADER=ON
%cmake_build
%install
%cmake_install
# We do not want static file .a
rm -fr %{buildroot}%{_libdir}/*.a
%check
%ctest
%files
%license LICENSE
# Include license in doc otherwise build complains
@ -90,6 +93,12 @@ want to compile applications using the OpenXR library.
%{_libdir}/pkgconfig/*.pc
%changelog
* Thu Jan 28 2021 Luya Tshimbalanga <luya@fedoraproject.org> 1.0.15-1
- Update to 1.0.15
- Fix tarball url
- Disable experimental DBUILD_WITH_STD_FILESYSTEM due to failure
- Resolves: #1921848
* Thu Jan 28 2021 Luya Tshimbalanga <luya@fedoraproject.org> 1.0.14-1
- Update to 1.0.14
- Use pkgconfig for vulkan-loader-devel as build requirement

View File

@ -1 +1 @@
SHA512 (OpenXR-SDK-Source-release-1.0.14.tar.gz) = 2d0c15e9b855f2f2ac174ff8649ddd7fce01b443eae1441079a8b0fba5a00a96c3fd38c3aea923df30b708bbb98f6a9fee3b22c58e3a45125ea80308a181ef57
SHA512 (release-1.0.15.tar.gz) = 6b3ae3863540b955eae49d6ea41677be3c9b905c3dbb88303456e87fae0800bb0c8ade75660f0f69985071b909e676657062453c718e6803136b84df2dee0386