401 lines
8.8 KiB
Diff
401 lines
8.8 KiB
Diff
diff -up openssl-1.0.0-beta3/crypto/fips/fips.c.fipscheck openssl-1.0.0-beta3/crypto/fips/fips.c
|
|
--- openssl-1.0.0-beta3/crypto/fips/fips.c.fipscheck 2009-08-10 20:11:59.000000000 +0200
|
|
+++ openssl-1.0.0-beta3/crypto/fips/fips.c 2009-08-10 20:11:59.000000000 +0200
|
|
@@ -47,6 +47,7 @@
|
|
*
|
|
*/
|
|
|
|
+#define _GNU_SOURCE
|
|
|
|
#include <openssl/rand.h>
|
|
#include <openssl/fips_rand.h>
|
|
@@ -56,6 +57,9 @@
|
|
#include <openssl/rsa.h>
|
|
#include <string.h>
|
|
#include <limits.h>
|
|
+#include <dlfcn.h>
|
|
+#include <stdio.h>
|
|
+#include <stdlib.h>
|
|
#include "fips_locl.h"
|
|
|
|
#ifdef OPENSSL_FIPS
|
|
@@ -165,6 +169,204 @@ int FIPS_selftest()
|
|
&& FIPS_selftest_dsa();
|
|
}
|
|
|
|
+/* we implement what libfipscheck does ourselves */
|
|
+
|
|
+static int
|
|
+get_library_path(const char *libname, const char *symbolname, char *path, size_t pathlen)
|
|
+{
|
|
+ Dl_info info;
|
|
+ void *dl, *sym;
|
|
+ int rv = -1;
|
|
+
|
|
+ dl = dlopen(libname, RTLD_LAZY);
|
|
+ if (dl == NULL) {
|
|
+ return -1;
|
|
+ }
|
|
+
|
|
+ sym = dlsym(dl, symbolname);
|
|
+
|
|
+ if (sym != NULL && dladdr(sym, &info)) {
|
|
+ strncpy(path, info.dli_fname, pathlen-1);
|
|
+ path[pathlen-1] = '\0';
|
|
+ rv = 0;
|
|
+ }
|
|
+
|
|
+ dlclose(dl);
|
|
+
|
|
+ return rv;
|
|
+}
|
|
+
|
|
+static const char conv[] = "0123456789abcdef";
|
|
+
|
|
+static char *
|
|
+bin2hex(void *buf, size_t len)
|
|
+{
|
|
+ char *hex, *p;
|
|
+ unsigned char *src = buf;
|
|
+
|
|
+ hex = malloc(len * 2 + 1);
|
|
+ if (hex == NULL)
|
|
+ return NULL;
|
|
+
|
|
+ p = hex;
|
|
+
|
|
+ while (len > 0) {
|
|
+ unsigned c;
|
|
+
|
|
+ c = *src;
|
|
+ src++;
|
|
+
|
|
+ *p = conv[c >> 4];
|
|
+ ++p;
|
|
+ *p = conv[c & 0x0f];
|
|
+ ++p;
|
|
+ --len;
|
|
+ }
|
|
+ *p = '\0';
|
|
+ return hex;
|
|
+}
|
|
+
|
|
+#define HMAC_PREFIX "."
|
|
+#define HMAC_SUFFIX ".hmac"
|
|
+#define READ_BUFFER_LENGTH 16384
|
|
+
|
|
+static char *
|
|
+make_hmac_path(const char *origpath)
|
|
+{
|
|
+ char *path, *p;
|
|
+ const char *fn;
|
|
+
|
|
+ path = malloc(sizeof(HMAC_PREFIX) + sizeof(HMAC_SUFFIX) + strlen(origpath));
|
|
+ if(path == NULL) {
|
|
+ return NULL;
|
|
+ }
|
|
+
|
|
+ fn = strrchr(origpath, '/');
|
|
+ if (fn == NULL) {
|
|
+ fn = origpath;
|
|
+ } else {
|
|
+ ++fn;
|
|
+ }
|
|
+
|
|
+ strncpy(path, origpath, fn-origpath);
|
|
+ p = path + (fn - origpath);
|
|
+ p = stpcpy(p, HMAC_PREFIX);
|
|
+ p = stpcpy(p, fn);
|
|
+ p = stpcpy(p, HMAC_SUFFIX);
|
|
+
|
|
+ return path;
|
|
+}
|
|
+
|
|
+static const char hmackey[] = "orboDeJITITejsirpADONivirpUkvarP";
|
|
+
|
|
+static int
|
|
+compute_file_hmac(const char *path, void **buf, size_t *hmaclen)
|
|
+{
|
|
+ FILE *f = NULL;
|
|
+ int rv = -1;
|
|
+ unsigned char rbuf[READ_BUFFER_LENGTH];
|
|
+ size_t len;
|
|
+ unsigned int hlen;
|
|
+ HMAC_CTX c;
|
|
+
|
|
+ HMAC_CTX_init(&c);
|
|
+
|
|
+ f = fopen(path, "r");
|
|
+
|
|
+ if (f == NULL) {
|
|
+ goto end;
|
|
+ }
|
|
+
|
|
+ HMAC_Init(&c, hmackey, sizeof(hmackey)-1, EVP_sha256());
|
|
+
|
|
+ while ((len=fread(rbuf, 1, sizeof(rbuf), f)) != 0) {
|
|
+ HMAC_Update(&c, rbuf, len);
|
|
+ }
|
|
+
|
|
+ len = sizeof(rbuf);
|
|
+ /* reuse rbuf for hmac */
|
|
+ HMAC_Final(&c, rbuf, &hlen);
|
|
+
|
|
+ *buf = malloc(hlen);
|
|
+ if (*buf == NULL) {
|
|
+ goto end;
|
|
+ }
|
|
+
|
|
+ *hmaclen = hlen;
|
|
+
|
|
+ memcpy(*buf, rbuf, hlen);
|
|
+
|
|
+ rv = 0;
|
|
+end:
|
|
+ HMAC_CTX_cleanup(&c);
|
|
+
|
|
+ if (f)
|
|
+ fclose(f);
|
|
+
|
|
+ return rv;
|
|
+}
|
|
+
|
|
+static int
|
|
+FIPSCHECK_verify(const char *libname, const char *symbolname)
|
|
+{
|
|
+ char path[PATH_MAX+1];
|
|
+ int rv;
|
|
+ FILE *hf;
|
|
+ char *hmacpath, *p;
|
|
+ char *hmac = NULL;
|
|
+ size_t n;
|
|
+
|
|
+ rv = get_library_path(libname, symbolname, path, sizeof(path));
|
|
+
|
|
+ if (rv < 0)
|
|
+ return 0;
|
|
+
|
|
+ hmacpath = make_hmac_path(path);
|
|
+
|
|
+ hf = fopen(hmacpath, "r");
|
|
+ if (hf == NULL) {
|
|
+ free(hmacpath);
|
|
+ return 0;
|
|
+ }
|
|
+
|
|
+ if (getline(&hmac, &n, hf) > 0) {
|
|
+ void *buf;
|
|
+ size_t hmaclen;
|
|
+ char *hex;
|
|
+
|
|
+ if ((p=strchr(hmac, '\n')) != NULL)
|
|
+ *p = '\0';
|
|
+
|
|
+ if (compute_file_hmac(path, &buf, &hmaclen) < 0) {
|
|
+ rv = -4;
|
|
+ goto end;
|
|
+ }
|
|
+
|
|
+ if ((hex=bin2hex(buf, hmaclen)) == NULL) {
|
|
+ free(buf);
|
|
+ rv = -5;
|
|
+ goto end;
|
|
+ }
|
|
+
|
|
+ if (strcmp(hex, hmac) != 0) {
|
|
+ rv = -1;
|
|
+ }
|
|
+ free(buf);
|
|
+ free(hex);
|
|
+ }
|
|
+
|
|
+end:
|
|
+ free(hmac);
|
|
+ free(hmacpath);
|
|
+ fclose(hf);
|
|
+
|
|
+ if (rv < 0)
|
|
+ return 0;
|
|
+
|
|
+ /* check successful */
|
|
+ return 1;
|
|
+}
|
|
+
|
|
int FIPS_mode_set(int onoff)
|
|
{
|
|
int fips_set_owning_thread();
|
|
@@ -201,6 +403,22 @@ int FIPS_mode_set(int onoff)
|
|
}
|
|
#endif
|
|
|
|
+ if(!FIPSCHECK_verify("libcrypto.so." SHLIB_VERSION_NUMBER,"FIPS_mode_set"))
|
|
+ {
|
|
+ FIPSerr(FIPS_F_FIPS_MODE_SET,FIPS_R_FINGERPRINT_DOES_NOT_MATCH);
|
|
+ fips_selftest_fail = 1;
|
|
+ ret = 0;
|
|
+ goto end;
|
|
+ }
|
|
+
|
|
+ if(!FIPSCHECK_verify("libssl.so." SHLIB_VERSION_NUMBER,"SSL_CTX_new"))
|
|
+ {
|
|
+ FIPSerr(FIPS_F_FIPS_MODE_SET,FIPS_R_FINGERPRINT_DOES_NOT_MATCH);
|
|
+ fips_selftest_fail = 1;
|
|
+ ret = 0;
|
|
+ goto end;
|
|
+ }
|
|
+
|
|
/* Perform RNG KAT before seeding */
|
|
if (!FIPS_selftest_rng())
|
|
{
|
|
diff -up openssl-1.0.0-beta3/crypto/fips/fips_standalone_sha1.c.fipscheck openssl-1.0.0-beta3/crypto/fips/fips_standalone_sha1.c
|
|
--- openssl-1.0.0-beta3/crypto/fips/fips_standalone_sha1.c.fipscheck 2009-08-10 20:11:59.000000000 +0200
|
|
+++ openssl-1.0.0-beta3/crypto/fips/fips_standalone_sha1.c 2009-08-10 20:11:59.000000000 +0200
|
|
@@ -62,7 +62,7 @@ void OPENSSL_cleanse(void *p,size_t len)
|
|
|
|
#ifdef OPENSSL_FIPS
|
|
|
|
-static void hmac_init(SHA_CTX *md_ctx,SHA_CTX *o_ctx,
|
|
+static void hmac_init(SHA256_CTX *md_ctx,SHA256_CTX *o_ctx,
|
|
const char *key)
|
|
{
|
|
size_t len=strlen(key);
|
|
@@ -72,10 +72,10 @@ static void hmac_init(SHA_CTX *md_ctx,SH
|
|
|
|
if (len > SHA_CBLOCK)
|
|
{
|
|
- SHA1_Init(md_ctx);
|
|
- SHA1_Update(md_ctx,key,len);
|
|
- SHA1_Final(keymd,md_ctx);
|
|
- len=20;
|
|
+ SHA256_Init(md_ctx);
|
|
+ SHA256_Update(md_ctx,key,len);
|
|
+ SHA256_Final(keymd,md_ctx);
|
|
+ len=SHA256_DIGEST_LENGTH;
|
|
}
|
|
else
|
|
memcpy(keymd,key,len);
|
|
@@ -83,22 +83,22 @@ static void hmac_init(SHA_CTX *md_ctx,SH
|
|
|
|
for(i=0 ; i < HMAC_MAX_MD_CBLOCK ; i++)
|
|
pad[i]=0x36^keymd[i];
|
|
- SHA1_Init(md_ctx);
|
|
- SHA1_Update(md_ctx,pad,SHA_CBLOCK);
|
|
+ SHA256_Init(md_ctx);
|
|
+ SHA256_Update(md_ctx,pad,SHA256_CBLOCK);
|
|
|
|
for(i=0 ; i < HMAC_MAX_MD_CBLOCK ; i++)
|
|
pad[i]=0x5c^keymd[i];
|
|
- SHA1_Init(o_ctx);
|
|
- SHA1_Update(o_ctx,pad,SHA_CBLOCK);
|
|
+ SHA256_Init(o_ctx);
|
|
+ SHA256_Update(o_ctx,pad,SHA256_CBLOCK);
|
|
}
|
|
|
|
-static void hmac_final(unsigned char *md,SHA_CTX *md_ctx,SHA_CTX *o_ctx)
|
|
+static void hmac_final(unsigned char *md,SHA256_CTX *md_ctx,SHA256_CTX *o_ctx)
|
|
{
|
|
- unsigned char buf[20];
|
|
+ unsigned char buf[SHA256_DIGEST_LENGTH];
|
|
|
|
- SHA1_Final(buf,md_ctx);
|
|
- SHA1_Update(o_ctx,buf,sizeof buf);
|
|
- SHA1_Final(md,o_ctx);
|
|
+ SHA256_Final(buf,md_ctx);
|
|
+ SHA256_Update(o_ctx,buf,sizeof buf);
|
|
+ SHA256_Final(md,o_ctx);
|
|
}
|
|
|
|
#endif
|
|
@@ -106,7 +106,7 @@ static void hmac_final(unsigned char *md
|
|
int main(int argc,char **argv)
|
|
{
|
|
#ifdef OPENSSL_FIPS
|
|
- static char key[]="etaonrishdlcupfm";
|
|
+ static char key[]="orboDeJITITejsirpADONivirpUkvarP";
|
|
int n,binary=0;
|
|
|
|
if(argc < 2)
|
|
@@ -125,8 +125,8 @@ int main(int argc,char **argv)
|
|
for(; n < argc ; ++n)
|
|
{
|
|
FILE *f=fopen(argv[n],"rb");
|
|
- SHA_CTX md_ctx,o_ctx;
|
|
- unsigned char md[20];
|
|
+ SHA256_CTX md_ctx,o_ctx;
|
|
+ unsigned char md[SHA256_DIGEST_LENGTH];
|
|
int i;
|
|
|
|
if(!f)
|
|
@@ -151,18 +151,18 @@ int main(int argc,char **argv)
|
|
else
|
|
break;
|
|
}
|
|
- SHA1_Update(&md_ctx,buf,l);
|
|
+ SHA256_Update(&md_ctx,buf,l);
|
|
}
|
|
hmac_final(md,&md_ctx,&o_ctx);
|
|
|
|
if (binary)
|
|
{
|
|
- fwrite(md,20,1,stdout);
|
|
+ fwrite(md,SHA256_DIGEST_LENGTH,1,stdout);
|
|
break; /* ... for single(!) file */
|
|
}
|
|
|
|
- printf("HMAC-SHA1(%s)= ",argv[n]);
|
|
- for(i=0 ; i < 20 ; ++i)
|
|
+/* printf("HMAC-SHA1(%s)= ",argv[n]); */
|
|
+ for(i=0 ; i < SHA256_DIGEST_LENGTH ; ++i)
|
|
printf("%02x",md[i]);
|
|
printf("\n");
|
|
}
|
|
diff -up openssl-1.0.0-beta3/crypto/fips/Makefile.fipscheck openssl-1.0.0-beta3/crypto/fips/Makefile
|
|
--- openssl-1.0.0-beta3/crypto/fips/Makefile.fipscheck 2009-08-10 20:11:59.000000000 +0200
|
|
+++ openssl-1.0.0-beta3/crypto/fips/Makefile 2009-08-10 20:27:45.000000000 +0200
|
|
@@ -16,6 +16,9 @@ GENERAL=Makefile
|
|
TEST=fips_test_suite.c fips_randtest.c
|
|
APPS=
|
|
|
|
+PROGRAM= fips_standalone_sha1
|
|
+EXE= $(PROGRAM)$(EXE_EXT)
|
|
+
|
|
LIB=$(TOP)/libcrypto.a
|
|
LIBSRC=fips_aes_selftest.c fips_des_selftest.c fips_hmac_selftest.c fips_rand_selftest.c \
|
|
fips_rsa_selftest.c fips_sha1_selftest.c fips.c fips_dsa_selftest.c fips_rand.c \
|
|
@@ -25,6 +28,8 @@ LIBOBJ=fips_aes_selftest.o fips_des_self
|
|
fips_rsa_selftest.o fips_sha1_selftest.o fips.o fips_dsa_selftest.o fips_rand.o \
|
|
fips_rsa_x931g.o
|
|
|
|
+LIBCRYPTO=-L.. -lcrypto
|
|
+
|
|
SRC= $(LIBSRC) fips_standalone_sha1.c
|
|
|
|
EXHEADER= fips.h fips_rand.h
|
|
@@ -35,13 +40,15 @@ ALL= $(GENERAL) $(SRC) $(HEADER)
|
|
top:
|
|
(cd ../..; $(MAKE) DIRS=crypto SDIRS=$(DIR) sub_all)
|
|
|
|
-all: lib
|
|
+all: lib exe
|
|
|
|
lib: $(LIBOBJ)
|
|
$(AR) $(LIB) $(LIBOBJ)
|
|
$(RANLIB) $(LIB) || echo Never mind.
|
|
@touch lib
|
|
|
|
+exe: $(EXE)
|
|
+
|
|
files:
|
|
$(PERL) $(TOP)/util/files.pl Makefile >> $(TOP)/MINFO
|
|
|
|
@@ -77,5 +84,9 @@ dclean:
|
|
clean:
|
|
rm -f *.o *.obj lib tags core .pure .nfs* *.old *.bak fluff
|
|
|
|
+$(EXE): $(PROGRAM).o
|
|
+ FIPS_SHA_ASM=""; for i in $(SHA1_ASM_OBJ) sha256.o ; do FIPS_SHA_ASM="$$FIPS_SHA_ASM ../sha/$$i" ; done; \
|
|
+ $(CC) -o $@ $(CFLAGS) $(PROGRAM).o $$FIPS_SHA_ASM
|
|
+
|
|
# DO NOT DELETE THIS LINE -- make depend depends on it.
|
|
|