- fix camellia compilation with asm and fips
This commit is contained in:
parent
62f5688f6b
commit
92200faba0
@ -393,6 +393,35 @@ diff -up openssl-1.0.0-beta3/crypto/bn/Makefile.fips openssl-1.0.0-beta3/crypto/
|
|||||||
|
|
||||||
SRC= $(LIBSRC)
|
SRC= $(LIBSRC)
|
||||||
|
|
||||||
|
diff -up openssl-1.0.0-beta3/crypto/camellia/asm/cmll-x86.pl.fips openssl-1.0.0-beta3/crypto/camellia/asm/cmll-x86.pl
|
||||||
|
--- openssl-1.0.0-beta3/crypto/camellia/asm/cmll-x86.pl.fips 2009-04-06 16:25:02.000000000 +0200
|
||||||
|
+++ openssl-1.0.0-beta3/crypto/camellia/asm/cmll-x86.pl 2009-08-20 16:54:59.000000000 +0200
|
||||||
|
@@ -722,12 +722,15 @@ my $bias=int(@T[0])?shift(@T):0;
|
||||||
|
}
|
||||||
|
&function_end("Camellia_Ekeygen");
|
||||||
|
|
||||||
|
+$setkeyfunc = "Camellia_set_key";
|
||||||
|
+$setkeyfunc = "private_Camellia_set_key" if ($ENV{FIPS} ne "");
|
||||||
|
+
|
||||||
|
if ($OPENSSL) {
|
||||||
|
# int Camellia_set_key (
|
||||||
|
# const unsigned char *userKey,
|
||||||
|
# int bits,
|
||||||
|
# CAMELLIA_KEY *key)
|
||||||
|
-&function_begin_B("Camellia_set_key");
|
||||||
|
+&function_begin_B($setkeyfunc);
|
||||||
|
&push ("ebx");
|
||||||
|
&mov ("ecx",&wparam(0)); # pull arguments
|
||||||
|
&mov ("ebx",&wparam(1));
|
||||||
|
@@ -760,7 +763,7 @@ if ($OPENSSL) {
|
||||||
|
&set_label("done",4);
|
||||||
|
&pop ("ebx");
|
||||||
|
&ret ();
|
||||||
|
-&function_end_B("Camellia_set_key");
|
||||||
|
+&function_end_B($setkeyfunc);
|
||||||
|
}
|
||||||
|
|
||||||
|
@SBOX=(
|
||||||
diff -up openssl-1.0.0-beta3/crypto/camellia/camellia.h.fips openssl-1.0.0-beta3/crypto/camellia/camellia.h
|
diff -up openssl-1.0.0-beta3/crypto/camellia/camellia.h.fips openssl-1.0.0-beta3/crypto/camellia/camellia.h
|
||||||
--- openssl-1.0.0-beta3/crypto/camellia/camellia.h.fips 2009-08-11 18:07:29.000000000 +0200
|
--- openssl-1.0.0-beta3/crypto/camellia/camellia.h.fips 2009-08-11 18:07:29.000000000 +0200
|
||||||
+++ openssl-1.0.0-beta3/crypto/camellia/camellia.h 2009-08-11 18:07:30.000000000 +0200
|
+++ openssl-1.0.0-beta3/crypto/camellia/camellia.h 2009-08-11 18:07:30.000000000 +0200
|
||||||
@ -408,10 +437,82 @@ diff -up openssl-1.0.0-beta3/crypto/camellia/camellia.h.fips openssl-1.0.0-beta3
|
|||||||
int Camellia_set_key(const unsigned char *userKey, const int bits,
|
int Camellia_set_key(const unsigned char *userKey, const int bits,
|
||||||
CAMELLIA_KEY *key);
|
CAMELLIA_KEY *key);
|
||||||
|
|
||||||
|
diff -up openssl-1.0.0-beta3/crypto/camellia/cmll_fblk.c.fips openssl-1.0.0-beta3/crypto/camellia/cmll_fblk.c
|
||||||
|
--- openssl-1.0.0-beta3/crypto/camellia/cmll_fblk.c.fips 2009-08-20 17:01:56.000000000 +0200
|
||||||
|
+++ openssl-1.0.0-beta3/crypto/camellia/cmll_fblk.c 2009-08-20 17:03:21.000000000 +0200
|
||||||
|
@@ -0,0 +1,68 @@
|
||||||
|
+/* crypto/camellia/camellia_misc.c -*- mode:C; c-file-style: "eay" -*- */
|
||||||
|
+/* ====================================================================
|
||||||
|
+ * Copyright (c) 2006 The OpenSSL Project. All rights reserved.
|
||||||
|
+ *
|
||||||
|
+ * Redistribution and use in source and binary forms, with or without
|
||||||
|
+ * modification, are permitted provided that the following conditions
|
||||||
|
+ * are met:
|
||||||
|
+ *
|
||||||
|
+ * 1. Redistributions of source code must retain the above copyright
|
||||||
|
+ * notice, this list of conditions and the following disclaimer.
|
||||||
|
+ *
|
||||||
|
+ * 2. Redistributions in binary form must reproduce the above copyright
|
||||||
|
+ * notice, this list of conditions and the following disclaimer in
|
||||||
|
+ * the documentation and/or other materials provided with the
|
||||||
|
+ * distribution.
|
||||||
|
+ *
|
||||||
|
+ * 3. All advertising materials mentioning features or use of this
|
||||||
|
+ * software must display the following acknowledgment:
|
||||||
|
+ * "This product includes software developed by the OpenSSL Project
|
||||||
|
+ * for use in the OpenSSL Toolkit. (http://www.openssl.org/)"
|
||||||
|
+ *
|
||||||
|
+ * 4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to
|
||||||
|
+ * endorse or promote products derived from this software without
|
||||||
|
+ * prior written permission. For written permission, please contact
|
||||||
|
+ * openssl-core@openssl.org.
|
||||||
|
+ *
|
||||||
|
+ * 5. Products derived from this software may not be called "OpenSSL"
|
||||||
|
+ * nor may "OpenSSL" appear in their names without prior written
|
||||||
|
+ * permission of the OpenSSL Project.
|
||||||
|
+ *
|
||||||
|
+ * 6. Redistributions of any form whatsoever must retain the following
|
||||||
|
+ * acknowledgment:
|
||||||
|
+ * "This product includes software developed by the OpenSSL Project
|
||||||
|
+ * for use in the OpenSSL Toolkit (http://www.openssl.org/)"
|
||||||
|
+ *
|
||||||
|
+ * THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND ANY
|
||||||
|
+ * EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
|
||||||
|
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
|
||||||
|
+ * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR
|
||||||
|
+ * ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||||
|
+ * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
|
||||||
|
+ * NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
|
||||||
|
+ * LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
|
||||||
|
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
|
||||||
|
+ * STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
|
||||||
|
+ * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
|
||||||
|
+ * OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
+ * ====================================================================
|
||||||
|
+ *
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+#include <openssl/opensslv.h>
|
||||||
|
+#include <openssl/camellia.h>
|
||||||
|
+#include "cmll_locl.h"
|
||||||
|
+#include <openssl/crypto.h>
|
||||||
|
+#ifdef OPENSSL_FIPS
|
||||||
|
+#include <openssl/fips.h>
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
+#ifdef OPENSSL_FIPS
|
||||||
|
+int Camellia_set_key(const unsigned char *userKey, const int bits,
|
||||||
|
+ CAMELLIA_KEY *key)
|
||||||
|
+ {
|
||||||
|
+ if (FIPS_mode())
|
||||||
|
+ FIPS_BAD_ABORT(CAMELLIA)
|
||||||
|
+ return private_Camellia_set_key(userKey, bits, key);
|
||||||
|
+ }
|
||||||
|
+#endif
|
||||||
diff -up openssl-1.0.0-beta3/crypto/camellia/cmll_misc.c.fips openssl-1.0.0-beta3/crypto/camellia/cmll_misc.c
|
diff -up openssl-1.0.0-beta3/crypto/camellia/cmll_misc.c.fips openssl-1.0.0-beta3/crypto/camellia/cmll_misc.c
|
||||||
--- openssl-1.0.0-beta3/crypto/camellia/cmll_misc.c.fips 2008-10-28 13:13:52.000000000 +0100
|
--- openssl-1.0.0-beta3/crypto/camellia/cmll_misc.c.fips 2008-10-28 13:13:52.000000000 +0100
|
||||||
+++ openssl-1.0.0-beta3/crypto/camellia/cmll_misc.c 2009-08-11 18:07:30.000000000 +0200
|
+++ openssl-1.0.0-beta3/crypto/camellia/cmll_misc.c 2009-08-20 17:04:10.000000000 +0200
|
||||||
@@ -52,11 +52,24 @@
|
@@ -52,11 +52,20 @@
|
||||||
#include <openssl/opensslv.h>
|
#include <openssl/opensslv.h>
|
||||||
#include <openssl/camellia.h>
|
#include <openssl/camellia.h>
|
||||||
#include "cmll_locl.h"
|
#include "cmll_locl.h"
|
||||||
@ -422,20 +523,31 @@ diff -up openssl-1.0.0-beta3/crypto/camellia/cmll_misc.c.fips openssl-1.0.0-beta
|
|||||||
|
|
||||||
const char CAMELLIA_version[]="CAMELLIA" OPENSSL_VERSION_PTEXT;
|
const char CAMELLIA_version[]="CAMELLIA" OPENSSL_VERSION_PTEXT;
|
||||||
|
|
||||||
int Camellia_set_key(const unsigned char *userKey, const int bits,
|
|
||||||
CAMELLIA_KEY *key)
|
|
||||||
+#ifdef OPENSSL_FIPS
|
+#ifdef OPENSSL_FIPS
|
||||||
+ {
|
|
||||||
+ if (FIPS_mode())
|
|
||||||
+ FIPS_BAD_ABORT(CAMELLIA)
|
|
||||||
+ return private_Camellia_set_key(userKey, bits, key);
|
|
||||||
+ }
|
|
||||||
+int private_Camellia_set_key(const unsigned char *userKey, const int bits,
|
+int private_Camellia_set_key(const unsigned char *userKey, const int bits,
|
||||||
+ CAMELLIA_KEY *key)
|
+ CAMELLIA_KEY *key)
|
||||||
|
+#else
|
||||||
|
int Camellia_set_key(const unsigned char *userKey, const int bits,
|
||||||
|
CAMELLIA_KEY *key)
|
||||||
+#endif
|
+#endif
|
||||||
{
|
{
|
||||||
if(!userKey || !key)
|
if(!userKey || !key)
|
||||||
return -1;
|
return -1;
|
||||||
|
diff -up openssl-1.0.0-beta3/crypto/camellia/Makefile.fips openssl-1.0.0-beta3/crypto/camellia/Makefile
|
||||||
|
--- openssl-1.0.0-beta3/crypto/camellia/Makefile.fips 2008-12-23 12:33:00.000000000 +0100
|
||||||
|
+++ openssl-1.0.0-beta3/crypto/camellia/Makefile 2009-08-20 17:02:56.000000000 +0200
|
||||||
|
@@ -23,9 +23,9 @@ APPS=
|
||||||
|
|
||||||
|
LIB=$(TOP)/libcrypto.a
|
||||||
|
LIBSRC=camellia.c cmll_misc.c cmll_ecb.c cmll_cbc.c cmll_ofb.c \
|
||||||
|
- cmll_cfb.c cmll_ctr.c
|
||||||
|
+ cmll_cfb.c cmll_ctr.c cmll_fblk.c
|
||||||
|
|
||||||
|
-LIBOBJ= cmll_ecb.o cmll_ofb.o cmll_cfb.o cmll_ctr.o $(CMLL_ENC)
|
||||||
|
+LIBOBJ= cmll_ecb.o cmll_ofb.o cmll_cfb.o cmll_ctr.o cmll_fblk.o $(CMLL_ENC)
|
||||||
|
|
||||||
|
SRC= $(LIBSRC)
|
||||||
|
|
||||||
diff -up openssl-1.0.0-beta3/crypto/cast/cast.h.fips openssl-1.0.0-beta3/crypto/cast/cast.h
|
diff -up openssl-1.0.0-beta3/crypto/cast/cast.h.fips openssl-1.0.0-beta3/crypto/cast/cast.h
|
||||||
--- openssl-1.0.0-beta3/crypto/cast/cast.h.fips 2009-08-11 18:07:29.000000000 +0200
|
--- openssl-1.0.0-beta3/crypto/cast/cast.h.fips 2009-08-11 18:07:29.000000000 +0200
|
||||||
+++ openssl-1.0.0-beta3/crypto/cast/cast.h 2009-08-11 18:07:30.000000000 +0200
|
+++ openssl-1.0.0-beta3/crypto/cast/cast.h 2009-08-11 18:07:30.000000000 +0200
|
||||||
|
Loading…
Reference in New Issue
Block a user