8a29dedfa7
ACSS was removed from upstream sources
272 lines
10 KiB
Diff
272 lines
10 KiB
Diff
diff -up openssh-6.2p1/entropy.c.entropy openssh-6.2p1/entropy.c
|
|
--- openssh-6.2p1/entropy.c.entropy 2013-03-25 19:31:42.737611051 +0100
|
|
+++ openssh-6.2p1/entropy.c 2013-03-25 19:31:42.797611433 +0100
|
|
@@ -237,6 +237,9 @@ seed_rng(void)
|
|
memset(buf, '\0', sizeof(buf));
|
|
|
|
#endif /* OPENSSL_PRNG_ONLY */
|
|
+#ifdef __linux__
|
|
+ linux_seed();
|
|
+#endif /* __linux__ */
|
|
if (RAND_status() != 1)
|
|
fatal("PRNG is not seeded");
|
|
}
|
|
diff -up openssh-6.2p1/openbsd-compat/Makefile.in.entropy openssh-6.2p1/openbsd-compat/Makefile.in
|
|
--- openssh-6.2p1/openbsd-compat/Makefile.in.entropy 2013-03-25 19:31:42.798611440 +0100
|
|
+++ openssh-6.2p1/openbsd-compat/Makefile.in 2013-03-25 19:33:02.042116876 +0100
|
|
@@ -20,7 +20,7 @@ OPENBSD=base64.o basename.o bindresvport
|
|
|
|
COMPAT=bsd-arc4random.o bsd-asprintf.o bsd-closefrom.o bsd-cray.o bsd-cygwin_util.o bsd-getpeereid.o getrrsetbyname-ldns.o bsd-misc.o bsd-nextstep.o bsd-openpty.o bsd-poll.o bsd-setres_id.o bsd-snprintf.o bsd-statvfs.o bsd-waitpid.o fake-rfc2553.o openssl-compat.o xmmap.o xcrypt.o
|
|
|
|
-PORTS=port-aix.o port-irix.o port-linux.o port-linux_part_2.o port-solaris.o port-tun.o port-uw.o
|
|
+PORTS=port-aix.o port-irix.o port-linux.o port-linux_part_2.o port-linux-prng.o port-solaris.o port-tun.o port-uw.o
|
|
|
|
.c.o:
|
|
$(CC) $(CFLAGS) $(CPPFLAGS) -c $<
|
|
diff -up openssh-6.2p1/openbsd-compat/port-linux-prng.c.entropy openssh-6.2p1/openbsd-compat/port-linux-prng.c
|
|
--- openssh-6.2p1/openbsd-compat/port-linux-prng.c.entropy 2013-03-25 19:31:42.798611440 +0100
|
|
+++ openssh-6.2p1/openbsd-compat/port-linux-prng.c 2013-03-25 19:31:42.798611440 +0100
|
|
@@ -0,0 +1,59 @@
|
|
+/* $Id: port-linux.c,v 1.11.4.2 2011/02/04 00:43:08 djm Exp $ */
|
|
+
|
|
+/*
|
|
+ * Copyright (c) 2011 Jan F. Chadima <jchadima@redhat.com>
|
|
+ *
|
|
+ * Permission to use, copy, modify, and distribute this software for any
|
|
+ * purpose with or without fee is hereby granted, provided that the above
|
|
+ * copyright notice and this permission notice appear in all copies.
|
|
+ *
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
|
|
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
|
|
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
|
|
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
|
|
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
|
|
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
|
|
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
|
|
+ */
|
|
+
|
|
+/*
|
|
+ * Linux-specific portability code - prng support
|
|
+ */
|
|
+
|
|
+#include "includes.h"
|
|
+
|
|
+#include <errno.h>
|
|
+#include <stdarg.h>
|
|
+#include <string.h>
|
|
+#include <stdio.h>
|
|
+#include <openssl/rand.h>
|
|
+
|
|
+#include "log.h"
|
|
+#include "xmalloc.h"
|
|
+#include "servconf.h"
|
|
+#include "port-linux.h"
|
|
+#include "key.h"
|
|
+#include "hostfile.h"
|
|
+#include "auth.h"
|
|
+
|
|
+void
|
|
+linux_seed(void)
|
|
+{
|
|
+ int len;
|
|
+ char *env = getenv("SSH_USE_STRONG_RNG");
|
|
+ char *random = "/dev/random";
|
|
+ size_t ienv, randlen = 6;
|
|
+
|
|
+ if (!env || !strcmp(env, "0"))
|
|
+ random = "/dev/urandom";
|
|
+ else if ((ienv = atoi(env)) > 6)
|
|
+ randlen = ienv;
|
|
+
|
|
+ errno = 0;
|
|
+ if ((len = RAND_load_file(random, randlen)) != randlen) {
|
|
+ if (errno)
|
|
+ fatal ("cannot read from %s, %s", random, strerror(errno));
|
|
+ else
|
|
+ fatal ("EOF reading %s", random);
|
|
+ }
|
|
+}
|
|
diff -up openssh-6.2p1/ssh-add.0.entropy openssh-6.2p1/ssh-add.0
|
|
--- openssh-6.2p1/ssh-add.0.entropy 2013-03-22 00:38:29.000000000 +0100
|
|
+++ openssh-6.2p1/ssh-add.0 2013-03-25 19:31:42.799611446 +0100
|
|
@@ -82,6 +82,16 @@ ENVIRONMENT
|
|
Identifies the path of a UNIX-domain socket used to communicate
|
|
with the agent.
|
|
|
|
+ SSH_USE_STRONG_RNG
|
|
+ The reseeding of the OpenSSL random generator is usually done
|
|
+ from /dev/urandom. If the SSH_USE_STRONG_RNG environment vari-
|
|
+ able is set to value other than 0 the OpenSSL random generator is
|
|
+ reseeded from /dev/random. The number of bytes read is defined
|
|
+ by the SSH_USE_STRONG_RNG value. Minimum is 6 bytes. This set-
|
|
+ ting is not recommended on the computers without the hardware
|
|
+ random generator because insufficient entropy causes the connec-
|
|
+ tion to be blocked until enough entropy is available.
|
|
+
|
|
FILES
|
|
~/.ssh/identity
|
|
Contains the protocol version 1 RSA authentication identity of
|
|
diff -up openssh-6.2p1/ssh-add.1.entropy openssh-6.2p1/ssh-add.1
|
|
--- openssh-6.2p1/ssh-add.1.entropy 2012-12-07 03:06:13.000000000 +0100
|
|
+++ openssh-6.2p1/ssh-add.1 2013-03-25 19:31:42.799611446 +0100
|
|
@@ -160,6 +160,20 @@ to make this work.)
|
|
Identifies the path of a
|
|
.Ux Ns -domain
|
|
socket used to communicate with the agent.
|
|
+.It Ev SSH_USE_STRONG_RNG
|
|
+The reseeding of the OpenSSL random generator is usually done from
|
|
+.Cm /dev/urandom .
|
|
+If the
|
|
+.Cm SSH_USE_STRONG_RNG
|
|
+environment variable is set to value other than
|
|
+.Cm 0
|
|
+the OpenSSL random generator is reseeded from
|
|
+.Cm /dev/random .
|
|
+The number of bytes read is defined by the SSH_USE_STRONG_RNG value.
|
|
+Minimum is 6 bytes.
|
|
+This setting is not recommended on the computers without the hardware
|
|
+random generator because insufficient entropy causes the connection to
|
|
+be blocked until enough entropy is available.
|
|
.El
|
|
.Sh FILES
|
|
.Bl -tag -width Ds
|
|
diff -up openssh-6.2p1/ssh-agent.1.entropy openssh-6.2p1/ssh-agent.1
|
|
--- openssh-6.2p1/ssh-agent.1.entropy 2010-12-01 01:50:35.000000000 +0100
|
|
+++ openssh-6.2p1/ssh-agent.1 2013-03-25 19:31:42.800611452 +0100
|
|
@@ -198,6 +198,24 @@ sockets used to contain the connection t
|
|
These sockets should only be readable by the owner.
|
|
The sockets should get automatically removed when the agent exits.
|
|
.El
|
|
+.Sh ENVIRONMENT
|
|
+.Bl -tag -width Ds -compact
|
|
+.Pp
|
|
+.It Pa SSH_USE_STRONG_RNG
|
|
+The reseeding of the OpenSSL random generator is usually done from
|
|
+.Cm /dev/urandom .
|
|
+If the
|
|
+.Cm SSH_USE_STRONG_RNG
|
|
+environment variable is set to value other than
|
|
+.Cm 0
|
|
+the OpenSSL random generator is reseeded from
|
|
+.Cm /dev/random .
|
|
+The number of bytes read is defined by the SSH_USE_STRONG_RNG value.
|
|
+Minimum is 6 bytes.
|
|
+This setting is not recommended on the computers without the hardware
|
|
+random generator because insufficient entropy causes the connection to
|
|
+be blocked until enough entropy is available.
|
|
+.El
|
|
.Sh SEE ALSO
|
|
.Xr ssh 1 ,
|
|
.Xr ssh-add 1 ,
|
|
diff -up openssh-6.2p1/sshd.8.entropy openssh-6.2p1/sshd.8
|
|
--- openssh-6.2p1/sshd.8.entropy 2013-03-25 19:31:42.752611146 +0100
|
|
+++ openssh-6.2p1/sshd.8 2013-03-25 19:31:42.800611452 +0100
|
|
@@ -945,6 +945,24 @@ concurrently for different ports, this c
|
|
started last).
|
|
The content of this file is not sensitive; it can be world-readable.
|
|
.El
|
|
+.Sh ENVIRONMENT
|
|
+.Bl -tag -width Ds -compact
|
|
+.Pp
|
|
+.It Pa SSH_USE_STRONG_RNG
|
|
+The reseeding of the OpenSSL random generator is usually done from
|
|
+.Cm /dev/urandom .
|
|
+If the
|
|
+.Cm SSH_USE_STRONG_RNG
|
|
+environment variable is set to value other than
|
|
+.Cm 0
|
|
+the OpenSSL random generator is reseeded from
|
|
+.Cm /dev/random .
|
|
+The number of bytes read is defined by the SSH_USE_STRONG_RNG value.
|
|
+Minimum is 6 bytes.
|
|
+This setting is not recommended on the computers without the hardware
|
|
+random generator because insufficient entropy causes the connection to
|
|
+be blocked until enough entropy is available.
|
|
+.El
|
|
.Sh IPV6
|
|
IPv6 address can be used everywhere where IPv4 address. In all entries must be the IPv6 address enclosed in square brackets. Note: The square brackets are metacharacters for the shell and must be escaped in shell.
|
|
.Sh SEE ALSO
|
|
diff -up openssh-6.2p1/ssh-keygen.1.entropy openssh-6.2p1/ssh-keygen.1
|
|
--- openssh-6.2p1/ssh-keygen.1.entropy 2013-01-20 12:35:06.000000000 +0100
|
|
+++ openssh-6.2p1/ssh-keygen.1 2013-03-25 19:31:42.801611459 +0100
|
|
@@ -806,6 +806,24 @@ Contains Diffie-Hellman groups used for
|
|
The file format is described in
|
|
.Xr moduli 5 .
|
|
.El
|
|
+.Sh ENVIRONMENT
|
|
+.Bl -tag -width Ds -compact
|
|
+.Pp
|
|
+.It Pa SSH_USE_STRONG_RNG
|
|
+The reseeding of the OpenSSL random generator is usually done from
|
|
+.Cm /dev/urandom .
|
|
+If the
|
|
+.Cm SSH_USE_STRONG_RNG
|
|
+environment variable is set to value other than
|
|
+.Cm 0
|
|
+the OpenSSL random generator is reseeded from
|
|
+.Cm /dev/random .
|
|
+The number of bytes read is defined by the SSH_USE_STRONG_RNG value.
|
|
+Minimum is 6 bytes.
|
|
+This setting is not recommended on the computers without the hardware
|
|
+random generator because insufficient entropy causes the connection to
|
|
+be blocked until enough entropy is available.
|
|
+.El
|
|
.Sh SEE ALSO
|
|
.Xr ssh 1 ,
|
|
.Xr ssh-add 1 ,
|
|
diff -up openssh-6.2p1/ssh-keysign.8.entropy openssh-6.2p1/ssh-keysign.8
|
|
--- openssh-6.2p1/ssh-keysign.8.entropy 2010-08-31 14:41:14.000000000 +0200
|
|
+++ openssh-6.2p1/ssh-keysign.8 2013-03-25 19:31:42.801611459 +0100
|
|
@@ -78,6 +78,24 @@ must be set-uid root if host-based authe
|
|
If these files exist they are assumed to contain public certificate
|
|
information corresponding with the private keys above.
|
|
.El
|
|
+.Sh ENVIRONMENT
|
|
+.Bl -tag -width Ds -compact
|
|
+.Pp
|
|
+.It Pa SSH_USE_STRONG_RNG
|
|
+The reseeding of the OpenSSL random generator is usually done from
|
|
+.Cm /dev/urandom .
|
|
+If the
|
|
+.Cm SSH_USE_STRONG_RNG
|
|
+environment variable is set to value other than
|
|
+.Cm 0
|
|
+the OpenSSL random generator is reseeded from
|
|
+.Cm /dev/random .
|
|
+The number of bytes read is defined by the SSH_USE_STRONG_RNG value.
|
|
+Minimum is 6 bytes.
|
|
+This setting is not recommended on the computers without the hardware
|
|
+random generator because insufficient entropy causes the connection to
|
|
+be blocked until enough entropy is available.
|
|
+.El
|
|
.Sh SEE ALSO
|
|
.Xr ssh 1 ,
|
|
.Xr ssh-keygen 1 ,
|
|
diff -up openssh-6.2p1/ssh.1.entropy openssh-6.2p1/ssh.1
|
|
--- openssh-6.2p1/ssh.1.entropy 2013-03-25 19:31:42.752611146 +0100
|
|
+++ openssh-6.2p1/ssh.1 2013-03-25 19:31:42.799611446 +0100
|
|
@@ -1277,6 +1277,23 @@ For more information, see the
|
|
.Cm PermitUserEnvironment
|
|
option in
|
|
.Xr sshd_config 5 .
|
|
+.Sh ENVIRONMENT
|
|
+.Bl -tag -width Ds -compact
|
|
+.It Ev SSH_USE_STRONG_RNG
|
|
+The reseeding of the OpenSSL random generator is usually done from
|
|
+.Cm /dev/urandom .
|
|
+If the
|
|
+.Cm SSH_USE_STRONG_RNG
|
|
+environment variable is set to value other than
|
|
+.Cm 0
|
|
+the OpenSSL random generator is reseeded from
|
|
+.Cm /dev/random .
|
|
+The number of bytes read is defined by the SSH_USE_STRONG_RNG value.
|
|
+Minimum is 6 bytes.
|
|
+This setting is not recommended on the computers without the hardware
|
|
+random generator because insufficient entropy causes the connection to
|
|
+be blocked until enough entropy is available.
|
|
+.El
|
|
.Sh FILES
|
|
.Bl -tag -width Ds -compact
|
|
.It Pa ~/.rhosts
|