6cf9b8e61b
* Drop unaccepted (unapplying) coverity patches * Drop server support for SSH1 (server) * Workaround #2641 for systemd * UseLogin is gone * Drop upstream commit 28652bca * Tighten seccomp filter (cache credentials before entering sandbox) (#1395288)
282 lines
11 KiB
Diff
282 lines
11 KiB
Diff
diff -up openssh-7.4p1/entropy.c.entropy openssh-7.4p1/entropy.c
|
|
--- openssh-7.4p1/entropy.c.entropy 2016-12-19 05:59:41.000000000 +0100
|
|
+++ openssh-7.4p1/entropy.c 2016-12-23 18:34:27.769753570 +0100
|
|
@@ -229,6 +229,9 @@ seed_rng(void)
|
|
memset(buf, '\0', sizeof(buf));
|
|
|
|
#endif /* OPENSSL_PRNG_ONLY */
|
|
+#ifdef __linux__
|
|
+ linux_seed();
|
|
+#endif /* __linux__ */
|
|
if (RAND_status() != 1)
|
|
fatal("PRNG is not seeded");
|
|
}
|
|
diff -up openssh-7.4p1/openbsd-compat/Makefile.in.entropy openssh-7.4p1/openbsd-compat/Makefile.in
|
|
--- openssh-7.4p1/openbsd-compat/Makefile.in.entropy 2016-12-23 18:34:53.715762155 +0100
|
|
+++ openssh-7.4p1/openbsd-compat/Makefile.in 2016-12-23 18:35:15.890769493 +0100
|
|
@@ -20,7 +20,7 @@ OPENBSD=base64.o basename.o bcrypt_pbkdf
|
|
|
|
COMPAT=arc4random.o bsd-asprintf.o bsd-closefrom.o bsd-cray.o bsd-cygwin_util.o bsd-getpeereid.o getrrsetbyname-ldns.o bsd-err.o bsd-misc.o bsd-nextstep.o bsd-openpty.o bsd-poll.o bsd-setres_id.o bsd-snprintf.o bsd-statvfs.o bsd-waitpid.o fake-rfc2553.o openssl-compat.o xcrypt.o kludge-fd_set.o
|
|
|
|
-PORTS=port-aix.o port-irix.o port-linux.o port-linux-sshd.o port-solaris.o port-tun.o port-uw.o
|
|
+PORTS=port-aix.o port-irix.o port-linux.o port-linux-sshd.o port-linux-prng.o port-solaris.o port-tun.o port-uw.o
|
|
|
|
.c.o:
|
|
$(CC) $(CFLAGS) $(CPPFLAGS) -c $<
|
|
diff -up openssh-7.4p1/openbsd-compat/port-linux.h.entropy openssh-7.4p1/openbsd-compat/port-linux.h
|
|
--- openssh-7.4p1/openbsd-compat/port-linux.h.entropy 2016-12-23 18:34:27.747753563 +0100
|
|
+++ openssh-7.4p1/openbsd-compat/port-linux.h 2016-12-23 18:34:27.769753570 +0100
|
|
@@ -34,4 +34,6 @@ void oom_adjust_restore(void);
|
|
void oom_adjust_setup(void);
|
|
#endif
|
|
|
|
+void linux_seed(void);
|
|
+
|
|
#endif /* ! _PORT_LINUX_H */
|
|
diff -up openssh-7.4p1/openbsd-compat/port-linux-prng.c.entropy openssh-7.4p1/openbsd-compat/port-linux-prng.c
|
|
--- openssh-7.4p1/openbsd-compat/port-linux-prng.c.entropy 2016-12-23 18:34:27.769753570 +0100
|
|
+++ openssh-7.4p1/openbsd-compat/port-linux-prng.c 2016-12-23 18:34:27.769753570 +0100
|
|
@@ -0,0 +1,59 @@
|
|
+/* $Id: port-linux.c,v 1.11.4.2 2011/02/04 00:43:08 djm Exp $ */
|
|
+
|
|
+/*
|
|
+ * Copyright (c) 2011 Jan F. Chadima <jchadima@redhat.com>
|
|
+ *
|
|
+ * Permission to use, copy, modify, and distribute this software for any
|
|
+ * purpose with or without fee is hereby granted, provided that the above
|
|
+ * copyright notice and this permission notice appear in all copies.
|
|
+ *
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
|
|
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
|
|
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
|
|
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
|
|
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
|
|
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
|
|
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
|
|
+ */
|
|
+
|
|
+/*
|
|
+ * Linux-specific portability code - prng support
|
|
+ */
|
|
+
|
|
+#include "includes.h"
|
|
+
|
|
+#include <errno.h>
|
|
+#include <stdarg.h>
|
|
+#include <string.h>
|
|
+#include <stdio.h>
|
|
+#include <openssl/rand.h>
|
|
+
|
|
+#include "log.h"
|
|
+#include "xmalloc.h"
|
|
+#include "misc.h" /* servconf.h needs misc.h for struct ForwardOptions */
|
|
+#include "servconf.h"
|
|
+#include "port-linux.h"
|
|
+#include "key.h"
|
|
+#include "hostfile.h"
|
|
+#include "auth.h"
|
|
+
|
|
+void
|
|
+linux_seed(void)
|
|
+{
|
|
+ char *env = getenv("SSH_USE_STRONG_RNG");
|
|
+ char *random = "/dev/random";
|
|
+ size_t len, ienv, randlen = 14;
|
|
+
|
|
+ if (!env || !strcmp(env, "0"))
|
|
+ random = "/dev/urandom";
|
|
+ else if ((ienv = atoi(env)) > randlen)
|
|
+ randlen = ienv;
|
|
+
|
|
+ errno = 0;
|
|
+ if ((len = RAND_load_file(random, randlen)) != randlen) {
|
|
+ if (errno)
|
|
+ fatal ("cannot read from %s, %s", random, strerror(errno));
|
|
+ else
|
|
+ fatal ("EOF reading %s", random);
|
|
+ }
|
|
+}
|
|
diff -up openssh-7.4p1/ssh.1.entropy openssh-7.4p1/ssh.1
|
|
--- openssh-7.4p1/ssh.1.entropy 2016-12-23 18:34:27.754753565 +0100
|
|
+++ openssh-7.4p1/ssh.1 2016-12-23 18:34:27.770753571 +0100
|
|
@@ -1441,6 +1441,23 @@ For more information, see the
|
|
.Cm PermitUserEnvironment
|
|
option in
|
|
.Xr sshd_config 5 .
|
|
+.Sh ENVIRONMENT
|
|
+.Bl -tag -width Ds -compact
|
|
+.It Ev SSH_USE_STRONG_RNG
|
|
+The reseeding of the OpenSSL random generator is usually done from
|
|
+.Cm /dev/urandom .
|
|
+If the
|
|
+.Cm SSH_USE_STRONG_RNG
|
|
+environment variable is set to value other than
|
|
+.Cm 0
|
|
+the OpenSSL random generator is reseeded from
|
|
+.Cm /dev/random .
|
|
+The number of bytes read is defined by the SSH_USE_STRONG_RNG value.
|
|
+Minimum is 14 bytes.
|
|
+This setting is not recommended on the computers without the hardware
|
|
+random generator because insufficient entropy causes the connection to
|
|
+be blocked until enough entropy is available.
|
|
+.El
|
|
.Sh FILES
|
|
.Bl -tag -width Ds -compact
|
|
.It Pa ~/.rhosts
|
|
diff -up openssh-7.4p1/ssh-add.0.entropy openssh-7.4p1/ssh-add.0
|
|
--- openssh-7.4p1/ssh-add.0.entropy 2016-12-19 06:21:21.000000000 +0100
|
|
+++ openssh-7.4p1/ssh-add.0 2016-12-23 18:34:27.770753571 +0100
|
|
@@ -88,6 +88,16 @@ ENVIRONMENT
|
|
Identifies the path of a UNIX-domain socket used to communicate
|
|
with the agent.
|
|
|
|
+ SSH_USE_STRONG_RNG
|
|
+ The reseeding of the OpenSSL random generator is usually done
|
|
+ from /dev/urandom. If the SSH_USE_STRONG_RNG environment vari-
|
|
+ able is set to value other than 0 the OpenSSL random generator is
|
|
+ reseeded from /dev/random. The number of bytes read is defined
|
|
+ by the SSH_USE_STRONG_RNG value. Minimum is 14 bytes. This set-
|
|
+ ting is not recommended on the computers without the hardware
|
|
+ random generator because insufficient entropy causes the connec-
|
|
+ tion to be blocked until enough entropy is available.
|
|
+
|
|
FILES
|
|
~/.ssh/identity
|
|
Contains the protocol version 1 RSA authentication identity of
|
|
diff -up openssh-7.4p1/ssh-add.1.entropy openssh-7.4p1/ssh-add.1
|
|
--- openssh-7.4p1/ssh-add.1.entropy 2016-12-19 05:59:41.000000000 +0100
|
|
+++ openssh-7.4p1/ssh-add.1 2016-12-23 18:34:27.770753571 +0100
|
|
@@ -171,6 +171,20 @@ to make this work.)
|
|
Identifies the path of a
|
|
.Ux Ns -domain
|
|
socket used to communicate with the agent.
|
|
+.It Ev SSH_USE_STRONG_RNG
|
|
+The reseeding of the OpenSSL random generator is usually done from
|
|
+.Cm /dev/urandom .
|
|
+If the
|
|
+.Cm SSH_USE_STRONG_RNG
|
|
+environment variable is set to value other than
|
|
+.Cm 0
|
|
+the OpenSSL random generator is reseeded from
|
|
+.Cm /dev/random .
|
|
+The number of bytes read is defined by the SSH_USE_STRONG_RNG value.
|
|
+Minimum is 14 bytes.
|
|
+This setting is not recommended on the computers without the hardware
|
|
+random generator because insufficient entropy causes the connection to
|
|
+be blocked until enough entropy is available.
|
|
.El
|
|
.Sh FILES
|
|
.Bl -tag -width Ds
|
|
diff -up openssh-7.4p1/ssh-agent.1.entropy openssh-7.4p1/ssh-agent.1
|
|
--- openssh-7.4p1/ssh-agent.1.entropy 2016-12-19 05:59:41.000000000 +0100
|
|
+++ openssh-7.4p1/ssh-agent.1 2016-12-23 18:34:27.770753571 +0100
|
|
@@ -214,6 +214,24 @@ sockets used to contain the connection t
|
|
These sockets should only be readable by the owner.
|
|
The sockets should get automatically removed when the agent exits.
|
|
.El
|
|
+.Sh ENVIRONMENT
|
|
+.Bl -tag -width Ds -compact
|
|
+.Pp
|
|
+.It Pa SSH_USE_STRONG_RNG
|
|
+The reseeding of the OpenSSL random generator is usually done from
|
|
+.Cm /dev/urandom .
|
|
+If the
|
|
+.Cm SSH_USE_STRONG_RNG
|
|
+environment variable is set to value other than
|
|
+.Cm 0
|
|
+the OpenSSL random generator is reseeded from
|
|
+.Cm /dev/random .
|
|
+The number of bytes read is defined by the SSH_USE_STRONG_RNG value.
|
|
+Minimum is 14 bytes.
|
|
+This setting is not recommended on the computers without the hardware
|
|
+random generator because insufficient entropy causes the connection to
|
|
+be blocked until enough entropy is available.
|
|
+.El
|
|
.Sh SEE ALSO
|
|
.Xr ssh 1 ,
|
|
.Xr ssh-add 1 ,
|
|
diff -up openssh-7.4p1/sshd.8.entropy openssh-7.4p1/sshd.8
|
|
--- openssh-7.4p1/sshd.8.entropy 2016-12-23 18:34:27.755753566 +0100
|
|
+++ openssh-7.4p1/sshd.8 2016-12-23 18:34:27.770753571 +0100
|
|
@@ -920,6 +920,24 @@ concurrently for different ports, this c
|
|
started last).
|
|
The content of this file is not sensitive; it can be world-readable.
|
|
.El
|
|
+.Sh ENVIRONMENT
|
|
+.Bl -tag -width Ds -compact
|
|
+.Pp
|
|
+.It Pa SSH_USE_STRONG_RNG
|
|
+The reseeding of the OpenSSL random generator is usually done from
|
|
+.Cm /dev/urandom .
|
|
+If the
|
|
+.Cm SSH_USE_STRONG_RNG
|
|
+environment variable is set to value other than
|
|
+.Cm 0
|
|
+the OpenSSL random generator is reseeded from
|
|
+.Cm /dev/random .
|
|
+The number of bytes read is defined by the SSH_USE_STRONG_RNG value.
|
|
+Minimum is 14 bytes.
|
|
+This setting is not recommended on the computers without the hardware
|
|
+random generator because insufficient entropy causes the connection to
|
|
+be blocked until enough entropy is available.
|
|
+.El
|
|
.Sh IPV6
|
|
IPv6 address can be used everywhere where IPv4 address. In all entries must be the IPv6 address enclosed in square brackets. Note: The square brackets are metacharacters for the shell and must be escaped in shell.
|
|
.Sh SEE ALSO
|
|
diff -up openssh-7.4p1/ssh-keygen.1.entropy openssh-7.4p1/ssh-keygen.1
|
|
--- openssh-7.4p1/ssh-keygen.1.entropy 2016-12-19 05:59:41.000000000 +0100
|
|
+++ openssh-7.4p1/ssh-keygen.1 2016-12-23 18:34:27.770753571 +0100
|
|
@@ -848,6 +848,24 @@ Contains Diffie-Hellman groups used for
|
|
The file format is described in
|
|
.Xr moduli 5 .
|
|
.El
|
|
+.Sh ENVIRONMENT
|
|
+.Bl -tag -width Ds -compact
|
|
+.Pp
|
|
+.It Pa SSH_USE_STRONG_RNG
|
|
+The reseeding of the OpenSSL random generator is usually done from
|
|
+.Cm /dev/urandom .
|
|
+If the
|
|
+.Cm SSH_USE_STRONG_RNG
|
|
+environment variable is set to value other than
|
|
+.Cm 0
|
|
+the OpenSSL random generator is reseeded from
|
|
+.Cm /dev/random .
|
|
+The number of bytes read is defined by the SSH_USE_STRONG_RNG value.
|
|
+Minimum is 14 bytes.
|
|
+This setting is not recommended on the computers without the hardware
|
|
+random generator because insufficient entropy causes the connection to
|
|
+be blocked until enough entropy is available.
|
|
+.El
|
|
.Sh SEE ALSO
|
|
.Xr ssh 1 ,
|
|
.Xr ssh-add 1 ,
|
|
diff -up openssh-7.4p1/ssh-keysign.8.entropy openssh-7.4p1/ssh-keysign.8
|
|
--- openssh-7.4p1/ssh-keysign.8.entropy 2016-12-19 05:59:41.000000000 +0100
|
|
+++ openssh-7.4p1/ssh-keysign.8 2016-12-23 18:34:27.770753571 +0100
|
|
@@ -80,6 +80,24 @@ must be set-uid root if host-based authe
|
|
If these files exist they are assumed to contain public certificate
|
|
information corresponding with the private keys above.
|
|
.El
|
|
+.Sh ENVIRONMENT
|
|
+.Bl -tag -width Ds -compact
|
|
+.Pp
|
|
+.It Pa SSH_USE_STRONG_RNG
|
|
+The reseeding of the OpenSSL random generator is usually done from
|
|
+.Cm /dev/urandom .
|
|
+If the
|
|
+.Cm SSH_USE_STRONG_RNG
|
|
+environment variable is set to value other than
|
|
+.Cm 0
|
|
+the OpenSSL random generator is reseeded from
|
|
+.Cm /dev/random .
|
|
+The number of bytes read is defined by the SSH_USE_STRONG_RNG value.
|
|
+Minimum is 14 bytes.
|
|
+This setting is not recommended on the computers without the hardware
|
|
+random generator because insufficient entropy causes the connection to
|
|
+be blocked until enough entropy is available.
|
|
+.El
|
|
.Sh SEE ALSO
|
|
.Xr ssh 1 ,
|
|
.Xr ssh-keygen 1 ,
|