164 lines
6.2 KiB
Diff
164 lines
6.2 KiB
Diff
diff --git a/configure.ac b/configure.ac
|
|
index 6553074..8dedb95 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -4676,6 +4676,12 @@ AC_ARG_WITH([lastlog],
|
|
fi
|
|
]
|
|
)
|
|
+AC_ARG_ENABLE(vendor-patchlevel,
|
|
+ [ --enable-vendor-patchlevel=TAG specify a vendor patch level],
|
|
+ [AC_DEFINE_UNQUOTED(SSH_VENDOR_PATCHLEVEL,[SSH_RELEASE "-" "$enableval"],[Define to your vendor patch level, if it has been modified from the upstream source release.])
|
|
+ SSH_VENDOR_PATCHLEVEL="$enableval"],
|
|
+ [AC_DEFINE(SSH_VENDOR_PATCHLEVEL,SSH_RELEASE,[Define to your vendor patch level, if it has been modified from the upstream source release.])
|
|
+ SSH_VENDOR_PATCHLEVEL=none])
|
|
|
|
dnl lastlog, [uw]tmpx? detection
|
|
dnl NOTE: set the paths in the platform section to avoid the
|
|
@@ -4938,6 +4944,7 @@ echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG"
|
|
echo " BSD Auth support: $BSD_AUTH_MSG"
|
|
echo " Random number source: $RAND_MSG"
|
|
echo " Privsep sandbox style: $SANDBOX_STYLE"
|
|
+echo " Vendor patch level: $SSH_VENDOR_PATCHLEVEL"
|
|
|
|
echo ""
|
|
|
|
diff --git a/servconf.c b/servconf.c
|
|
index e3ebaac..c8a3f28 100644
|
|
--- a/servconf.c
|
|
+++ b/servconf.c
|
|
@@ -141,6 +141,7 @@ initialize_server_options(ServerOptions *options)
|
|
options->max_authtries = -1;
|
|
options->max_sessions = -1;
|
|
options->banner = NULL;
|
|
+ options->show_patchlevel = -1;
|
|
options->use_dns = -1;
|
|
options->client_alive_interval = -1;
|
|
options->client_alive_count_max = -1;
|
|
@@ -310,6 +311,8 @@ fill_default_server_options(ServerOptions *options)
|
|
options->ip_qos_bulk = IPTOS_THROUGHPUT;
|
|
if (options->version_addendum == NULL)
|
|
options->version_addendum = xstrdup("");
|
|
+ if (options->show_patchlevel == -1)
|
|
+ options->show_patchlevel = 0;
|
|
if (options->fwd_opts.streamlocal_bind_mask == (mode_t)-1)
|
|
options->fwd_opts.streamlocal_bind_mask = 0177;
|
|
if (options->fwd_opts.streamlocal_bind_unlink == -1)
|
|
@@ -353,7 +356,7 @@ typedef enum {
|
|
sIgnoreUserKnownHosts, sCiphers, sMacs, sProtocol, sPidFile,
|
|
sGatewayPorts, sPubkeyAuthentication, sXAuthLocation, sSubsystem,
|
|
sMaxStartups, sMaxAuthTries, sMaxSessions,
|
|
- sBanner, sUseDNS, sHostbasedAuthentication,
|
|
+ sBanner, sShowPatchLevel, sUseDNS, sHostbasedAuthentication,
|
|
sHostbasedUsesNameFromPacketOnly, sClientAliveInterval,
|
|
sClientAliveCountMax, sAuthorizedKeysFile,
|
|
sGssAuthentication, sGssCleanupCreds, sAcceptEnv, sPermitTunnel,
|
|
@@ -467,6 +470,7 @@ static struct {
|
|
{ "maxauthtries", sMaxAuthTries, SSHCFG_ALL },
|
|
{ "maxsessions", sMaxSessions, SSHCFG_ALL },
|
|
{ "banner", sBanner, SSHCFG_ALL },
|
|
+ { "showpatchlevel", sShowPatchLevel, SSHCFG_GLOBAL },
|
|
{ "usedns", sUseDNS, SSHCFG_GLOBAL },
|
|
{ "verifyreversemapping", sDeprecated, SSHCFG_GLOBAL },
|
|
{ "reversemappingcheck", sDeprecated, SSHCFG_GLOBAL },
|
|
@@ -1263,6 +1267,10 @@ process_server_config_line(ServerOptions *options, char *line,
|
|
multistate_ptr = multistate_privsep;
|
|
goto parse_multistate;
|
|
|
|
+ case sShowPatchLevel:
|
|
+ intptr = &options->show_patchlevel;
|
|
+ goto parse_flag;
|
|
+
|
|
case sAllowUsers:
|
|
while ((arg = strdelim(&cp)) && *arg != '\0') {
|
|
if (options->num_allow_users >= MAX_ALLOW_USERS)
|
|
@@ -2081,6 +2089,7 @@ dump_config(ServerOptions *o)
|
|
dump_cfg_fmtint(sUseLogin, o->use_login);
|
|
dump_cfg_fmtint(sCompression, o->compression);
|
|
dump_cfg_fmtint(sGatewayPorts, o->fwd_opts.gateway_ports);
|
|
+ dump_cfg_fmtint(sShowPatchLevel, o->show_patchlevel);
|
|
dump_cfg_fmtint(sUseDNS, o->use_dns);
|
|
dump_cfg_fmtint(sAllowTcpForwarding, o->allow_tcp_forwarding);
|
|
dump_cfg_fmtint(sAllowStreamLocalForwarding, o->allow_streamlocal_forwarding);
|
|
diff --git a/servconf.h b/servconf.h
|
|
index 49b228b..21719e2 100644
|
|
--- a/servconf.h
|
|
+++ b/servconf.h
|
|
@@ -149,6 +149,7 @@ typedef struct {
|
|
int max_authtries;
|
|
int max_sessions;
|
|
char *banner; /* SSH-2 banner message */
|
|
+ int show_patchlevel; /* Show vendor patch level to clients */
|
|
int use_dns;
|
|
int client_alive_interval; /*
|
|
* poke the client this often to
|
|
diff --git a/sshd.c b/sshd.c
|
|
index afe9afa..193b206 100644
|
|
--- a/sshd.c
|
|
+++ b/sshd.c
|
|
@@ -432,7 +432,7 @@ sshd_exchange_identification(int sock_in, int sock_out)
|
|
}
|
|
|
|
xasprintf(&server_version_string, "SSH-%d.%d-%.100s%s%s%s",
|
|
- major, minor, SSH_VERSION,
|
|
+ major, minor, (options.show_patchlevel == 1) ? SSH_VENDOR_PATCHLEVEL : SSH_VERSION,
|
|
*options.version_addendum == '\0' ? "" : " ",
|
|
options.version_addendum, newline);
|
|
|
|
@@ -1677,7 +1677,8 @@ main(int ac, char **av)
|
|
exit(1);
|
|
}
|
|
|
|
- debug("sshd version %s, %s", SSH_VERSION,
|
|
+ debug("sshd version %s, %s",
|
|
+ (options.show_patchlevel == 1) ? SSH_VENDOR_PATCHLEVEL : SSH_VERSION,
|
|
#ifdef WITH_OPENSSL
|
|
SSLeay_version(SSLEAY_VERSION)
|
|
#else
|
|
diff --git a/sshd_config b/sshd_config
|
|
index 3092ac6..da3db5d 100644
|
|
--- a/sshd_config
|
|
+++ b/sshd_config
|
|
@@ -119,6 +119,7 @@ UsePrivilegeSeparation sandbox # Default for new installations.
|
|
#Compression delayed
|
|
#ClientAliveInterval 0
|
|
#ClientAliveCountMax 3
|
|
+#ShowPatchLevel no
|
|
#UseDNS yes
|
|
#PidFile /var/run/sshd.pid
|
|
#MaxStartups 10:30:100
|
|
diff --git a/sshd_config.0 b/sshd_config.0
|
|
index 43867d3..a3898c3 100644
|
|
--- a/sshd_config.0
|
|
+++ b/sshd_config.0
|
|
@@ -700,6 +700,11 @@ DESCRIPTION
|
|
Defines the number of bits in the ephemeral protocol version 1
|
|
server key. The minimum value is 512, and the default is 1024.
|
|
|
|
+ ShowPatchLevel
|
|
+ Specifies whether sshd will display the specific patch level of
|
|
+ the binary in the server identification string. The patch level
|
|
+ is set at compile-time. The default is M-bM-^@M-^\noM-bM-^@M-^].
|
|
+
|
|
StreamLocalBindMask
|
|
Sets the octal file creation mode mask (umask) used when creating
|
|
a Unix-domain socket file for local or remote port forwarding.
|
|
diff --git a/sshd_config.5 b/sshd_config.5
|
|
index 89a0cf2..cccb310 100644
|
|
--- a/sshd_config.5
|
|
+++ b/sshd_config.5
|
|
@@ -1200,6 +1200,13 @@ This option applies to protocol version 1 only.
|
|
.It Cm ServerKeyBits
|
|
Defines the number of bits in the ephemeral protocol version 1 server key.
|
|
The minimum value is 512, and the default is 1024.
|
|
+.It Cm ShowPatchLevel
|
|
+Specifies whether
|
|
+.Nm sshd
|
|
+will display the patch level of the binary in the identification string.
|
|
+The patch level is set at compile-time.
|
|
+The default is
|
|
+.Dq no .
|
|
.It Cm StreamLocalBindMask
|
|
Sets the octal file creation mode mask
|
|
.Pq umask
|