93a4744539
- fixed a problem with public key authentication and explicitely specified SELinux role
329 lines
11 KiB
Diff
329 lines
11 KiB
Diff
diff -up openssh-5.1p1/configure.ac.selinux openssh-5.1p1/configure.ac
|
|
--- openssh-5.1p1/configure.ac.selinux 2008-07-23 16:32:13.000000000 +0200
|
|
+++ openssh-5.1p1/configure.ac 2008-07-23 16:32:13.000000000 +0200
|
|
@@ -3309,6 +3309,7 @@ AC_ARG_WITH(selinux,
|
|
AC_CHECK_LIB(selinux, setexeccon, [ LIBSELINUX="-lselinux" ],
|
|
AC_MSG_ERROR(SELinux support requires libselinux library))
|
|
SSHDLIBS="$SSHDLIBS $LIBSELINUX"
|
|
+ LIBS="$LIBS $LIBSELINUX"
|
|
AC_CHECK_FUNCS(getseuserbyname get_default_context_with_level)
|
|
LIBS="$save_LIBS"
|
|
fi ]
|
|
diff -up openssh-5.1p1/auth1.c.selinux openssh-5.1p1/auth1.c
|
|
--- openssh-5.1p1/auth1.c.selinux 2008-07-23 16:32:13.000000000 +0200
|
|
+++ openssh-5.1p1/auth1.c 2008-07-23 16:32:13.000000000 +0200
|
|
@@ -391,7 +391,7 @@ void
|
|
do_authentication(Authctxt *authctxt)
|
|
{
|
|
u_int ulen;
|
|
- char *user, *style = NULL;
|
|
+ char *user, *style = NULL, *role=NULL;
|
|
|
|
/* Get the name of the user that we wish to log in as. */
|
|
packet_read_expect(SSH_CMSG_USER);
|
|
@@ -400,11 +400,19 @@ do_authentication(Authctxt *authctxt)
|
|
user = packet_get_string(&ulen);
|
|
packet_check_eom();
|
|
|
|
+ if ((role = strchr(user, '/')) != NULL)
|
|
+ *role++ = '\0';
|
|
+
|
|
if ((style = strchr(user, ':')) != NULL)
|
|
*style++ = '\0';
|
|
+ else
|
|
+ if (role && (style = strchr(role, ':')) != NULL)
|
|
+ *style++ = '\0';
|
|
+
|
|
|
|
authctxt->user = user;
|
|
authctxt->style = style;
|
|
+ authctxt->role = role;
|
|
|
|
/* Verify that the user is a valid user. */
|
|
if ((authctxt->pw = PRIVSEP(getpwnamallow(user))) != NULL)
|
|
diff -up openssh-5.1p1/auth2-pubkey.c.selinux openssh-5.1p1/auth2-pubkey.c
|
|
--- openssh-5.1p1/auth2-pubkey.c.selinux 2008-07-04 04:54:25.000000000 +0200
|
|
+++ openssh-5.1p1/auth2-pubkey.c 2008-07-23 16:32:13.000000000 +0200
|
|
@@ -117,7 +117,14 @@ userauth_pubkey(Authctxt *authctxt)
|
|
}
|
|
/* reconstruct packet */
|
|
buffer_put_char(&b, SSH2_MSG_USERAUTH_REQUEST);
|
|
- buffer_put_cstring(&b, authctxt->user);
|
|
+ if (authctxt->role) {
|
|
+ buffer_put_int(&b, strlen(authctxt->user)+strlen(authctxt->role)+1);
|
|
+ buffer_append(&b, authctxt->user, strlen(authctxt->user));
|
|
+ buffer_put_char(&b, '/');
|
|
+ buffer_append(&b, authctxt->role, strlen(authctxt->role));
|
|
+ } else {
|
|
+ buffer_put_cstring(&b, authctxt->user);
|
|
+ }
|
|
buffer_put_cstring(&b,
|
|
datafellows & SSH_BUG_PKSERVICE ?
|
|
"ssh-userauth" :
|
|
diff -up openssh-5.1p1/monitor_wrap.h.selinux openssh-5.1p1/monitor_wrap.h
|
|
--- openssh-5.1p1/monitor_wrap.h.selinux 2006-08-05 04:39:40.000000000 +0200
|
|
+++ openssh-5.1p1/monitor_wrap.h 2008-07-23 16:32:13.000000000 +0200
|
|
@@ -41,6 +41,7 @@ int mm_is_monitor(void);
|
|
DH *mm_choose_dh(int, int, int);
|
|
int mm_key_sign(Key *, u_char **, u_int *, u_char *, u_int);
|
|
void mm_inform_authserv(char *, char *);
|
|
+void mm_inform_authrole(char *);
|
|
struct passwd *mm_getpwnamallow(const char *);
|
|
char *mm_auth2_read_banner(void);
|
|
int mm_auth_password(struct Authctxt *, char *);
|
|
diff -up openssh-5.1p1/monitor.h.selinux openssh-5.1p1/monitor.h
|
|
--- openssh-5.1p1/monitor.h.selinux 2006-03-26 05:30:02.000000000 +0200
|
|
+++ openssh-5.1p1/monitor.h 2008-07-23 16:32:13.000000000 +0200
|
|
@@ -30,7 +30,7 @@
|
|
|
|
enum monitor_reqtype {
|
|
MONITOR_REQ_MODULI, MONITOR_ANS_MODULI,
|
|
- MONITOR_REQ_FREE, MONITOR_REQ_AUTHSERV,
|
|
+ MONITOR_REQ_FREE, MONITOR_REQ_AUTHSERV,MONITOR_REQ_AUTHROLE,
|
|
MONITOR_REQ_SIGN, MONITOR_ANS_SIGN,
|
|
MONITOR_REQ_PWNAM, MONITOR_ANS_PWNAM,
|
|
MONITOR_REQ_AUTH2_READ_BANNER, MONITOR_ANS_AUTH2_READ_BANNER,
|
|
diff -up openssh-5.1p1/auth2-hostbased.c.selinux openssh-5.1p1/auth2-hostbased.c
|
|
--- openssh-5.1p1/auth2-hostbased.c.selinux 2008-07-17 10:57:19.000000000 +0200
|
|
+++ openssh-5.1p1/auth2-hostbased.c 2008-07-23 16:32:13.000000000 +0200
|
|
@@ -106,7 +106,14 @@ userauth_hostbased(Authctxt *authctxt)
|
|
buffer_put_string(&b, session_id2, session_id2_len);
|
|
/* reconstruct packet */
|
|
buffer_put_char(&b, SSH2_MSG_USERAUTH_REQUEST);
|
|
- buffer_put_cstring(&b, authctxt->user);
|
|
+ if (authctxt->role) {
|
|
+ buffer_put_int(&b, strlen(authctxt->user)+strlen(authctxt->role)+1);
|
|
+ buffer_append(&b, authctxt->user, strlen(authctxt->user));
|
|
+ buffer_put_char(&b, '/');
|
|
+ buffer_append(&b, authctxt->role, strlen(authctxt->role));
|
|
+ } else {
|
|
+ buffer_put_cstring(&b, authctxt->user);
|
|
+ }
|
|
buffer_put_cstring(&b, service);
|
|
buffer_put_cstring(&b, "hostbased");
|
|
buffer_put_string(&b, pkalg, alen);
|
|
diff -up openssh-5.1p1/monitor_wrap.c.selinux openssh-5.1p1/monitor_wrap.c
|
|
--- openssh-5.1p1/monitor_wrap.c.selinux 2008-07-11 09:36:48.000000000 +0200
|
|
+++ openssh-5.1p1/monitor_wrap.c 2008-07-23 16:32:13.000000000 +0200
|
|
@@ -296,6 +296,23 @@ mm_inform_authserv(char *service, char *
|
|
buffer_free(&m);
|
|
}
|
|
|
|
+/* Inform the privileged process about role */
|
|
+
|
|
+void
|
|
+mm_inform_authrole(char *role)
|
|
+{
|
|
+ Buffer m;
|
|
+
|
|
+ debug3("%s entering", __func__);
|
|
+
|
|
+ buffer_init(&m);
|
|
+ buffer_put_cstring(&m, role ? role : "");
|
|
+
|
|
+ mm_request_send(pmonitor->m_recvfd, MONITOR_REQ_AUTHROLE, &m);
|
|
+
|
|
+ buffer_free(&m);
|
|
+}
|
|
+
|
|
/* Do the password authentication */
|
|
int
|
|
mm_auth_password(Authctxt *authctxt, char *password)
|
|
diff -up openssh-5.1p1/openbsd-compat/port-linux.c.selinux openssh-5.1p1/openbsd-compat/port-linux.c
|
|
--- openssh-5.1p1/openbsd-compat/port-linux.c.selinux 2008-03-26 21:27:21.000000000 +0100
|
|
+++ openssh-5.1p1/openbsd-compat/port-linux.c 2008-07-23 16:32:13.000000000 +0200
|
|
@@ -30,11 +30,16 @@
|
|
#ifdef WITH_SELINUX
|
|
#include "log.h"
|
|
#include "port-linux.h"
|
|
+#include "key.h"
|
|
+#include "hostfile.h"
|
|
+#include "auth.h"
|
|
|
|
#include <selinux/selinux.h>
|
|
#include <selinux/flask.h>
|
|
#include <selinux/get_context_list.h>
|
|
|
|
+extern Authctxt *the_authctxt;
|
|
+
|
|
/* Wrapper around is_selinux_enabled() to log its return value once only */
|
|
int
|
|
ssh_selinux_enabled(void)
|
|
@@ -53,23 +58,36 @@ ssh_selinux_enabled(void)
|
|
static security_context_t
|
|
ssh_selinux_getctxbyname(char *pwname)
|
|
{
|
|
- security_context_t sc;
|
|
- char *sename = NULL, *lvl = NULL;
|
|
- int r;
|
|
+ security_context_t sc = NULL;
|
|
+ char *sename, *lvl;
|
|
+ char *role = NULL;
|
|
+ int r = 0;
|
|
|
|
+ if (the_authctxt)
|
|
+ role=the_authctxt->role;
|
|
#ifdef HAVE_GETSEUSERBYNAME
|
|
- if (getseuserbyname(pwname, &sename, &lvl) != 0)
|
|
- return NULL;
|
|
+ if ((r=getseuserbyname(pwname, &sename, &lvl)) != 0) {
|
|
+ sename = NULL;
|
|
+ lvl = NULL;
|
|
+ }
|
|
#else
|
|
sename = pwname;
|
|
lvl = NULL;
|
|
#endif
|
|
|
|
+ if (r == 0) {
|
|
#ifdef HAVE_GET_DEFAULT_CONTEXT_WITH_LEVEL
|
|
- r = get_default_context_with_level(sename, lvl, NULL, &sc);
|
|
+ if (role != NULL && role[0])
|
|
+ r = get_default_context_with_rolelevel(sename, role, lvl, NULL, &sc);
|
|
+ else
|
|
+ r = get_default_context_with_level(sename, lvl, NULL, &sc);
|
|
#else
|
|
- r = get_default_context(sename, NULL, &sc);
|
|
+ if (role != NULL && role[0])
|
|
+ r = get_default_context_with_role(sename, role, NULL, &sc);
|
|
+ else
|
|
+ r = get_default_context(sename, NULL, &sc);
|
|
#endif
|
|
+ }
|
|
|
|
if (r != 0) {
|
|
switch (security_getenforce()) {
|
|
diff -up openssh-5.1p1/auth.h.selinux openssh-5.1p1/auth.h
|
|
--- openssh-5.1p1/auth.h.selinux 2008-07-02 14:37:30.000000000 +0200
|
|
+++ openssh-5.1p1/auth.h 2008-07-23 16:32:13.000000000 +0200
|
|
@@ -58,6 +58,7 @@ struct Authctxt {
|
|
char *service;
|
|
struct passwd *pw; /* set if 'valid' */
|
|
char *style;
|
|
+ char *role;
|
|
void *kbdintctxt;
|
|
#ifdef BSD_AUTH
|
|
auth_session_t *as;
|
|
diff -up openssh-5.1p1/auth2.c.selinux openssh-5.1p1/auth2.c
|
|
--- openssh-5.1p1/auth2.c.selinux 2008-07-05 01:44:53.000000000 +0200
|
|
+++ openssh-5.1p1/auth2.c 2008-07-23 16:32:13.000000000 +0200
|
|
@@ -209,7 +209,7 @@ input_userauth_request(int type, u_int32
|
|
{
|
|
Authctxt *authctxt = ctxt;
|
|
Authmethod *m = NULL;
|
|
- char *user, *service, *method, *style = NULL;
|
|
+ char *user, *service, *method, *style = NULL, *role = NULL;
|
|
int authenticated = 0;
|
|
|
|
if (authctxt == NULL)
|
|
@@ -221,6 +221,9 @@ input_userauth_request(int type, u_int32
|
|
debug("userauth-request for user %s service %s method %s", user, service, method);
|
|
debug("attempt %d failures %d", authctxt->attempt, authctxt->failures);
|
|
|
|
+ if ((role = strchr(user, '/')) != NULL)
|
|
+ *role++ = 0;
|
|
+
|
|
if ((style = strchr(user, ':')) != NULL)
|
|
*style++ = 0;
|
|
|
|
@@ -246,8 +249,11 @@ input_userauth_request(int type, u_int32
|
|
use_privsep ? " [net]" : "");
|
|
authctxt->service = xstrdup(service);
|
|
authctxt->style = style ? xstrdup(style) : NULL;
|
|
- if (use_privsep)
|
|
+ authctxt->role = role ? xstrdup(role) : NULL;
|
|
+ if (use_privsep) {
|
|
mm_inform_authserv(service, style);
|
|
+ mm_inform_authrole(role);
|
|
+ }
|
|
userauth_banner();
|
|
} else if (strcmp(user, authctxt->user) != 0 ||
|
|
strcmp(service, authctxt->service) != 0) {
|
|
diff -up openssh-5.1p1/monitor.c.selinux openssh-5.1p1/monitor.c
|
|
--- openssh-5.1p1/monitor.c.selinux 2008-07-11 09:36:48.000000000 +0200
|
|
+++ openssh-5.1p1/monitor.c 2008-07-23 16:36:10.000000000 +0200
|
|
@@ -134,6 +134,7 @@ int mm_answer_sign(int, Buffer *);
|
|
int mm_answer_pwnamallow(int, Buffer *);
|
|
int mm_answer_auth2_read_banner(int, Buffer *);
|
|
int mm_answer_authserv(int, Buffer *);
|
|
+int mm_answer_authrole(int, Buffer *);
|
|
int mm_answer_authpassword(int, Buffer *);
|
|
int mm_answer_bsdauthquery(int, Buffer *);
|
|
int mm_answer_bsdauthrespond(int, Buffer *);
|
|
@@ -205,6 +206,7 @@ struct mon_table mon_dispatch_proto20[]
|
|
{MONITOR_REQ_SIGN, MON_ONCE, mm_answer_sign},
|
|
{MONITOR_REQ_PWNAM, MON_ONCE, mm_answer_pwnamallow},
|
|
{MONITOR_REQ_AUTHSERV, MON_ONCE, mm_answer_authserv},
|
|
+ {MONITOR_REQ_AUTHROLE, MON_ONCE, mm_answer_authrole},
|
|
{MONITOR_REQ_AUTH2_READ_BANNER, MON_ONCE, mm_answer_auth2_read_banner},
|
|
{MONITOR_REQ_AUTHPASSWORD, MON_AUTH, mm_answer_authpassword},
|
|
#ifdef USE_PAM
|
|
@@ -658,6 +660,7 @@ mm_answer_pwnamallow(int sock, Buffer *m
|
|
else {
|
|
/* Allow service/style information on the auth context */
|
|
monitor_permit(mon_dispatch, MONITOR_REQ_AUTHSERV, 1);
|
|
+ monitor_permit(mon_dispatch, MONITOR_REQ_AUTHROLE, 1);
|
|
monitor_permit(mon_dispatch, MONITOR_REQ_AUTH2_READ_BANNER, 1);
|
|
}
|
|
|
|
@@ -703,6 +706,23 @@ mm_answer_authserv(int sock, Buffer *m)
|
|
}
|
|
|
|
int
|
|
+mm_answer_authrole(int sock, Buffer *m)
|
|
+{
|
|
+ monitor_permit_authentications(1);
|
|
+
|
|
+ authctxt->role = buffer_get_string(m, NULL);
|
|
+ debug3("%s: role=%s",
|
|
+ __func__, authctxt->role);
|
|
+
|
|
+ if (strlen(authctxt->role) == 0) {
|
|
+ xfree(authctxt->role);
|
|
+ authctxt->role = NULL;
|
|
+ }
|
|
+
|
|
+ return (0);
|
|
+}
|
|
+
|
|
+int
|
|
mm_answer_authpassword(int sock, Buffer *m)
|
|
{
|
|
static int call_count;
|
|
@@ -1080,7 +1100,7 @@ static int
|
|
monitor_valid_userblob(u_char *data, u_int datalen)
|
|
{
|
|
Buffer b;
|
|
- char *p;
|
|
+ char *p, *r;
|
|
u_int len;
|
|
int fail = 0;
|
|
|
|
@@ -1106,6 +1126,8 @@ monitor_valid_userblob(u_char *data, u_i
|
|
if (buffer_get_char(&b) != SSH2_MSG_USERAUTH_REQUEST)
|
|
fail++;
|
|
p = buffer_get_string(&b, NULL);
|
|
+ if ((r = strchr(p, '/')) != NULL)
|
|
+ *r = '\0';
|
|
if (strcmp(authctxt->user, p) != 0) {
|
|
logit("wrong user name passed to monitor: expected %s != %.100s",
|
|
authctxt->user, p);
|
|
@@ -1137,7 +1159,7 @@ monitor_valid_hostbasedblob(u_char *data
|
|
char *chost)
|
|
{
|
|
Buffer b;
|
|
- char *p;
|
|
+ char *p, *r;
|
|
u_int len;
|
|
int fail = 0;
|
|
|
|
@@ -1154,6 +1176,8 @@ monitor_valid_hostbasedblob(u_char *data
|
|
if (buffer_get_char(&b) != SSH2_MSG_USERAUTH_REQUEST)
|
|
fail++;
|
|
p = buffer_get_string(&b, NULL);
|
|
+ if ((r = strchr(p, '/')) != NULL)
|
|
+ *r = '\0';
|
|
if (strcmp(authctxt->user, p) != 0) {
|
|
logit("wrong user name passed to monitor: expected %s != %.100s",
|
|
authctxt->user, p);
|