Build seccomp filter on ppc64(le) architecture (#1195065)

This commit is contained in:
Jakub Jelen 2016-06-06 10:16:31 +02:00
parent 1144aef1d1
commit f6a096caf2
2 changed files with 8 additions and 2 deletions

View File

@ -16,7 +16,7 @@ diff --git a/configure.ac b/configure.ac
index 24378a7..0bed910 100644
--- a/configure.ac
+++ b/configure.ac
@@ -811,6 +811,12 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
@@ -811,6 +811,18 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
aarch64*-*)
seccomp_audit_arch=AUDIT_ARCH_AARCH64
;;
@ -25,6 +25,12 @@ index 24378a7..0bed910 100644
+ ;;
+ s390-*)
+ seccomp_audit_arch=AUDIT_ARCH_S390
+ ;;
+ powerpc64-*)
+ seccomp_audit_arch=AUDIT_ARCH_PPC64
+ ;;
+ powerpc64le-*)
+ seccomp_audit_arch=AUDIT_ARCH_PPC64LE
+ ;;
esac
if test "x$seccomp_audit_arch" != "x" ; then

View File

@ -574,7 +574,7 @@ make clean
%endif
%if %{WITH_SELINUX}
--with-selinux --with-audit=linux \
%ifarch %{ix86} x86_64 %{arm} aarch64 s390x x390
%ifnarch ppc
--with-sandbox=seccomp_filter \
%else
--with-sandbox=rlimit \