Sync FIPS patch with RHEL

This commit is contained in:
Jakub Jelen 2017-06-30 12:18:02 +02:00
parent cdc7ba7293
commit 9dbec70c9c
1 changed files with 165 additions and 98 deletions

View File

@ -1,6 +1,6 @@
diff -up openssh-7.4p1/cipher.c.fips openssh-7.4p1/cipher.c
--- openssh-7.4p1/cipher.c.fips 2016-12-23 16:37:49.290741582 +0100
+++ openssh-7.4p1/cipher.c 2016-12-23 16:37:49.300741586 +0100
diff -up openssh-7.5p1/cipher.c.fips openssh-7.5p1/cipher.c
--- openssh-7.5p1/cipher.c.fips 2017-06-30 12:06:36.455713788 +0200
+++ openssh-7.5p1/cipher.c 2017-06-30 12:06:36.465713761 +0200
@@ -39,6 +39,8 @@
#include <sys/types.h>
@ -67,9 +67,9 @@ diff -up openssh-7.4p1/cipher.c.fips openssh-7.4p1/cipher.c
if (strcasecmp(c->name, name) == 0)
return c->number;
return -1;
diff -up openssh-7.4p1/cipher-ctr.c.fips openssh-7.4p1/cipher-ctr.c
--- openssh-7.4p1/cipher-ctr.c.fips 2016-12-23 16:37:49.225741551 +0100
+++ openssh-7.4p1/cipher-ctr.c 2016-12-23 16:37:49.297741585 +0100
diff -up openssh-7.5p1/cipher-ctr.c.fips openssh-7.5p1/cipher-ctr.c
--- openssh-7.5p1/cipher-ctr.c.fips 2017-06-30 12:06:36.386713974 +0200
+++ openssh-7.5p1/cipher-ctr.c 2017-06-30 12:06:36.465713761 +0200
@@ -179,7 +179,8 @@ evp_aes_128_ctr(void)
aes_ctr.do_cipher = ssh_aes_ctr;
#ifndef SSH_OLD_EVP
@ -80,9 +80,22 @@ diff -up openssh-7.4p1/cipher-ctr.c.fips openssh-7.4p1/cipher-ctr.c
#endif
return (&aes_ctr);
}
diff -up openssh-7.4p1/dh.h.fips openssh-7.4p1/dh.h
--- openssh-7.4p1/dh.h.fips 2016-12-19 05:59:41.000000000 +0100
+++ openssh-7.4p1/dh.h 2016-12-23 16:37:49.297741585 +0100
diff -up openssh-7.5p1/clientloop.c.fips openssh-7.5p1/clientloop.c
--- openssh-7.5p1/clientloop.c.fips 2017-06-30 12:06:36.466713758 +0200
+++ openssh-7.5p1/clientloop.c 2017-06-30 12:09:11.503295871 +0200
@@ -2412,7 +2412,8 @@ key_accepted_by_hostkeyalgs(const struct
{
const char *ktype = sshkey_ssh_name(key);
const char *hostkeyalgs = options.hostkeyalgorithms != NULL ?
- options.hostkeyalgorithms : KEX_DEFAULT_PK_ALG;
+ options.hostkeyalgorithms : (FIPS_mode() ?
+ KEX_FIPS_PK_ALG : KEX_DEFAULT_PK_ALG);
if (key == NULL || key->type == KEY_UNSPEC)
return 0;
diff -up openssh-7.5p1/dh.h.fips openssh-7.5p1/dh.h
--- openssh-7.5p1/dh.h.fips 2017-03-20 03:39:27.000000000 +0100
+++ openssh-7.5p1/dh.h 2017-06-30 12:06:36.466713758 +0200
@@ -51,6 +51,7 @@ u_int dh_estimate(int);
* Miniumum increased in light of DH precomputation attacks.
*/
@ -91,9 +104,9 @@ diff -up openssh-7.4p1/dh.h.fips openssh-7.4p1/dh.h
#define DH_GRP_MAX 8192
/*
diff -up openssh-7.4p1/entropy.c.fips openssh-7.4p1/entropy.c
--- openssh-7.4p1/entropy.c.fips 2016-12-23 16:37:49.219741548 +0100
+++ openssh-7.4p1/entropy.c 2016-12-23 16:37:49.297741585 +0100
diff -up openssh-7.5p1/entropy.c.fips openssh-7.5p1/entropy.c
--- openssh-7.5p1/entropy.c.fips 2017-06-30 12:06:36.377713998 +0200
+++ openssh-7.5p1/entropy.c 2017-06-30 12:06:36.466713758 +0200
@@ -217,6 +217,9 @@ seed_rng(void)
fatal("OpenSSL version mismatch. Built against %lx, you "
"have %lx", (u_long)OPENSSL_VERSION_NUMBER, SSLeay());
@ -104,9 +117,9 @@ diff -up openssh-7.4p1/entropy.c.fips openssh-7.4p1/entropy.c
#ifndef OPENSSL_PRNG_ONLY
if (RAND_status() == 1) {
debug3("RNG is ready, skipping seeding");
diff -up openssh-7.4p1/kex.c.fips openssh-7.4p1/kex.c
--- openssh-7.4p1/kex.c.fips 2016-12-23 16:37:49.290741582 +0100
+++ openssh-7.4p1/kex.c 2016-12-23 16:37:49.300741586 +0100
diff -up openssh-7.5p1/kex.c.fips openssh-7.5p1/kex.c
--- openssh-7.5p1/kex.c.fips 2017-06-30 12:06:36.455713788 +0200
+++ openssh-7.5p1/kex.c 2017-06-30 12:06:36.466713758 +0200
@@ -35,6 +35,7 @@
#ifdef WITH_OPENSSL
#include <openssl/crypto.h>
@ -142,7 +155,7 @@ diff -up openssh-7.4p1/kex.c.fips openssh-7.4p1/kex.c
char *
kex_alg_list(char sep)
{
@@ -152,7 +170,7 @@ kex_alg_by_name(const char *name)
@@ -152,7 +173,7 @@ kex_alg_by_name(const char *name)
{
const struct kexalg *k;
@ -151,7 +164,7 @@ diff -up openssh-7.4p1/kex.c.fips openssh-7.4p1/kex.c
if (strcmp(k->name, name) == 0)
return k;
#ifdef GSSAPI
@@ -178,7 +196,10 @@ kex_names_valid(const char *names)
@@ -178,7 +199,10 @@ kex_names_valid(const char *names)
for ((p = strsep(&cp, ",")); p && *p != '\0';
(p = strsep(&cp, ","))) {
if (kex_alg_by_name(p) == NULL) {
@ -163,9 +176,9 @@ diff -up openssh-7.4p1/kex.c.fips openssh-7.4p1/kex.c
free(s);
return 0;
}
diff -up openssh-7.4p1/kexgexc.c.fips openssh-7.4p1/kexgexc.c
--- openssh-7.4p1/kexgexc.c.fips 2016-12-19 05:59:41.000000000 +0100
+++ openssh-7.4p1/kexgexc.c 2016-12-23 16:38:38.727763540 +0100
diff -up openssh-7.5p1/kexgexc.c.fips openssh-7.5p1/kexgexc.c
--- openssh-7.5p1/kexgexc.c.fips 2017-03-20 03:39:27.000000000 +0100
+++ openssh-7.5p1/kexgexc.c 2017-06-30 12:06:36.467713756 +0200
@@ -28,6 +28,7 @@
#ifdef WITH_OPENSSL
@ -183,9 +196,9 @@ diff -up openssh-7.4p1/kexgexc.c.fips openssh-7.4p1/kexgexc.c
kex->max = DH_GRP_MAX;
kex->nbits = nbits;
if (datafellows & SSH_BUG_DHGEX_LARGE)
diff -up openssh-7.4p1/kexgexs.c.fips openssh-7.4p1/kexgexs.c
--- openssh-7.4p1/kexgexs.c.fips 2016-12-23 16:37:49.297741585 +0100
+++ openssh-7.4p1/kexgexs.c 2016-12-23 16:39:35.009776626 +0100
diff -up openssh-7.5p1/kexgexs.c.fips openssh-7.5p1/kexgexs.c
--- openssh-7.5p1/kexgexs.c.fips 2017-03-20 03:39:27.000000000 +0100
+++ openssh-7.5p1/kexgexs.c 2017-06-30 12:06:36.467713756 +0200
@@ -83,9 +83,9 @@ input_kex_dh_gex_request(int type, u_int
kex->nbits = nbits;
kex->min = min;
@ -198,9 +211,9 @@ diff -up openssh-7.4p1/kexgexs.c.fips openssh-7.4p1/kexgexs.c
nbits = MINIMUM(DH_GRP_MAX, nbits);
if (kex->max < kex->min || kex->nbits < kex->min ||
diff -up openssh-7.4p1/mac.c.fips openssh-7.4p1/mac.c
--- openssh-7.4p1/mac.c.fips 2016-12-23 16:37:49.291741582 +0100
+++ openssh-7.4p1/mac.c 2016-12-23 16:37:49.298741585 +0100
diff -up openssh-7.5p1/mac.c.fips openssh-7.5p1/mac.c
--- openssh-7.5p1/mac.c.fips 2017-06-30 12:06:36.456713785 +0200
+++ openssh-7.5p1/mac.c 2017-06-30 12:06:36.467713756 +0200
@@ -27,6 +27,8 @@
#include <sys/types.h>
@ -262,9 +275,9 @@ diff -up openssh-7.4p1/mac.c.fips openssh-7.4p1/mac.c
if (strcmp(name, m->name) != 0)
continue;
if (mac != NULL)
diff -up openssh-7.4p1/Makefile.in.fips openssh-7.4p1/Makefile.in
--- openssh-7.4p1/Makefile.in.fips 2016-12-23 16:37:49.291741582 +0100
+++ openssh-7.4p1/Makefile.in 2016-12-23 16:37:49.298741585 +0100
diff -up openssh-7.5p1/Makefile.in.fips openssh-7.5p1/Makefile.in
--- openssh-7.5p1/Makefile.in.fips 2017-06-30 12:06:36.456713785 +0200
+++ openssh-7.5p1/Makefile.in 2017-06-30 12:06:36.467713756 +0200
@@ -169,25 +169,25 @@ libssh.a: $(LIBSSH_OBJS)
$(RANLIB) $@
@ -306,10 +319,25 @@ diff -up openssh-7.4p1/Makefile.in.fips openssh-7.4p1/Makefile.in
sftp-server$(EXEEXT): $(LIBCOMPAT) libssh.a sftp.o sftp-common.o sftp-server.o sftp-server-main.o
$(LD) -o $@ sftp-server.o sftp-common.o sftp-server-main.o $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS)
diff -up openssh-7.4p1/myproposal.h.fips openssh-7.4p1/myproposal.h
--- openssh-7.4p1/myproposal.h.fips 2016-12-19 05:59:41.000000000 +0100
+++ openssh-7.4p1/myproposal.h 2016-12-23 16:37:49.300741586 +0100
@@ -138,6 +138,37 @@
diff -up openssh-7.5p1/myproposal.h.fips openssh-7.5p1/myproposal.h
--- openssh-7.5p1/myproposal.h.fips 2017-03-20 03:39:27.000000000 +0100
+++ openssh-7.5p1/myproposal.h 2017-06-30 12:10:21.953116208 +0200
@@ -114,6 +114,14 @@
"rsa-sha2-256," \
"ssh-rsa"
+#define KEX_FIPS_PK_ALG \
+ HOSTKEY_ECDSA_CERT_METHODS \
+ "ssh-rsa-cert-v01@openssh.com," \
+ HOSTKEY_ECDSA_METHODS \
+ "rsa-sha2-512," \
+ "rsa-sha2-256," \
+ "ssh-rsa"
+
/* the actual algorithms */
#define KEX_SERVER_ENCRYPT \
@@ -138,6 +146,37 @@
#define KEX_CLIENT_MAC KEX_SERVER_MAC
@ -347,9 +375,9 @@ diff -up openssh-7.4p1/myproposal.h.fips openssh-7.4p1/myproposal.h
#else /* WITH_OPENSSL */
#define KEX_SERVER_KEX \
diff -up openssh-7.4p1/pam_ssh_agent_auth-0.10.3/pam_user_key_allowed2.c.fips openssh-7.4p1/pam_ssh_agent_auth-0.10.3/pam_user_key_allowed2.c
--- openssh-7.4p1/pam_ssh_agent_auth-0.10.3/pam_user_key_allowed2.c.fips 2016-12-23 16:37:49.185741531 +0100
+++ openssh-7.4p1/pam_ssh_agent_auth-0.10.3/pam_user_key_allowed2.c 2016-12-23 16:37:49.300741586 +0100
diff -up openssh-7.5p1/pam_ssh_agent_auth-0.10.3/pam_user_key_allowed2.c.fips openssh-7.5p1/pam_ssh_agent_auth-0.10.3/pam_user_key_allowed2.c
--- openssh-7.5p1/pam_ssh_agent_auth-0.10.3/pam_user_key_allowed2.c.fips 2017-06-30 12:06:36.340714098 +0200
+++ openssh-7.5p1/pam_ssh_agent_auth-0.10.3/pam_user_key_allowed2.c 2017-06-30 12:06:36.467713756 +0200
@@ -55,6 +55,7 @@
#include "secure_filename.h"
#include "uidswap.h"
@ -368,29 +396,36 @@ diff -up openssh-7.4p1/pam_ssh_agent_auth-0.10.3/pam_user_key_allowed2.c.fips op
logit("Found matching %s key: %s",
key_type(found), fp);
free(fp);
diff -up openssh-7.4p1/readconf.c.fips openssh-7.4p1/readconf.c
--- openssh-7.4p1/readconf.c.fips 2016-12-23 16:37:49.274741574 +0100
+++ openssh-7.4p1/readconf.c 2016-12-23 16:37:49.298741585 +0100
@@ -2110,9 +2110,12 @@ fill_default_options(Options * options)
diff -up openssh-7.5p1/readconf.c.fips openssh-7.5p1/readconf.c
--- openssh-7.5p1/readconf.c.fips 2017-06-30 12:06:36.468713753 +0200
+++ openssh-7.5p1/readconf.c 2017-06-30 12:12:40.560769198 +0200
@@ -2132,12 +2132,17 @@ fill_default_options(Options * options)
}
if (options->update_hostkeys == -1)
options->update_hostkeys = 0;
- if (kex_assemble_names(KEX_CLIENT_ENCRYPT, &options->ciphers) != 0 ||
- kex_assemble_names(KEX_CLIENT_MAC, &options->macs) != 0 ||
- kex_assemble_names(KEX_CLIENT_KEX, &options->kex_algorithms) != 0 ||
- kex_assemble_names(KEX_DEFAULT_PK_ALG,
+ if (kex_assemble_names((FIPS_mode() ? KEX_FIPS_ENCRYPT
+ : KEX_CLIENT_ENCRYPT), &options->ciphers) != 0 ||
+ kex_assemble_names((FIPS_mode() ? KEX_FIPS_MAC
+ : KEX_CLIENT_MAC), &options->macs) != 0 ||
+ kex_assemble_names((FIPS_mode() ? KEX_DEFAULT_KEX_FIPS
+ : KEX_CLIENT_KEX), &options->kex_algorithms) != 0 ||
kex_assemble_names(KEX_DEFAULT_PK_ALG,
+ kex_assemble_names((FIPS_mode() ? KEX_FIPS_PK_ALG
+ : KEX_DEFAULT_PK_ALG),
&options->hostbased_key_types) != 0 ||
kex_assemble_names(KEX_DEFAULT_PK_ALG,
diff -up openssh-7.4p1/sandbox-seccomp-filter.c.fips openssh-7.4p1/sandbox-seccomp-filter.c
--- openssh-7.4p1/sandbox-seccomp-filter.c.fips 2016-12-23 16:37:49.292741583 +0100
+++ openssh-7.4p1/sandbox-seccomp-filter.c 2016-12-23 16:37:49.300741586 +0100
@@ -118,6 +118,9 @@ static const struct sock_filter preauth_
- kex_assemble_names(KEX_DEFAULT_PK_ALG,
+ kex_assemble_names((FIPS_mode() ? KEX_FIPS_PK_ALG
+ : KEX_DEFAULT_PK_ALG),
&options->pubkey_key_types) != 0)
fatal("%s: kex_assemble_names failed", __func__);
diff -up openssh-7.5p1/sandbox-seccomp-filter.c.fips openssh-7.5p1/sandbox-seccomp-filter.c
--- openssh-7.5p1/sandbox-seccomp-filter.c.fips 2017-06-30 12:06:36.458713780 +0200
+++ openssh-7.5p1/sandbox-seccomp-filter.c 2017-06-30 12:06:36.468713753 +0200
@@ -137,6 +137,9 @@ static const struct sock_filter preauth_
#ifdef __NR_open
SC_DENY(__NR_open, EACCES),
#endif
@ -400,52 +435,39 @@ diff -up openssh-7.4p1/sandbox-seccomp-filter.c.fips openssh-7.4p1/sandbox-secco
#ifdef __NR_openat
SC_DENY(__NR_openat, EACCES),
#endif
diff -up openssh-7.4p1/servconf.c.fips openssh-7.4p1/servconf.c
--- openssh-7.4p1/servconf.c.fips 2016-12-23 16:37:49.285741579 +0100
+++ openssh-7.4p1/servconf.c 2016-12-23 16:37:49.299741586 +0100
@@ -185,9 +185,12 @@ option_clear_or_none(const char *o)
diff -up openssh-7.5p1/servconf.c.fips openssh-7.5p1/servconf.c
--- openssh-7.5p1/servconf.c.fips 2017-06-30 12:06:36.468713753 +0200
+++ openssh-7.5p1/servconf.c 2017-06-30 12:14:09.260547133 +0200
@@ -185,14 +185,20 @@ option_clear_or_none(const char *o)
static void
assemble_algorithms(ServerOptions *o)
{
- if (kex_assemble_names(KEX_SERVER_ENCRYPT, &o->ciphers) != 0 ||
- kex_assemble_names(KEX_SERVER_MAC, &o->macs) != 0 ||
- kex_assemble_names(KEX_SERVER_KEX, &o->kex_algorithms) != 0 ||
- kex_assemble_names(KEX_DEFAULT_PK_ALG,
+ if (kex_assemble_names((FIPS_mode() ? KEX_FIPS_ENCRYPT
+ : KEX_SERVER_ENCRYPT), &o->ciphers) != 0 ||
+ kex_assemble_names((FIPS_mode() ? KEX_FIPS_MAC
+ : KEX_SERVER_MAC), &o->macs) != 0 ||
+ kex_assemble_names((FIPS_mode() ? KEX_DEFAULT_KEX_FIPS
+ : KEX_SERVER_KEX), &o->kex_algorithms) != 0 ||
kex_assemble_names(KEX_DEFAULT_PK_ALG,
+ kex_assemble_names((FIPS_mode() ? KEX_FIPS_PK_ALG
+ : KEX_DEFAULT_PK_ALG),
&o->hostkeyalgorithms) != 0 ||
kex_assemble_names(KEX_DEFAULT_PK_ALG,
@@ -2390,8 +2393,10 @@ dump_config(ServerOptions *o)
/* string arguments */
dump_cfg_string(sPidFile, o->pid_file);
dump_cfg_string(sXAuthLocation, o->xauth_location);
- dump_cfg_string(sCiphers, o->ciphers ? o->ciphers : KEX_SERVER_ENCRYPT);
- dump_cfg_string(sMacs, o->macs ? o->macs : KEX_SERVER_MAC);
+ dump_cfg_string(sCiphers, o->ciphers ? o->ciphers : FIPS_mode()
+ ? KEX_FIPS_ENCRYPT : KEX_SERVER_ENCRYPT);
+ dump_cfg_string(sMacs, o->macs ? o->macs : FIPS_mode()
+ ? KEX_FIPS_MAC : KEX_SERVER_MAC);
dump_cfg_string(sBanner, o->banner != NULL ? o->banner : "none");
dump_cfg_string(sForceCommand, o->adm_forced_command);
dump_cfg_string(sChrootDirectory, o->chroot_directory);
@@ -2406,8 +2411,8 @@ dump_config(ServerOptions *o)
dump_cfg_string(sAuthorizedPrincipalsCommand, o->authorized_principals_command);
dump_cfg_string(sAuthorizedPrincipalsCommandUser, o->authorized_principals_command_user);
dump_cfg_string(sHostKeyAgent, o->host_key_agent);
- dump_cfg_string(sKexAlgorithms,
- o->kex_algorithms ? o->kex_algorithms : KEX_SERVER_KEX);
+ dump_cfg_string(sKexAlgorithms, o->kex_algorithms ? o->kex_algorithms :
+ FIPS_mode() ? KEX_DEFAULT_KEX_FIPS : KEX_SERVER_KEX);
dump_cfg_string(sHostbasedAcceptedKeyTypes, o->hostbased_key_types ?
o->hostbased_key_types : KEX_DEFAULT_PK_ALG);
dump_cfg_string(sHostKeyAlgorithms, o->hostkeyalgorithms ?
diff -up openssh-7.4p1/ssh.c.fips openssh-7.4p1/ssh.c
--- openssh-7.4p1/ssh.c.fips 2016-12-19 05:59:41.000000000 +0100
+++ openssh-7.4p1/ssh.c 2016-12-23 16:37:49.299741586 +0100
- kex_assemble_names(KEX_DEFAULT_PK_ALG,
+ kex_assemble_names((FIPS_mode() ? KEX_FIPS_PK_ALG
+ : KEX_DEFAULT_PK_ALG),
&o->hostbased_key_types) != 0 ||
- kex_assemble_names(KEX_DEFAULT_PK_ALG, &o->pubkey_key_types) != 0)
+ kex_assemble_names((FIPS_mode() ? KEX_FIPS_PK_ALG
+ : KEX_DEFAULT_PK_ALG), &o->pubkey_key_types) != 0)
fatal("kex_assemble_names failed");
}
diff -up openssh-7.5p1/ssh.c.fips openssh-7.5p1/ssh.c
--- openssh-7.5p1/ssh.c.fips 2017-03-20 03:39:27.000000000 +0100
+++ openssh-7.5p1/ssh.c 2017-06-30 12:06:36.469713750 +0200
@@ -76,6 +76,8 @@
#include <openssl/evp.h>
#include <openssl/err.h>
@ -512,9 +534,9 @@ diff -up openssh-7.4p1/ssh.c.fips openssh-7.4p1/ssh.c
/* Open a connection to the remote host. */
if (ssh_connect(host, addrs, &hostaddr, options.port,
options.address_family, options.connection_attempts,
diff -up openssh-7.4p1/sshconnect2.c.fips openssh-7.4p1/sshconnect2.c
--- openssh-7.4p1/sshconnect2.c.fips 2016-12-23 16:37:49.275741574 +0100
+++ openssh-7.4p1/sshconnect2.c 2016-12-23 16:37:49.299741586 +0100
diff -up openssh-7.5p1/sshconnect2.c.fips openssh-7.5p1/sshconnect2.c
--- openssh-7.5p1/sshconnect2.c.fips 2017-06-30 12:06:36.439713831 +0200
+++ openssh-7.5p1/sshconnect2.c 2017-06-30 12:06:36.469713750 +0200
@@ -44,6 +44,8 @@
#include <vis.h>
#endif
@ -524,7 +546,17 @@ diff -up openssh-7.4p1/sshconnect2.c.fips openssh-7.4p1/sshconnect2.c
#include "openbsd-compat/sys-queue.h"
#include "xmalloc.h"
@@ -172,21 +174,26 @@ ssh_kex2(char *host, struct sockaddr *ho
@@ -117,7 +119,8 @@ order_hostkeyalgs(char *host, struct soc
for (i = 0; i < options.num_system_hostfiles; i++)
load_hostkeys(hostkeys, hostname, options.system_hostfiles[i]);
- oavail = avail = xstrdup(KEX_DEFAULT_PK_ALG);
+ oavail = avail = xstrdup((FIPS_mode()
+ ? KEX_FIPS_PK_ALG : KEX_DEFAULT_PK_ALG));
maxlen = strlen(avail) + 1;
first = xmalloc(maxlen);
last = xmalloc(maxlen);
@@ -172,21 +175,26 @@ ssh_kex2(char *host, struct sockaddr *ho
#ifdef GSSAPI
if (options.gss_keyex) {
@ -566,9 +598,28 @@ diff -up openssh-7.4p1/sshconnect2.c.fips openssh-7.4p1/sshconnect2.c
}
}
#endif
diff -up openssh-7.4p1/sshd.c.fips openssh-7.4p1/sshd.c
--- openssh-7.4p1/sshd.c.fips 2016-12-23 16:37:49.293741583 +0100
+++ openssh-7.4p1/sshd.c 2016-12-23 16:37:49.299741586 +0100
@@ -204,14 +212,16 @@ ssh_kex2(char *host, struct sockaddr *ho
myproposal[PROPOSAL_MAC_ALGS_CTOS] =
myproposal[PROPOSAL_MAC_ALGS_STOC] = options.macs;
if (options.hostkeyalgorithms != NULL) {
- if (kex_assemble_names(KEX_DEFAULT_PK_ALG,
+ if (kex_assemble_names((FIPS_mode() ? KEX_FIPS_PK_ALG
+ : KEX_DEFAULT_PK_ALG),
&options.hostkeyalgorithms) != 0)
fatal("%s: kex_assemble_namelist", __func__);
myproposal[PROPOSAL_SERVER_HOST_KEY_ALGS] =
compat_pkalg_proposal(options.hostkeyalgorithms);
} else {
/* Enforce default */
- options.hostkeyalgorithms = xstrdup(KEX_DEFAULT_PK_ALG);
+ options.hostkeyalgorithms = xstrdup((FIPS_mode()
+ ? KEX_FIPS_PK_ALG : KEX_DEFAULT_PK_ALG));
/* Prefer algorithms that we already have keys for */
myproposal[PROPOSAL_SERVER_HOST_KEY_ALGS] =
compat_pkalg_proposal(
diff -up openssh-7.5p1/sshd.c.fips openssh-7.5p1/sshd.c
--- openssh-7.5p1/sshd.c.fips 2017-06-30 12:06:36.459713777 +0200
+++ openssh-7.5p1/sshd.c 2017-06-30 12:06:36.469713750 +0200
@@ -66,6 +66,7 @@
#include <grp.h>
#include <pwd.h>
@ -586,7 +637,7 @@ diff -up openssh-7.4p1/sshd.c.fips openssh-7.4p1/sshd.c
#include "openbsd-compat/openssl-compat.h"
#endif
@@ -1475,6 +1478,18 @@ main(int ac, char **av)
@@ -1484,6 +1487,18 @@ main(int ac, char **av)
#endif
__progname = ssh_get_progname(av[0]);
@ -605,7 +656,7 @@ diff -up openssh-7.4p1/sshd.c.fips openssh-7.4p1/sshd.c
/* Save argv. Duplicate so setproctitle emulation doesn't clobber it */
saved_argc = ac;
rexec_argc = ac;
@@ -1623,7 +1638,7 @@ main(int ac, char **av)
@@ -1632,7 +1647,7 @@ main(int ac, char **av)
else
closefrom(REEXEC_DEVCRYPTO_RESERVED_FD);
@ -614,7 +665,7 @@ diff -up openssh-7.4p1/sshd.c.fips openssh-7.4p1/sshd.c
OpenSSL_add_all_algorithms();
#endif
@@ -1937,6 +1952,10 @@ main(int ac, char **av)
@@ -1951,6 +1966,10 @@ main(int ac, char **av)
/* Reinitialize the log (because of the fork above). */
log_init(__progname, options.log_level, options.log_facility, log_stderr);
@ -625,7 +676,7 @@ diff -up openssh-7.4p1/sshd.c.fips openssh-7.4p1/sshd.c
/* Chdir to the root directory so that the current disk can be
unmounted if desired. */
if (chdir("/") == -1)
@@ -2309,10 +2328,14 @@ do_ssh2_kex(void)
@@ -2328,10 +2347,14 @@ do_ssh2_kex(void)
if (strlen(myproposal[PROPOSAL_SERVER_HOST_KEY_ALGS]) == 0)
orig = NULL;
@ -644,9 +695,9 @@ diff -up openssh-7.4p1/sshd.c.fips openssh-7.4p1/sshd.c
if (gss && orig)
xasprintf(&newstr, "%s,%s", gss, orig);
diff -up openssh-7.4p1/sshkey.c.fips openssh-7.4p1/sshkey.c
--- openssh-7.4p1/sshkey.c.fips 2016-12-23 16:37:49.293741583 +0100
+++ openssh-7.4p1/sshkey.c 2016-12-23 16:37:49.300741586 +0100
diff -up openssh-7.5p1/sshkey.c.fips openssh-7.5p1/sshkey.c
--- openssh-7.5p1/sshkey.c.fips 2017-06-30 12:06:36.459713777 +0200
+++ openssh-7.5p1/sshkey.c 2017-06-30 12:06:36.470713747 +0200
@@ -34,6 +34,7 @@
#include <openssl/evp.h>
#include <openssl/err.h>
@ -655,15 +706,15 @@ diff -up openssh-7.4p1/sshkey.c.fips openssh-7.4p1/sshkey.c
#endif
#include "crypto_api.h"
@@ -56,6 +57,7 @@
#include "digest.h"
#define SSHKEY_INTERNAL
@@ -58,6 +59,7 @@
#include "sshkey.h"
+#include "log.h"
#include "match.h"
#include "xmalloc.h"
+#include "log.h"
@@ -1580,6 +1582,8 @@ rsa_generate_private_key(u_int bits, RSA
/* openssh private key file format */
#define MARK_BEGIN "-----BEGIN OPENSSH PRIVATE KEY-----\n"
@@ -1587,6 +1589,8 @@ rsa_generate_private_key(u_int bits, RSA
}
if (!BN_set_word(f4, RSA_F4) ||
!RSA_generate_key_ex(private, bits, f4, NULL)) {
@ -672,3 +723,19 @@ diff -up openssh-7.4p1/sshkey.c.fips openssh-7.4p1/sshkey.c
ret = SSH_ERR_LIBCRYPTO_ERROR;
goto out;
}
diff -up openssh-7.5p1/ssh-keygen.c.fips openssh-7.5p1/ssh-keygen.c
--- openssh-7.5p1/ssh-keygen.c.fips 2017-03-20 03:39:27.000000000 +0100
+++ openssh-7.5p1/ssh-keygen.c 2017-06-30 12:06:36.470713747 +0200
@@ -217,6 +217,12 @@ type_bits_valid(int type, const char *na
OPENSSL_DSA_MAX_MODULUS_BITS : OPENSSL_RSA_MAX_MODULUS_BITS;
if (*bitsp > maxbits)
fatal("key bits exceeds maximum %d", maxbits);
+ if (FIPS_mode()) {
+ if (type == KEY_DSA)
+ fatal("DSA keys are not allowed in FIPS mode");
+ if (type == KEY_ED25519)
+ fatal("ED25519 keys are not allowed in FIPS mode");
+ }
if (type == KEY_DSA && *bitsp != 1024)
fatal("DSA keys must be 1024 bits");
else if (type != KEY_ECDSA && type != KEY_ED25519 && *bitsp < 1024)