Remove krb5-config workaround for #1203900

This commit is contained in:
Jakub Jelen 2015-03-30 10:52:52 +02:00
parent af7be11f1d
commit 23bc31b25a
2 changed files with 2 additions and 27 deletions

View File

@ -1,22 +0,0 @@
diff --git a/configure.ac b/configure.ac
index 4e6abce..af08091 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4173,7 +4173,7 @@ AC_ARG_WITH([kerberos5],
[$KRB5ROOT/bin:$PATH])
if test -x $KRB5CONF ; then
K5CFLAGS="`$KRB5CONF --cflags`"
- K5LIBS="`$KRB5CONF --libs`"
+ K5LIBS="-lkrb5 -lk5crypto -lcom_err"
CPPFLAGS="$CPPFLAGS $K5CFLAGS"
AC_MSG_CHECKING([for gssapi support])
@@ -4183,7 +4183,7 @@ AC_ARG_WITH([kerberos5],
[Define this if you want GSSAPI
support in the version 2 protocol])
GSSCFLAGS="`$KRB5CONF --cflags gssapi`"
- GSSLIBS="`$KRB5CONF --libs gssapi`"
+ GSSLIBS="-lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err"
CPPFLAGS="$CPPFLAGS $GSSCFLAGS"
else
AC_MSG_RESULT([no])

View File

@ -215,10 +215,8 @@ Patch924: openssh-6.7p1-seccomp-aarch64.patch
Patch925: openssh-6.7p1-ssh-copy-id-truncated-keys.patch
# Add sftp option to force mode of created files (#1191055)
Patch926: openssh-6.7p1-sftp-force-permission.patch
# Workaround krb5-config bug #1204646
Patch927: openssh-6.8p1-workaround-krb5-config-bug.patch
# Upstream bug #1878 reintroduced in openssh6.7p1
Patch928: openssh-6.8p1-880575.patch
Patch927: openssh-6.8p1-880575.patch
@ -439,8 +437,7 @@ popd
%patch924 -p1 -b .seccomp
%patch925 -p1 -b .newline
%patch926 -p1 -b .sftp-force-mode
%patch927 -p1 -b .bz1204646
%patch928 -p1 -b .bz880575
%patch927 -p1 -b .bz880575
%patch200 -p1 -b .audit
%patch700 -p1 -b .fips