Update to 1.10.0

This commit is contained in:
Orion Poplawski 2015-10-07 14:39:44 -06:00
commit f25b134a7a
9 changed files with 426 additions and 134 deletions

24
.gitignore vendored
View File

@ -5,3 +5,27 @@ openmpi-1.4.1-RH.tar.bz2
/openmpi-1.6.tar.bz2
/openmpi-1.6-clean.tar.bz2
/openmpi-1.6.1-clean.tar.xz
/openmpi-1.6.2-clean.tar.xz
/openmpi-1.6.3-clean.tar.xz
/openmpi-1.6.4-clean.tar.bz2
/openmpi-1.6.4-clean.tar.xz
/openmpi-1.7-clean.tar.xz
/openmpi-1.7.1-clean.tar.xz
/openmpi-1.7.2-clean.tar.xz
/openmpi-1.7.3.tar.bz2
/openmpi-1.7.4.tar.bz2
/openmpi-1.7.5.tar.bz2
/openmpi-1.8.tar.bz2
/openmpi-1.8.1.tar.bz2
/openmpi-1.8.2.tar.bz2
/openmpi-1.8.3.tar.bz2
/openmpi-1.8.4.tar.bz2
/openmpi-v1.8.4-99-gd83fb30.tar.gz
/openmpi-v1.8.4-134-g9ad2aa8.tar.bz2
/openmpi-1.8.5rc1.tar.bz2
/openmpi-1.8.5rc3.tar.bz2
/openmpi-1.8.5.tar.bz2
/openmpi-1.8.6.tar.bz2
/openmpi-1.8.7.tar.bz2
/openmpi-1.8.8.tar.bz2
/openmpi-1.10.0.tar.bz2

View File

@ -1,7 +1,6 @@
%_openmpi_load \
. /etc/profile.d/modules.sh; \
module load openmpi-%{_arch}; \
export CFLAGS="$CFLAGS %{optflags}";
module load mpi/openmpi%{_cc_name_suffix};
%_openmpi_unload \
. /etc/profile.d/modules.sh; \
module unload openmpi-%{_arch};
module unload mpi/openmpi%{_cc_name_suffix};

33
openmpi-opal.patch Normal file
View File

@ -0,0 +1,33 @@
diff -up openmpi-1.10.0/ompi/mca/mtl/ofi/mtl_ofi_component.c.opal openmpi-1.10.0/ompi/mca/mtl/ofi/mtl_ofi_component.c
--- openmpi-1.10.0/ompi/mca/mtl/ofi/mtl_ofi_component.c.opal 2015-08-22 13:19:46.000000000 -0600
+++ openmpi-1.10.0/ompi/mca/mtl/ofi/mtl_ofi_component.c 2015-09-16 13:20:27.749403522 -0600
@@ -13,6 +13,7 @@
*/
#include "mtl_ofi.h"
+#include "opal/util/argv.h"
static int ompi_mtl_ofi_component_open(void);
static int ompi_mtl_ofi_component_query(mca_base_module_t **module, int *priority);
diff -up openmpi-1.10.0/ompi/tools/ompi_info/ompi_info.c.opal openmpi-1.10.0/ompi/tools/ompi_info/ompi_info.c
--- openmpi-1.10.0/ompi/tools/ompi_info/ompi_info.c.opal 2015-07-16 09:10:59.000000000 -0600
+++ openmpi-1.10.0/ompi/tools/ompi_info/ompi_info.c 2015-09-16 13:24:34.460318311 -0600
@@ -50,6 +50,7 @@
#endif
#include "opal/mca/base/base.h"
#include "opal/runtime/opal_info_support.h"
+#include "opal/util/argv.h"
#include "opal/util/show_help.h"
#if OMPI_RTE_ORTE
diff -up openmpi-1.10.0/orte/mca/plm/base/plm_base_receive.c.opal openmpi-1.10.0/orte/mca/plm/base/plm_base_receive.c
--- openmpi-1.10.0/orte/mca/plm/base/plm_base_receive.c.opal 2015-07-16 09:10:59.000000000 -0600
+++ openmpi-1.10.0/orte/mca/plm/base/plm_base_receive.c 2015-09-16 13:25:43.628016451 -0600
@@ -37,6 +37,7 @@
#include "opal/mca/mca.h"
#include "opal/dss/dss.h"
#include "opal/threads/threads.h"
+#include "opal/util/argv.h"
#include "orte/constants.h"
#include "orte/types.h"

View File

@ -1,31 +0,0 @@
--- openmpi-1.5.5/configure.orig 2012-03-20 20:05:01.000000000 +0000
+++ openmpi-1.5.5/configure 2012-04-03 12:58:28.871397855 +0100
@@ -150328,10 +150328,6 @@
-ac_config_files="$ac_config_files opal/mca/backtrace/darwin/Makefile"
-
-
-
ac_config_files="$ac_config_files opal/mca/backtrace/execinfo/Makefile"
@@ -174422,7 +174418,6 @@
"opal/mca/hwloc/hwloc132/hwloc/src/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/hwloc/hwloc132/hwloc/src/Makefile" ;;
"opal/mca/installdirs/config/install_dirs.h") CONFIG_FILES="$CONFIG_FILES opal/mca/installdirs/config/install_dirs.h" ;;
"opal/mca/backtrace/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/backtrace/Makefile" ;;
- "opal/mca/backtrace/darwin/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/backtrace/darwin/Makefile" ;;
"opal/mca/backtrace/execinfo/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/backtrace/execinfo/Makefile" ;;
"opal/mca/backtrace/none/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/backtrace/none/Makefile" ;;
"opal/mca/backtrace/printstack/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/backtrace/printstack/Makefile" ;;
--- openmpi-1.5.5/Makefile.in.orig 2012-04-03 12:58:21.937232790 +0100
+++ openmpi-1.5.5/Makefile.in 2012-04-03 12:58:28.874397927 +0100
@@ -197,7 +197,6 @@
$(top_srcdir)/config/ext_no_configure_components.m4 \
$(top_srcdir)/config/mca_m4_config_include.m4 \
$(top_srcdir)/opal/mca/backtrace/configure.m4 \
- $(top_srcdir)/opal/mca/backtrace/darwin/configure.m4 \
$(top_srcdir)/opal/mca/backtrace/execinfo/configure.m4 \
$(top_srcdir)/opal/mca/backtrace/none/configure.m4 \
$(top_srcdir)/opal/mca/backtrace/printstack/configure.m4 \

View File

@ -5,7 +5,7 @@
conflict mpi
prepend-path PATH @PREFIX@/bin
prepend-path LD_LIBRARY_PATH @LIBDIR@
prepend-path PYTHONPATH @PYSITEARCH@
prepend-path PKG_CONFIG_PATH @LIBDIR@/lib/pkgconfig
prepend-path MANPATH @MANDIR@
setenv MPI_BIN @PREFIX@/bin
setenv MPI_SYSCONFIG @ETCDIR@
@ -13,6 +13,9 @@ setenv MPI_FORTRAN_MOD_DIR @FMODDIR@
setenv MPI_INCLUDE @INCDIR@
setenv MPI_LIB @LIBDIR@
setenv MPI_MAN @MANDIR@
setenv MPI_PYTHON_SITEARCH @PYSITEARCH@
setenv MPI_PYTHON_SITEARCH @PY2SITEARCH@
setenv MPI_PYTHON2_SITEARCH @PY2SITEARCH@
setenv MPI_PYTHON3_SITEARCH @PY3SITEARCH@
setenv MPI_COMPILER @COMPILER@
setenv MPI_SUFFIX @SUFFIX@
setenv MPI_HOME @PREFIX@

1
openmpi.pth.py2 Normal file
View File

@ -0,0 +1 @@
import sys, os; s = os.getenv('MPI_PYTHON2_SITEARCH'); s and (s in sys.path or sys.path.append(s))

1
openmpi.pth.py3 Normal file
View File

@ -0,0 +1 @@
import sys, os; s = os.getenv('MPI_PYTHON3_SITEARCH'); s and (s in sys.path or sys.path.append(s))

View File

@ -1,3 +1,5 @@
%global _hardened_build 1
# AltCCRPMS
%global shortname openmpi
@ -17,72 +19,96 @@
# Non gcc compilers don't generate build ids
%undefine _missing_build_ids_terminate_build
%global intel_flags -O3 -axSSE2,SSE4.1,SSE4.2
# We only compile with gcc, but other people may want other compilers.
# Set the compiler here.
%global opt_cc icc
# Optional CFLAGS to use with the specific compiler...gcc doesn't need any,
# so uncomment and define to use
%global opt_cflags %{intel_flags}
#global opt_cflags
%global opt_cxx icpc
%global opt_cxxflags %{intel_flags}
#global opt_cxxflags
%global opt_f77 ifort
%global opt_fflags %{intel_flags}
#global opt_fflags
%global opt_fc ifort
%global opt_fcflags %{intel_flags}
#global opt_fcflags
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
# Optional name suffix to use...we leave it off when compiling with gcc, but
# for other compiled versions to install side by side, it will need a
# suffix in order to keep the names from conflicting.
#global _cc_name_suffix -gcc
Name: openmpi161%{?_cc_name_suffix}
Version: 1.6.1
Release: 2%{?dist}.1
%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
Name: openmpi-1.10.0%{?_cc_name_suffix}
Version: 1.10.0
Release: 2%{?dist}
Summary: Open Message Passing Interface
Group: Development/Libraries
License: BSD, MIT and Romio
URL: http://www.open-mpi.org/
# We can't use %{name} here because of _cc_name_suffix
#Source0: http://www.open-mpi.org/software/ompi/v1.6/downloads/openmpi-%{version}.tar.bz2
# openmpi-%{version}-clean.tar.xz was generated by taking the upstream tarball
# and removing license-incompatible files:
# rm -r opal/mca/backtrace/darwin/MoreBacktrace
Source0: openmpi-%{version}-clean.tar.xz
Source0: http://www.open-mpi.org/software/ompi/v1.10/downloads/openmpi-%{version}.tar.bz2
Source1: openmpi.module.in
Source2: macros.openmpi
# Patch to handle removed items
Patch0: openmpi-removed.patch
Source2: openmpi.pth.py2
Source3: openmpi.pth.py3
Source4: macros.openmpi
#sparc 64 doesn't have valgrind
%ifnarch %{sparc}
# Add needed opal/util/argv.h include
# https://github.com/open-mpi/ompi-release/pull/584
Patch0: openmpi-opal.patch
%ifnarch s390
BuildRequires: valgrind-devel
%endif
BuildRequires: libibverbs-devel >= 1.1.3, opensm-devel > 3.3.0
BuildRequires: librdmacm-devel libibcm-devel
%if 0%{?fedora}
# Doesn't compile:
# vt_dyn.cc:958:28: error: 'class BPatch_basicBlockLoop' has no member named 'getLoopHead'
# loop->getLoopHead()->getStartAddress(), loop_stmts );
#BuildRequires: dyninst-devel
BuildRequires: hwloc-devel
# So configure can find lstopo
BuildRequires: hwloc-gui
BuildRequires: java-devel
BuildRequires: libevent-devel
BuildRequires: libfabric-devel
BuildRequires: papi-devel
BuildRequires: perl(Getopt::Long)
BuildRequires: python
BuildRequires: python2-devel
%if 0%{?fedora}
BuildRequires: python3-devel
%endif
BuildRequires: libtool-ltdl-devel
BuildRequires: torque-devel
BuildRequires: zlib-devel
%if 0%{?fedora} >= 23
BuildRequires: rpm-mpi-hooks
%endif
BuildRequires: python libtool-ltdl-devel
BuildRequires: libesmtp-devel
Provides: mpi
Requires: environment-modules
# openmpi currently requires ssh to run
# https://svn.open-mpi.org/trac/ompi/ticket/4228
Requires: openssh-clients
# otf appears to be bundled
Provides: bundled(otf) = 1.12.3
# AltCCRPMS
Provides: %{shortname}%{?_cc_name_suffix} = %{version}-%{release}
Provides: %{shortname}%{?_cc_name_suffix}%{?_isa} = %{version}-%{release}
Requires: hwloc-libs
Requires: libevent
# s390 is unlikely to have the hardware we want, and some of the -devel
# packages we require aren't available there.
ExcludeArch: s390 s390x
# Private openmpi libraries
%global __provides_exclude_from %{_libdir}/openmpi/lib/(lib(mca|o|v)|openmpi/).*.so
%global __requires_exclude lib(mca|o|v).*
%global __provides_exclude_from %{_libdir}/openmpi/lib/(lib(mca|ompi|open-(pal|rte|trace)|otf)|openmpi/).*.so
%global __requires_exclude lib(mca|ompi|open-(pal|rte|trace)|otf|vt).*
%description
Open MPI is an open source, freely available implementation of both the
@ -94,44 +120,41 @@ software vendors, application developers, and computer science
researchers. For more information, see http://www.open-mpi.org/ .
%package devel
Summary: Development files for openmpi
Group: Development/Libraries
Summary: Development files for openmpi
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Provides: mpi-devel
%if 0%{?fedora} >= 23
Requires: rpm-mpi-hooks
%endif
# AltCCRPMS
Provides: %{shortname}%{?_cc_name_suffix}-devel = %{version}-%{release}
Provides: %{shortname}%{?_cc_name_suffix}-devel%{?_isa} = %{version}-%{release}
%description devel
Contains development headers and libraries for openmpi
Contains development headers and libraries for openmpi.
# When dealing with multilib installations, aka the ability to run either
# i386 or x86_64 binaries on x86_64 machines, we install the native i386
# openmpi libs/compilers and the native x86_64 libs/compilers. Obviously,
# on i386 you can only run i386, so you don't really need the -m32 flag
# to gcc in order to force 32 bit mode. However, since we use the native
# i386 package to support i386 operation on x86_64, and since on x86_64
# the default is x86_64, the i386 package needs to force i386 mode. This
# is true of all the multilib arches, hence the non-default arch (aka i386
# on x86_64) must force the non-default mode (aka 32 bit compile) in it's
# native-arch package (aka, when built on i386) so that it will work
# properly on the non-native arch as a multilib package (aka i386 installed
# on x86_64). Just to be safe, we also force the default mode (aka 64 bit)
# in default arch packages (aka, the x86_64 package). There are, however,
# some arches that don't support forcing *any* mode, those we just leave
# undefined.
%package java
Summary: Java library
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
%if 0%{?fedora} >= 20 || 0%{?rhel} >= 7
Requires: java-headless
%else
Requires: java
%endif
%ifarch %{ix86} ppc sparcv9
%global mode 32
%global modeflag -m32
%endif
%ifarch ia64
%global mode 64
%endif
%ifarch x86_64 ppc64 sparc64
%global mode 64
%global modeflag -m64
%endif
%description java
Java library.
%package java-devel
Summary: Java development files for openmpi
Group: Development/Libraries
Requires: %{name}-java = %{version}-%{release}
Requires: java-devel
%description java-devel
Contains development wrapper for compiling Java with openmpi.
# We set this to for convenience, since this is the unique dir we use for this
# particular package, version, compiler
@ -139,40 +162,32 @@ Contains development headers and libraries for openmpi
%prep
%setup -q -n openmpi-%{version}
%patch0 -p1 -b .removed
# Make sure we don't use the local libltdl library
rm -r opal/libltdl
%patch0 -p1 -b .opal
%build
./configure --prefix=%{_prefix} \
--libdir=%{_prefix}/%{_lib} \
--enable-opal-multi-threads \
--with-openib=/usr \
--disable-silent-rules \
--enable-mpi-java \
--with-libevent=/usr \
--with-sge \
%ifnarch %{sparc}
%ifnarch s390
--with-valgrind \
--enable-memchecker \
%endif
--with-esmtp \
%if 0%{?fedora}
--with-hwloc=/usr \
%endif
--with-libltdl=/usr \
--with-wrapper-cflags="%{?modeflag}" \
--with-wrapper-cxxflags="%{?modeflag}" \
--with-wrapper-fflags="%{?modeflag}" \
--with-wrapper-fcflags="%{?modeflag}" \
CC=%{opt_cc} CXX=%{opt_cxx} \
LDFLAGS='-Wl,-z,noexecstack' \
CFLAGS="%{?opt_cflags} %{!?opt_cflags:$RPM_OPT_FLAGS}" \
CXXFLAGS="%{?opt_cxxflags} %{!?opt_cxxflags:$RPM_OPT_FLAGS}" \
FC=%{opt_fc} FCFLAGS="%{?opt_fcflags} %{!?opt_fcflags:$RPM_OPT_FLAGS}" \
F77=%{opt_f77} FFLAGS="%{?opt_fflags} %{!?opt_fflags:$RPM_OPT_FLAGS}"
make %{?_smp_mflags}
LDFLAGS='%{__global_ldflags}' \
CFLAGS="${CFLAGS:-%{?opt_cflags} %{!?opt_cflags:$RPM_OPT_FLAGS}} -gcc-sys" \
CXXFLAGS="${CXXFLAGS:-%{?opt_cxxflags} %{!?opt_cxxflags:$RPM_OPT_FLAGS}} -gcc-sys" \
FC=%{opt_fc} FCFLAGS="${FCFLAGS:-%{?opt_fcflags} %{!?opt_fcflags:$RPM_OPT_FLAGS}}"
# --with-contrib-vt-flags='CXXFLAGS="-I%{_includedir}/dyninst -L%{_libdir}/dyninst"' \
make %{?_smp_mflags} V=1
%install
make install DESTDIR=%{buildroot}
rm -fr %{buildroot}%{_libdir}/pkgconfig
find %{buildroot}%{_libdir} -name \*.la | xargs rm
find %{buildroot}%{_mandir} -type f | xargs gzip -9
ln -s mpicc.1.gz %{buildroot}%{_mandir}/man1/mpiCC.1.gz
@ -182,75 +197,322 @@ rm -f %{buildroot}%{_libdir}/%{name}/share/vampirtrace/doc/opari/lacsi01.ps.gz
mkdir %{buildroot}%{_mandir}/man{2,4,5,6,8,9,n}
# Make the environment-modules file
mkdir -p %{buildroot}/etc/modulefiles/mpi/openmpi%{?_cc_name_suffix}/%{version}
mkdir -p %{buildroot}/etc/modulefiles/mpi/openmpi%{?_cc_name_suffix}
# Since we're doing our own substitution here, use our own definitions.
sed 's#@PREFIX@#%{_prefix}#;s#@LIBDIR@#%{_libdir}#g;s#@ETCDIR@#%{_sysconfdir}#g;s#@FMODDIR@#%{_libdir}#g;s#@INCDIR@#%{_includedir}#g;s#@MANDIR@#%{_mandir}#g;s#@PYSITEARCH@#%{python_sitearch}/%{name}#g;s#@COMPILER@#openmpi%{?_cc_name_suffix}#g' < %SOURCE1 > %{buildroot}/etc/modulefiles/mpi/openmpi%{_cc_name_suffix}/%{version}/%{_arch}
sed 's#@PREFIX@#%{_prefix}#;
s#@LIBDIR@#%{_libdir}#g;
s#@ETCDIR@#%{_sysconfdir}#g;
s#@FMODDIR@#%{_libdir}#g;
s#@INCDIR@#%{_includedir}#g;
s#@MANDIR@#%{_mandir}#g;
s#@PY2SITEARCH@#%{_libdir}/python%{python2_version}/site-packages#;
%if 0%{?fedora}
s#@PY3SITEARCH@#%{_libdir}/python%{python3_version}/site-packages#;
%endif
s#@COMPILER@#openmpi%{?_cc_name_suffix}#g
s#@SUFFIX@#%{?_cc_name_suffix}_openmpi#' \
<%{SOURCE1} \
>%{buildroot}/etc/modulefiles/mpi/openmpi%{_cc_name_suffix}/%{version}
# make the rpm config file
mkdir -p %{buildroot}/%{_sysconfdir}/rpm
cp %SOURCE2 %{buildroot}/%{_sysconfdir}/rpm/macros.%{namearch}
mkdir -p %{buildroot}/%{python_sitearch}/%{name}
install -Dpm 644 %{SOURCE4} %{buildroot}/%{macrosdir}/macros.%{namearch}%{?_cc_name_suffix}
mkdir -p %{buildroot}/%{_fmoddir}/%{name}
# Remove extraneous wrapper link libraries (bug 814798)
sed -i -e s/-ldl// -e s/-lhwloc// \
%{buildroot}%{_bindir}/orte_wrapper_script \
%{buildroot}%{_datadir}/openmpi/*-wrapper-data.txt
# install .pth files
mkdir -p %{buildroot}/%{python2_sitearch}/%{name}
install -pDm0644 %{SOURCE2} %{buildroot}/%{python2_sitearch}/openmpi.pth
%if 0%{?fedora}
mkdir -p %{buildroot}/%{python3_sitearch}/%{name}
install -pDm0644 %{SOURCE3} %{buildroot}/%{python3_sitearch}/openmpi.pth
%endif
%check
make check
%files
%defattr(-,root,root,-)
%dir %{_prefix}
%dir %{_libdir}
%dir %{_sysconfdir}
%dir %{_mandir}
%dir %{_mandir}/man*
%dir %{python_sitearch}/%{name}
%dir %{python2_sitearch}/%{name}
%{python2_sitearch}/openmpi.pth
%if 0%{?fedora}
%dir %{python3_sitearch}/%{name}
%{python3_sitearch}/openmpi.pth
%endif
%config(noreplace) %{_sysconfdir}/*
%{_bindir}/mpi[er]*
%{_bindir}/ompi*
#%{_bindir}/opal-*
%{_bindir}/opari
%{_bindir}/orte*
%{_bindir}/orte[-dr_]*
%{_bindir}/oshmem_info
%{_bindir}/oshrun
%{_bindir}/otf*
%{_bindir}/shmemrun
%{_libdir}/*.so.*
%{_mandir}/man1/mpi[er]*
%{_mandir}/man1/ompi*
#%{_mandir}/man1/opal-*
%{_mandir}/man1/orte*
%{_mandir}/man1/orte[-dr_]*
%{_mandir}/man1/oshmem_info*
%{_mandir}/man7/ompi*
%{_mandir}/man7/orte*
%{_libdir}/openmpi/*
/etc/modulefiles/mpi
#%files common
/etc/modulefiles/mpi/
%dir %{_datadir}
%dir %{_datadir}/openmpi
%dir %{_libdir}/openmpi
%{_datadir}/openmpi/doc
%{_datadir}/openmpi/amca-param-sets
%{_datadir}/openmpi/help*.txt
%{_datadir}/openmpi/mca-btl-openib-device-params.ini
%{_datadir}/openmpi/mca-coll-ml.config
%files devel
%defattr(-,root,root,-)
%dir %{_includedir}
%dir %{_datadir}/vampirtrace
%{_bindir}/mpi[cCf]*
%{_bindir}/vt*
%{_bindir}/opal_*
%{_bindir}/orte[cCf]*
%{_bindir}/osh[cf]*
%{_bindir}/shmem[cf]*
%{_bindir}/vt*
%{_includedir}/*
%{_libdir}/*.so
%{_libdir}/lib*.a
%{_libdir}/mpi.mod
%{_libdir}/*.mod
%{_libdir}/pkgconfig/
%{_mandir}/man1/mpi[cCf]*
%{_mandir}/man1/opal_*
%{_mandir}/man3/*
%{_mandir}/man7/opal*
%{_datadir}/openmpi/openmpi-valgrind.supp
%{_datadir}/openmpi/mpi*.txt
%{_datadir}/openmpi/orte*.txt
%{_datadir}/openmpi/*-wrapper-data.txt
%{_datadir}/vampirtrace/*
%{_sysconfdir}/rpm/macros.%{namearch}
%{macrosdir}/macros.%{namearch}%{?_cc_name_suffix}
%files java
%{_libdir}/mpi.jar
%files java-devel
%{_bindir}/mpijavac
%{_bindir}/mpijavac.pl
# Currently this only contaings openmpi/javadoc
%{_datadir}/doc/
%{_mandir}/man1/mpijavac.1.gz
%changelog
* Fri Nov 2 2012 Orion Poplawski <orion@cora.nwra.com> 1.6.1-2.1
* Wed Sep 16 2015 Orion Poplawski <orion@cora.nwra.com> - 1.10.0-2
- Add patch to add needed opal/util/argv.h includes
* Tue Sep 15 2015 Orion Poplawski <orion@cora.nwra.com> - 1.10.0-1
- Update to 1.10.0
* Thu Aug 27 2015 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 1.8.8-5
- Use .pth files to set the python path (https://fedorahosted.org/fpc/ticket/563)
* Mon Aug 24 2015 Orion Poplawski <orion@cora.nwra.com> 1.8.8-4
- Disable valgrind only on s390
* Mon Aug 17 2015 Orion Poplawski <orion@cora.nwra.com> 1.8.8-3
- Do not filter libvt* provides as some dependencies link to it
* Mon Aug 10 2015 Sandro Mani <manisandro@gmail.com> - 1.8.8-2
- Require, BuildRequire: rpm-mpi-hooks
* Mon Aug 10 2015 Orion Poplawski <orion@cora.nwra.com> 1.8.8-1
- Update to 1.8.8
- Drop atomic patch applied upstream
* Wed Jul 15 2015 Orion Poplawski <orion@cora.nwra.com> 1.8.7-1
- Update to 1.8.7
* Tue Jun 23 2015 Orion Poplawski <orion@cora.nwra.com> 1.8.6-1
- Update to 1.8.6
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Tue May 5 2015 Orion Poplawski <orion@cora.nwra.com> 1.8.5-1
- Update to 1.8.5
* Fri May 1 2015 Orion Poplawski <orion@cora.nwra.com> 1.8.5-0.2.rc3
- Update to 1.8.5rc3
* Sun Apr 5 2015 Orion Poplawski <orion@cora.nwra.com> 1.8.5-0.1.rc1
- Update to 1.8.5rc1
* Mon Mar 30 2015 Orion Poplawski <orion@cora.nwra.com> 1.8.4-7.20150324gitg9ad2aa8
- Add upstream patch to fix race/hang on 32bit machines
* Fri Mar 27 2015 Orion Poplawski <orion@cora.nwra.com> 1.8.4-6.20150324gitg9ad2aa8
- Update to latest 1.8.4 snapshot
- Add upstream patch to fix atomics on 32bit
* Mon Mar 23 2015 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 1.8.4-5.20150228gitgd83fb30
- Rebuild for fortran update (#1204420)
* Mon Mar 16 2015 Orion Poplawski <orion@cora.nwra.com> 1.8.4-4.99.20150228gitgd83fb30
- Own and ship pkgconfig files, set PKG_CONFIG_PATH in modulefile (bug #1113626)
- Drop old configure settings
* Wed Mar 4 2015 Orion Poplawski <orion@cora.nwra.com> 1.8.4-3.99.20150228gitgd83fb30
- Update to 1.8.4.99 snapshot
* Fri Feb 13 2015 Orion Poplawski <orion@cora.nwra.com> 1.8.4-2
- Fix MPI_FORTRAN_MOD_DIR (bug #1154982)
* Tue Dec 23 2014 Orion Poplawski <orion@cora.nwra.com> 1.8.4-1
- Update to 1.8.4
* Mon Nov 17 2014 Orion Poplawski <orion@cora.nwra.com> 1.8.3-3
- Rebuild for papi soname change
* Fri Oct 3 2014 Orion Poplawski <orion@cora.nwra.com> 1.8.3-2
- Fix typo in oshmem library name
* Sat Sep 27 2014 Orion Poplawski <orion@cora.nwra.com> 1.8.3-1
- Update to 1.8.3
* Tue Sep 16 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.8.2-2
- ppc64le now has valgrind
* Tue Aug 26 2014 Orion Poplawski <orion@cora.nwra.com> 1.8.2-1
- Update to 1.8.2
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Wed Aug 6 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.8.1-6
- Rebuild (papi)
* Mon Aug 4 2014 Dan Horák <dan[at]danny.cz> 1.8.1-5
- no valgrind on ppc64le yet
* Sat Aug 2 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.8.1-4
- aarch64 now has valgrind
* Thu Jul 17 2014 Orion Poplawski <orion@cora.nwra.com> 1.8.1-3
- Add patch to prevent shmem wrappers from adding extra libs
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Wed Apr 23 2014 Orion Poplawski <orion@cora.nwra.com> 1.8.1-1
- Update to 1.8.1, fixes bug #1089044
* Tue Apr 1 2014 Orion Poplawski <orion@cora.nwra.com> 1.8-1
- Update to 1.8
* Tue Mar 25 2014 Orion Poplawski <orion@cora.nwra.com> 1.7.5-2
- Update provides filter
* Mon Mar 24 2014 Orion Poplawski <orion@cora.nwra.com> 1.7.5-1
- Update to 1.7.5
* Fri Feb 21 2014 Orion Poplawski <orion@cora.nwra.com> - 1.7.4-3
- Require java-headless
* Sat Feb 8 2014 Ville Skyttä <ville.skytta@iki.fi> - 1.7.4-2
- Install macros to %%{_rpmconfdir}/macros.d where available.
* Wed Feb 5 2014 Orion Poplawski <orion@cora.nwra.com> 1.7.4-1
- Update to 1.7.4
- Drop format patch fixed upstream
- Build against system libevent
- Build Java mpi bindings, ship in -java sub-package
- Add requires openssh-clients
* Tue Jan 28 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.7.3-5
- Drop mode/modeflag. mode no longer used, modeflag obsolete as set in CFLAGS
- Use distro LDFLAGS for hardened build
- Drop armv5tel options
- General spec cleanups
* Thu Jan 16 2014 Orion Poplawski <orion@cora.nwra.com> 1.7.3-4
- Rebuild with papi 5.3.0
* Wed Dec 4 2013 Peter Robinson <pbrobinson@fedoraproject.org> 1.7.3-3
- valgrind not currently supported on aarch64
* Tue Dec 3 2013 Orion Poplawski <orion@cora.nwra.com> 1.7.3-2
- Fix compilation with -Werror=format-security (bug #1037231)
* Sun Oct 20 2013 Orion Poplawski <orion@cora.nwra.com> 1.7.3-1
- Update to 1.7.3
- Upstream no longer ships license incompatible files
* Fri Aug 16 2013 Orion Poplawski <orion@cora.nwra.com> 1.7.2-7
- Move orte* compiler wrappers to devel sub-package (bug #997330)
* Thu Aug 08 2013 Dennis Gilmore <dennis@ausil.us> - 1.7.2-6
- rebuild for papi soname bump bz#995092
* Sat Aug 03 2013 Petr Pisar <ppisar@redhat.com> - 1.7.2-5
- Perl 5.18 rebuild
* Fri Jul 26 2013 Orion Poplawski <orion@cora.nwra.com> 1.7.2-4
- Fix build issue with _cc_name_suffix (bug #986664)
* Mon Jul 22 2013 Deji Akingunola <dakingun@gmail.com> - 1.7.2-3
- Rebuild for papi's shared lib fix
* Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 1.7.2-2
- Perl 5.18 rebuild
* Thu Jun 27 2013 Orion Poplawski <orion@cora.nwra.com> 1.7.2-1
- Update to 1.7.2
* Wed Apr 17 2013 Orion Poplawski <orion@cora.nwra.com> 1.7.1-1
- Update to 1.7.1
- Add BR on hwloc
- Add BR on papi-devel
* Tue Apr 16 2013 Orion Poplawski <orion@cora.nwra.com> 1.7-1
- Update to 1.7
- Rebase patch to handle removed components
- Drop esmtp - no longer used
* Sat Feb 23 2013 Orion Poplawski <orion@cora.nwra.com> 1.6.4-2
- Exclude libopen-trace.* from requires
* Fri Feb 22 2013 Orion Poplawski <orion@cora.nwra.com> 1.6.4-1
- Update to 1.6.4
- Drop f90sover and arm-atomics patch fixed upstream
* Mon Jan 28 2013 Orion Poplawski <orion@cora.nwra.com> 1.6.3-7
- Make __requires_exclude more specific so we don't exclude needed libs
(bug #905263)
* Sun Nov 18 2012 Peter Robinson <pbrobinson@fedoraproject.org> 1.6.3-6
- Update atomics patch for ARM (thanks to Jon Masters)
* Sun Nov 11 2012 Peter Robinson <pbrobinson@fedoraproject.org> 1.6.3-5
- Atomics patch to fix building on ARM (thanks to Jon Masters)
* Mon Nov 5 2012 Orion Poplawski <orion@cora.nwra.com> 1.6.3-4
- Add patch to fix libmpi_f90.so version
- Add patch to link tests with system libltdl
- Run make check
* Fri Nov 2 2012 Orion Poplawski <orion@cora.nwra.com> 1.6.3-3
- Set enable-opal-multi-threads for IB support
* Thu Nov 1 2012 Orion Poplawski <orion@cora.nwra.com> 1.6.3-2
- Update rpm macros to use the new module location
* Wed Oct 31 2012 Orion Poplawski <orion@cora.nwra.com> 1.6.3-1
- Update to 1.6.3
* Sat Oct 13 2012 Orion Poplawski <orion@cora.nwra.com> 1.6.2-1
- Update to 1.6.2
- Add BR torque-devel to enable torque support
- Drop old module file location (bug #838467)
* Thu Sep 13 2012 Orion Poplawski <orion@cora.nwra.com> 1.6.1-2
- Drop adding -fPIC, no longer needed
- Set --disable-silent-rules for more verbose build logs
@ -321,7 +583,7 @@ sed -i -e s/-ldl// -e s/-lhwloc// \
- Adjust the files entries for share/openmpi/mpi*
- Add files entry for share/openmpi/orte*.txt
* Sat Sep 05 2010 Dennis Gilmore <dennis@ausil.us> - 1.4.1-7
* Sun Sep 05 2010 Dennis Gilmore <dennis@ausil.us> - 1.4.1-7
- disable valgrind support on sparc arches
* Sat Jul 24 2010 David Malcolm <dmalcolm@redhat.com> - 1.4.1-6

View File

@ -1 +1 @@
74702e0693ee5b4ba697a04f42db02b1 openmpi-1.6.1-clean.tar.xz
280cf952de68369cebaca886c5ce0304 openmpi-1.10.0.tar.bz2