Merge remote-tracking branch 'up/master' into master-riscv64

Signed-off-by: David Abdurachmanov <david.abdurachmanov@sifive.com>
This commit is contained in:
David Abdurachmanov 2019-07-25 08:51:39 +03:00
commit f05ec5cb25
Signed by: davidlt
GPG Key ID: 8B7F1DA0E2C9FDBB
7 changed files with 218 additions and 196 deletions

7
.gitignore vendored
View File

@ -37,3 +37,10 @@ openmpi-1.4.1-RH.tar.bz2
/openmpi-2.0.2.tar.bz2
/openmpi-2.1.0.tar.bz2
/openmpi-2.1.1.tar.bz2
/openmpi-2.1.5.tar.bz2
/openmpi-2.1.6rc1.tar.bz2
/openmpi-2.1.6.tar.bz2
/openmpi-3.1.3.tar.bz2
/openmpi-3.1.4.tar.bz2
/openmpi-4.0.0.tar.bz2
/openmpi-4.0.1.tar.bz2

View File

@ -1,43 +0,0 @@
From 44a66e208c5771e0897bcf27430a3afa171ba4c2 Mon Sep 17 00:00:00 2001
From: Gilles Gouaillardet <gilles@rist.or.jp>
Date: Wed, 7 Sep 2016 08:49:20 +0900
Subject: [PATCH] threads: fix WAIT_SYNC_INIT with a zero count
WAIT_SYNC_INIT(sync,0); WAIT_SYNC_RELEASE(sync);
hanged because sync->signaled was initialised to true, and
there is no reason to invoke WAIT_SYNC_SIGNALED(sync) before
WAIT_SYNC_RELEASE(sync)
this commit initializes sync->signaled to true unless the count is zero.
Thanks George for the review and guidance.
---
opal/threads/wait_sync.h | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/opal/threads/wait_sync.h b/opal/threads/wait_sync.h
index 9ebb4d7..2ec8485 100644
--- a/opal/threads/wait_sync.h
+++ b/opal/threads/wait_sync.h
@@ -6,6 +6,8 @@
* Copyright (c) 2016 Los Alamos National Security, LLC. All rights
* reserved.
* Copyright (c) 2016 Mellanox Technologies. All rights reserved.
+ * Copyright (c) 2016 Research Organization for Information Science
+ * and Technology (RIST). All rights reserved.
* $COPYRIGHT$
*
* Additional copyrights may follow
@@ -86,11 +88,11 @@ static inline int sync_wait_st (ompi_wait_sync_t *sync)
#define WAIT_SYNC_INIT(sync,c) \
do { \
- (sync)->count = c; \
+ (sync)->count = (c); \
(sync)->next = NULL; \
(sync)->prev = NULL; \
(sync)->status = 0; \
- (sync)->signaling = true; \
+ (sync)->signaling = (0 != (c)); \
if (opal_using_threads()) { \
pthread_cond_init (&(sync)->condition, NULL); \
pthread_mutex_init (&(sync)->lock, NULL); \

32
6594.patch Normal file
View File

@ -0,0 +1,32 @@
From 68c88e86f2c8ff515a4c54927077143de13516b9 Mon Sep 17 00:00:00 2001
From: Valentin Petrov <valentinp@mellanox.com>
Date: Tue, 16 Apr 2019 14:04:11 +0300
Subject: [PATCH] OSC/UCX: use correct rkey for atomic_fadd in rget/rput
Signed-off-by: Valentin Petrov <valentinp@mellanox.com>
---
ompi/mca/osc/ucx/osc_ucx_comm.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/ompi/mca/osc/ucx/osc_ucx_comm.c b/ompi/mca/osc/ucx/osc_ucx_comm.c
index ec760d4fda3..bc3b7f5e7ed 100644
--- a/ompi/mca/osc/ucx/osc_ucx_comm.c
+++ b/ompi/mca/osc/ucx/osc_ucx_comm.c
@@ -881,7 +881,7 @@ int ompi_osc_ucx_rput(const void *origin_addr, int origin_count,
CHECK_VALID_RKEY(module, target, target_count);
- rkey = (module->win_info_array[target]).rkey;
+ rkey = (module->state_info_array[target]).rkey;
OMPI_OSC_UCX_REQUEST_ALLOC(win, ucx_req);
assert(NULL != ucx_req);
@@ -942,7 +942,7 @@ int ompi_osc_ucx_rget(void *origin_addr, int origin_count,
CHECK_VALID_RKEY(module, target, target_count);
- rkey = (module->win_info_array[target]).rkey;
+ rkey = (module->state_info_array[target]).rkey;
OMPI_OSC_UCX_REQUEST_ALLOC(win, ucx_req);
assert(NULL != ucx_req);

34
6668.patch Normal file
View File

@ -0,0 +1,34 @@
From c6ba949f3a0618e26ce2ef53b052b3d38cbbd0d8 Mon Sep 17 00:00:00 2001
From: Nathan Hjelm <hjelmn@me.com>
Date: Wed, 15 May 2019 12:24:22 -0600
Subject: [PATCH] btl/uct: check for support before disabling UCX memory hooks
Signed-off-by: Nathan Hjelm <hjelmn@me.com>
---
opal/mca/btl/uct/btl_uct_component.c | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/opal/mca/btl/uct/btl_uct_component.c b/opal/mca/btl/uct/btl_uct_component.c
index 971b31a1d85..830c262325d 100644
--- a/opal/mca/btl/uct/btl_uct_component.c
+++ b/opal/mca/btl/uct/btl_uct_component.c
@@ -17,6 +17,7 @@
* Copyright (c) 2018 Amazon.com, Inc. or its affiliates. All Rights reserved.
* Copyright (c) 2018 Triad National Security, LLC. All rights
* reserved.
+ * Copyright (c) 2019 Google, LLC. All rights reserved.
* $COPYRIGHT$
*
* Additional copyrights may follow
@@ -129,7 +130,10 @@ static int mca_btl_uct_component_open(void)
mca_btl_uct_component.num_contexts_per_module = MCA_BTL_UCT_MAX_WORKERS;
}
- if (mca_btl_uct_component.disable_ucx_memory_hooks) {
+ if (mca_btl_uct_component.disable_ucx_memory_hooks &&
+ ((OPAL_MEMORY_FREE_SUPPORT | OPAL_MEMORY_MUNMAP_SUPPORT) ==
+ ((OPAL_MEMORY_FREE_SUPPORT | OPAL_MEMORY_MUNMAP_SUPPORT) &
+ opal_mem_hooks_support_level()))) {
ucm_set_external_event(UCM_EVENT_VM_UNMAPPED);
opal_mem_hooks_register_release(mca_btl_uct_mem_release_cb, NULL);
}

View File

@ -1,103 +0,0 @@
--- openmpi-2.1.1/test/class/Makefile.am 2017-05-10 08:41:36.000000000 -0700
+++ openmpi-2.1.1/test/class/Makefile.am.new 2017-08-24 09:07:12.539374461 -0700
@@ -95,11 +95,14 @@
$(top_builddir)/test/support/libsupport.a
opal_lifo_DEPENDENCIES = $(opal_lifo_LDADD)
-opal_fifo_SOURCES = opal_fifo.c
-opal_fifo_LDADD = \
- $(top_builddir)/opal/lib@OPAL_LIB_PREFIX@open-pal.la \
- $(top_builddir)/test/support/libsupport.a
-opal_fifo_DEPENDENCIES = $(opal_fifo_LDADD)
+# Disabled due to:
+# https://github.com/open-mpi/ompi/issues/2526
+# https://github.com/open-mpi/ompi/issues/2966
+#opal_fifo_SOURCES = opal_fifo.c
+#opal_fifo_LDADD = \
+# $(top_builddir)/opal/lib@OPAL_LIB_PREFIX@open-pal.la \
+# $(top_builddir)/test/support/libsupport.a
+#opal_fifo_DEPENDENCIES = $(opal_fifo_LDADD)
clean-local:
rm -f opal_bitmap_test_out.txt opal_hash_table_test_out.txt opal_proc_table_test_out.txt
--- openmpi-2.1.1/test/class/Makefile.in 2017-05-10 09:01:13.000000000 -0700
+++ openmpi-2.1.1/test/class/Makefile.in.new 2017-08-24 09:07:12.539374461 -0700
@@ -115,7 +115,7 @@
opal_hash_table$(EXEEXT) opal_proc_table$(EXEEXT) \
opal_tree$(EXEEXT) opal_list$(EXEEXT) \
opal_value_array$(EXEEXT) opal_pointer_array$(EXEEXT) \
- opal_lifo$(EXEEXT) opal_fifo$(EXEEXT)
+ opal_lifo$(EXEEXT)
subdir = test/class
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/config/c_get_alignment.m4 \
@@ -411,8 +411,6 @@
am__v_lt_1 =
am_opal_bitmap_OBJECTS = opal_bitmap.$(OBJEXT)
opal_bitmap_OBJECTS = $(am_opal_bitmap_OBJECTS)
-am_opal_fifo_OBJECTS = opal_fifo.$(OBJEXT)
-opal_fifo_OBJECTS = $(am_opal_fifo_OBJECTS)
am_opal_hash_table_OBJECTS = opal_hash_table.$(OBJEXT)
opal_hash_table_OBJECTS = $(am_opal_hash_table_OBJECTS)
am_opal_lifo_OBJECTS = opal_lifo.$(OBJEXT)
@@ -462,12 +460,12 @@
am__v_CCLD_0 = @echo " CCLD " $@;
am__v_CCLD_1 =
SOURCES = $(ompi_rb_tree_SOURCES) $(opal_bitmap_SOURCES) \
- $(opal_fifo_SOURCES) $(opal_hash_table_SOURCES) \
+ $(opal_hash_table_SOURCES) \
$(opal_lifo_SOURCES) $(opal_list_SOURCES) \
$(opal_pointer_array_SOURCES) $(opal_proc_table_SOURCES) \
$(opal_tree_SOURCES) $(opal_value_array_SOURCES)
DIST_SOURCES = $(ompi_rb_tree_SOURCES) $(opal_bitmap_SOURCES) \
- $(opal_fifo_SOURCES) $(opal_hash_table_SOURCES) \
+ $(opal_hash_table_SOURCES) \
$(opal_lifo_SOURCES) $(opal_list_SOURCES) \
$(opal_pointer_array_SOURCES) $(opal_proc_table_SOURCES) \
$(opal_tree_SOURCES) $(opal_value_array_SOURCES)
@@ -1900,12 +1898,6 @@
$(top_builddir)/test/support/libsupport.a
opal_lifo_DEPENDENCIES = $(opal_lifo_LDADD)
-opal_fifo_SOURCES = opal_fifo.c
-opal_fifo_LDADD = \
- $(top_builddir)/opal/lib@OPAL_LIB_PREFIX@open-pal.la \
- $(top_builddir)/test/support/libsupport.a
-
-opal_fifo_DEPENDENCIES = $(opal_fifo_LDADD)
all: all-am
.SUFFIXES:
@@ -1957,10 +1949,6 @@
@rm -f opal_bitmap$(EXEEXT)
$(AM_V_CCLD)$(LINK) $(opal_bitmap_OBJECTS) $(opal_bitmap_LDADD) $(LIBS)
-opal_fifo$(EXEEXT): $(opal_fifo_OBJECTS) $(opal_fifo_DEPENDENCIES) $(EXTRA_opal_fifo_DEPENDENCIES)
- @rm -f opal_fifo$(EXEEXT)
- $(AM_V_CCLD)$(LINK) $(opal_fifo_OBJECTS) $(opal_fifo_LDADD) $(LIBS)
-
opal_hash_table$(EXEEXT): $(opal_hash_table_OBJECTS) $(opal_hash_table_DEPENDENCIES) $(EXTRA_opal_hash_table_DEPENDENCIES)
@rm -f opal_hash_table$(EXEEXT)
$(AM_V_CCLD)$(LINK) $(opal_hash_table_OBJECTS) $(opal_hash_table_LDADD) $(LIBS)
@@ -1997,7 +1985,6 @@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ompi_rb_tree.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/opal_bitmap.Po@am__quote@
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/opal_fifo.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/opal_hash_table.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/opal_lifo.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/opal_list.Po@am__quote@
@@ -2291,13 +2278,6 @@
$(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
--log-file $$b.log --trs-file $$b.trs \
$(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
- "$$tst" $(AM_TESTS_FD_REDIRECT)
-opal_fifo.log: opal_fifo$(EXEEXT)
- @p='opal_fifo$(EXEEXT)'; \
- b='opal_fifo'; \
- $(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
- --log-file $$b.log --trs-file $$b.trs \
- $(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
"$$tst" $(AM_TESTS_FD_REDIRECT)
.test.log:
@p='$<'; \

View File

@ -19,37 +19,42 @@
%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
%ifarch aarch64 ppc64le x86_64
%bcond_without ucx
%else
%bcond_with ucx
%endif
Name: openmpi%{?_cc_name_suffix}
Version: 2.1.1
Release: 11.1.riscv64%{?dist}
Version: 4.0.1
Release: 6.0.riscv64%{?dist}
Summary: Open Message Passing Interface
Group: Development/Libraries
License: BSD and MIT and Romio
URL: http://www.open-mpi.org/
# We can't use %{name} here because of _cc_name_suffix
Source0: https://www.open-mpi.org/software/ompi/v2.1/downloads/openmpi-%{version}.tar.bz2
Source0: https://www.open-mpi.org/software/ompi/v4.0/downloads/openmpi-%{version}.tar.bz2
Source1: openmpi.module.in
Source2: openmpi.pth.py2
Source3: openmpi.pth.py3
Source4: macros.openmpi
# Only for ppc64le
# https://github.com/open-mpi/ompi/issues/2526
# https://github.com/open-mpi/ompi/issues/2966
Patch0: openmpi-2.1.1-disable-fifo-test.patch
# Fix for UCX usage with BTL/UCT
Patch0: https://patch-diff.githubusercontent.com/raw/open-mpi/ompi/pull/6668.patch
# OSC/UCX: use correct rkey for atomic_fadd in rget/rput
Patch1: https://patch-diff.githubusercontent.com/raw/open-mpi/ompi/pull/6594.patch
# Add support for riscv64
Patch1: openmpi-2.1.1-riscv64.patch
Patch10: openmpi-2.1.1-riscv64.patch
BuildRequires: gcc-c++
BuildRequires: gcc-gfortran
%ifarch %{valgrind_arches}
BuildRequires: valgrind-devel
%endif
%ifnarch s390 s390x %{arm}
BuildRequires: libibverbs-devel >= 1.1.3, opensm-devel > 3.3.0
BuildRequires: librdmacm-devel rdma-core-devel
%ifnarch %{arm}
BuildRequires: opensm-devel > 3.3.0
%endif
BuildRequires: rdma-core-devel
# Doesn't compile:
# vt_dyn.cc:958:28: error: 'class BPatch_basicBlockLoop' has no member named 'getLoopHead'
# loop->getLoopHead()->getStartAddress(), loop_stmts );
@ -58,23 +63,33 @@ BuildRequires: hwloc-devel
# So configure can find lstopo
BuildRequires: hwloc-gui
BuildRequires: java-devel
%ifnarch s390 s390x
# Old libevent causes issues
%if !0%{?el7}
BuildRequires: libevent-devel
%endif
BuildRequires: libfabric-devel
%ifnarch s390 s390x
BuildRequires: papi-devel
%endif
BuildRequires: orangefs-devel
BuildRequires: perl-generators
BuildRequires: perl(Getopt::Long)
BuildRequires: pmix-devel
BuildRequires: python2
BuildRequires: python2-devel
BuildRequires: python3-devel
BuildRequires: python%{python3_pkgversion}-devel
%ifarch x86_64
BuildRequires: infinipath-psm-devel
BuildRequires: libpsm2-devel
%endif
BuildRequires: torque-devel
%if %{with ucx}
BuildRequires: ucx-devel
%endif
BuildRequires: zlib-devel
%if !0%{?el7}
BuildRequires: rpm-mpi-hooks
%endif
BuildRequires: automake
BuildRequires: autoconf
@ -82,13 +97,14 @@ BuildRequires: libtool
BuildRequires: gettext
Provides: mpi
%if 0%{?rhel}
# Need this for /etc/profile.d/modules.sh
Requires: environment-modules
%endif
Requires: environment(modules)
# openmpi currently requires ssh to run
# https://svn.open-mpi.org/trac/ompi/ticket/4228
Requires: openssh-clients
# We have problems using the system libevent - openmpi's is modified
# https://bugzilla.redhat.com/show_bug.cgi?id=1235044
Provides: bundled(libevent) = 2.0.22
# Private openmpi libraries
%global __provides_exclude_from %{_libdir}/openmpi/lib/(lib(mca|ompi|open-(pal|rte|trace))|openmpi/).*.so
@ -105,17 +121,21 @@ researchers. For more information, see http://www.open-mpi.org/ .
%package devel
Summary: Development files for openmpi
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}, gcc-gfortran
Provides: mpi-devel
%if !0%{?el7}
Requires: rpm-mpi-hooks
# Make sure this package is rebuilt with correct Python version when updating
# Otherwise mpi.req from rpm-mpi-hooks doesn't work
# https://bugzilla.redhat.com/show_bug.cgi?id=1705296
Requires: (python(abi) = %{python3_version} if python3)
%endif
%description devel
Contains development headers and libraries for openmpi.
%package java
Summary: Java library
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
%if 0%{?fedora} >= 20 || 0%{?rhel} >= 7
Requires: java-headless
@ -128,7 +148,6 @@ Java library.
%package java-devel
Summary: Java development files for openmpi
Group: Development/Libraries
Requires: %{name}-java = %{version}-%{release}
Requires: java-devel
@ -141,28 +160,23 @@ Contains development wrapper for compiling Java with openmpi.
%package -n python2-openmpi
Summary: OpenMPI support for Python 2
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: python(abi) = %{python2_version}
%description -n python2-openmpi
OpenMPI support for Python 2.
%package -n python3-openmpi
%package -n python%{python3_pkgversion}-openmpi
Summary: OpenMPI support for Python 3
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: python(abi) = %{python3_version}
%description -n python3-openmpi
%description -n python%{python3_pkgversion}-openmpi
OpenMPI support for Python 3.
%prep
%setup -q -n openmpi-%{version}
%ifarch ppc64le
%patch0 -p1
%endif
%patch1 -p1 -b .riscv64~
%autosetup -p1 -n openmpi-%{version}
autoreconf -fiv
@ -182,32 +196,32 @@ done
--sysconfdir=%{_sysconfdir}/%{namearch} \
--disable-silent-rules \
--enable-builtin-atomics \
--enable-mpi-thread-multiple \
%ifnarch %{power64}
--enable-mpi-cxx \
%endif
--enable-mpi-java \
--enable-mpi1-compatibility \
--with-sge \
%ifarch %{valgrind_arches}
--with-valgrind \
--enable-memchecker \
%endif
--enable-memchecker \
--with-hwloc=/usr \
%if !0%{?el7}
--with-libevent=external \
--with-pmix=external \
%endif
CC=%{opt_cc} CXX=%{opt_cxx} \
LDFLAGS='%{__global_ldflags}' \
CFLAGS="%{?opt_cflags} %{!?opt_cflags:$RPM_OPT_FLAGS}" \
CXXFLAGS="%{?opt_cxxflags} %{!?opt_cxxflags:$RPM_OPT_FLAGS}" \
FC=%{opt_fc} FCFLAGS="%{?opt_fcflags} %{!?opt_fcflags:$RPM_OPT_FLAGS}"
# This fails - https://github.com/open-mpi/ompi/issues/2616
# --with-hwloc=external \
# We cannot use external pmix without external libevent
# --with-pmix=external \
# --with-contrib-vt-flags='CXXFLAGS="-I%{_includedir}/dyninst -L%{_libdir}/dyninst"' \
make %{?_smp_mflags} V=1
%make_build V=1
%install
make install DESTDIR=%{buildroot}
%make_install
find %{buildroot}%{_libdir}/%{name}/lib -name \*.la | xargs rm
find %{buildroot}%{_mandir}/%{namearch} -type f | xargs gzip -9
ln -s mpicc.1.gz %{buildroot}%{_mandir}/%{namearch}/man1/mpiCC.1.gz
@ -261,7 +275,7 @@ install -pDm0644 %{SOURCE3} %{buildroot}/%{python3_sitearch}/openmpi.pth
make check
%files
%license LICENSE opal/mca/event/libevent2022/libevent/LICENSE
%license LICENSE
%dir %{_libdir}/%{name}
%dir %{_sysconfdir}/%{namearch}
%dir %{_libdir}/%{name}/bin
@ -273,16 +287,27 @@ make check
%{_libdir}/%{name}/bin/mpi[er]*
%{_libdir}/%{name}/bin/ompi*
%{_libdir}/%{name}/bin/orte[-dr_]*
%if %{with ucx}
%{_libdir}/%{name}/bin/oshmem_info
%{_libdir}/%{name}/bin/oshrun
%{_libdir}/%{name}/bin/shmemrun
%{_libdir}/%{name}/lib/*.so.*
%endif
%{_libdir}/%{name}/lib/*.so.40*
%{_libdir}/%{name}/lib/libmca*.so.41*
%{_libdir}/%{name}/lib/libmca*.so.50*
%if 0%{?el7}
%{_libdir}/%{name}/lib/pmix/
%endif
%{_mandir}/%{namearch}/man1/mpi[er]*
%{_mandir}/%{namearch}/man1/ompi*
%{_mandir}/%{namearch}/man1/orte[-dr_]*
%if %{with ucx}
%{_mandir}/%{namearch}/man1/oshmem_info*
%{_mandir}/%{namearch}/man1/oshrun*
%{_mandir}/%{namearch}/man1/shmemrun*
%endif
%{_mandir}/%{namearch}/man7/ompi_*
%{_mandir}/%{namearch}/man7/opal_*
%{_mandir}/%{namearch}/man7/orte*
%{_libdir}/%{name}/lib/openmpi/*
%{_datadir}/modulefiles/mpi/
@ -290,17 +315,24 @@ make check
%dir %{_libdir}/%{name}/share/openmpi
%{_libdir}/%{name}/share/openmpi/amca-param-sets
%{_libdir}/%{name}/share/openmpi/help*.txt
%ifnarch s390 %{arm}
%{_libdir}/%{name}/share/openmpi/mca-btl-openib-device-params.ini
%if 0%{?el7}
%{_libdir}/%{name}/share/pmix/
%endif
%files devel
%dir %{_includedir}/%{namearch}
%{_libdir}/%{name}/bin/aggregate_profile.pl
%{_libdir}/%{name}/bin/mpi[cCf]*
%{_libdir}/%{name}/bin/opal_*
%{_libdir}/%{name}/bin/orte[cCf]*
%{_libdir}/%{name}/bin/osh[cf]*
%{_libdir}/%{name}/bin/shmem[cf]*
%if %{with ucx}
%{_libdir}/%{name}/bin/osh[cCf]*
%endif
%{_libdir}/%{name}/bin/profile2mat.pl
%if %{with ucx}
%{_libdir}/%{name}/bin/shmem[cCf]*
%endif
%{_includedir}/%{namearch}/*
%{_fmoddir}/%{name}/
%{_libdir}/%{name}/lib/*.so
@ -308,8 +340,10 @@ make check
%{_libdir}/%{name}/lib/pkgconfig/
%{_libdir}/pkgconfig/*.pc
%{_mandir}/%{namearch}/man1/mpi[cCf]*
%if %{with ucx}
%{_mandir}/%{namearch}/man1/osh[cCf]*
%{_mandir}/%{namearch}/man1/shmem[cCf]*
%endif
%{_mandir}/%{namearch}/man1/opal_*
%{_mandir}/%{namearch}/man3/*
%{_libdir}/%{name}/share/openmpi/openmpi-valgrind.supp
@ -330,18 +364,79 @@ make check
%dir %{python2_sitearch}/%{name}
%{python2_sitearch}/openmpi.pth
%files -n python3-openmpi
%files -n python%{python3_pkgversion}-openmpi
%dir %{python3_sitearch}/%{name}
%{python3_sitearch}/openmpi.pth
%changelog
* Sat Jun 02 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 2.1.1-11.1.riscv64
* Thu Jul 25 2019 David Abdurachmanov <david.abdurachmanov@sifive.com> - 4.0.1-6.0.riscv64
- Add OPAL patch to enable riscv64
* Fri Jun 01 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 2.1.1-11.0.riscv64
- Switch to use %{valgrind_arches}
* Fri Jun 21 2019 Orion Poplawski <orion@nwra.com> - 4.0.1-6
- Rebuild for libfabric 1.8
- Re-enable UCX, hopefully issue fixed in 1.5.2
* Mon May 27 2019 Orion Poplawski <orion@nwra.com> - 4.0.1-5
- Drop UCX support for now
* Wed May 15 2019 Orion Poplawski <orion@nwra.com> - 4.0.1-4
- Add upstream patch OSC/UCX: use correct rkey for atomic_fadd in rget/rput
* Wed May 15 2019 Orion Poplawski <orion@nwra.com> - 4.0.1-3
- Add upstream patch to fix issue with UCX usage in BTL/UCT
* Tue May 7 2019 Orion Poplawski <orion@nwra.com> - 4.0.1-2
- Add a guard for python3 version (#1705296)
- Add requires on python(abi) to python packages
* Sun Apr 28 2019 Orion Poplawski <orion@nwra.com> - 4.0.1-1
- Update to 4.0.1
* Sun Apr 28 2019 Orion Poplawski <orion@nwra.com> - 3.1.4-1
- Update to 3.1.4
* Mon Apr 22 2019 Björn Esser <besser82@fedoraproject.org> - 3.1.3-5
- rebuilt(opensm)
* Wed Apr 17 2019 Christoph Junghans <junghans@votca.org> - 3.1.3-4
- Rebuild to fix ibosmcomp linkage
* Sat Mar 2 2019 Orion Poplawski <orion@nwra.com> - 3.1.3-3
- Enable valgrind on s390x
- Cleanup arch conditionals
* Tue Feb 19 2019 Orion Poplawski <orion@nwra.com> - 3.1.3-2
- Enable PVFS2/OrangeFS MPI-IO support (bug #1655010)
* Wed Feb 13 2019 Orion Poplawski <orion@nwra.com> - 3.1.3-1
- Update to 3.1.3
- Drop ppc64le patch fixed upstream
- Use external libevent and pmix, except on EL7
- Fix EPEL7 builds
* Sat Feb 2 2019 Orion Poplawski <orion@nwra.com> - 2.1.6-1
- Update to 2.1.6
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.6-0.2.rc1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Wed Nov 28 2018 Orion Poplawski <orion@nwra.com> - 2.1.6-0.1.rc1
- Update to 2.1.6rc1
* Thu Oct 11 2018 Orion Poplawski <orion@nwra.com> - 2.1.5-1
- Update to 2.1.5
* Sun Jul 22 2018 Orion Poplawski <orion@nwra.com> - 2.1.1-14
- Add BR gcc-c++ (fix FTBFS bug #1605323)
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.1-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 2.1.1-12
- Rebuilt for Python 3.7
* Thu May 10 2018 Troy Dawson <tdawson@redhat.com> - 2.1.1-11
- Build with rdma-core-devel instead of libibcm-devel
@ -744,7 +839,7 @@ make check
- Update to fix licencing and packaging issues:
Use the system plpa and ltdl librarires rather than the ones in the tarball
Remove licence incompatible files from the tarball.
- update module.in to prepend-path PYTHONPATH
- update module.in to prepend-path PYTHONPATH
* Tue Mar 9 2010 Jay Fenlason <fenlason@redhat.com> - 1.4.1-3
- remove the pkgconfig file completely like we did in RHEL.

View File

@ -1 +1 @@
SHA512 (openmpi-2.1.1.tar.bz2) = c11bba6ec815f9c8d32fce3578f8995f6cd694e02fb850d7e6cd3975989bb38fdbef348064264a1de418d0a21411c70ca74347ecff4f27eb5a2f6835019d6bca
SHA512 (openmpi-4.0.1.tar.bz2) = 09f35dc2e44b4f84aab9c5af9d81f90bbdb030e4d90800a5d3ffae88cb32b7faecc9bea0abb113da53c21f73e9d19db68f961f997bc47bdd28d83a87beee0731