update to 1.5.5, fix build with external hwloc, add initial support for building on ARM

This commit is contained in:
Peter Robinson 2012-04-03 14:06:33 +01:00
parent 471689a157
commit e84526fa2a
4 changed files with 32 additions and 34 deletions

1
.gitignore vendored
View File

@ -1,3 +1,4 @@
openmpi-1.4.1-RH.tar.bz2
/openmpi-1.5-RH.tar.bz2
/openmpi-1.5.4-clean.tar.bz2
/openmpi-1.5.5-clean.tar.bz2

View File

@ -1,7 +1,6 @@
diff -up openmpi-1.5.4/configure.removed openmpi-1.5.4/configure
--- openmpi-1.5.4/configure.removed 2011-08-18 07:49:03.000000000 -0600
+++ openmpi-1.5.4/configure 2011-11-17 15:13:57.461774628 -0700
@@ -146215,10 +146215,6 @@ ac_config_files="$ac_config_files opal/m
--- openmpi-1.5.5/configure.orig 2012-03-20 20:05:01.000000000 +0000
+++ openmpi-1.5.5/configure 2012-04-03 12:58:28.871397855 +0100
@@ -150328,10 +150328,6 @@
@ -12,18 +11,17 @@ diff -up openmpi-1.5.4/configure.removed openmpi-1.5.4/configure
ac_config_files="$ac_config_files opal/mca/backtrace/execinfo/Makefile"
@@ -169069,7 +169065,6 @@ do
"opal/mca/paffinity/hwloc/hwloc/include/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/paffinity/hwloc/hwloc/include/Makefile" ;;
"opal/mca/paffinity/hwloc/hwloc/src/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/paffinity/hwloc/hwloc/src/Makefile" ;;
@@ -174422,7 +174418,6 @@
"opal/mca/hwloc/hwloc132/hwloc/src/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/hwloc/hwloc132/hwloc/src/Makefile" ;;
"opal/mca/installdirs/config/install_dirs.h") CONFIG_FILES="$CONFIG_FILES opal/mca/installdirs/config/install_dirs.h" ;;
"opal/mca/backtrace/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/backtrace/Makefile" ;;
- "opal/mca/backtrace/darwin/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/backtrace/darwin/Makefile" ;;
"opal/mca/backtrace/execinfo/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/backtrace/execinfo/Makefile" ;;
"opal/mca/backtrace/none/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/backtrace/none/Makefile" ;;
"opal/mca/backtrace/printstack/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/backtrace/printstack/Makefile" ;;
diff -up openmpi-1.5.4/Makefile.in.removed openmpi-1.5.4/Makefile.in
--- openmpi-1.5.4/Makefile.in.removed 2011-08-18 07:46:01.000000000 -0600
+++ openmpi-1.5.4/Makefile.in 2011-11-17 15:21:13.302181490 -0700
@@ -197,7 +197,6 @@ am__aclocal_m4_deps = $(top_srcdir)/ompi
--- openmpi-1.5.5/Makefile.in.orig 2012-04-03 12:58:21.937232790 +0100
+++ openmpi-1.5.5/Makefile.in 2012-04-03 12:58:28.874397927 +0100
@@ -197,7 +197,6 @@
$(top_srcdir)/config/ext_no_configure_components.m4 \
$(top_srcdir)/config/mca_m4_config_include.m4 \
$(top_srcdir)/opal/mca/backtrace/configure.m4 \

View File

@ -18,8 +18,8 @@
#define _cc_name_suffix -gcc
Name: openmpi%{?_cc_name_suffix}
Version: 1.5.4
Release: 5%{?dist}.1
Version: 1.5.5
Release: 1%{?dist}
Summary: Open Message Passing Interface
Group: Development/Libraries
License: BSD, MIT and Romio
@ -35,9 +35,14 @@ Source1: openmpi.module.in
Source2: macros.openmpi
# Patch to handle removed items
Patch0: openmpi-removed.patch
Patch1: configure_arm_fix.patch
BuildRequires: gcc-gfortran, libtool, numactl-devel
#sparc 64 doesnt have valgrind
BuildRequires: gcc-gfortran, libtool
# ARM HW doesn't support NUMA
%ifnarch %{arm}
BuildRequires: numactl-devel
%endif
#sparc 64 doesn't have valgrind
%ifnarch %{sparc}
BuildRequires: valgrind-devel
%endif
@ -46,18 +51,13 @@ BuildRequires: librdmacm librdmacm-devel libibcm libibcm-devel
BuildRequires: hwloc-devel
BuildRequires: python libtool-ltdl-devel
BuildRequires: libesmtp-devel
#%ifnarch ppc
#BuildRequires: compat-dapl-devel
#%endif
Provides: mpi
Requires: environment-modules
# Requires: openmpi-common = %{version}-%{release}
Obsoletes: openmpi-libs
# s390 is unlikely to have the hardware we want, and some of the -devel
# packages we require aren't available there.
# ARM has issues with a lack of "atomic primitives" so we'll exclude it as well for the moment
ExcludeArch: s390 s390x %{arm}
ExcludeArch: s390 s390x
# Private openmpi libraries
%define __provides_exclude_from %{_libdir}/openmpi/lib/(lib(mca|o|v)|openmpi/).*.so
@ -72,14 +72,6 @@ compliant implementation, Open MPI offers advantages for system and
software vendors, application developers, and computer science
researchers. For more information, see http://www.open-mpi.org/ .
#%package common
#Summary: Common files for openmpi
#Group: Development/Libraries
#BuildArch: noarch
#%description common
#contains files that are common across installations of op
%package devel
Summary: Development files for openmpi
Group: Development/Libraries
@ -104,6 +96,7 @@ Contains development headers and libraries for openmpi
# in default arch packages (aka, the x86_64 package). There are, however,
# some arches that don't support forcing *any* mode, those we just leave
# undefined.
%ifarch %{ix86} ppc sparcv9
%define mode 32
%define modeflag -m32
@ -130,7 +123,10 @@ rm -r opal/libltdl
%ifarch x86_64
XFLAGS="-fPIC"
%endif
./configure --prefix=%{_libdir}/%{name} --with-libnuma=/usr \
./configure --prefix=%{_libdir}/%{name} \
%ifnarch %{arm}
--with-libnuma=/usr \
%endif
--with-openib=/usr \
--mandir=%{_mandir}/%{namearch} \
--includedir=%{_includedir}/%{namearch} \
@ -141,8 +137,8 @@ XFLAGS="-fPIC"
--enable-memchecker \
%endif
--with-esmtp \
--with-hwloc=external \
--with-libltdl=external \
--with-hwloc=/usr \
--with-libltdl=/usr \
--with-wrapper-cflags="%{?opt_cflags} %{?modeflag}" \
--with-wrapper-cxxflags="%{?opt_cxxflags} %{?modeflag}" \
--with-wrapper-fflags="%{?opt_fflags} %{?modeflag}" \
@ -236,6 +232,9 @@ mkdir -p %{buildroot}/%{python_sitearch}/openmpi%{?_cc_name_suffix}
%{_sysconfdir}/rpm/macros.%{namearch}
%changelog
* Tue Apr 3 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 1.5.5-1
- Update to 1.5.5
* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.4-5.1
- Rebuilt for c++ ABI breakage

View File

@ -1 +1 @@
9a6c16e0b4235f00eefad17cb6b489b1 openmpi-1.5.4-clean.tar.bz2
74a04e4f140299eee7f4db5e318b6c53 openmpi-1.5.5-clean.tar.bz2