- Update to latest upstream stable version
- Add support for libibcm usage - Enable sge support via configure options since it's no longer on by default - Add patch to resolve allreduce issue (bz538199) - Remove no longer needed patch for Chelsio cards
This commit is contained in:
parent
ceec91f01c
commit
746245f1ae
@ -1,2 +1,3 @@
|
||||
openmpi-1.3.1.tar.bz2
|
||||
openmpi-1.3.3.tar.bz2
|
||||
openmpi-1.4.tar.bz2
|
||||
|
@ -1,13 +0,0 @@
|
||||
Index: ompi/mca/btl/openib/mca-btl-openib-device-params.ini
|
||||
===================================================================
|
||||
--- ompi/mca/btl/openib/mca-btl-openib-device-params.ini (revision 21744)
|
||||
+++ ompi/mca/btl/openib/mca-btl-openib-device-params.ini (working copy)
|
||||
@@ -212,7 +212,7 @@
|
||||
|
||||
[Chelsio T3]
|
||||
vendor_id = 0x1425
|
||||
-vendor_part_id = 0x0020,0x0021,0x0022,0x0023,0x0024,0x0025,0x0026,0x0030,0x0031,0x0032
|
||||
+vendor_part_id = 0x0020,0x0021,0x0022,0x0023,0x0024,0x0025,0x0026,0x0030,0x0031,0x0032,0x0035,0x0036
|
||||
use_eager_rdma = 1
|
||||
mtu = 2048
|
||||
receive_queues = P,65536,256,192,128
|
50
openmpi-changeset_r22324.patch
Normal file
50
openmpi-changeset_r22324.patch
Normal file
@ -0,0 +1,50 @@
|
||||
Index: /trunk/opal/include/opal/sys/amd64/atomic.h
|
||||
===================================================================
|
||||
--- /trunk/opal/include/opal/sys/amd64/atomic.h (revision 21180)
|
||||
+++ /trunk/opal/include/opal/sys/amd64/atomic.h (revision 22324)
|
||||
@@ -85,9 +85,9 @@
|
||||
unsigned char ret;
|
||||
__asm__ __volatile__ (
|
||||
- SMPLOCK "cmpxchgl %1,%2 \n\t"
|
||||
+ SMPLOCK "cmpxchgl %3,%4 \n\t"
|
||||
"sete %0 \n\t"
|
||||
- : "=qm" (ret)
|
||||
- : "q"(newval), "m"(*addr), "a"(oldval)
|
||||
- : "memory");
|
||||
+ : "=qm" (ret), "=a" (oldval), "=m" (*addr)
|
||||
+ : "q"(newval), "m"(*addr), "1"(oldval)
|
||||
+ );
|
||||
|
||||
return (int)ret;
|
||||
@@ -106,9 +106,9 @@
|
||||
unsigned char ret;
|
||||
__asm__ __volatile__ (
|
||||
- SMPLOCK "cmpxchgq %1,%2 \n\t"
|
||||
+ SMPLOCK "cmpxchgq %3,%4 \n\t"
|
||||
"sete %0 \n\t"
|
||||
- : "=qm" (ret)
|
||||
- : "q"(newval), "m"(*((volatile long*)addr)), "a"(oldval)
|
||||
- : "memory");
|
||||
+ : "=qm" (ret), "=a" (oldval), "=m" (*((volatile long*)addr))
|
||||
+ : "q"(newval), "m"(*((volatile long*)addr)), "1"(oldval)
|
||||
+ );
|
||||
|
||||
return (int)ret;
|
||||
Index: /trunk/opal/include/opal/sys/ia32/atomic.h
|
||||
===================================================================
|
||||
--- /trunk/opal/include/opal/sys/ia32/atomic.h (revision 21180)
|
||||
+++ /trunk/opal/include/opal/sys/ia32/atomic.h (revision 22324)
|
||||
@@ -92,9 +92,9 @@
|
||||
unsigned char ret;
|
||||
__asm__ __volatile__ (
|
||||
- SMPLOCK "cmpxchgl %1,%2 \n\t"
|
||||
+ SMPLOCK "cmpxchgl %3,%4 \n\t"
|
||||
"sete %0 \n\t"
|
||||
- : "=qm" (ret)
|
||||
- : "q"(newval), "m"(*((volatile long*)addr)), "a"(oldval)
|
||||
- : "memory");
|
||||
+ : "=qm" (ret), "=a" (oldval), "=m" (*addr)
|
||||
+ : "q"(newval), "m"(*((volatile long*)addr)), "1"(oldval)
|
||||
+ );
|
||||
|
||||
return (int)ret;
|
21
openmpi.spec
21
openmpi.spec
@ -18,8 +18,8 @@
|
||||
#define _cc_name_suffix -gcc
|
||||
|
||||
Name: openmpi%{?_cc_name_suffix}
|
||||
Version: 1.3.3
|
||||
Release: 6%{?dist}
|
||||
Version: 1.4
|
||||
Release: 1%{?dist}
|
||||
Summary: Open Message Passing Interface
|
||||
Group: Development/Libraries
|
||||
License: BSD
|
||||
@ -29,11 +29,11 @@ Source0: http://www.open-mpi.org/software/ompi/v1.3/downloads/openmpi-%{version
|
||||
Source1: openmpi.pc.in
|
||||
Source2: openmpi.module.in
|
||||
Source3: macros.openmpi
|
||||
Patch0: openmpi-bz515567.patch
|
||||
Patch0: openmpi-changeset_r22324.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: gcc-gfortran, libtool, numactl-devel, valgrind-devel
|
||||
BuildRequires: libibverbs-devel, opensm-devel > 3.3.0
|
||||
BuildRequires: librdmacm librdmacm-devel
|
||||
BuildRequires: libibverbs-devel >= 1.1.3, opensm-devel > 3.3.0
|
||||
BuildRequires: librdmacm librdmacm-devel libibcm libibcm-devel
|
||||
#%ifnarch ppc
|
||||
#BuildRequires: compat-dapl-devel
|
||||
#%endif
|
||||
@ -106,7 +106,7 @@ Contains development headers and libraries for openmpi
|
||||
|
||||
%prep
|
||||
%setup -q -n openmpi-%{version}
|
||||
%patch0 -p0 -b .bz515567
|
||||
%patch0 -p2 -b .bz538199
|
||||
%ifarch x86_64
|
||||
XFLAGS="-fPIC"
|
||||
%endif
|
||||
@ -117,6 +117,8 @@ XFLAGS="-fPIC"
|
||||
--includedir=%{_includedir}/%{namearch} \
|
||||
--sysconfdir=%{_sysconfdir}/%{namearch} \
|
||||
--enable-mpi-threads \
|
||||
--enable-openib-ibcm \
|
||||
--with-sge \
|
||||
--with-valgrind \
|
||||
--with-wrapper-cflags="%{?opt_cflags} %{?modeflag}" \
|
||||
--with-wrapper-cxxflags="%{?opt_cxxflags} %{?modeflag}" \
|
||||
@ -214,6 +216,13 @@ rm -rf %{buildroot}
|
||||
%{_sysconfdir}/rpm/macros.%{namearch}
|
||||
|
||||
%changelog
|
||||
* Wed Jan 13 2010 Doug Ledford <dledford@redhat.com> - 1.4-1
|
||||
- Update to latest upstream stable version
|
||||
- Add support for libibcm usage
|
||||
- Enable sge support via configure options since it's no longer on by default
|
||||
- Add patch to resolve allreduce issue (bz538199)
|
||||
- Remove no longer needed patch for Chelsio cards
|
||||
|
||||
* Tue Sep 22 2009 Jay Fenlason <fenlason@redhat.com> - 1.3.3-6
|
||||
- Create and own man* directories for use by dependent packages.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user