Update to 1.10.2
- Drop upsream nbc_copy patch
This commit is contained in:
parent
c031955c53
commit
1f89378e58
1
.gitignore
vendored
1
.gitignore
vendored
@ -30,3 +30,4 @@ openmpi-1.4.1-RH.tar.bz2
|
||||
/openmpi-1.8.8.tar.bz2
|
||||
/openmpi-1.10.0.tar.bz2
|
||||
/openmpi-1.10.1.tar.bz2
|
||||
/openmpi-1.10.2.tar.bz2
|
||||
|
@ -1,30 +0,0 @@
|
||||
commit 4ee20ba31dd64b8f899447cdad78ec2379acfce7
|
||||
Author: Gilles Gouaillardet <gilles@rist.or.jp>
|
||||
Date: Tue Nov 10 08:59:03 2015 +0900
|
||||
|
||||
fix NBC_Copy for legitimate zero size messages
|
||||
|
||||
(back ported from commit open-mpi/ompi@0bd765eddd33e3d4ac18ec644c60a5c160cb48dc)
|
||||
(back ported from commit open-mpi/ompi@9a70765f27fdf17e70e1a115754fef7e5f16132a)
|
||||
|
||||
diff --git a/ompi/mca/coll/libnbc/nbc_internal.h b/ompi/mca/coll/libnbc/nbc_internal.h
|
||||
index bf2f1cb..81be8cc 100644
|
||||
--- a/ompi/mca/coll/libnbc/nbc_internal.h
|
||||
+++ b/ompi/mca/coll/libnbc/nbc_internal.h
|
||||
@@ -501,7 +501,14 @@ static inline int NBC_Copy(void *src, int srccount, MPI_Datatype srctype, void *
|
||||
} else {
|
||||
/* we have to pack and unpack */
|
||||
res = MPI_Pack_size(srccount, srctype, comm, &size);
|
||||
- if (MPI_SUCCESS != res || 0 == size) { printf("MPI Error in MPI_Pack_size() (%i:%i)\n", res, size); return (MPI_SUCCESS == res) ? MPI_ERR_SIZE : res;}
|
||||
+ if (MPI_SUCCESS != res) {
|
||||
+ printf ("MPI Error in MPI_Pack_size() (%i:%i)", res, size);
|
||||
+ return res;
|
||||
+ }
|
||||
+
|
||||
+ if (0 == size) {
|
||||
+ return OMPI_SUCCESS;
|
||||
+ }
|
||||
packbuf = malloc(size);
|
||||
if (NULL == packbuf) { printf("Error in malloc()\n"); return res; }
|
||||
pos=0;
|
||||
|
12
openmpi.spec
12
openmpi.spec
@ -21,8 +21,8 @@
|
||||
%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
|
||||
|
||||
Name: openmpi%{?_cc_name_suffix}
|
||||
Version: 1.10.1
|
||||
Release: 3%{?dist}
|
||||
Version: 1.10.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Open Message Passing Interface
|
||||
Group: Development/Libraries
|
||||
License: BSD, MIT and Romio
|
||||
@ -34,9 +34,6 @@ Source1: openmpi.module.in
|
||||
Source2: openmpi.pth.py2
|
||||
Source3: openmpi.pth.py3
|
||||
Source4: macros.openmpi
|
||||
# Upstream fix for mpi4py tests
|
||||
# http://www.open-mpi.org/community/lists/users/2015/11/28027.php
|
||||
Patch0: http://www.open-mpi.org/community/lists/users/att-28030/nbc_copy.patch
|
||||
|
||||
BuildRequires: gcc-gfortran
|
||||
%ifnarch s390
|
||||
@ -127,7 +124,6 @@ Contains development wrapper for compiling Java with openmpi.
|
||||
|
||||
%prep
|
||||
%setup -q -n openmpi-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
./configure --prefix=%{_libdir}/%{name} \
|
||||
@ -280,6 +276,10 @@ make check
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jan 21 2016 Orion Poplawski <orion@cora.nwra.com> - 1.10.2-1
|
||||
- Update to 1.10.2
|
||||
- Drop upsream nbc_copy patch
|
||||
|
||||
* Tue Nov 10 2015 Orion Poplawski <orion@cora.nwra.com> - 1.10.1-3
|
||||
- Add upstream patch to fix zero size message
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user