20 lines
580 B
Diff
20 lines
580 B
Diff
If libexecdir and sbindir are the same, avoid making an absolute symlink.
|
|
|
|
|
|
--- openldap-2.3.11/servers/slapd/Makefile.in.toollinks 2005-10-28 21:09:04.000000000 -0400
|
|
+++ openldap-2.3.11/servers/slapd/Makefile.in 2005-10-28 21:11:18.000000000 -0400
|
|
@@ -270,7 +270,12 @@
|
|
$(WRAP_LIBS)
|
|
$(RM) $(SLAPTOOLS)
|
|
for i in $(SLAPTOOLS); do \
|
|
- $(LN_S) slapd$(EXEEXT) $$i$(EXEEXT); done
|
|
+ if test $(libexecdir) != $(sbindir) ; then \
|
|
+ $(LN_S) $(libexecdir)/slapd$(EXEEXT) $$i$(EXEEXT); \
|
|
+ else \
|
|
+ $(LN_S) slapd$(EXEEXT) $$i$(EXEEXT); \
|
|
+ fi \
|
|
+ done
|
|
|
|
|
|
sslapd: version.o
|