ad3da8cc04
- upstream changes: - server: support for delta-syncrepl in multi master replication - server: add experimental backend - MDB - server: dynamic configuration for passwd, perl, shell, sock, and sql backends - server: support passwords in APR1 - library: support for Wahl (draft) - a lot of bugfixes - remove patches which were merged upstream
17 lines
524 B
Diff
17 lines
524 B
Diff
Build slapd as position-independent executable (PIE) to take an advantage of
|
|
address space layout randomization (ASLD).
|
|
|
|
Author: Thomas Woerner <twoerner@redhat.com>
|
|
|
|
--- a/servers/slapd/Makefile.in
|
|
+++ b/servers/slapd/Makefile.in
|
|
@@ -263,7 +263,7 @@ slapi/libslapi.la: FORCE
|
|
(cd slapi; $(MAKE) $(MFLAGS) all)
|
|
|
|
slapd: $(SLAPD_DEPENDS) @LIBSLAPI@
|
|
- $(LTLINK) -o $@ $(SLAPD_OBJECTS) $(LIBS) \
|
|
+ $(LTLINK) -pie -Wl,-z,defs -o $@ $(SLAPD_OBJECTS) $(LIBS) \
|
|
$(WRAP_LIBS)
|
|
$(RM) $(SLAPTOOLS)
|
|
for i in $(SLAPTOOLS); do \
|