6b99432a4e
- move nptl libraries into arch-specific subdirectories on %%{ix86} boxes - require a newer glibc which can provide nptl libpthread on i486/i586 - move slapd startup to earlier in the boot sequence (#103160) - change version number on compat-openldap to include the non-compat version from which it's compiled, otherwise would have to start 2.2.17 at release 3 so that it upgrades correctly so that version compare would sort correctly
27 lines
1.0 KiB
Diff
27 lines
1.0 KiB
Diff
Build both slapd and slurpd as position-independent executables. This really
|
|
should be threaded into the various autotools, but I guess this is what we have
|
|
until that happens, if it happens.
|
|
|
|
--- openldap-2.2.13/servers/slapd/Makefile.in 2004-04-12 14:07:40.000000000 -0400
|
|
+++ openldap-2.2.13/servers/slapd/Makefile.in 2004-06-15 13:45:45.000000000 -0400
|
|
@@ -255,7 +255,7 @@
|
|
cp slapi/.libs/libslapi.a .
|
|
|
|
slapd: $(SLAPD_DEPENDS) @LIBSLAPI@
|
|
- $(LTLINK) -o $@ $(SLAPD_OBJECTS) $(LIBS) \
|
|
+ $(LTLINK) -pie -Wl,-z,defs -o $@ $(SLAPD_OBJECTS) $(LIBS) \
|
|
$(WRAP_LIBS)
|
|
rm -f $(SLAPTOOLS)
|
|
for i in $(SLAPTOOLS); do \
|
|
--- openldap-2.2.13/servers/slurpd/Makefile.in 2004-01-01 13:16:42.000000000 -0500
|
|
+++ openldap-2.2.13/servers/slurpd/Makefile.in 2004-06-15 13:44:45.000000000 -0400
|
|
@@ -44,7 +44,7 @@
|
|
XXXLIBS = $(LTHREAD_LIBS)
|
|
|
|
slurpd: version.o
|
|
- $(LTLINK) -o $@ $(OBJS) version.o $(LIBS)
|
|
+ $(LTLINK) -pie -Wl,-z,defs -o $@ $(OBJS) version.o $(LIBS)
|
|
|
|
sslurpd: version.o
|
|
$(LTLINK) -static -o $@ $(OBJS) version.o $(LIBS)
|