add ldif.h interface into -devel subpackage
This commit is contained in:
parent
b2338c38f5
commit
31a7816a3a
@ -1,59 +1,18 @@
|
||||
Patch exposes LDIF reading/writing API. This change is required to replace
|
||||
mozldap with openldap in FreeIPA project.
|
||||
Add 'ldif.h' into -devel subpackage. 'libldif' was removed by upstrem and the symbols
|
||||
were moved to 'libldap'. But the interface is missing.
|
||||
|
||||
Upstream: ITS #6194
|
||||
Author: Rich Megginson <rmeggins@redhat.com>
|
||||
Author: Jan Vcelak <jvcelak@redhat.com>
|
||||
|
||||
--- openldap-2.4.24.orig/include/Makefile.in
|
||||
+++ openldap-2.4.24/include/Makefile.in
|
||||
diff -uNPrp openldap-2.4.25/include/Makefile.in openldap-2.4.25.ldif/include/Makefile.in
|
||||
--- openldap-2.4.25/include/Makefile.in 2011-01-05 00:49:52.000000000 +0100
|
||||
+++ openldap-2.4.25.ldif/include/Makefile.in 2011-06-27 17:13:57.629416190 +0200
|
||||
@@ -20,7 +20,8 @@ install-local: FORCE
|
||||
for header in $(srcdir)/lber.h lber_types.h \
|
||||
$(srcdir)/ldap.h $(srcdir)/ldap_cdefs.h \
|
||||
$(srcdir)/ldap_schema.h $(srcdir)/ldap_utf8.h \
|
||||
- $(srcdir)/slapi-plugin.h ldap_features.h; \
|
||||
+ $(srcdir)/slapi-plugin.h ldap_features.h \
|
||||
+ $(srcdir)/ldif.h ; \
|
||||
+ $(srcdir)/ldif.h; \
|
||||
do \
|
||||
$(INSTALL) $(INSTALLFLAGS) -m 644 $$header $(DESTDIR)$(includedir); \
|
||||
done
|
||||
--- openldap-2.4.24.orig/libraries/liblutil/Makefile.in
|
||||
+++ openldap-2.4.24/libraries/liblutil/Makefile.in
|
||||
@@ -14,6 +14,9 @@
|
||||
## <http://www.OpenLDAP.org/license.html>.
|
||||
|
||||
LIBRARY = liblutil.a
|
||||
+
|
||||
+SHAREDLIB = libldif.la
|
||||
+
|
||||
PROGRAM = testavl
|
||||
|
||||
LDAP_INCDIR= ../../include
|
||||
@@ -40,6 +43,8 @@ OBJS = base64.o entropy.o sasl.o signal.
|
||||
meter.o \
|
||||
@LIBOBJS@ $(@PLAT@_OBJS)
|
||||
|
||||
+SHAREDLIBOBJS = ldif.lo fetch.lo
|
||||
+
|
||||
testavl: $(XLIBS) testavl.o
|
||||
(LTLINK) -o $@ testavl.o $(LIBS)
|
||||
|
||||
@@ -59,3 +64,19 @@ slapdmsg.res: slapdmsg.rc slapdmsg.bin
|
||||
clean-local:
|
||||
$(RM) *.res
|
||||
|
||||
+all-local: $(SHAREDLIB)
|
||||
+
|
||||
+.SUFFIXES: .c .o .lo
|
||||
+
|
||||
+.c.lo:
|
||||
+ $(LTCOMPILE_LIB) $<
|
||||
+
|
||||
+$(LIBRARY): $(SHAREDLIBOBJS) version.lo
|
||||
+
|
||||
+$(SHAREDLIB): $(SHAREDLIBOBJS) version.lo
|
||||
+ $(LTLINK_LIB) -o $(SHAREDLIB) $(SHAREDLIBOBJS) version.lo $(LINK_LIBS)
|
||||
+
|
||||
+install-local: FORCE
|
||||
+ -$(MKDIR) $(DESTDIR)$(libdir)
|
||||
+ $(LTINSTALL) $(INSTALLFLAGS) -m 644 $(SHAREDLIB) $(DESTDIR)$(libdir)
|
||||
+ $(LTFINISH) $(DESTDIR)$(libdir)
|
||||
|
@ -602,7 +602,6 @@ exit 0
|
||||
%attr(0755,root,root) %dir %{_sysconfdir}/openldap
|
||||
%attr(0755,root,root) %dir %{_sysconfdir}/openldap/cacerts
|
||||
%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/openldap/ldap*.conf
|
||||
%attr(0755,root,root) %{_libdir}/libldif-2.4*.so.*
|
||||
%attr(0755,root,root) %{_libdir}/liblber-2.4*.so.*
|
||||
%attr(0755,root,root) %{_libdir}/libldap-2.4*.so.*
|
||||
%attr(0755,root,root) %{_libdir}/libldap_r-2.4*.so.*
|
||||
|
Loading…
Reference in New Issue
Block a user