Update 4.5.0
This commit is contained in:
parent
f4647943a4
commit
dfdbb6495c
@ -1,27 +1,32 @@
|
||||
#!/bin/bash
|
||||
|
||||
VERSION=4.3.0
|
||||
VERSION=4.5.0
|
||||
|
||||
rm -rf opencv-${VERSION}/
|
||||
wget -c https://github.com/opencv/opencv/archive/${VERSION}/opencv-${VERSION}.tar.gz
|
||||
tar xf opencv-${VERSION}.tar.gz
|
||||
cd opencv-${VERSION}/
|
||||
find ./ -iname "len*.*" -exec rm {} +
|
||||
rm -rf modules/xfeatures2d/
|
||||
find -iname "*lena*" -exec rm {} ';' -print
|
||||
find -iname "*lenna*" -exec rm {} ';' -print
|
||||
rm -r modules/xfeatures2d/
|
||||
cd ..; tar zcf opencv-clean-${VERSION}.tar.gz opencv-${VERSION}/
|
||||
rm -rf opencv-${VERSION}/
|
||||
rm -r opencv-${VERSION}/
|
||||
|
||||
rm -rf opencv_contrib-${VERSION}/
|
||||
wget -c https://github.com/opencv/opencv_contrib/archive/${VERSION}/opencv_contrib-${VERSION}.tar.gz
|
||||
tar xf opencv_contrib-${VERSION}.tar.gz
|
||||
cd opencv_contrib-${VERSION}/
|
||||
rm -rf modules/xfeatures2d/
|
||||
find -iname "*lena*" -exec rm {} ';' -print
|
||||
find -iname "*lenna*" -exec rm {} ';' -print
|
||||
rm -r modules/xfeatures2d/
|
||||
cd ..; tar zcf opencv_contrib-clean-${VERSION}.tar.gz opencv_contrib-${VERSION}/
|
||||
rm -rf opencv_contrib-${VERSION}/
|
||||
rm -r opencv_contrib-${VERSION}/
|
||||
|
||||
rm -rf opencv_extra-${VERSION}/
|
||||
wget -c https://github.com/opencv/opencv_extra/archive/${VERSION}/opencv_extra-${VERSION}.tar.gz
|
||||
tar xf opencv_extra-${VERSION}.tar.gz
|
||||
find opencv_extra-${VERSION} \( -iname "len*.*" -o -iname "*lena*.png" -o -iname "*lena*.jpg" \) -exec rm {} +
|
||||
find opencv_extra-${VERSION} -iname "*lena*" -exec rm {} ';' -print
|
||||
find opencv_extra-${VERSION} -iname "*lenna*" -exec rm {} ';' -print
|
||||
find opencv_extra-${VERSION} \( -iname "len*.*" -o -iname "*lena*.png" -o -iname "*lena*.jpg" \) -exec rm {} ';' -print
|
||||
tar zcf opencv_extra-clean-${VERSION}.tar.gz opencv_extra-${VERSION}/
|
||||
rm -rf opencv_extra-${VERSION}/
|
||||
rm -r opencv_extra-${VERSION}/
|
||||
|
37
opencv.spec
37
opencv.spec
@ -6,17 +6,7 @@
|
||||
%bcond_without gstreamer
|
||||
%bcond_with eigen2
|
||||
%bcond_without eigen3
|
||||
%ifnarch ppc64le
|
||||
%bcond_without opencl
|
||||
%else
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1487174
|
||||
# fixed on f30
|
||||
%if 0%{?fedora} > 29
|
||||
%bcond_without opencl
|
||||
%else
|
||||
%bcond_with opencl
|
||||
%endif
|
||||
%endif
|
||||
%ifarch %{ix86} x86_64 %{arm}
|
||||
%bcond_without openni
|
||||
%else
|
||||
@ -49,18 +39,13 @@
|
||||
%endif
|
||||
|
||||
%global srcname opencv
|
||||
%global abiver 4.3
|
||||
|
||||
# Required because opencv-core has lot of spurious dependencies
|
||||
# (despite supposed to be "-core")
|
||||
# TODO: to be fixed properly upstream
|
||||
# https://github.com/opencv/opencv/issues/7001
|
||||
%global optflags %(echo %{optflags} -Wl,--as-needed )
|
||||
|
||||
Name: opencv
|
||||
Version: 4.3.0
|
||||
Version: 4.5.0
|
||||
%global javaver %(foo=%{version}; echo ${foo//./})
|
||||
Release: 9%{?dist}
|
||||
%global abiver %(foo=%{version}; echo ${foo:0:3})
|
||||
Release: 1%{?dist}
|
||||
Summary: Collection of algorithms for computer vision
|
||||
# This is normal three clause BSD.
|
||||
License: BSD
|
||||
@ -79,10 +64,6 @@ Source4: b624b995ec9c439cbc2e9e6ee940d3a2-v0.1.1f.zip
|
||||
Source5: xorg.conf
|
||||
|
||||
Patch0: opencv-4.1.0-install_3rdparty_licenses.patch
|
||||
Patch1: https://patch-diff.githubusercontent.com/raw/opencv/opencv/pull/17431.patch
|
||||
Patch2: https://patch-diff.githubusercontent.com/raw/opencv/opencv_contrib/pull/2549.patch
|
||||
# Comment out removed vulkan symbols
|
||||
Patch3: opencv_vulkan.patch
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: libtool
|
||||
@ -149,6 +130,7 @@ BuildRequires: qt5-qtbase-devel
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: hdf5-devel
|
||||
BuildRequires: openjpeg2-devel
|
||||
# Module opencv_ovis disabled because of incompatible OGRE3D version < 1.10
|
||||
# BuildRequires: ogre-devel
|
||||
%{?with_vtk:BuildRequires: vtk-devel}
|
||||
@ -260,11 +242,8 @@ popd &>/dev/null
|
||||
%endif
|
||||
|
||||
%patch0 -p1 -b .install_3rdparty_licenses
|
||||
%patch1 -p1
|
||||
%patch3 -p1
|
||||
|
||||
pushd %{name}_contrib-%{version}
|
||||
%patch2 -p1
|
||||
popd
|
||||
|
||||
# Install face_landmark_model
|
||||
@ -464,6 +443,7 @@ ln -s -r %{buildroot}%{_jnidir}/opencv-%{javaver}.jar %{buildroot}%{_jnidir}/ope
|
||||
%{_libdir}/libopencv_hdf.so.%{abiver}*
|
||||
%{_libdir}/libopencv_img_hash.so.%{abiver}*
|
||||
%{_libdir}/libopencv_line_descriptor.so.%{abiver}*
|
||||
%{_libdir}/libopencv_mcc.so.%{abiver}*
|
||||
%{_libdir}/libopencv_optflow.so.%{abiver}*
|
||||
%{_libdir}/libopencv_phase_unwrapping.so.%{abiver}*
|
||||
%{_libdir}/libopencv_plot.so.%{abiver}*
|
||||
@ -481,6 +461,13 @@ ln -s -r %{buildroot}%{_jnidir}/opencv-%{javaver}.jar %{buildroot}%{_jnidir}/ope
|
||||
%{_libdir}/libopencv_xphoto.so.%{abiver}*
|
||||
|
||||
%changelog
|
||||
* Thu Oct 15 2020 Sérgio Basto <sergio@serjux.com> - 4.5.0-1
|
||||
- Update 4.5.0
|
||||
|
||||
* Wed Oct 07 2020 Sérgio Basto <sergio@serjux.com> - 4.4.0-1
|
||||
- Update 4.4.0
|
||||
- opencv_vulkan.patch already applied in upstream
|
||||
|
||||
* Thu Sep 24 2020 Adrian Reber <adrian@lisas.de> - 4.3.0-9
|
||||
- Rebuilt for protobuf 3.13
|
||||
|
||||
|
@ -1,28 +0,0 @@
|
||||
diff -rupN opencv-4.2.0/modules/dnn/src/vkcom/vulkan/function_list.inl.hpp opencv-4.2.0-new/modules/dnn/src/vkcom/vulkan/function_list.inl.hpp
|
||||
--- opencv-4.2.0/modules/dnn/src/vkcom/vulkan/function_list.inl.hpp 2019-12-20 14:44:16.000000000 +0100
|
||||
+++ opencv-4.2.0-new/modules/dnn/src/vkcom/vulkan/function_list.inl.hpp 2020-05-21 12:39:08.652679166 +0200
|
||||
@@ -254,15 +254,15 @@ VK_FUNC(vkCmdDrawIndirectCountAMD)
|
||||
VK_FUNC(vkCmdDrawIndexedIndirectCountAMD)
|
||||
VK_FUNC(vkGetShaderInfoAMD)
|
||||
VK_FUNC(vkGetPhysicalDeviceExternalImageFormatPropertiesNV)
|
||||
-VK_FUNC(vkCmdProcessCommandsNVX)
|
||||
-VK_FUNC(vkCmdReserveSpaceForCommandsNVX)
|
||||
-VK_FUNC(vkCreateIndirectCommandsLayoutNVX)
|
||||
-VK_FUNC(vkDestroyIndirectCommandsLayoutNVX)
|
||||
-VK_FUNC(vkCreateObjectTableNVX)
|
||||
-VK_FUNC(vkDestroyObjectTableNVX)
|
||||
-VK_FUNC(vkRegisterObjectsNVX)
|
||||
-VK_FUNC(vkUnregisterObjectsNVX)
|
||||
-VK_FUNC(vkGetPhysicalDeviceGeneratedCommandsPropertiesNVX)
|
||||
+// VK_FUNC(vkCmdProcessCommandsNVX)
|
||||
+// VK_FUNC(vkCmdReserveSpaceForCommandsNVX)
|
||||
+// VK_FUNC(vkCreateIndirectCommandsLayoutNVX)
|
||||
+// VK_FUNC(vkDestroyIndirectCommandsLayoutNVX)
|
||||
+// VK_FUNC(vkCreateObjectTableNVX)
|
||||
+// VK_FUNC(vkDestroyObjectTableNVX)
|
||||
+// VK_FUNC(vkRegisterObjectsNVX)
|
||||
+// VK_FUNC(vkUnregisterObjectsNVX)
|
||||
+// VK_FUNC(vkGetPhysicalDeviceGeneratedCommandsPropertiesNVX)
|
||||
VK_FUNC(vkCmdSetViewportWScalingNV)
|
||||
VK_FUNC(vkReleaseDisplayEXT)
|
||||
VK_FUNC(vkGetPhysicalDeviceSurfaceCapabilities2EXT)
|
8
sources
8
sources
@ -1,5 +1,5 @@
|
||||
SHA512 (opencv-clean-4.3.0.tar.gz) = f582ffc45d1143abf62eac7d6ed416986e6aa0e26d9a4a2cb4d88458e1eecb24ad33570dccd99004998a4899b0a9c05de7dfa405564c0e59bc91a48b7e9d2343
|
||||
SHA512 (b624b995ec9c439cbc2e9e6ee940d3a2-v0.1.1f.zip) = f2994d5e92a2ae05cee6e153943afe151ce734ced6e06dcdb02dee9fed9336a7f1ea69661d9e033f1412fbb5e2a44a6e641662c85be5ba0604d0446abeabe836
|
||||
SHA512 (opencv_contrib-clean-4.3.0.tar.gz) = bc4f88f3624cf4aed237f8cf36ef62b20f31205e891948797e416faa5e1dd215d1bad85506aa4afacb5c11988a6fc3f81f282fd82fe491f5ffa070f97cc793d5
|
||||
SHA512 (opencv-clean-4.5.0.tar.gz) = 536897f0fddaadb4cf5b23df7703e0826852867fdef0d9b9ee029c2c8df374246b9cb78795d1e8e4ef6da3285e1b6e4c74bea7aee16e974694d1ffa7a1d1d09f
|
||||
SHA512 (opencv_contrib-clean-4.5.0.tar.gz) = b9b42630847f0fbe083d2a3c8816ca676de668e25194b623973f351ba579a39144c858749087fc723333d41f44b0e0e30dd0ce86353e63ca3e4939fa590e0aea
|
||||
SHA512 (opencv_extra-clean-4.5.0.tar.gz) = 410693ca3a976ccf146ea04d5efa3a808f89c880b88dfa10dc9e7f1f37f639d4a3629fd5c402f44f2a68b22f6e7986ceb285d18a13af56ca866d49c4c6936180
|
||||
SHA512 (face_landmark_model.dat.xz) = 7558f29431bb9cad1f22ee067ad3ed41be8f68b865992eb7d3a5ce6b6b9e1d031cb03e33c3c149220ef8faebd0471703a8a3bbb06402bcc8ce76bd28317aa307
|
||||
SHA512 (opencv_extra-clean-4.3.0.tar.gz) = 0f9f8b027ed7a105a6ed09d8953bb5d8c44a03ea99495aaf1dd4380a1488ca1acc614ad160a59080be4723469116d1213f3af6dfda0062d56f3575f6d2179bc4
|
||||
SHA512 (b624b995ec9c439cbc2e9e6ee940d3a2-v0.1.1f.zip) = f2994d5e92a2ae05cee6e153943afe151ce734ced6e06dcdb02dee9fed9336a7f1ea69661d9e033f1412fbb5e2a44a6e641662c85be5ba0604d0446abeabe836
|
||||
|
Loading…
Reference in New Issue
Block a user