Update to 2.4.7

This commit is contained in:
Nicolas Chauvet 2013-11-14 21:53:27 +01:00
parent dd94c0e87b
commit cc055f4eef
5 changed files with 32 additions and 11 deletions

1
.gitignore vendored
View File

@ -10,3 +10,4 @@ OpenCV-2.1.0.tar.bz2
/OpenCV-2.4.4a-clean.tar.bz2
/opencv-2.4.5-clean.tar.xz
/opencv-clean-2.4.6.1.tar.xz
/opencv-clean-2.4.7.tar.xz

View File

@ -0,0 +1,12 @@
diff -up opencv-2.4.7/modules/ts/CMakeLists.txt.ts_static opencv-2.4.7/modules/ts/CMakeLists.txt
--- opencv-2.4.7/modules/ts/CMakeLists.txt.ts_static 2013-11-06 15:26:39.000000000 +0100
+++ opencv-2.4.7/modules/ts/CMakeLists.txt 2013-11-14 21:28:28.289051531 +0100
@@ -4,7 +4,7 @@ if(IOS)
ocv_module_disable(ts)
endif()
-set(OPENCV_MODULE_TYPE STATIC)
+#set(OPENCV_MODULE_TYPE STATIC)
set(OPENCV_MODULE_IS_PART_OF_WORLD FALSE)
if(HAVE_CUDA)

View File

@ -1,6 +1,6 @@
diff -up OpenCV-2.4.2/cmake/OpenCVGenPkgconfig.cmake.pkgcmake OpenCV-2.4.2/cmake/OpenCVGenPkgconfig.cmake
--- OpenCV-2.4.2/cmake/OpenCVGenPkgconfig.cmake.pkgcmake 2012-06-29 00:55:15.000000000 +0200
+++ OpenCV-2.4.2/cmake/OpenCVGenPkgconfig.cmake 2012-07-09 14:53:33.338597708 +0200
diff -up opencv-2.4.7/cmake/OpenCVGenPkgconfig.cmake.pkgcmake opencv-2.4.7/cmake/OpenCVGenPkgconfig.cmake
--- opencv-2.4.7/cmake/OpenCVGenPkgconfig.cmake.pkgcmake 2013-11-06 15:26:39.000000000 +0100
+++ opencv-2.4.7/cmake/OpenCVGenPkgconfig.cmake 2013-11-13 23:19:49.414798348 +0100
@@ -10,7 +10,7 @@
# -------------------------------------------------------------------------------------------
set(prefix "${CMAKE_INSTALL_PREFIX}")
@ -8,9 +8,9 @@ diff -up OpenCV-2.4.2/cmake/OpenCVGenPkgconfig.cmake.pkgcmake OpenCV-2.4.2/cmake
-set(libdir "") #TODO: need link paths for OpenCV_EXTRA_COMPONENTS
+set(libdir "\${prefix}/${OPENCV_LIB_INSTALL_PATH}")
set(includedir "\${prefix}/${OPENCV_INCLUDE_INSTALL_PATH}")
set(VERSION ${OPENCV_VERSION})
@@ -36,7 +36,7 @@ ocv_list_reverse(OpenCV_LIB_COMPONENTS)
if(CMAKE_BUILD_TYPE MATCHES "Release")
@@ -35,7 +35,7 @@ ocv_list_reverse(OpenCV_LIB_COMPONENTS)
ocv_list_reverse(OpenCV_EXTRA_COMPONENTS)
#build the list of components
@ -19,7 +19,7 @@ diff -up OpenCV-2.4.2/cmake/OpenCVGenPkgconfig.cmake.pkgcmake OpenCV-2.4.2/cmake
foreach(CVLib ${OpenCV_LIB_COMPONENTS})
get_target_property(libpath ${CVLib} LOCATION_${CMAKE_BUILD_TYPE})
get_filename_component(libname "${libpath}" NAME)
@@ -51,8 +51,10 @@ foreach(CVLib ${OpenCV_LIB_COMPONENTS})
@@ -50,8 +50,10 @@ foreach(CVLib ${OpenCV_LIB_COMPONENTS})
else()
set(installDir "${OPENCV_LIB_INSTALL_PATH}")
endif()

View File

@ -1,8 +1,8 @@
#global indice a
Name: opencv
Version: 2.4.6.1
Release: 2%{?dist}
Version: 2.4.7
Release: 1%{?dist}
Summary: Collection of algorithms for computer vision
Group: Development/Libraries
@ -12,6 +12,8 @@ URL: http://opencv.org
# Need to remove SIFT/SURF from source tarball, due to legal concerns
# rm -rf opencv-%%{version}/modules/nonfree/src/sift.cpp
# rm -rf opencv-%%{version}/modules/nonfree/src/surf.cpp
# Removed because we don't use pre-built contribs
# rm -rf 3rdparty
#Source0: http://downloads.sourceforge.net/opencvlibrary/opencv-unix/%{version}/%{name}-%{version}%{?indice}.tar.gz
Source0: %{name}-clean-%{version}%{?indice}.tar.xz
Source1: opencv-samples-Makefile
@ -19,6 +21,7 @@ Patch0: opencv-pkgcmake.patch
Patch1: opencv-pkgcmake2.patch
#http://code.opencv.org/issues/2720
Patch2: OpenCV-2.4.4-pillow.patch
Patch3: opencv-2.4.7-ts_static.patch
BuildRequires: libtool
BuildRequires: cmake >= 2.6.3
@ -40,6 +43,8 @@ BuildRequires: libpng-devel
BuildRequires: libjpeg-devel
BuildRequires: libtiff-devel
BuildRequires: libv4l-devel
BuildRequires: libGL-devel
BuildRequires: gtkglext-devel
BuildRequires: OpenEXR-devel
%{?_with_openni:
%ifarch %{ix86} x86_64
@ -114,6 +119,7 @@ This package contains Python bindings for the OpenCV library.
%patch0 -p1 -b .pkgcmake
%patch1 -p1 -b .pkgcmake2
%patch2 -p1 -b .pillow
%patch3 -p1 -b .ts_static
# fix dos end of lines
sed -i 's|\r||g' samples/c/adaptiveskindetector.cpp
@ -220,8 +226,8 @@ popd
%{_libdir}/libopencv_legacy.so.2.4*
%{_libdir}/libopencv_objdetect.so.2.4*
%{_libdir}/libopencv_stitching.so.2.4*
%{_libdir}/libopencv_ts.so.2.4*
%{_libdir}/libopencv_superres.so.2.4*
%{_libdir}/libopencv_ts.so.2.4*
%{_libdir}/libopencv_videostab.so.2.4*
%dir %{_datadir}/OpenCV
%{_datadir}/OpenCV/haarcascades
@ -248,7 +254,6 @@ popd
%files devel-docs
%doc doc/*.{htm,png,jpg}
%doc %{_datadir}/OpenCV/samples
%doc %{_datadir}/opencv/samples
%files python
%{python_sitearch}/cv.py*
@ -256,6 +261,9 @@ popd
%changelog
* Wed Nov 13 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-1
- Update to 2.4.7
* Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.6.1-2
- rebuild (openexr)

View File

@ -1 +1 @@
2d3953ed758812f1836e58b6b70e6955 opencv-clean-2.4.6.1.tar.xz
b540d75cdc7695098ab19fc7f56fd267 opencv-clean-2.4.7.tar.xz