Update to 4.5.4

This commit is contained in:
Sérgio M. Basto 2021-10-10 23:54:27 +01:00
parent c810b39bfb
commit 9d58856c22
4 changed files with 20 additions and 6 deletions

View File

@ -1,6 +1,6 @@
#!/bin/bash
VERSION=4.5.3
VERSION=4.5.4
wget -c https://github.com/opencv/opencv/archive/${VERSION}/opencv-${VERSION}.tar.gz
wget -c https://github.com/opencv/opencv_contrib/archive/${VERSION}/opencv_contrib-${VERSION}.tar.gz

View File

@ -47,10 +47,10 @@
%endif
Name: opencv
Version: 4.5.3
Version: 4.5.4
%global javaver %(foo=%{version}; echo ${foo//./})
%global abiver %(foo=%{version}; echo ${foo:0:3})
Release: 6%{?dist}
Release: 1%{?dist}
Summary: Collection of algorithms for computer vision
# This is normal three clause BSD.
License: BSD
@ -69,6 +69,7 @@ Source4: b624b995ec9c439cbc2e9e6ee940d3a2-v0.1.1f.zip
Source5: xorg.conf
Patch0: opencv-4.1.0-install_3rdparty_licenses.patch
Patch1: opencv_contrib-4.5.4-enable_cvv.patch
BuildRequires: gcc-c++
BuildRequires: libtool
@ -251,6 +252,7 @@ popd &>/dev/null
%patch0 -p1 -b .install_3rdparty_licenses
pushd %{name}_contrib-%{version}
%patch1 -p1 -b .install_cvv
popd
# Install face_landmark_model
@ -258,6 +260,7 @@ mkdir -p .cache/data
install -pm 0644 %{SOURCE3} .cache/data
pushd .cache/data
xz -d face_landmark_model.dat.xz
mv face_landmark_model.dat 7505c44ca4eb54b4ab1e4777cb96ac05-face_landmark_model.dat
popd
# Install ADE, needed for opencv_gapi
@ -479,6 +482,9 @@ ln -s -r %{buildroot}%{_jnidir}/opencv-%{javaver}.jar %{buildroot}%{_jnidir}/ope
%{_libdir}/libopencv_xphoto.so.%{abiver}*
%changelog
* Sun Oct 10 2021 Sérgio Basto <sergio@serjux.com> - 4.5.4-1
- Update to 4.5.4
* Fri Aug 20 2021 Richard Shaw <hobbes1069@gmail.com> - 4.5.3-6
- Rebuild for OpenEXR/Imath 3.1.

View File

@ -0,0 +1,8 @@
--- opencv_contrib-4.5.4/modules/cvv/CMakeLists.txt.orig 2021-10-10 20:30:59.898095647 +0100
+++ opencv_contrib-4.5.4/modules/cvv/CMakeLists.txt 2021-10-10 20:31:11.609057069 +0100
@@ -1,4 +1,4 @@
-if(NOT HAVE_QT5 OR NOT HAVE_CXX11)
+if(NOT HAVE_QT OR NOT HAVE_CXX11)
ocv_module_disable(cvv)
return()
endif()

View File

@ -1,5 +1,5 @@
SHA512 (face_landmark_model.dat.xz) = 7558f29431bb9cad1f22ee067ad3ed41be8f68b865992eb7d3a5ce6b6b9e1d031cb03e33c3c149220ef8faebd0471703a8a3bbb06402bcc8ce76bd28317aa307
SHA512 (b624b995ec9c439cbc2e9e6ee940d3a2-v0.1.1f.zip) = f2994d5e92a2ae05cee6e153943afe151ce734ced6e06dcdb02dee9fed9336a7f1ea69661d9e033f1412fbb5e2a44a6e641662c85be5ba0604d0446abeabe836
SHA512 (opencv-clean-4.5.3.tar.gz) = 85f6d145da8b4c0c0ad8d3d4a0f99de1043ea3bc41f6957ce8fe3ef746d4c255ad502495a58fba31e76b527b2e6fea875ec6f5e5e2ced880235678122089fd21
SHA512 (opencv_contrib-clean-4.5.3.tar.gz) = 4c1fa68f0b2c523504cd3fa46e1109e8e615714c4bca6701ad1dec37440e0ae7a5303eb3c0668df1a07062c59a64088c3d39f3adff93a1637e73e95683bfa7f2
SHA512 (opencv_extra-clean-4.5.3.tar.gz) = e5eb9aedcf7e36cda8a5df9ddfca493c6edb32a70331320877d75628db0f372d8826daaa7000f54fa9d89e176b480a69dcf2ede0e3f3e851692ad2be037b4473
SHA512 (opencv-clean-4.5.4.tar.gz) = 630b57d8d499213a825915ac16735d93217e68872a174e9d82137300e0be49d287c26c3e8f23e44bccd428ba92cd890d6301cff35e275dc7ec5a269876d8eb2c
SHA512 (opencv_contrib-clean-4.5.4.tar.gz) = f00b2c3c56620191c244332f608087754a85c3d6b0331eb2b3038062f6b1e095f9995f93554175184e1d58d4c943be8e87e8e3cf1aeceb464ec57284ce794bc8
SHA512 (opencv_extra-clean-4.5.4.tar.gz) = 4ee5deba106e7becdb3dddb0c62267dbae2ec172e6dbcd664a991a5186a33c50ab3956e4eab21e22a746a4e5b8953086ee9d4e32ed6bafa2b26877f644f90fc5