Fix nonstandard executable permissions (more complete debuginfo, python so

files stripped) Removed unused old patches
This commit is contained in:
Karel Klíč 2010-04-13 17:44:28 +00:00
parent db0fac94f5
commit 83f1587798
9 changed files with 10 additions and 206 deletions

View File

@ -1,12 +0,0 @@
diff -up opencv-1.0.0/cxcore/include/cxmisc.h.gcc44 opencv-1.0.0/cxcore/include/cxmisc.h
--- opencv-1.0.0/cxcore/include/cxmisc.h.gcc44 2006-05-04 17:55:17.000000000 +0200
+++ opencv-1.0.0/cxcore/include/cxmisc.h 2009-04-22 12:42:49.000000000 +0200
@@ -130,7 +130,7 @@
#include <alloca.h>
#elif defined HAVE_ALLOCA
#include <stdlib.h>
-#elif
+#else
#error
#endif

View File

@ -1,52 +0,0 @@
diff -up opencv-1.1.0/configure.in.nooptim opencv-1.1.0/configure.in
--- opencv-1.1.0/configure.in.nooptim 2008-10-15 17:47:43.000000000 +0200
+++ opencv-1.1.0/configure.in 2009-04-23 18:54:30.000000000 +0200
@@ -274,41 +274,41 @@ else
AC_MSG_NOTICE( TARGET=$target )
case $target in
i*86-apple-*)
- if test x"$ac_cv_c_compiler_gnu" = "xyes"; then
+ if test x"no" = "xyes"; then
# apples g++ fails with '-march=i686' and there are no apple machines older than prescott/core anyway
DEFAULT_CXXFLAGS="-g -march=prescott -ffast-math -fomit-frame-pointer $DEFAULT_CXXFLAGS"
fi
;;
i686-*-*)
- if test x"$ac_cv_c_compiler_gnu" = "xyes"; then
+ if test x"no" = "xyes"; then
# default to i686/pentiumpro -- people can override this
DEFAULT_CXXFLAGS="-g -march=i686 -ffast-math -fomit-frame-pointer $DEFAULT_CXXFLAGS"
fi
;;
amd64-*-* | x86_64-*-*)
- if test x"$ac_cv_c_compiler_gnu" = "xyes"; then
+ if test x"no" = "xyes"; then
# default to i686/pentiumpro -- people can override this
DEFAULT_CXXFLAGS="-g $DEFAULT_CXXFLAGS"
fi
;;
powerpc-*-*)
- if test x"$ac_cv_c_compiler_gnu" = "xyes"; then
+ if test x"no" = "xyes"; then
# default to G3 processors -- people can override this
DEFAULT_CXXFLAGS="-g -mcpu=G3 -mtune=G5 -fomit-frame-pointer $DEFAULT_CXXFLAGS"
fi
;;
*-*-*)
- if test x"$ac_cv_c_compiler_gnu" = "xyes"; then
+ if test x"no" = "xyes"; then
DEFAULT_CXXFLAGS="-fomit-frame-pointer $DEFAULT_CXXFLAGS"
fi
;;
esac
CPPFLAGS="-DNDEBUG $CPPFLAGS"
- DEFAULT_CXXFLAGS="-O3 $DEFAULT_CXXFLAGS"
+# DEFAULT_CXXFLAGS="-O3 $DEFAULT_CXXFLAGS"
fi
-if test x"$ac_cv_c_compiler_gnu" = "xyes"; then
+if test x"no" = "xyes"; then
PY_CXXFLAGS="-Wall -pipe $DEFAULT_CXXFLAGS"
OCT_CXXFLAGS="-fno-strict-aliasing -Wall -Wno-uninitialized -pipe $DEFAULT_CXXFLAGS"
DEF_CXXFLAGS="-Wall -fno-rtti -pipe $DEFAULT_CXXFLAGS"

View File

@ -1,12 +0,0 @@
diff -up opencv-1.1.0/configure.in.conflicts opencv-1.1.0/configure.in
--- opencv-1.1.0/configure.in.conflicts 2009-04-24 12:01:24.000000000 +0200
+++ opencv-1.1.0/configure.in 2009-04-24 12:01:29.000000000 +0200
@@ -37,7 +37,7 @@ AC_PREREQ(2.60)
AC_INIT([opencv],[opencv_version],[opencvlibrary-devel@lists.sourceforge.net])
AC_CONFIG_SRCDIR([opencv.pc.in])
AC_CONFIG_AUX_DIR([autotools])
-AC_CONFIG_MACRO_DIR([autotools/aclocal])
+
# put CVS revision of this configure.in into the resulting configure script
AC_REVISION($Revision: 1.60 $)

View File

@ -1,15 +0,0 @@
diff -up opencv-1.1.0/interfaces/swig/python/Makefile.am.pydir opencv-1.1.0/interfaces/swig/python/Makefile.am
--- opencv-1.1.0/interfaces/swig/python/Makefile.am.pydir 2009-04-24 10:48:47.000000000 +0200
+++ opencv-1.1.0/interfaces/swig/python/Makefile.am 2009-04-24 10:49:49.000000000 +0200
@@ -107,9 +107,9 @@ endif
if BUILD_PYTHON_WRAPPERS
#pkgpython_LTLIBRARIES = _cv.la _highgui.la
-pkgpython_LTLIBRARIES = _cv.la _ml.la _highgui.la
+pkgpyexec_LTLIBRARIES = _cv.la _ml.la _highgui.la
-pkgpython_PYTHON = \
+pkgpyexec_PYTHON = \
__init__.py \
cv.py \
ml.py \

View File

@ -1,14 +0,0 @@
diff -up opencv-1.1.0/samples/c/Makefile.am.automake opencv-1.1.0/samples/c/Makefile.am
--- opencv-1.1.0/samples/c/Makefile.am.automake 2009-07-16 09:19:35.000000000 +0200
+++ opencv-1.1.0/samples/c/Makefile.am 2009-07-16 09:21:46.000000000 +0200
@@ -7,8 +7,8 @@ left08.jpg left09.jpg left11.jpg left12.
right01.jpg right02.jpg right03.jpg right04.jpg right05.jpg right06.jpg right07.jpg \
right08.jpg right09.jpg right11.jpg right12.jpg right13.jpg right14.jpg \
stereo_calib.txt build_all.sh cvsample.dsp makefile.ms makefile.gnu \
-agaricus-lepiota.data letter-recognition.data bgfg_codebook.cpp bgfg_segm.cpp blobtrack.cpp camshiftdemo.c \
-contours.c convexhull.c camshiftdemo.c contours.c convert_cascade.c convexhull.c \
+agaricus-lepiota.data letter-recognition.data bgfg_codebook.cpp bgfg_segm.cpp blobtrack.cpp \
+camshiftdemo.c contours.c convert_cascade.c convexhull.c \
delaunay.c demhist.c dft.c distrans.c drawing.c edge.c facedetect.c \
facedetect.cmd ffilldemo.c find_obj.cpp fitellipse.c houghlines.c kalman.c kmeans.c image.cpp \
inpaint.cpp laplace.c letter_recog.cpp lkdemo.c minarea.c morphology.c motempl.c \

View File

@ -1,40 +0,0 @@
diff -up opencv-1.1.0/otherlibs/highgui/cvcap_xine.cpp.gcc43 opencv-1.1.0/otherlibs/highgui/cvcap_xine.cpp
--- opencv-1.1.0/otherlibs/highgui/cvcap_xine.cpp.gcc43 2008-05-03 20:20:57.000000000 +0200
+++ opencv-1.1.0/otherlibs/highgui/cvcap_xine.cpp 2009-07-16 12:30:58.000000000 +0200
@@ -784,7 +784,7 @@ public:
CvCaptureAVI_XINE_CPP() { captureXINE = 0; }
virtual ~CvCaptureAVI_XINE_CPP() { close(); }
- virtual bool open( int index );
+ virtual bool open( const char* filename );
virtual void close();
virtual double getProperty(int);
@@ -796,10 +796,10 @@ protected:
CvCaptureAVI_XINE* captureXINE;
};
-bool CvCaptureAVI_XINE_CPP::open( int index )
+bool CvCaptureAVI_XINE_CPP::open( const char* filename )
{
close();
- captureXINE = icvCaptureFromFile_XINE(index);
+ captureXINE = icvCaptureFromFile_XINE(filename);
return captureXINE != 0;
}
@@ -832,11 +832,11 @@
return captureXINE ? icvSetPropertyAVI_XINE( captureXINE, propId, value ) != 0 : false;
}
-CvCapture* cvCreateCameraCapture_XINE( int index )
+CvCapture* cvCreateFileCapture_XINE(const char* filename)
{
CvCaptureAVI_XINE_CPP* capture = new CvCaptureAVI_XINE_CPP;
- if( capture->open( index ))
+ if( capture->open(filename))
return capture;
delete capture;

View File

@ -1,50 +0,0 @@
--- OpenCV-2.0.0/apps/Makefile.am.orig 2009-10-01 01:20:58.000000000 +0100
+++ OpenCV-2.0.0/apps/Makefile.am 2009-12-04 13:36:09.000000000 +0100
@@ -4,11 +4,16 @@ AM_LDFLAGS = @OPENMP_CXXFLAGS@
EXTRA_DIST = \
CMakeLists.txt \
- haartraining/CMakeLists.txt
+ haartraining/CMakeLists.txt \
+ transcascade/CMakeLists.txt
noinst_LTLIBRARIES = libcvhaartraining.la
-bin_PROGRAMS = opencv-haartraining opencv-createsamples opencv-performance
+bin_PROGRAMS = \
+ opencv-haartraining \
+ opencv-createsamples \
+ opencv-performance \
+ opencv-traincascade
ALL_CV_LIBS = \
$(top_builddir)/src/libhighgui.la \
@@ -27,7 +32,12 @@ noinst_HEADERS = \
haartraining/cvclassifier.h \
haartraining/cvhaartraining.h \
haartraining/_cvhaartraining.h \
- haartraining/_cvcommon.h
+ haartraining/_cvcommon.h \
+ traincascade/boost.h \
+ traincascade/cascadeclassifier.h \
+ traincascade/features.h \
+ traincascade/imagestorage.h \
+ traincascade/lbpfeatures.h
opencv_haartraining_SOURCES = haartraining/haartraining.cpp
opencv_haartraining_LDADD = libcvhaartraining.la $(ALL_CV_LIBS)
@@ -38,3 +48,14 @@ opencv_createsamples_LDADD = libcvhaartr
opencv_performance_SOURCES = haartraining/performance.cpp
opencv_performance_LDADD = libcvhaartraining.la $(ALL_CV_LIBS)
+opencv_traincascade_SOURCES = \
+ traincascade/traincascade.cpp \
+ traincascade/cascadeclassifier.cpp \
+ traincascade/boost.cpp \
+ traincascade/features.cpp \
+ traincascade/haarfeatures.cpp \
+ traincascade/lbpfeatures.cpp \
+ traincascade/imagestorage.cpp
+opencv_traincascade_LDADD = \
+ $(ALL_CV_LIBS) \
+ $(top_builddir)/src/libml.la

View File

@ -1,10 +0,0 @@
--- OpenCV-2.0.0/data/Makefile.am.orig 2009-10-01 01:20:58.000000000 +0100
+++ OpenCV-2.0.0/data/Makefile.am 2009-12-04 13:05:11.000000000 +0100
@@ -25,4 +25,6 @@
haarcascades/haarcascade_mcs_mouth.xml \
haarcascades/haarcascade_mcs_nose.xml \
haarcascades/haarcascade_mcs_righteye.xml \
- haarcascades/haarcascade_mcs_upperbody.xml
+ haarcascades/haarcascade_mcs_upperbody.xml \
+ \
+ lbpcascades/lbpcascade_frontalface.xml

View File

@ -4,7 +4,7 @@
Name: opencv
Version: 2.0.0
Release: 9%{?dist}
Release: 10%{?dist}
Summary: Collection of algorithms for computer vision
Group: Development/Libraries
@ -130,6 +130,12 @@ sed -i 's|\r||g' $RPM_BUILD_ROOT/%{_datadir}/%{name}/samples/c/adaptiveskindete
# remove unnecessary documentation
rm -rf $RPM_BUILD_ROOT%{_datadir}/opencv/{doc/,samples/octave/}
# Fix nonstandard executable permissions
chmod 0755 $RPM_BUILD_ROOT%{_datadir}/opencv/samples/python/*.py
chmod 0755 $RPM_BUILD_ROOT%{python_sitearch}/cv.so
chmod 0755 $RPM_BUILD_ROOT%{python_sitearch}/opencv/*.so
%check
# Check fails since we don't support most video
# read/write capability and we don't provide a display
@ -184,6 +190,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Tue Apr 13 2010 Karel Klic <kklic@redhat.com> - 2.0.0-10
- Fix nonstandard executable permissions
* Mon Mar 09 2010 Karel Klic <kklic@redhat.com> - 2.0.0-9
- apply the previously added patch