Update opencv to 4.5.5 (#2035628)

This commit is contained in:
Sérgio M. Basto 2021-12-28 17:13:16 +00:00
parent c0ffc90083
commit 7a7944b9e7
5 changed files with 42 additions and 18 deletions

View File

@ -0,0 +1,28 @@
From 81a6d1b0d4d93a3330cc99fbb1601c90b9516a9c Mon Sep 17 00:00:00 2001
From: Alexander Alekhin <alexander.a.alekhin@gmail.com>
Date: Thu, 2 Dec 2021 13:32:59 +0000
Subject: [PATCH] cmake: update SOVERSION
- OpenCV 4.x doesn't guarantee or maintain ABI compatibility
- We should increase SO version on each release
---
cmake/OpenCVVersion.cmake | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/cmake/OpenCVVersion.cmake b/cmake/OpenCVVersion.cmake
index a2b4926cf0d2..6ffaab94cf02 100644
--- a/cmake/OpenCVVersion.cmake
+++ b/cmake/OpenCVVersion.cmake
@@ -10,8 +10,10 @@ set(OPENCV_VERSION_PLAIN "${OPENCV_VERSION_MAJOR}.${OPENCV_VERSION_MINOR}.${OPEN
set(OPENCV_VERSION "${OPENCV_VERSION_PLAIN}${OPENCV_VERSION_STATUS}")
-set(OPENCV_SOVERSION "${OPENCV_VERSION_MAJOR}.${OPENCV_VERSION_MINOR}")
-set(OPENCV_LIBVERSION "${OPENCV_VERSION_MAJOR}.${OPENCV_VERSION_MINOR}.${OPENCV_VERSION_PATCH}")
+string(REGEX MATCH "[0-9][0-9]$" OPENCV_VERSION_MINOR_2DIGITS "00${OPENCV_VERSION_MINOR}")
+string(REGEX MATCH "[0-9][0-9]$" OPENCV_VERSION_PATCH_2DIGITS "00${OPENCV_VERSION_PATCH}")
+ocv_update(OPENCV_SOVERSION "${OPENCV_VERSION_MAJOR}${OPENCV_VERSION_MINOR_2DIGITS}")
+ocv_update(OPENCV_LIBVERSION "${OPENCV_VERSION_MAJOR}.${OPENCV_VERSION_MINOR}.${OPENCV_VERSION_PATCH}")
# create a dependency on the version file
# we never use the output of the following command but cmake will rerun automatically if the version file changes

View File

@ -1,6 +1,6 @@
#!/bin/bash
VERSION=4.5.4
VERSION=4.5.5
wget -c https://github.com/opencv/opencv/archive/${VERSION}/opencv-${VERSION}.tar.gz
wget -c https://github.com/opencv/opencv_contrib/archive/${VERSION}/opencv_contrib-${VERSION}.tar.gz

View File

@ -47,15 +47,16 @@
%endif
Name: opencv
Version: 4.5.4
Version: 4.5.5
%global javaver %(foo=%{version}; echo ${foo//./})
%global abiver %(foo=%{version}; echo ${foo:0:3})
Release: 8%{?dist}
Release: 1%{?dist}
Summary: Collection of algorithms for computer vision
# This is normal three clause BSD.
License: BSD
URL: https://opencv.org
# RUN opencv-clean.sh TO PREPARE TARBALLS FOR FEDORA
# TO PREPARE TARBALLS FOR FEDORA
# Edit opencv-clean.sh and set VERSION, save file, after run opencv-clean.sh
#
# Need to remove copyrighted lena.jpg images from tarball (rhbz#1295173)
# and SIFT/SURF from tarball, due to legal concerns.
@ -69,10 +70,9 @@ Source4: b624b995ec9c439cbc2e9e6ee940d3a2-v0.1.1f.zip
Source5: xorg.conf
Patch0: opencv-4.1.0-install_3rdparty_licenses.patch
Patch1: opencv_contrib-4.5.4-enable_cvv.patch
Patch1: 81a6d1b0d4d93a3330cc99fbb1601c90b9516a9c.patch
BuildRequires: gcc-c++
BuildRequires: libtool
BuildRequires: cmake >= 2.6.3
BuildRequires: chrpath
%{?with_cuda:
@ -250,9 +250,10 @@ popd &>/dev/null
%endif
%patch0 -p1 -b .install_3rdparty_licenses
%patch1 -p1 -R -b .soversion
pushd %{name}_contrib-%{version}
%patch1 -p1 -b .install_cvv
#patch1 -p1 -b .install_cvv
popd
# Install face_landmark_model
@ -482,6 +483,9 @@ ln -s -r %{buildroot}%{_jnidir}/opencv-%{javaver}.jar %{buildroot}%{_jnidir}/ope
%{_libdir}/libopencv_xphoto.so.%{abiver}*
%changelog
* Mon Dec 27 2021 Sérgio Basto <sergio@serjux.com> - 4.5.5-1
- Update opencv to 4.5.5 (#2035628)
* Sun Dec 19 2021 Sandro Mani <manisandro@gmail.com> - 4.5.4-8
- Rebuild (tesseract)

View File

@ -1,8 +0,0 @@
--- opencv_contrib-4.5.4/modules/cvv/CMakeLists.txt.orig 2021-10-10 20:30:59.898095647 +0100
+++ opencv_contrib-4.5.4/modules/cvv/CMakeLists.txt 2021-10-10 20:31:11.609057069 +0100
@@ -1,4 +1,4 @@
-if(NOT HAVE_QT5 OR NOT HAVE_CXX11)
+if(NOT HAVE_QT OR NOT HAVE_CXX11)
ocv_module_disable(cvv)
return()
endif()

View File

@ -1,5 +1,5 @@
SHA512 (opencv-clean-4.5.5.tar.gz) = e98c7a864c9747185cda7711761fb5a15dee77c11d9082c53f43922fc77c44d808acb489fc3384fc4be1255e03529ae36202b013b04d1b5e7208cdcce76a8477
SHA512 (opencv_contrib-clean-4.5.5.tar.gz) = 7fb0d65a0a808b80538bbf9c108c84d45f1e416b6924b0d1e3b7b5cebfeca192a6cad26d282e7d74e804ee8186dea0d08e959472bb68f159cb2575b637b3ed40
SHA512 (opencv_extra-clean-4.5.5.tar.gz) = 5e12e33dbd63785cd857cff2bde3297abf01726c0b54a7cd33eb594c510b524d69ea8ee4e89574bf33a8ac9a1d275a3d9f4f40b53180d3709cc58842b5ad5107
SHA512 (face_landmark_model.dat.xz) = 7558f29431bb9cad1f22ee067ad3ed41be8f68b865992eb7d3a5ce6b6b9e1d031cb03e33c3c149220ef8faebd0471703a8a3bbb06402bcc8ce76bd28317aa307
SHA512 (b624b995ec9c439cbc2e9e6ee940d3a2-v0.1.1f.zip) = f2994d5e92a2ae05cee6e153943afe151ce734ced6e06dcdb02dee9fed9336a7f1ea69661d9e033f1412fbb5e2a44a6e641662c85be5ba0604d0446abeabe836
SHA512 (opencv-clean-4.5.4.tar.gz) = 630b57d8d499213a825915ac16735d93217e68872a174e9d82137300e0be49d287c26c3e8f23e44bccd428ba92cd890d6301cff35e275dc7ec5a269876d8eb2c
SHA512 (opencv_contrib-clean-4.5.4.tar.gz) = f00b2c3c56620191c244332f608087754a85c3d6b0331eb2b3038062f6b1e095f9995f93554175184e1d58d4c943be8e87e8e3cf1aeceb464ec57284ce794bc8
SHA512 (opencv_extra-clean-4.5.4.tar.gz) = 4ee5deba106e7becdb3dddb0c62267dbae2ec172e6dbcd664a991a5186a33c50ab3956e4eab21e22a746a4e5b8953086ee9d4e32ed6bafa2b26877f644f90fc5