Update to 3.4.2

This commit is contained in:
Sérgio M. Basto 2018-09-26 20:17:16 +01:00
parent 59fec25454
commit 5ffe0b28c9
6 changed files with 12 additions and 32 deletions

2
.gitignore vendored
View File

@ -24,3 +24,5 @@ OpenCV-2.1.0.tar.bz2
/opencv-clean-3.3.1.tar.gz
/opencv_contrib-clean-3.4.1.tar.gz
/opencv-clean-3.4.1.tar.gz
/opencv_contrib-clean-3.4.2.tar.gz
/opencv-clean-3.4.2.tar.gz

View File

@ -1,9 +0,0 @@
--- ./samples/va_intel/CMakeLists.txt.bak 2018-02-28 01:53:40.199554269 +0000
+++ ./samples/va_intel/CMakeLists.txt 2018-02-28 01:54:34.036200492 +0000
@@ -17,5 +17,5 @@ ocv_include_modules_recurse(${OPENCV_VA_
file(GLOB all_samples RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.cpp)
foreach(sample_filename ${all_samples})
ocv_define_sample(tgt ${sample_filename} va_intel)
- ocv_target_link_libraries(${tgt} ${OPENCV_LINKER_LIBS} ${OPENCV_VA_INTEL_SAMPLES_REQUIRED_DEPS})
+ ocv_target_link_libraries(${tgt} ${OPENCV_LINKER_LIBS} ${OPENCV_VA_INTEL_SAMPLES_REQUIRED_DEPS} ${VA_LIBRARIES} ${VA_INTEL_LIBRARIES})
endforeach()

View File

@ -1,13 +0,0 @@
diff --git a/modules/python/src2/cv2.cpp b/modules/python/src2/cv2.cpp
index fab60fd03..2c48041dc 100644
--- a/modules/python/src2/cv2.cpp
+++ b/modules/python/src2/cv2.cpp
@@ -886,7 +886,7 @@ bool pyopencv_to(PyObject* obj, String& value, const char* name)
(void)name;
if(!obj || obj == Py_None)
return true;
- char* str = PyString_AsString(obj);
+ const char* str = PyString_AsString(obj);
if(!str)
return false;
value = String(str);

View File

@ -1,4 +1,4 @@
export VERSION=3.4.1
export VERSION=3.4.2
wget -c https://github.com/opencv/opencv/archive/${VERSION}/opencv-${VERSION}.tar.gz
tar xf opencv-${VERSION}.tar.gz

View File

@ -46,8 +46,8 @@
%global optflags %(echo %{optflags} -Wl,--as-needed )
Name: opencv
Version: 3.4.1
Release: 6%{?dist}
Version: 3.4.2
Release: 1%{?dist}
Summary: Collection of algorithms for computer vision
# This is normal three clause BSD.
License: BSD
@ -62,8 +62,6 @@ Source1: %{name}_contrib-clean-%{version}.tar.gz
# fix/simplify cmake config install location (upstreamable)
# https://bugzilla.redhat.com/1031312
Patch1: opencv-3.4.1-cmake_paths.patch
Patch2: opencv-3.4.1-cmake_va_intel_fix.patch
Patch3: opencv-3.4.1-python37.patch
BuildRequires: libtool
BuildRequires: cmake >= 2.6.3
@ -229,12 +227,10 @@ rm -r 3rdparty/
rm -r modules/dnn/
%patch1 -p1 -b .cmake_paths
%patch2 -p1 -b .va_intel
%patch3 -p1 -b .python37
pushd %{name}_contrib-%{version}
# missing dependecies for dnn_modern module in Fedora (tiny-dnn)
rm -r modules/dnn_modern/
#rm -r modules/dnn_modern/
popd
# fix dos end of lines
@ -297,6 +293,7 @@ popd
%install
%make_install -C build
find %{buildroot} -name '*.la' -delete
rm -rf %{buildroot}%{_datadir}/OpenCV/licenses/
%check
# Check fails since we don't support most video
@ -396,6 +393,9 @@ popd
%{_libdir}/libopencv_xphoto.so.%{abiver}*
%changelog
* Wed Sep 26 2018 Sérgio Basto <sergio@serjux.com> - 3.4.2-1
- Update to 3.4.2
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.4.1-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

View File

@ -1,2 +1,2 @@
SHA512 (opencv_contrib-clean-3.4.1.tar.gz) = 1bdd54f3f48a268a1099a91456415af86ef2d449ef547ac14447cf5fcc6af84561e76f183b6124ecc638a8b80b312909521a4c9b5d9e7f3ed544d99acfe9cc96
SHA512 (opencv-clean-3.4.1.tar.gz) = d73038400cafe9f03eab27f3ec79f0cf42930603727d8682d45853bf1165aa62e5fde77e56e8ca73ae65096bf3c6b5dff0780994bc7d67414657f2e027eb8f8a
SHA512 (opencv_contrib-clean-3.4.2.tar.gz) = 4a58b1631d991080adb5b360c57821da27b25d23c533bbff79ff6d3ea95c5643252c1630c6301dc3b7ae6b36ae2f8bdd92e776dddcf896c98c1ca6c5f13b470e
SHA512 (opencv-clean-3.4.2.tar.gz) = 67356799f6deed200feb018003a12d4c808572c37b2df87d72190f76c4d151ee9454ca08652454c0d3f915a4f6d1fa83ecbb5ed2c080195a7756351a0c29b0c8