Update to 0.3.0
This commit is contained in:
parent
04dda99dcb
commit
dab62fddac
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@
|
|||||||
/openblas-0.2.17.tar.gz
|
/openblas-0.2.17.tar.gz
|
||||||
/v0.2.18.tar.gz
|
/v0.2.18.tar.gz
|
||||||
/v0.2.19.tar.gz
|
/v0.2.19.tar.gz
|
||||||
|
/v0.3.0.tar.gz
|
||||||
|
23
1495.patch
23
1495.patch
@ -1,23 +0,0 @@
|
|||||||
From e453555d97732f1691c0f07378486e10ab04cd86 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Martin Kroeker <martin@ruby.chemie.uni-freiburg.de>
|
|
||||||
Date: Mon, 19 Mar 2018 18:02:23 +0100
|
|
||||||
Subject: [PATCH] Disable CPU affinity by default again
|
|
||||||
|
|
||||||
This setting must have been changed unintentionally by my PR #1214 (probably leftover from unrelated tests)
|
|
||||||
---
|
|
||||||
Makefile.rule | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/Makefile.rule b/Makefile.rule
|
|
||||||
index 718f04090..62bf63df4 100644
|
|
||||||
--- a/Makefile.rule
|
|
||||||
+++ b/Makefile.rule
|
|
||||||
@@ -100,7 +100,7 @@ BUILD_LAPACK_DEPRECATED = 1
|
|
||||||
NO_WARMUP = 1
|
|
||||||
|
|
||||||
# If you want to disable CPU/Memory affinity on Linux.
|
|
||||||
-#NO_AFFINITY = 1
|
|
||||||
+NO_AFFINITY = 1
|
|
||||||
|
|
||||||
# if you are compiling for Linux and you have more than 16 numa nodes or more than 256 cpus
|
|
||||||
# BIGNUMA = 1
|
|
@ -1,6 +1,6 @@
|
|||||||
%bcond_with system_lapack
|
%bcond_with system_lapack
|
||||||
# Version of bundled lapack
|
# Version of bundled lapack
|
||||||
%global lapackver 3.7.0
|
%global lapackver 3.8.0
|
||||||
|
|
||||||
# DO NOT "CLEAN UP" OR MODIFY THIS SPEC FILE WITHOUT ASKING THE
|
# DO NOT "CLEAN UP" OR MODIFY THIS SPEC FILE WITHOUT ASKING THE
|
||||||
# MAINTAINER FIRST!
|
# MAINTAINER FIRST!
|
||||||
@ -14,8 +14,8 @@
|
|||||||
# "obsoleted" features are still kept in the spec.
|
# "obsoleted" features are still kept in the spec.
|
||||||
|
|
||||||
Name: openblas
|
Name: openblas
|
||||||
Version: 0.2.20
|
Version: 0.3.0
|
||||||
Release: 10%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: An optimized BLAS library based on GotoBLAS2
|
Summary: An optimized BLAS library based on GotoBLAS2
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -29,8 +29,6 @@ Patch1: openblas-0.2.5-libname.patch
|
|||||||
Patch2: openblas-0.2.15-constructor.patch
|
Patch2: openblas-0.2.15-constructor.patch
|
||||||
# Supply the proper flags to the test makefile
|
# Supply the proper flags to the test makefile
|
||||||
Patch3: openblas-0.2.19-tests.patch
|
Patch3: openblas-0.2.19-tests.patch
|
||||||
# Disable CPU affinity (patch from upstream)
|
|
||||||
Patch4: https://patch-diff.githubusercontent.com/raw/xianyi/OpenBLAS/pull/1495.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-gfortran
|
BuildRequires: gcc-gfortran
|
||||||
@ -230,7 +228,6 @@ cd OpenBLAS-%{version}
|
|||||||
%patch2 -p1 -b .constructor
|
%patch2 -p1 -b .constructor
|
||||||
%endif
|
%endif
|
||||||
%patch3 -p1 -b .tests
|
%patch3 -p1 -b .tests
|
||||||
%patch4 -p1 -b .affinity
|
|
||||||
|
|
||||||
# Fix source permissions
|
# Fix source permissions
|
||||||
find -name \*.f -exec chmod 644 {} \;
|
find -name \*.f -exec chmod 644 {} \;
|
||||||
@ -663,6 +660,9 @@ rm -rf %{buildroot}%{_libdir}/pkgconfig
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 24 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.3.0-1
|
||||||
|
- Update to 0.3.0.
|
||||||
|
|
||||||
* Thu Mar 22 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.2.20-10
|
* Thu Mar 22 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.2.20-10
|
||||||
- Disable CPU affinity unintentionally enabled upstream (BZ #1558091).
|
- Disable CPU affinity unintentionally enabled upstream (BZ #1558091).
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (v0.2.20.tar.gz) = 8dfc8e8c8d456b834d2e9544c8eadd9f4770e30db8b8dd76af601ec0735fd86c9cf63dd6a03ccd23fc02ec2e05069a09875b9073dfe29f99aadab3a958ae2634
|
SHA512 (v0.3.0.tar.gz) = 6a982d2adc13febc162d5c0077cedc116c771409ee1dbb651da6a073e5f6a439e1d0eba0349b3b2e506b274d3014adbf48fc96625ed942a61a54a0c936576b89
|
||||||
|
Loading…
Reference in New Issue
Block a user