Update patch.

This commit is contained in:
Susi Lehtola 2018-08-02 14:15:24 +02:00
parent 38b97aef71
commit bf5eb9904a
2 changed files with 19 additions and 1 deletions

View File

@ -0,0 +1,18 @@
diff -up OpenBLAS-0.3.2/Makefile.tests OpenBLAS-0.3.2/Makefile
--- OpenBLAS-0.3.2/Makefile.tests 2018-08-02 14:12:01.615117002 +0200
+++ OpenBLAS-0.3.2/Makefile 2018-08-02 14:13:29.582918971 +0200
@@ -122,11 +122,11 @@ tests :
ifeq ($(NOFORTRAN), $(filter 0,$(NOFORTRAN)))
touch $(LIBNAME)
ifndef NO_FBLAS
- $(MAKE) -C test all
- $(MAKE) -C utest all
+ $(MAKE) -C test FC="$(FC)" CC="$(CC)" COMMON_OPT="$(COMMON_OPT)" FCOMMON_OPT="$(FCOMMON_OPT)" all
+ $(MAKE) -C utest FC="$(FC)" CC="$(CC)" COMMON_OPT="$(COMMON_OPT)" FCOMMON_OPT="$(FCOMMON_OPT)" all
endif
ifndef NO_CBLAS
- $(MAKE) -C ctest all
+ $(MAKE) -C ctest FC="$(FC)" CC="$(CC)" COMMON_OPT="$(COMMON_OPT)" FCOMMON_OPT="$(FCOMMON_OPT)" all
endif
endif

View File

@ -28,7 +28,7 @@ Patch1: openblas-0.2.5-libname.patch
# Don't use constructor priorities on too old architectures
Patch2: openblas-0.2.15-constructor.patch
# Supply the proper flags to the test makefile
Patch3: openblas-0.2.19-tests.patch
Patch3: openblas-0.3.2-tests.patch
BuildRequires: gcc
BuildRequires: gcc-gfortran