Update to 0.3.0.
This commit is contained in:
parent
c65b671839
commit
a9c38764a6
23
1495.patch
23
1495.patch
@ -1,23 +0,0 @@
|
||||
From e453555d97732f1691c0f07378486e10ab04cd86 Mon Sep 17 00:00:00 2001
|
||||
From: Martin Kroeker <martin@ruby.chemie.uni-freiburg.de>
|
||||
Date: Mon, 19 Mar 2018 18:02:23 +0100
|
||||
Subject: [PATCH] Disable CPU affinity by default again
|
||||
|
||||
This setting must have been changed unintentionally by my PR #1214 (probably leftover from unrelated tests)
|
||||
---
|
||||
Makefile.rule | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile.rule b/Makefile.rule
|
||||
index 718f04090..62bf63df4 100644
|
||||
--- a/Makefile.rule
|
||||
+++ b/Makefile.rule
|
||||
@@ -100,7 +100,7 @@ BUILD_LAPACK_DEPRECATED = 1
|
||||
NO_WARMUP = 1
|
||||
|
||||
# If you want to disable CPU/Memory affinity on Linux.
|
||||
-#NO_AFFINITY = 1
|
||||
+NO_AFFINITY = 1
|
||||
|
||||
# if you are compiling for Linux and you have more than 16 numa nodes or more than 256 cpus
|
||||
# BIGNUMA = 1
|
23
1572.patch
Normal file
23
1572.patch
Normal file
@ -0,0 +1,23 @@
|
||||
From 961d25e9c7e4a1758adb1dbeaa15187de69dd052 Mon Sep 17 00:00:00 2001
|
||||
From: Martin Kroeker <martin@ruby.chemie.uni-freiburg.de>
|
||||
Date: Wed, 23 May 2018 22:54:39 +0200
|
||||
Subject: [PATCH] Use the new zrot.c on POWER8 for crot as well
|
||||
|
||||
fixes #1571 (the old zrot.S assembly does not handle incx=0 correctly)
|
||||
---
|
||||
kernel/power/KERNEL.POWER8 | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/kernel/power/KERNEL.POWER8 b/kernel/power/KERNEL.POWER8
|
||||
index 00ff8682a..1aa061078 100644
|
||||
--- a/kernel/power/KERNEL.POWER8
|
||||
+++ b/kernel/power/KERNEL.POWER8
|
||||
@@ -133,7 +133,7 @@ ZNRM2KERNEL = ../arm/znrm2.c
|
||||
#
|
||||
SROTKERNEL = srot.c
|
||||
DROTKERNEL = drot.c
|
||||
-#CROTKERNEL = ../arm/zrot.c
|
||||
+CROTKERNEL = zrot.c
|
||||
ZROTKERNEL = zrot.c
|
||||
#
|
||||
SSCALKERNEL = sscal.c
|
@ -1,140 +0,0 @@
|
||||
diff -up OpenBLAS-0.2.10/exports/gensymbol.lapacke OpenBLAS-0.2.10/exports/gensymbol
|
||||
--- OpenBLAS-0.2.10/exports/gensymbol.lapacke 2014-07-16 12:04:30.000000000 +0200
|
||||
+++ OpenBLAS-0.2.10/exports/gensymbol 2014-07-16 19:35:48.856855925 +0200
|
||||
@@ -175,7 +175,7 @@
|
||||
sggglm, sgghrd, sgglse, sggqrf,
|
||||
sggrqf, sggsvd, sggsvp, sgtcon, sgtrfs, sgtsv,
|
||||
sgtsvx, sgttrf, sgttrs, sgtts2, shgeqz,
|
||||
- shsein, shseqr, slabrd, slacon, slacn2,
|
||||
+ shsein, shseqr, slabrd, slacon,
|
||||
slaein, slaexc, slag2, slags2, slagtm, slagv2, slahqr,
|
||||
slahrd, slahr2, slaic1, slaln2, slals0, slalsa, slalsd,
|
||||
slangb, slange, slangt, slanhs, slansb, slansp,
|
||||
@@ -256,7 +256,7 @@
|
||||
chpevx, chpgst, chpgv, chpgvd, chpgvx, chprfs, chpsv,
|
||||
chpsvx,
|
||||
chptrd, chptrf, chptri, chptrs, chsein, chseqr, clabrd,
|
||||
- clacgv, clacon, clacn2, clacp2, clacpy, clacrm, clacrt, cladiv,
|
||||
+ clacgv, clacon, clacpy, clacrm, clacrt, cladiv,
|
||||
claed0, claed7, claed8,
|
||||
claein, claesy, claev2, clags2, clagtm,
|
||||
clahef, clahqr,
|
||||
@@ -323,7 +323,7 @@
|
||||
dggglm, dgghrd, dgglse, dggqrf,
|
||||
dggrqf, dggsvd, dggsvp, dgtcon, dgtrfs, dgtsv,
|
||||
dgtsvx, dgttrf, dgttrs, dgtts2, dhgeqz,
|
||||
- dhsein, dhseqr, dlabrd, dlacon, dlacn2,
|
||||
+ dhsein, dhseqr, dlabrd, dlacon,
|
||||
dlaein, dlaexc, dlag2, dlags2, dlagtm, dlagv2, dlahqr,
|
||||
dlahrd, dlahr2, dlaic1, dlaln2, dlals0, dlalsa, dlalsd,
|
||||
dlangb, dlange, dlangt, dlanhs, dlansb, dlansp,
|
||||
@@ -398,7 +398,7 @@
|
||||
zhpevx, zhpgst, zhpgv, zhpgvd, zhpgvx, zhprfs, zhpsv,
|
||||
zhpsvx,
|
||||
zhptrd, zhptrf, zhptri, zhptrs, zhsein, zhseqr, zlabrd,
|
||||
- zlacgv, zlacon, zlacn2, zlacp2, zlacpy, zlacrm, zlacrt, zladiv,
|
||||
+ zlacgv, zlacon, zlacpy, zlacrm, zlacrt, zladiv,
|
||||
zlaed0, zlaed7, zlaed8,
|
||||
zlaein, zlaesy, zlaev2, zlags2, zlagtm,
|
||||
zlahef, zlahqr,
|
||||
@@ -845,10 +845,6 @@
|
||||
LAPACKE_chseqr_work,
|
||||
LAPACKE_clacgv,
|
||||
LAPACKE_clacgv_work,
|
||||
- LAPACKE_clacn2,
|
||||
- LAPACKE_clacn2_work,
|
||||
- LAPACKE_clacp2,
|
||||
- LAPACKE_clacp2_work,
|
||||
LAPACKE_clacpy,
|
||||
LAPACKE_clacpy_work,
|
||||
LAPACKE_clag2z,
|
||||
@@ -984,8 +980,6 @@
|
||||
LAPACKE_csyrfs,
|
||||
LAPACKE_csyrfs_work,
|
||||
LAPACKE_csysv,
|
||||
- LAPACKE_csysv_rook,
|
||||
- LAPACKE_csysv_rook_work,
|
||||
LAPACKE_csysv_work,
|
||||
LAPACKE_csysvx,
|
||||
LAPACKE_csysvx_work,
|
||||
@@ -1259,8 +1253,6 @@
|
||||
LAPACKE_dhsein_work,
|
||||
LAPACKE_dhseqr,
|
||||
LAPACKE_dhseqr_work,
|
||||
- LAPACKE_dlacn2,
|
||||
- LAPACKE_dlacn2_work,
|
||||
LAPACKE_dlacpy,
|
||||
LAPACKE_dlacpy_work,
|
||||
LAPACKE_dlag2s,
|
||||
@@ -1510,8 +1502,6 @@
|
||||
LAPACKE_dsyrfs,
|
||||
LAPACKE_dsyrfs_work,
|
||||
LAPACKE_dsysv,
|
||||
- LAPACKE_dsysv_rook,
|
||||
- LAPACKE_dsysv_rook_work,
|
||||
LAPACKE_dsysv_work,
|
||||
LAPACKE_dsysvx,
|
||||
LAPACKE_dsysvx_work,
|
||||
@@ -1749,8 +1739,6 @@
|
||||
LAPACKE_shsein_work,
|
||||
LAPACKE_shseqr,
|
||||
LAPACKE_shseqr_work,
|
||||
- LAPACKE_slacn2,
|
||||
- LAPACKE_slacn2_work,
|
||||
LAPACKE_slacpy,
|
||||
LAPACKE_slacpy_work,
|
||||
LAPACKE_slag2d,
|
||||
@@ -1996,8 +1984,6 @@
|
||||
LAPACKE_ssyrfs,
|
||||
LAPACKE_ssyrfs_work,
|
||||
LAPACKE_ssysv,
|
||||
- LAPACKE_ssysv_rook,
|
||||
- LAPACKE_ssysv_rook_work,
|
||||
LAPACKE_ssysv_work,
|
||||
LAPACKE_ssysvx,
|
||||
LAPACKE_ssysvx_work,
|
||||
@@ -2321,10 +2307,6 @@
|
||||
LAPACKE_zhseqr_work,
|
||||
LAPACKE_zlacgv,
|
||||
LAPACKE_zlacgv_work,
|
||||
- LAPACKE_zlacn2,
|
||||
- LAPACKE_zlacn2_work,
|
||||
- LAPACKE_zlacp2,
|
||||
- LAPACKE_zlacp2_work,
|
||||
LAPACKE_zlacpy,
|
||||
LAPACKE_zlacpy_work,
|
||||
LAPACKE_zlag2c,
|
||||
@@ -2460,8 +2442,6 @@
|
||||
LAPACKE_zsyrfs,
|
||||
LAPACKE_zsyrfs_work,
|
||||
LAPACKE_zsysv,
|
||||
- LAPACKE_zsysv_rook,
|
||||
- LAPACKE_zsysv_rook_work,
|
||||
LAPACKE_zsysv_work,
|
||||
LAPACKE_zsysvx,
|
||||
LAPACKE_zsysvx_work,
|
||||
@@ -2705,20 +2685,20 @@
|
||||
#These function may need 2 underscores.
|
||||
@lapack_embeded_underscore_objs=(xerbla_array, chla_transtype, slasyf_rook,
|
||||
ssytf2_rook, ssytrf_rook, ssytrs_rook,
|
||||
- ssytri_rook, ssycon_rook, ssysv_rook,
|
||||
+ ssytri_rook, ssycon_rook,
|
||||
chetf2_rook, chetrf_rook, chetri_rook,
|
||||
chetrs_rook, checon_rook, chesv_rook,
|
||||
clahef_rook, clasyf_rook,
|
||||
csytf2_rook, csytrf_rook, csytrs_rook,
|
||||
- csytri_rook, csycon_rook, csysv_rook,
|
||||
+ csytri_rook, csycon_rook,
|
||||
dlasyf_rook,
|
||||
dsytf2_rook, dsytrf_rook, dsytrs_rook,
|
||||
- dsytri_rook, dsycon_rook, dsysv_rook,
|
||||
+ dsytri_rook, dsycon_rook,
|
||||
zhetf2_rook, zhetrf_rook, zhetri_rook,
|
||||
zhetrs_rook, zhecon_rook, zhesv_rook,
|
||||
zlahef_rook, zlasyf_rook,
|
||||
zsytf2_rook, zsytrf_rook, zsytrs_rook,
|
||||
- zsytri_rook, zsycon_rook, zsysv_rook,
|
||||
+ zsytri_rook, zsycon_rook,
|
||||
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
%bcond_with system_lapack
|
||||
# Version of bundled lapack
|
||||
%global lapackver 3.7.0
|
||||
%global lapackver 3.8.0
|
||||
|
||||
# DO NOT "CLEAN UP" OR MODIFY THIS SPEC FILE WITHOUT ASKING THE
|
||||
# MAINTAINER FIRST!
|
||||
@ -14,8 +14,8 @@
|
||||
# "obsoleted" features are still kept in the spec.
|
||||
|
||||
Name: openblas
|
||||
Version: 0.2.20
|
||||
Release: 6%{?dist}
|
||||
Version: 0.3.0
|
||||
Release: 1%{?dist}
|
||||
Summary: An optimized BLAS library based on GotoBLAS2
|
||||
Group: Development/Libraries
|
||||
License: BSD
|
||||
@ -29,10 +29,8 @@ Patch1: openblas-0.2.5-libname.patch
|
||||
Patch2: openblas-0.2.15-constructor.patch
|
||||
# Supply the proper flags to the test makefile
|
||||
Patch3: openblas-0.2.19-tests.patch
|
||||
# Disable CPU affinity, from upstream
|
||||
Patch4: https://patch-diff.githubusercontent.com/raw/xianyi/OpenBLAS/pull/1495.patch
|
||||
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
# Fix build on ppc64le, from upstream
|
||||
Patch4: https://patch-diff.githubusercontent.com/raw/xianyi/OpenBLAS/pull/1572.patch
|
||||
|
||||
BuildRequires: gcc-gfortran
|
||||
BuildRequires: perl-devel
|
||||
@ -228,7 +226,7 @@ cd OpenBLAS-%{version}
|
||||
%patch2 -p1 -b .constructor
|
||||
%endif
|
||||
%patch3 -p1 -b .tests
|
||||
%patch4 -p1 -b .affinity
|
||||
%patch4 -p1 -b .ppc64le
|
||||
|
||||
# Fix source permissions
|
||||
find -name \*.f -exec chmod 644 {} \;
|
||||
@ -666,6 +664,9 @@ rm -rf %{buildroot}
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sat Jun 02 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.3.0-1
|
||||
- Update to 0.3.0.
|
||||
|
||||
* Thu Mar 22 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.2.20-6
|
||||
- Disable CPU affinity that was unintentionally enabled upstream (BZ #1558091).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user