Update to 0.3.3.

This commit is contained in:
Susi Lehtola 2018-09-09 10:26:33 +02:00
parent 1aae703b57
commit 9fdb102afd
3 changed files with 5 additions and 44 deletions

View File

@ -1,12 +0,0 @@
diff -up OpenBLAS-0.3.2/driver/others/memory.c.threads OpenBLAS-0.3.2/driver/others/memory.c
--- OpenBLAS-0.3.2/driver/others/memory.c.threads 2018-07-30 07:25:01.000000000 +0200
+++ OpenBLAS-0.3.2/driver/others/memory.c 2018-08-24 18:45:36.826078344 +0200
@@ -497,7 +497,7 @@ static const int allocation_block_size =
#if defined(SMP) && !defined(USE_OPENMP_UNUSED)
/* This is the number of threads than can be spawned by the server, which is the
server plus the number of threads in the thread pool */
-# define MAX_ALLOCATING_THREADS MAX_CPU_NUMBER * 2 * MAX_PARALLEL_NUMBER * 2
+# define MAX_ALLOCATING_THREADS 8192
static int next_memory_table_pos = 0;
# if defined(HAS_COMPILER_TLS)
/* Use compiler generated thread-local-storage */

View File

@ -1,24 +0,0 @@
From f3fd44a731c1997b1d79d4d16abc25d78dce88a7 Mon Sep 17 00:00:00 2001
From: Martin Kroeker <martin@ruby.chemie.uni-freiburg.de>
Date: Tue, 28 Aug 2018 21:34:07 +0200
Subject: [PATCH] Set USE_TRMM for all ZARCH variants to fix TRMM faults with
zarch-generic
fixes #1743
---
kernel/Makefile.L3 | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/kernel/Makefile.L3 b/kernel/Makefile.L3
index b37e536ef..9258f216d 100644
--- a/kernel/Makefile.L3
+++ b/kernel/Makefile.L3
@@ -44,7 +44,7 @@ ifeq ($(CORE), POWER8)
USE_TRMM = 1
endif
-ifeq ($(CORE), Z13)
+ifeq ($(ARCH), zarch)
USE_TRMM = 1
endif

View File

@ -14,8 +14,8 @@
# "obsoleted" features are still kept in the spec.
Name: openblas
Version: 0.3.2
Release: 5%{?dist}
Version: 0.3.3
Release: 1%{?dist}
Summary: An optimized BLAS library based on GotoBLAS2
Group: Development/Libraries
License: BSD
@ -29,10 +29,6 @@ Patch1: openblas-0.2.5-libname.patch
Patch2: openblas-0.2.15-constructor.patch
# Supply the proper flags to the test makefile
Patch3: openblas-0.3.2-tests.patch
# Crude hack to avoid problems with threading code (see https://github.com/xianyi/OpenBLAS/issues/1735)
Patch4: openblas-0.3.2-threads.patch
# https://github.com/xianyi/OpenBLAS/commit/e11126b26ada8d97b4a522e461ca92311653bfc6
Patch5: openblas-0.3.2-zarch.patch
BuildRequires: gcc
BuildRequires: gcc-gfortran
@ -254,8 +250,6 @@ cd OpenBLAS-%{version}
%patch2 -p1 -b .constructor
%endif
%patch3 -p1 -b .tests
%patch4 -p1 -b .threads
%patch5 -p1 -b .zarch
# Fix source permissions
find -name \*.f -exec chmod 644 {} \;
@ -695,6 +689,9 @@ rm -rf %{buildroot}%{_libdir}/pkgconfig
%endif
%changelog
* Sun Sep 09 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.3.3-1
- Update to 0.3.3.
* Wed Aug 29 2018 Dan Horák <dan[at]danny.cz> - 0.3.2-5
- Fix precision in generic target on s390x