Disable running of all tests on RISC-V
Signed-off-by: David Abdurachmanov <david.abdurachmanov@gmail.com>
This commit is contained in:
parent
0c4b2cc81f
commit
79be0c377b
13
openblas-0.3.0-disable-tests.patch
Normal file
13
openblas-0.3.0-disable-tests.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/OpenBLAS-0.3.0/Makefile b/OpenBLAS-0.3.0/Makefile
|
||||||
|
index 679bc8d..a8e26b3 100644
|
||||||
|
--- a/OpenBLAS-0.3.0/Makefile
|
||||||
|
+++ b/OpenBLAS-0.3.0/Makefile
|
||||||
|
@@ -28,7 +28,7 @@ SUBDIRS_ALL = $(SUBDIRS) test ctest utest exports benchmark ../laswp ../bench
|
||||||
|
.PHONY : all libs netlib $(RELA) test ctest shared install
|
||||||
|
.NOTPARALLEL : all libs $(RELA) prof lapack-test install blas-test
|
||||||
|
|
||||||
|
-all :: libs netlib $(RELA) tests shared
|
||||||
|
+all :: libs netlib $(RELA) shared
|
||||||
|
@echo
|
||||||
|
@echo " OpenBLAS build complete. ($(LIB_COMPONENTS))"
|
||||||
|
@echo
|
@ -15,7 +15,7 @@
|
|||||||
|
|
||||||
Name: openblas
|
Name: openblas
|
||||||
Version: 0.3.0
|
Version: 0.3.0
|
||||||
Release: 1.0.riscv64%{?dist}
|
Release: 1.1.riscv64%{?dist}
|
||||||
Summary: An optimized BLAS library based on GotoBLAS2
|
Summary: An optimized BLAS library based on GotoBLAS2
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -34,7 +34,9 @@ Patch4: 1572.patch
|
|||||||
# Add support for RISC-V (riscv64)
|
# Add support for RISC-V (riscv64)
|
||||||
# Taken from https://github.com/xianyi/OpenBLAS/pull/1526
|
# Taken from https://github.com/xianyi/OpenBLAS/pull/1526
|
||||||
# No additional modifications done
|
# No additional modifications done
|
||||||
Patch5: openblass-0.3.0-riscv64.patch
|
Patch5: openblas-0.3.0-riscv64.patch
|
||||||
|
# Disable running of tests
|
||||||
|
Patch6: openblas-0.3.0-disable-tests.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-gfortran
|
BuildRequires: gcc-gfortran
|
||||||
@ -236,6 +238,9 @@ cd OpenBLAS-%{version}
|
|||||||
%patch3 -p1 -b .tests
|
%patch3 -p1 -b .tests
|
||||||
%patch4 -p1 -b .ppc64le
|
%patch4 -p1 -b .ppc64le
|
||||||
%patch5 -p2 -b .riscv64
|
%patch5 -p2 -b .riscv64
|
||||||
|
%ifarch riscv64
|
||||||
|
%patch6 -p2 -b .disable-tests
|
||||||
|
%endif
|
||||||
|
|
||||||
# Fix source permissions
|
# Fix source permissions
|
||||||
find -name \*.f -exec chmod 644 {} \;
|
find -name \*.f -exec chmod 644 {} \;
|
||||||
@ -674,6 +679,10 @@ rm -rf %{buildroot}%{_libdir}/pkgconfig
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 04 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 0.3.0-1.1.riscv64
|
||||||
|
- Fix typo in RISC-V patch name
|
||||||
|
- Disable running of all tests on RISC-V
|
||||||
|
|
||||||
* Sun Jun 03 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 0.3.0-1.0.riscv64
|
* Sun Jun 03 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 0.3.0-1.0.riscv64
|
||||||
- Add support for RISC-V (riscv64)
|
- Add support for RISC-V (riscv64)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user