Build deprecated LAPACK functions.

This commit is contained in:
Susi Lehtola 2016-03-18 19:27:41 +01:00
parent 25483414d9
commit 2691fb2ce9
2 changed files with 20 additions and 2 deletions

View File

@ -0,0 +1,12 @@
diff -up OpenBLAS-0.2.16/Makefile.rule.lapack OpenBLAS-0.2.16/Makefile.rule
--- OpenBLAS-0.2.16/Makefile.rule.lapack 2016-03-15 19:49:10.000000000 +0100
+++ OpenBLAS-0.2.16/Makefile.rule 2016-03-18 19:25:31.778098957 +0100
@@ -80,7 +80,7 @@ VERSION = 0.2.16
# NO_LAPACKE = 1
# Build LAPACK Deprecated functions since LAPACK 3.6.0
-# BUILD_LAPACK_DEPRECATED = 1
+BUILD_LAPACK_DEPRECATED = 1
# If you want to use legacy threaded Level 3 implementation.
# USE_SIMPLE_THREADED_LEVEL3 = 1

View File

@ -4,7 +4,7 @@
Name: openblas
Version: 0.2.16
Release: 2%{?dist}
Release: 3%{?dist}
Summary: An optimized BLAS library based on GotoBLAS2
Group: Development/Libraries
License: BSD
@ -14,8 +14,10 @@ Source0: https://github.com/xianyi/OpenBLAS/archive/v%{version}.tar.gz
Patch0: openblas-0.2.15-system_lapack.patch
# Drop extra p from threaded library name
Patch1: openblas-0.2.5-libname.patch
# Don't use constructor priorities
# Don't use constructor priorities on too old architectures
Patch2: openblas-0.2.15-constructor.patch
# Build deprecated LAPACK functions
Patch3: openblas-0.2.16-lapack.patch
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
BuildRequires: gcc-gfortran
@ -209,6 +211,7 @@ cd OpenBLAS-%{version}
%if 0%{?rhel} == 5
%patch2 -p1 -b .constructor
%endif
%patch3 -p1 -b .lapack
# Fix source permissions
find -name \*.f -exec chmod 644 {} \;
@ -595,6 +598,9 @@ rm -rf %{buildroot}
%endif
%changelog
* Fri Mar 18 2016 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.2.16-3
- Include deprecated LAPACK functions.
* Wed Mar 16 2016 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.2.16-2
- Fix library suffix on ppc64le.