Update patches.
This commit is contained in:
parent
2fe8665d19
commit
1d85c7acff
@ -1,26 +1,13 @@
|
||||
diff -up OpenBLAS-0.2.10/Makefile.system.system_lapack OpenBLAS-0.2.10/Makefile.system
|
||||
--- OpenBLAS-0.2.10/Makefile.system.system_lapack 2014-07-16 12:04:30.000000000 +0200
|
||||
+++ OpenBLAS-0.2.10/Makefile.system 2014-07-16 19:24:55.233859424 +0200
|
||||
@@ -9,7 +9,7 @@ ifndef TOPDIR
|
||||
TOPDIR = .
|
||||
endif
|
||||
|
||||
-NETLIB_LAPACK_DIR = $(TOPDIR)/lapack-netlib
|
||||
+NETLIB_LAPACK_DIR = $(TOPDIR)/netliblapack
|
||||
|
||||
# Default C compiler
|
||||
# - Only set if not specified on the command line or inherited from the environment.
|
||||
diff -up OpenBLAS-0.2.10/Makefile.system_lapack OpenBLAS-0.2.10/Makefile
|
||||
--- OpenBLAS-0.2.10/Makefile.system_lapack 2014-07-16 19:24:55.231859424 +0200
|
||||
+++ OpenBLAS-0.2.10/Makefile 2014-07-16 19:29:58.370855854 +0200
|
||||
@@ -209,64 +209,9 @@ hpl_p :
|
||||
diff -up OpenBLAS-0.2.11/Makefile.system_lapack OpenBLAS-0.2.11/Makefile
|
||||
--- OpenBLAS-0.2.11/Makefile.system_lapack 2014-08-18 05:16:14.000000000 +0200
|
||||
+++ OpenBLAS-0.2.11/Makefile 2014-08-18 21:33:52.341214018 +0200
|
||||
@@ -209,58 +209,6 @@ hpl_p :
|
||||
fi; \
|
||||
done
|
||||
|
||||
-ifeq ($(NO_LAPACK), 1)
|
||||
netlib :
|
||||
+ @$(MAKE) -C $(NETLIB_LAPACK_DIR)
|
||||
|
||||
-netlib :
|
||||
-
|
||||
-else
|
||||
-netlib : lapack_prebuild
|
||||
-ifndef NOFORTRAN
|
||||
@ -56,7 +43,7 @@ diff -up OpenBLAS-0.2.10/Makefile.system_lapack OpenBLAS-0.2.10/Makefile
|
||||
- -@echo "SUFFIX = $(SUFFIX)" >> $(NETLIB_LAPACK_DIR)/make.inc
|
||||
- -@echo "PSUFFIX = $(PSUFFIX)" >> $(NETLIB_LAPACK_DIR)/make.inc
|
||||
- -@echo "CEXTRALIB = $(EXTRALIB)" >> $(NETLIB_LAPACK_DIR)/make.inc
|
||||
-ifeq ($(FC), GFORTRAN)
|
||||
-ifeq ($(FC), gfortran)
|
||||
- -@echo "TIMER = INT_ETIME" >> $(NETLIB_LAPACK_DIR)/make.inc
|
||||
-ifdef SMP
|
||||
- -@echo "LOADER = $(FC) -pthread" >> $(NETLIB_LAPACK_DIR)/make.inc
|
||||
@ -70,12 +57,18 @@ diff -up OpenBLAS-0.2.10/Makefile.system_lapack OpenBLAS-0.2.10/Makefile
|
||||
- -@cat make.inc >> $(NETLIB_LAPACK_DIR)/make.inc
|
||||
-endif
|
||||
-
|
||||
-large.tgz :
|
||||
-ifndef NOFORTRAN
|
||||
- if [ ! -a $< ]; then
|
||||
- -wget http://www.netlib.org/lapack/timing/large.tgz;
|
||||
- fi
|
||||
-endif
|
||||
|
||||
timing.tgz :
|
||||
large.tgz :
|
||||
ifndef NOFORTRAN
|
||||
if [ ! -a $< ]; then
|
||||
diff -up OpenBLAS-0.2.11/Makefile.system.system_lapack OpenBLAS-0.2.11/Makefile.system
|
||||
--- OpenBLAS-0.2.11/Makefile.system.system_lapack 2014-08-18 05:16:14.000000000 +0200
|
||||
+++ OpenBLAS-0.2.11/Makefile.system 2014-08-18 21:33:06.792213605 +0200
|
||||
@@ -9,7 +9,7 @@ ifndef TOPDIR
|
||||
TOPDIR = .
|
||||
endif
|
||||
|
||||
-NETLIB_LAPACK_DIR = $(TOPDIR)/lapack-netlib
|
||||
+NETLIB_LAPACK_DIR = $(TOPDIR)/netliblapack
|
||||
|
||||
# Default C compiler
|
||||
# - Only set if not specified on the command line or inherited from the environment.
|
@ -7,7 +7,7 @@ License: BSD
|
||||
URL: https://github.com/xianyi/OpenBLAS/
|
||||
Source0: https://github.com/xianyi/OpenBLAS/archive/v%{version}.tar.gz
|
||||
# Use system lapack
|
||||
Patch0: openblas-0.2.10-system_lapack.patch
|
||||
Patch0: openblas-0.2.11-system_lapack.patch
|
||||
# Drop extra p from threaded library name
|
||||
Patch1: openblas-0.2.5-libname.patch
|
||||
# Don't test link against functions in lapacke 3.5.0 if only 3.4.0 is available
|
||||
|
Loading…
Reference in New Issue
Block a user