Merge remote-tracking branch 'up/f29' into f29-riscv64
Signed-off-by: David Abdurachmanov <david.abdurachmanov@gmail.com>
This commit is contained in:
commit
0cd9fe5678
2
.gitignore
vendored
2
.gitignore
vendored
@ -13,3 +13,5 @@
|
||||
/v0.2.18.tar.gz
|
||||
/v0.2.19.tar.gz
|
||||
/v0.3.0.tar.gz
|
||||
/v0.3.1.tar.gz
|
||||
/openblas-0.3.2.tar.gz
|
||||
|
23
1572.patch
23
1572.patch
@ -1,23 +0,0 @@
|
||||
From 961d25e9c7e4a1758adb1dbeaa15187de69dd052 Mon Sep 17 00:00:00 2001
|
||||
From: Martin Kroeker <martin@ruby.chemie.uni-freiburg.de>
|
||||
Date: Wed, 23 May 2018 22:54:39 +0200
|
||||
Subject: [PATCH] Use the new zrot.c on POWER8 for crot as well
|
||||
|
||||
fixes #1571 (the old zrot.S assembly does not handle incx=0 correctly)
|
||||
---
|
||||
kernel/power/KERNEL.POWER8 | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/kernel/power/KERNEL.POWER8 b/kernel/power/KERNEL.POWER8
|
||||
index 00ff8682a..1aa061078 100644
|
||||
--- a/kernel/power/KERNEL.POWER8
|
||||
+++ b/kernel/power/KERNEL.POWER8
|
||||
@@ -133,7 +133,7 @@ ZNRM2KERNEL = ../arm/znrm2.c
|
||||
#
|
||||
SROTKERNEL = srot.c
|
||||
DROTKERNEL = drot.c
|
||||
-#CROTKERNEL = ../arm/zrot.c
|
||||
+CROTKERNEL = zrot.c
|
||||
ZROTKERNEL = zrot.c
|
||||
#
|
||||
SSCALKERNEL = sscal.c
|
18
openblas-0.3.2-tests.patch
Normal file
18
openblas-0.3.2-tests.patch
Normal file
@ -0,0 +1,18 @@
|
||||
diff -up OpenBLAS-0.3.2/Makefile.tests OpenBLAS-0.3.2/Makefile
|
||||
--- OpenBLAS-0.3.2/Makefile.tests 2018-08-02 14:12:01.615117002 +0200
|
||||
+++ OpenBLAS-0.3.2/Makefile 2018-08-02 14:13:29.582918971 +0200
|
||||
@@ -122,11 +122,11 @@ tests :
|
||||
ifeq ($(NOFORTRAN), $(filter 0,$(NOFORTRAN)))
|
||||
touch $(LIBNAME)
|
||||
ifndef NO_FBLAS
|
||||
- $(MAKE) -C test all
|
||||
- $(MAKE) -C utest all
|
||||
+ $(MAKE) -C test FC="$(FC)" CC="$(CC)" COMMON_OPT="$(COMMON_OPT)" FCOMMON_OPT="$(FCOMMON_OPT)" all
|
||||
+ $(MAKE) -C utest FC="$(FC)" CC="$(CC)" COMMON_OPT="$(COMMON_OPT)" FCOMMON_OPT="$(FCOMMON_OPT)" all
|
||||
endif
|
||||
ifndef NO_CBLAS
|
||||
- $(MAKE) -C ctest all
|
||||
+ $(MAKE) -C ctest FC="$(FC)" CC="$(CC)" COMMON_OPT="$(COMMON_OPT)" FCOMMON_OPT="$(FCOMMON_OPT)" all
|
||||
endif
|
||||
endif
|
||||
|
103
openblas.spec
103
openblas.spec
@ -14,13 +14,13 @@
|
||||
# "obsoleted" features are still kept in the spec.
|
||||
|
||||
Name: openblas
|
||||
Version: 0.3.0
|
||||
Release: 1.2.riscv64%{?dist}
|
||||
Version: 0.3.3
|
||||
Release: 1.0.riscv64%{?dist}
|
||||
Summary: An optimized BLAS library based on GotoBLAS2
|
||||
Group: Development/Libraries
|
||||
License: BSD
|
||||
URL: https://github.com/xianyi/OpenBLAS/
|
||||
Source0: https://github.com/xianyi/OpenBLAS/archive/v%{version}.tar.gz
|
||||
Source0: https://github.com/xianyi/OpenBLAS/archive/v%{version}/openblas-%{version}.tar.gz
|
||||
# Use system lapack
|
||||
Patch0: openblas-0.2.15-system_lapack.patch
|
||||
# Drop extra p from threaded library name
|
||||
@ -28,9 +28,7 @@ Patch1: openblas-0.2.5-libname.patch
|
||||
# Don't use constructor priorities on too old architectures
|
||||
Patch2: openblas-0.2.15-constructor.patch
|
||||
# Supply the proper flags to the test makefile
|
||||
Patch3: openblas-0.2.19-tests.patch
|
||||
# Upstream pull 1572, fixes fail on ppc64le
|
||||
Patch4: 1572.patch
|
||||
Patch3: openblas-0.3.2-tests.patch
|
||||
# Add support for RISC-V (riscv64)
|
||||
# Taken from https://github.com/xianyi/OpenBLAS/pull/1526
|
||||
# No additional modifications done
|
||||
@ -107,90 +105,111 @@ Computational Science, ISCAS. http://www.rdcps.ac.cn
|
||||
%{base_description}
|
||||
|
||||
%package Rblas
|
||||
Summary: A version of OpenBLAS for R to use as libRblas
|
||||
Group: Development/Libraries
|
||||
Summary: A version of OpenBLAS for R to use as libRblas
|
||||
Group: Development/Libraries
|
||||
|
||||
%description Rblas
|
||||
%{base_description}
|
||||
|
||||
%package serial
|
||||
Summary: An optimized BLAS library based on GotoBLAS2, serial version
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description serial
|
||||
%{base_description}
|
||||
|
||||
This package contains the sequential library compiled with a 32-bit
|
||||
integer interface.
|
||||
|
||||
%package openmp
|
||||
Summary: An optimized BLAS library based on GotoBLAS2, OpenMP version
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description openmp
|
||||
%{base_description}
|
||||
|
||||
This package contains the library compiled with OpenMP support.
|
||||
This package contains the library compiled with OpenMP support with
|
||||
32-bit integer interface.
|
||||
|
||||
%package threads
|
||||
Summary: An optimized BLAS library based on GotoBLAS2, pthreads version
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description threads
|
||||
%{base_description}
|
||||
|
||||
This package contains the library compiled with threading support.
|
||||
This package contains the library compiled with threading support and
|
||||
a 32-bit integer interface.
|
||||
|
||||
%if %build64
|
||||
%package serial64
|
||||
Summary: An optimized BLAS library based on GotoBLAS2, serial version
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description serial64
|
||||
%{base_description}
|
||||
|
||||
This package contains the sequential library compiled with a 64-bit
|
||||
interface.
|
||||
integer interface.
|
||||
|
||||
%package openmp64
|
||||
Summary: An optimized BLAS library based on GotoBLAS2, OpenMP version
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description openmp64
|
||||
%{base_description}
|
||||
|
||||
This package contains the library compiled with OpenMP support and
|
||||
64-bit interface.
|
||||
64-bit integer interface.
|
||||
|
||||
%package threads64
|
||||
Summary: An optimized BLAS library based on GotoBLAS2, pthreads version
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description threads64
|
||||
%{base_description}
|
||||
|
||||
This package contains the library compiled with threading support and
|
||||
64-bit interface.
|
||||
64-bit integer interface.
|
||||
|
||||
%package serial64_
|
||||
Summary: An optimized BLAS library based on GotoBLAS2, serial version
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description serial64_
|
||||
%{base_description}
|
||||
|
||||
This package contains the sequential library compiled with a 64-bit
|
||||
interface and a symbol name suffix.
|
||||
integer interface and a symbol name suffix.
|
||||
|
||||
%package openmp64_
|
||||
Summary: An optimized BLAS library based on GotoBLAS2, OpenMP version
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description openmp64_
|
||||
%{base_description}
|
||||
|
||||
This package contains the library compiled with OpenMP support and
|
||||
64-bit interface and a symbol name suffix.
|
||||
64-bit integer interface and a symbol name suffix.
|
||||
|
||||
%package threads64_
|
||||
Summary: An optimized BLAS library based on GotoBLAS2, pthreads version
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description threads64_
|
||||
%{base_description}
|
||||
|
||||
This package contains the library compiled with threading support and
|
||||
64-bit interface and a symbol name suffix.
|
||||
64-bit integer interface and a symbol name suffix.
|
||||
%endif
|
||||
|
||||
|
||||
@ -198,6 +217,7 @@ This package contains the library compiled with threading support and
|
||||
Summary: Development headers and libraries for OpenBLAS
|
||||
Group: Development/Libraries
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-serial%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-openmp%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-threads%{?_isa} = %{version}-%{release}
|
||||
%if %build64
|
||||
@ -240,7 +260,6 @@ cd OpenBLAS-%{version}
|
||||
%patch2 -p1 -b .constructor
|
||||
%endif
|
||||
%patch3 -p1 -b .tests
|
||||
%patch4 -p1 -b .ppc64le
|
||||
%patch5 -p2 -b .riscv64
|
||||
%ifarch riscv64
|
||||
%patch6 -p2 -b .disable-tests
|
||||
@ -356,7 +375,7 @@ LAPACKE="NO_LAPACKE=1"
|
||||
NMAX="NUM_THREADS=128"
|
||||
|
||||
%ifarch %{ix86} x86_64
|
||||
TARGET="TARGET=CORE2 DYNAMIC_ARCH=1"
|
||||
TARGET="TARGET=CORE2 DYNAMIC_ARCH=1 DYNAMIC_OLDER=1"
|
||||
|
||||
# Compability for old versions of GCC
|
||||
%if 0%{?rhel} == 5
|
||||
@ -385,12 +404,16 @@ TARGET="TARGET=ARMV8 DYNAMIC_ARCH=0"
|
||||
%ifarch riscv64
|
||||
TARGET="TARGET=RISCV64 DYNAMIC_ARCH=0"
|
||||
%endif
|
||||
%ifarch s390x
|
||||
TARGET="TARGET=ZARCH_GENERIC DYNAMIC_ARCH=0"
|
||||
%endif
|
||||
|
||||
%if 0%{?rhel} == 5
|
||||
# Gfortran too old to recognize -frecursive
|
||||
COMMON="%{optflags} -fPIC"
|
||||
FCOMMON="%{optflags} -fPIC"
|
||||
%else
|
||||
COMMON="%{optflags} -fPIC"
|
||||
FCOMMON="%{optflags} -fPIC -frecursive"
|
||||
%endif
|
||||
# Use Fedora linker flags
|
||||
@ -614,7 +637,10 @@ rm -rf %{buildroot}%{_libdir}/pkgconfig
|
||||
%endif
|
||||
|
||||
%files
|
||||
%doc serial/Changelog.txt serial/GotoBLAS* serial/LICENSE
|
||||
%license serial/LICENSE
|
||||
%doc serial/Changelog.txt serial/GotoBLAS*
|
||||
|
||||
%files serial
|
||||
%{_libdir}/lib%{name}-*.so
|
||||
%{_libdir}/lib%{name}.so.*
|
||||
|
||||
@ -683,16 +709,39 @@ rm -rf %{buildroot}%{_libdir}/pkgconfig
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jun 04 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 0.3.0-1.2.riscv64
|
||||
- Disable execstack for RISC-V (riscv64)
|
||||
|
||||
* Mon Jun 04 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 0.3.0-1.1.riscv64
|
||||
- Fix typo in RISC-V patch name
|
||||
- Disable running of all tests on RISC-V
|
||||
|
||||
* Sun Jun 03 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 0.3.0-1.0.riscv64
|
||||
* Sat Sep 22 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 0.3.3-1.0.riscv64
|
||||
- Add support for RISC-V (riscv64)
|
||||
|
||||
* Sun Sep 09 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.3.3-1
|
||||
- Update to 0.3.3.
|
||||
|
||||
* Wed Aug 29 2018 Dan Horák <dan[at]danny.cz> - 0.3.2-5
|
||||
- Fix precision in generic target on s390x
|
||||
|
||||
* Fri Aug 24 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.3.2-4
|
||||
- Patch to avoid threading issues.
|
||||
|
||||
* Fri Aug 24 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.3.2-3
|
||||
- Add missing %%{optflags} to COMMON (see discussion in #1619074).
|
||||
|
||||
* Wed Aug 15 2018 Dan Horák <dan[at]danny.cz> - 0.3.2-2
|
||||
- Explicitly set the target to generic on s390x to avoid surprises (#1615760)
|
||||
|
||||
* Thu Aug 02 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.3.2-1
|
||||
- Update to 0.3.2.
|
||||
|
||||
* Sun Jul 22 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.3.1-3
|
||||
- Fix crash with multiple instances (BZ #1605231).
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Sun Jul 01 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.3.1-1
|
||||
- Update to 0.3.1.
|
||||
|
||||
* Mon Jun 11 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.3.0-2
|
||||
- Split sequential libraries from core package to openblas-serial.
|
||||
|
||||
* Thu May 24 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.3.0-1
|
||||
- Update to 0.3.0.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (v0.3.0.tar.gz) = 6a982d2adc13febc162d5c0077cedc116c771409ee1dbb651da6a073e5f6a439e1d0eba0349b3b2e506b274d3014adbf48fc96625ed942a61a54a0c936576b89
|
||||
SHA512 (openblas-0.3.3.tar.gz) = 1c72dbe2b85675f564e777a807d0a8f2ab836abee8223b15ac4eb001c6ca06eeb2db7fa83a66d3f9e8420202b5afca6b6b1acb920e52abb3cec27b6f4629e618
|
||||
|
Loading…
x
Reference in New Issue
Block a user