openbabel/openbabel-rpm.patch
Dominik Mierzejewski 7ec9e5e5c4 - updated to 2.2.0
- fixed testsuite
- added strict perl version requirements (patch by Paul Howarth)
- fixed some rpmlint warnings
- merged a sed call into -rpm patch
2008-07-06 14:57:34 +00:00

29 lines
1.4 KiB
Diff

diff -up openbabel-2.2.0/scripts/Makefile.am.r openbabel-2.2.0/scripts/Makefile.am
--- openbabel-2.2.0/scripts/Makefile.am.r 2008-07-03 20:25:54.000000000 +0200
+++ openbabel-2.2.0/scripts/Makefile.am 2008-07-06 15:59:23.000000000 +0200
@@ -63,8 +63,8 @@ ruby/openbabel_ruby.cpp: openbabel-ruby.
$(SWIG) -small -O -ruby -naturalvar -autorename -c++ -o $@ \
-templatereduce -I$(top_srcdir)/include -I$(top_builddir)/include $<;
(cd ruby; ruby extconf.rb \
- --with-openbabel-include=$(includedir)/openbabel-2.0 \
- --with-openbabel-lib=$(libdir) )
+ --with-openbabel-include=../../include/openbabel \
+ --with-openbabel-lib=../../src/.libs )
sed -e 's/rb_define_module(\"Openbabel\")/rb_define_module(\"OpenBabel\")/' -e 's/void Init_OpenBabel/void Init_openbabel/' <ruby/openbabel_ruby.cpp >ruby/openbabel_ruby.new
mv ruby/openbabel_ruby.new ruby/openbabel_ruby.cpp
endif # BUILD_RUBY
diff -up openbabel-2.2.0/scripts/perl/Makefile.PL.r openbabel-2.2.0/scripts/perl/Makefile.PL
--- openbabel-2.2.0/scripts/perl/Makefile.PL.r 2008-07-06 16:16:45.000000000 +0200
+++ openbabel-2.2.0/scripts/perl/Makefile.PL 2008-07-06 16:48:59.000000000 +0200
@@ -3,8 +3,8 @@ use ExtUtils::MakeMaker;
use lib 'inc';
use Devel::CheckLib;
-check_lib_or_exit( lib => 'openbabel' , libpath =>
-@ENV{"LD_LIBRARY_PATH"});
+#check_lib_or_exit( lib => 'openbabel' , libpath =>
+#@ENV{"LD_LIBRARY_PATH"});
$CC = 'g++';
$srcdir = '../../src';