openbabel/openbabel-chicken.patch

25 lines
1.1 KiB
Diff

--- openbabel-2.0.2/scripts/perl/Makefile.PL.chicken 2006-05-03 17:54:54.000000000 +0200
+++ openbabel-2.0.2/scripts/perl/Makefile.PL 2006-09-20 05:55:53.000000000 +0200
@@ -4,7 +4,8 @@
$srcdir = '../../src';
# check if we're compiling in the source directory
-$ldfrom = '$(OBJECT) -lopenbabel -lz';
+$ldfrom = "\$(OBJECT) -L$srcdir/.libs -lopenbabel -lz"
+ if (-r "$srcdir/.libs/libopenbabel.so") and (-s _) and (-B _);
$ldfrom = "\$(OBJECT) $srcdir/.libs/libopenbabel.a -lz"
if (-r "$srcdir/.libs/libopenbabel.a") and (-s _) and (-B _);
--- openbabel-2.0.2/scripts/python/setup.py.chicken 2006-05-03 17:54:53.000000000 +0200
+++ openbabel-2.0.2/scripts/python/setup.py 2006-09-20 05:53:33.000000000 +0200
@@ -41,6 +41,9 @@
"INFO: Looking for library and include files in ../../src\n")
if os.path.isfile("../../src/atom.o"):
return ["../../src"],["../../src"]
+ else:
+ if os.path.isfile("../../src/atom.lo"):
+ return ["../../src"],["../../src/.libs"]
sys.stderr.write("ERROR: Cannot find Open Babel library directory\n")
return (None,None)