openbabel/openbabel-rpm.patch
Dominik Mierzejewski 837df1df43 - updated to 2.2.0 beta4
- enable CML tests again (fixed upstream)
2008-03-02 19:04:13 +00:00

15 lines
944 B
Diff

diff -up openbabel-2.2.0b3-20080215-r2249/scripts/Makefile.am.r openbabel-2.2.0b3-20080215-r2249/scripts/Makefile.am
--- openbabel-2.2.0b3-20080215-r2249/scripts/Makefile.am.r 2008-01-24 21:43:42.000000000 +0100
+++ openbabel-2.2.0b3-20080215-r2249/scripts/Makefile.am 2008-02-23 15:48:26.000000000 +0100
@@ -58,8 +58,8 @@ ruby/openbabel_ruby.cpp: openbabel-ruby.
$(SWIG) -ruby -naturalvar -autorename -c++ -o $@ -I$(top_srcdir)/include \
-I$(top_builddir)/include $<;
(cd ruby; ruby extconf.rb \
- --with-openbabel-include=$(includedir)/openbabel-2.0 \
- --with-openbabel-lib=$(libdir) )
+ --with-openbabel-include=../../include/openbabel \
+ --with-openbabel-lib=../../src/.libs )
sed -e 's/rb_define_module(\"Openbabel\")/rb_define_module(\"OpenBabel\")/' -e 's/void Init_OpenBabel/void Init_openbabel/' <ruby/openbabel_ruby.cpp >ruby/openbabel_ruby.new
mv ruby/openbabel_ruby.new ruby/openbabel_ruby.cpp
endif # BUILD_RUBY