* Tue Mar 22 2011 Kevin Kofler <Kevin@tigcc.ticalc.org> 2.3.0-3

- fix plugin directory location (#680292, patch by lg)
- show forcefields list in obenergy output (#680292, patch by lg)
This commit is contained in:
Kevin Kofler 2011-03-22 22:57:13 +01:00
parent 0378631764
commit d832d3c29a
3 changed files with 41 additions and 1 deletions

View File

@ -0,0 +1,18 @@
--- openbabel-2.3.0_orig/tools/obenergy.cpp 2010-10-10 06:05:20.000000000 +0400
+++ openbabel-2.3.0/tools/obenergy.cpp 2011-03-19 18:58:18.000000000 +0300
@@ -40,6 +40,7 @@
int verbose = 0;
bool hydrogens = false;
string basename, filename = "", option, option2, ff = "";
+ OBConversion conv;
if (argc < 2) {
cout << "Usage: obenergy [options] <filename>" << endl;
@@ -89,7 +90,6 @@
}
// Find Input filetype
- OBConversion conv;
OBFormat *format_in = conv.FormatFromExt(filename.c_str());
if (!format_in || !conv.SetInFormat(format_in)) {

View File

@ -0,0 +1,12 @@
diff -ru openbabel-2.3.0/CMakeLists.txt openbabel-2.3.0-lg/CMakeLists.txt
--- openbabel-2.3.0/CMakeLists.txt 2010-10-23 02:05:07.000000000 +0400
+++ openbabel-2.3.0-lg/CMakeLists.txt 2011-02-26 18:49:31.000000000 +0300
@@ -218,7 +218,7 @@
}
" SCANDIR_NEEDS_CONST)
- set(OB_MODULE_PATH "${CMAKE_INSTALL_PREFIX}/${OB_PLUGIN_INSTALL_DIR}")
+ set(OB_MODULE_PATH "${OB_PLUGIN_INSTALL_DIR}")
add_definitions(-DOB_MODULE_PATH="\\"${OB_MODULE_PATH}\\"")
# Add some visibility support when using GCC

View File

@ -10,7 +10,7 @@
Name: openbabel
Version: 2.3.0
Release: 2%{beta_ver}%{?dist}
Release: 3%{beta_ver}%{?dist}
Summary: Chemistry software file format converter
License: GPLv2
Group: Applications/File
@ -18,6 +18,10 @@ URL: http://openbabel.org/
Source: http://downloads.sourceforge.net/sourceforge/openbabel/%{name}-%{version}%{beta_str}.tar.gz
Patch1: %{name}-rpm.patch
Patch3: %{name}-inchi.patch
# fix plugin directory location (#680292, patch by lg)
Patch4: openbabel-2.3.0-plugindir.patch
# show forcefields list in obenergy output (#680292, patch by lg)
Patch5: openbabel-2.3.0-obenergy-fflist.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: cmake
BuildRequires: eigen2-devel
@ -119,6 +123,8 @@ Ruby wrapper for the Open Babel library.
%setup -q -n %{name}-%{version}%{beta_dir}
%patch1 -p1 -b .r
%patch3 -p1 -b .inchi
%patch4 -p1 -b .plugindir
%patch5 -p1 -b .obenergy-fflist
chmod 644 src/formats/{fchk,genbank,mmcif}format.cpp
chmod 644 src/math/align.cpp
chmod 644 include/openbabel/{graphsym.h,math/align.h}
@ -199,6 +205,10 @@ chmod 755 $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Chemistry/OpenBabel/OpenBabel.s
%{ruby_sitearch}/openbabel.so
%changelog
* Tue Mar 22 2011 Kevin Kofler <Kevin@tigcc.ticalc.org> 2.3.0-3
- fix plugin directory location (#680292, patch by lg)
- show forcefields list in obenergy output (#680292, patch by lg)
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild