- updated to 2.2.3

- dropped obsolete patch
- fix configure to detect external inchi-1.0.2
This commit is contained in:
Dominik Mierzejewski 2009-09-13 17:27:34 +00:00
parent 74b3a72dc5
commit c0d8acee97
4 changed files with 30 additions and 169 deletions

View File

@ -1,10 +1,10 @@
diff -up openbabel-2.2.1b3-20090215-r2890/test/wrapper.sh.chk openbabel-2.2.1b3-20090215-r2890/test/wrapper.sh
--- openbabel-2.2.1b3-20090215-r2890/test/wrapper.sh.chk 2009-01-12 20:10:33.000000000 +0100
+++ openbabel-2.2.1b3-20090215-r2890/test/wrapper.sh 2009-03-01 16:19:28.000000000 +0100
diff -up openbabel-2.2.3/test/wrapper.sh.chk openbabel-2.2.3/test/wrapper.sh
--- openbabel-2.2.3/test/wrapper.sh.chk 2009-07-29 01:05:03.000000000 +0200
+++ openbabel-2.2.3/test/wrapper.sh 2009-08-26 15:55:28.000000000 +0200
@@ -16,11 +16,11 @@ TESTS="${TESTS} logp_psa math"
TESTS="${TESTS} mol phmodel residue rings"
TESTS="${TESTS} smarts smilesmatch unitcell"
TESTS="${TESTS} cml.sh test-set.sh"
TESTS="${TESTS} smarts smilesmatch strip unitcell"
TESTS="${TESTS} zipstream cml.sh test-set.sh"
-if [ "x${srcdir}" != "x" ]; then
- TESTS="${TESTS} ${srcdir}/inchi.pl ${srcdir}/inchi2.pl"
-else
@ -18,21 +18,3 @@ diff -up openbabel-2.2.1b3-20090215-r2890/test/wrapper.sh.chk openbabel-2.2.1b3-
PROVE=prove
echo "top srcdir: .${topsrcdir}."
@@ -45,4 +45,4 @@ if [ -d ../src/formats/.libs ]; then
fi
fi
-${PROVE} "$@" ${TESTS}
+${PROVE} --verbose "$@" ${TESTS}
diff -up openbabel-2.2.0/test/bond.cpp.chk openbabel-2.2.0/test/bond.cpp
--- openbabel-2.2.0/test/bond.cpp.chk 2008-06-13 22:48:05.000000000 +0200
+++ openbabel-2.2.0/test/bond.cpp 2008-07-06 21:45:44.000000000 +0200
@@ -58,7 +58,7 @@ int main(int argc,char *argv[])
bond1.SetBegin(&begin1);
bond1.SetEnd(&end1);
- cout << "ok 4\n";
+ cout << "ok 3\n";
return(0);
}

View File

@ -1,138 +0,0 @@
diff -up openbabel-2.2.1b3-20090215-r2890/include/openbabel/data.h.gcc43 openbabel-2.2.1b3-20090215-r2890/include/openbabel/data.h
--- openbabel-2.2.1b3-20090215-r2890/include/openbabel/data.h.gcc43 2008-12-01 18:42:20.000000000 +0100
+++ openbabel-2.2.1b3-20090215-r2890/include/openbabel/data.h 2009-03-01 10:54:43.000000000 +0100
@@ -23,7 +23,7 @@ GNU General Public License for more deta
#include <openbabel/babelconfig.h>
#include <stdio.h>
-
+#include <cstring>
#include <fstream>
#include <vector>
#include <string>
diff -up openbabel-2.2.1b3-20090215-r2890/include/openbabel/obconversion.h.gcc43 openbabel-2.2.1b3-20090215-r2890/include/openbabel/obconversion.h
--- openbabel-2.2.1b3-20090215-r2890/include/openbabel/obconversion.h.gcc43 2008-12-01 18:42:19.000000000 +0100
+++ openbabel-2.2.1b3-20090215-r2890/include/openbabel/obconversion.h 2009-03-01 10:54:43.000000000 +0100
@@ -28,6 +28,7 @@ GNU General Public License for more deta
#include <string>
#include <vector>
#include <map>
+#include <strings.h>
#include <openbabel/dlhandler.h>
#include <openbabel/oberror.h>
diff -up openbabel-2.2.1b3-20090215-r2890/include/openbabel/obmolecformat.h.gcc43 openbabel-2.2.1b3-20090215-r2890/include/openbabel/obmolecformat.h
--- openbabel-2.2.1b3-20090215-r2890/include/openbabel/obmolecformat.h.gcc43 2008-12-01 18:42:20.000000000 +0100
+++ openbabel-2.2.1b3-20090215-r2890/include/openbabel/obmolecformat.h 2009-03-01 10:54:43.000000000 +0100
@@ -23,6 +23,8 @@ GNU General Public License for more deta
#include <hash_map>
#endif
+#include <typeinfo>
+
#include <openbabel/mol.h>
#include <openbabel/babelconfig.h>
#include <openbabel/obconversion.h>
diff -up openbabel-2.2.1b3-20090215-r2890/include/openbabel/xml.h.gcc43 openbabel-2.2.1b3-20090215-r2890/include/openbabel/xml.h
--- openbabel-2.2.1b3-20090215-r2890/include/openbabel/xml.h.gcc43 2008-12-01 18:42:19.000000000 +0100
+++ openbabel-2.2.1b3-20090215-r2890/include/openbabel/xml.h 2009-03-01 10:54:43.000000000 +0100
@@ -13,6 +13,8 @@ MERCHANTABILITY or FITNESS FOR A PARTICU
GNU General Public License for more details.
***********************************************************************/
+#include <typeinfo>
+
#include <openbabel/mol.h>
#include <openbabel/obconversion.h>
#include <openbabel/obmolecformat.h>
diff -up openbabel-2.2.1b3-20090215-r2890/src/dlhandler_unix.cpp.gcc43 openbabel-2.2.1b3-20090215-r2890/src/dlhandler_unix.cpp
--- openbabel-2.2.1b3-20090215-r2890/src/dlhandler_unix.cpp.gcc43 2009-01-16 16:43:58.000000000 +0100
+++ openbabel-2.2.1b3-20090215-r2890/src/dlhandler_unix.cpp 2009-03-01 10:59:50.000000000 +0100
@@ -27,6 +27,7 @@ GNU General Public License for more deta
#include <dlfcn.h>
#include <cstring>
#include <cstdlib>
+#include <cstdio>
using namespace std;
diff -up openbabel-2.2.1b3-20090215-r2890/src/fingerprint.cpp.gcc43 openbabel-2.2.1b3-20090215-r2890/src/fingerprint.cpp
--- openbabel-2.2.1b3-20090215-r2890/src/fingerprint.cpp.gcc43 2008-12-01 18:42:02.000000000 +0100
+++ openbabel-2.2.1b3-20090215-r2890/src/fingerprint.cpp 2009-03-01 10:54:43.000000000 +0100
@@ -21,7 +21,7 @@ GNU General Public License for more deta
#include <vector>
#include <algorithm>
#include <iosfwd>
-#include <vector>
+#include <cstring>
#include <fstream>
#include <openbabel/fingerprint.h>
diff -up openbabel-2.2.1b3-20090215-r2890/src/formats/fchkformat.cpp.gcc43 openbabel-2.2.1b3-20090215-r2890/src/formats/fchkformat.cpp
--- openbabel-2.2.1b3-20090215-r2890/src/formats/fchkformat.cpp.gcc43 2009-02-10 23:40:18.000000000 +0100
+++ openbabel-2.2.1b3-20090215-r2890/src/formats/fchkformat.cpp 2009-03-01 10:54:43.000000000 +0100
@@ -12,6 +12,7 @@ GNU General Public License for more deta
***********************************************************************/
#include <numeric>
+#include <typeinfo>
// No diagnoalization yet. Perhaps for 2.2 -GRH
// #include <eigen/matrix.h>
diff -up openbabel-2.2.1b3-20090215-r2890/src/formats/rxnformat.cpp.gcc43 openbabel-2.2.1b3-20090215-r2890/src/formats/rxnformat.cpp
--- openbabel-2.2.1b3-20090215-r2890/src/formats/rxnformat.cpp.gcc43 2009-01-14 23:52:20.000000000 +0100
+++ openbabel-2.2.1b3-20090215-r2890/src/formats/rxnformat.cpp 2009-03-01 10:54:43.000000000 +0100
@@ -16,6 +16,7 @@ GNU General Public License for more deta
#include "openbabel/babelconfig.h"
#include <string>
#include <iomanip>
+#include <typeinfo>
#include "openbabel/mol.h"
#include "openbabel/obconversion.h"
#include "openbabel/reaction.h"
diff -up openbabel-2.2.1b3-20090215-r2890/src/obconversion.cpp.gcc43 openbabel-2.2.1b3-20090215-r2890/src/obconversion.cpp
--- openbabel-2.2.1b3-20090215-r2890/src/obconversion.cpp.gcc43 2009-01-28 21:38:24.000000000 +0100
+++ openbabel-2.2.1b3-20090215-r2890/src/obconversion.cpp 2009-03-01 10:54:43.000000000 +0100
@@ -38,6 +38,7 @@ GNU General Public License for more deta
#include <map>
#include <locale>
#include <limits>
+#include <typeinfo>
#include <stdlib.h>
diff -up openbabel-2.2.1b3-20090215-r2890/src/residue.cpp.gcc43 openbabel-2.2.1b3-20090215-r2890/src/residue.cpp
--- openbabel-2.2.1b3-20090215-r2890/src/residue.cpp.gcc43 2008-12-01 18:42:02.000000000 +0100
+++ openbabel-2.2.1b3-20090215-r2890/src/residue.cpp 2009-03-01 10:54:43.000000000 +0100
@@ -26,6 +26,8 @@ obtained in part or whole from RasMol2 b
// File Includes
///////////////////////////////////////////////////////////////////////////////
+#include <cstring>
+
#include <openbabel/babelconfig.h>
#include <openbabel/residue.h>
diff -up openbabel-2.2.1b3-20090215-r2890/src/zipstreamimpl.h.gcc43 openbabel-2.2.1b3-20090215-r2890/src/zipstreamimpl.h
--- openbabel-2.2.1b3-20090215-r2890/src/zipstreamimpl.h.gcc43 2008-12-01 18:42:02.000000000 +0100
+++ openbabel-2.2.1b3-20090215-r2890/src/zipstreamimpl.h 2009-03-01 10:54:43.000000000 +0100
@@ -31,6 +31,8 @@ Altered by: Geoffrey Hutchison 2005 for
minor namespace modifications, VC++ compatibility
*/
+#include <cstring>
+
//*****************************************************************************
// template class basic_zip_streambuf
//*****************************************************************************
diff -up openbabel-2.2.1b3-20090215-r2890/tools/babel.cpp.gcc43 openbabel-2.2.1b3-20090215-r2890/tools/babel.cpp
--- openbabel-2.2.1b3-20090215-r2890/tools/babel.cpp.gcc43 2008-12-01 18:42:04.000000000 +0100
+++ openbabel-2.2.1b3-20090215-r2890/tools/babel.cpp 2009-03-01 10:54:43.000000000 +0100
@@ -42,6 +42,7 @@ extern "C" int strncasecmp(const char *s
#include <openbabel/obconversion.h>
#include <openbabel/plugin.h>
#include <cstdlib>
+#include <cstring>
using namespace std;
using namespace OpenBabel;

12
openbabel-inchi.patch Normal file
View File

@ -0,0 +1,12 @@
diff -up openbabel-2.2.3/configure.in.inchi openbabel-2.2.3/configure.in
--- openbabel-2.2.3/configure.in.inchi 2009-07-29 03:05:04.000000000 +0200
+++ openbabel-2.2.3/configure.in 2009-08-26 16:26:08.000000000 +0200
@@ -239,7 +239,7 @@ AC_SUBST(LIBDL)
AM_PATH_XML2(2.6.5)
AM_CONDITIONAL(BUILD_XML, test x"$XML_LIBS" != "x")
-AC_CHECK_LIB(inchi, GetINCHI, LIBINCHI="-linchi", LIBINCHI="")
+AC_CHECK_LIB(stdinchi, GetStdINCHI, LIBINCHI="-lstdinchi", LIBINCHI="")
AM_CONDITIONAL(BUILD_INCHI, test x"$LIBINCHI" = "x" -o "$inchi" = "yes")
AC_CHECK_LIB(z, inflateEnd, [zlib_cv_libz=yes], [zlib_cv_libz=no])

View File

@ -4,20 +4,20 @@
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
%define ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"]')
%define beta_ver b3
%define beta_str b3-20090215-r2890
%define beta_ver %{nil}
%define beta_str %{nil}
Name: openbabel
Version: 2.2.1
Release: 0.2.%{beta_ver}%{?dist}
Version: 2.2.3
Release: 1%{beta_ver}%{?dist}
Summary: Chemistry software file format converter
License: GPLv2
Group: Applications/File
URL: http://openbabel.org/
Source: http://dl.sourceforge.net/sourceforge/openbabel/%{name}-%{version}%{beta_str}.tar.gz
Patch: %{name}-gcc43.patch
Source: http://downloads.sourceforge.net/sourceforge/openbabel/%{name}-%{version}%{beta_str}.tar.gz
Patch1: %{name}-rpm.patch
Patch2: %{name}-check.patch
Patch3: %{name}-inchi.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: inchi-devel
BuildRequires: libtool
@ -90,10 +90,10 @@ Ruby wrapper for the Open Babel library.
%prep
%setup -q -n %{name}-%{version}%{beta_str}
%patch -p1 -b .gcc43
%patch1 -p1 -b .r
%patch2 -p1 -b .chk
chmod 644 src/formats/{mmcif,fchk}format.cpp
%patch3 -p1 -b .inchi
chmod 644 src/formats/mmcifformat.cpp
%build
autoreconf --force --install
@ -183,6 +183,11 @@ popd
%{ruby_sitearch}/openbabel.so
%changelog
* Wed Aug 26 2009 Dominik Mierzejewski <rpm@greysector.net> 2.2.3-1
- updated to 2.2.3
- dropped obsolete patch
- fix configure to detect external inchi-1.0.2
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.1-0.2.b3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild