- updated to 2.2.0 beta3

- renamed language bindings subpackages
- added ruby bindings
- fixed ruby buildings build with local shared lib
- disable CML tests (broken upstream)
This commit is contained in:
Dominik Mierzejewski 2008-02-23 20:02:14 +00:00
parent 20ce8b420e
commit 971a7a72c9
5 changed files with 138 additions and 102 deletions

View File

@ -1 +1 @@
openbabel-2.1.1.tar.gz
openbabel-2.2.0b3-20080215-r2249.tar.gz

View File

@ -1,17 +1,17 @@
diff -up openbabel-2.1.1/src/dlhandler_unix.cpp.gcc43 openbabel-2.1.1/src/dlhandler_unix.cpp
--- openbabel-2.1.1/src/dlhandler_unix.cpp.gcc43 2007-04-14 02:34:11.000000000 +0200
+++ openbabel-2.1.1/src/dlhandler_unix.cpp 2008-01-07 23:15:46.000000000 +0100
@@ -25,6 +25,7 @@ GNU General Public License for more deta
#include <sys/stat.h>
diff -up openbabel-2.2.0b3-20080215-r2249/src/dlhandler_unix.cpp.gcc43 openbabel-2.2.0b3-20080215-r2249/src/dlhandler_unix.cpp
--- openbabel-2.2.0b3-20080215-r2249/src/dlhandler_unix.cpp.gcc43 2007-12-12 20:16:13.000000000 +0100
+++ openbabel-2.2.0b3-20080215-r2249/src/dlhandler_unix.cpp 2008-02-23 20:55:49.000000000 +0100
@@ -26,6 +26,7 @@ GNU General Public License for more deta
#include <dlfcn.h>
#include <cstring>
#include <cstdlib>
+#include <cstring>
using namespace std;
diff -up openbabel-2.1.1/src/zipstreamimpl.h.gcc43 openbabel-2.1.1/src/zipstreamimpl.h
--- openbabel-2.1.1/src/zipstreamimpl.h.gcc43 2006-12-28 16:19:05.000000000 +0100
+++ openbabel-2.1.1/src/zipstreamimpl.h 2008-01-07 23:15:46.000000000 +0100
diff -up openbabel-2.2.0b3-20080215-r2249/src/zipstreamimpl.h.gcc43 openbabel-2.2.0b3-20080215-r2249/src/zipstreamimpl.h
--- openbabel-2.2.0b3-20080215-r2249/src/zipstreamimpl.h.gcc43 2007-11-30 00:01:23.000000000 +0100
+++ openbabel-2.2.0b3-20080215-r2249/src/zipstreamimpl.h 2008-02-23 20:55:49.000000000 +0100
@@ -31,6 +31,8 @@ Altered by: Geoffrey Hutchison 2005 for
minor namespace modifications, VC++ compatibility
*/
@ -21,9 +21,9 @@ diff -up openbabel-2.1.1/src/zipstreamimpl.h.gcc43 openbabel-2.1.1/src/zipstream
//*****************************************************************************
// template class basic_zip_streambuf
//*****************************************************************************
diff -up openbabel-2.1.1/src/residue.cpp.gcc43 openbabel-2.1.1/src/residue.cpp
--- openbabel-2.1.1/src/residue.cpp.gcc43 2007-01-05 17:29:49.000000000 +0100
+++ openbabel-2.1.1/src/residue.cpp 2008-01-07 23:15:46.000000000 +0100
diff -up openbabel-2.2.0b3-20080215-r2249/src/residue.cpp.gcc43 openbabel-2.2.0b3-20080215-r2249/src/residue.cpp
--- openbabel-2.2.0b3-20080215-r2249/src/residue.cpp.gcc43 2007-12-12 20:16:13.000000000 +0100
+++ openbabel-2.2.0b3-20080215-r2249/src/residue.cpp 2008-02-23 20:55:49.000000000 +0100
@@ -26,6 +26,8 @@ obtained in part or whole from RasMol2 b
// File Includes
///////////////////////////////////////////////////////////////////////////////
@ -33,22 +33,11 @@ diff -up openbabel-2.1.1/src/residue.cpp.gcc43 openbabel-2.1.1/src/residue.cpp
#include <openbabel/babelconfig.h>
#include <openbabel/residue.h>
diff -up openbabel-2.1.1/src/tokenst.cpp.gcc43 openbabel-2.1.1/src/tokenst.cpp
--- openbabel-2.1.1/src/tokenst.cpp.gcc43 2006-12-28 16:21:51.000000000 +0100
+++ openbabel-2.1.1/src/tokenst.cpp 2008-01-07 23:15:46.000000000 +0100
@@ -25,7 +25,7 @@ GNU General Public License for more deta
#include <algorithm>
#include <vector>
#include <string>
-
+#include <cstring>
using namespace std;
diff -up openbabel-2.1.1/src/obconversion.cpp.gcc43 openbabel-2.1.1/src/obconversion.cpp
--- openbabel-2.1.1/src/obconversion.cpp.gcc43 2007-07-01 21:16:17.000000000 +0200
+++ openbabel-2.1.1/src/obconversion.cpp 2008-01-07 23:15:46.000000000 +0100
@@ -37,6 +37,7 @@ GNU General Public License for more deta
diff -up openbabel-2.2.0b3-20080215-r2249/src/tokenst.cpp.gcc43 openbabel-2.2.0b3-20080215-r2249/src/tokenst.cpp
diff -up openbabel-2.2.0b3-20080215-r2249/src/obconversion.cpp.gcc43 openbabel-2.2.0b3-20080215-r2249/src/obconversion.cpp
--- openbabel-2.2.0b3-20080215-r2249/src/obconversion.cpp.gcc43 2008-01-21 22:48:26.000000000 +0100
+++ openbabel-2.2.0b3-20080215-r2249/src/obconversion.cpp 2008-02-23 20:55:49.000000000 +0100
@@ -36,6 +36,7 @@ GNU General Public License for more deta
#include <sstream>
#include <string>
#include <map>
@ -56,21 +45,20 @@ diff -up openbabel-2.1.1/src/obconversion.cpp.gcc43 openbabel-2.1.1/src/obconver
#include <openbabel/obconversion.h>
diff -up openbabel-2.1.1/src/formats/rxnformat.cpp.gcc43 openbabel-2.1.1/src/formats/rxnformat.cpp
--- openbabel-2.1.1/src/formats/rxnformat.cpp.gcc43 2007-03-12 15:23:38.000000000 +0100
+++ openbabel-2.1.1/src/formats/rxnformat.cpp 2008-01-07 23:15:46.000000000 +0100
@@ -18,6 +18,8 @@ GNU General Public License for more deta
#pragma warning (disable : 4251) //
#endif
diff -up openbabel-2.2.0b3-20080215-r2249/src/formats/rxnformat.cpp.gcc43 openbabel-2.2.0b3-20080215-r2249/src/formats/rxnformat.cpp
--- openbabel-2.2.0b3-20080215-r2249/src/formats/rxnformat.cpp.gcc43 2007-12-18 20:12:51.000000000 +0100
+++ openbabel-2.2.0b3-20080215-r2249/src/formats/rxnformat.cpp 2008-02-23 20:58:22.000000000 +0100
@@ -16,6 +16,7 @@ GNU General Public License for more deta
#include "openbabel/babelconfig.h"
#include <string>
#include <iomanip>
+#include <typeinfo>
+
#include <openbabel/babelconfig.h>
#include <openbabel/mol.h>
diff -up openbabel-2.1.1/src/formats/fchkformat.cpp.gcc43 openbabel-2.1.1/src/formats/fchkformat.cpp
--- openbabel-2.1.1/src/formats/fchkformat.cpp.gcc43 2007-03-12 18:42:23.000000000 +0100
+++ openbabel-2.1.1/src/formats/fchkformat.cpp 2008-01-07 23:15:46.000000000 +0100
#include "openbabel/mol.h"
#include "openbabel/obconversion.h"
#include "openbabel/reaction.h"
diff -up openbabel-2.2.0b3-20080215-r2249/src/formats/fchkformat.cpp.gcc43 openbabel-2.2.0b3-20080215-r2249/src/formats/fchkformat.cpp
--- openbabel-2.2.0b3-20080215-r2249/src/formats/fchkformat.cpp.gcc43 2007-11-30 00:01:23.000000000 +0100
+++ openbabel-2.2.0b3-20080215-r2249/src/formats/fchkformat.cpp 2008-02-23 20:55:49.000000000 +0100
@@ -12,6 +12,7 @@ GNU General Public License for more deta
***********************************************************************/
@ -79,9 +67,9 @@ diff -up openbabel-2.1.1/src/formats/fchkformat.cpp.gcc43 openbabel-2.1.1/src/fo
// No diagnoalization yet. Perhaps for 2.2 -GRH
// #include <eigen/matrix.h>
diff -up openbabel-2.1.1/src/fingerprint.cpp.gcc43 openbabel-2.1.1/src/fingerprint.cpp
--- openbabel-2.1.1/src/fingerprint.cpp.gcc43 2007-06-02 15:56:31.000000000 +0200
+++ openbabel-2.1.1/src/fingerprint.cpp 2008-01-07 23:15:46.000000000 +0100
diff -up openbabel-2.2.0b3-20080215-r2249/src/fingerprint.cpp.gcc43 openbabel-2.2.0b3-20080215-r2249/src/fingerprint.cpp
--- openbabel-2.2.0b3-20080215-r2249/src/fingerprint.cpp.gcc43 2007-11-30 00:01:23.000000000 +0100
+++ openbabel-2.2.0b3-20080215-r2249/src/fingerprint.cpp 2008-02-23 20:55:49.000000000 +0100
@@ -21,7 +21,7 @@ GNU General Public License for more deta
#include <vector>
#include <algorithm>
@ -91,21 +79,9 @@ diff -up openbabel-2.1.1/src/fingerprint.cpp.gcc43 openbabel-2.1.1/src/fingerpri
#include <fstream>
#include <openbabel/fingerprint.h>
diff -up openbabel-2.1.1/scripts/perl/openbabel_perl.cpp.gcc43 openbabel-2.1.1/scripts/perl/openbabel_perl.cpp
--- openbabel-2.1.1/scripts/perl/openbabel_perl.cpp.gcc43 2007-07-01 22:14:02.000000000 +0200
+++ openbabel-2.1.1/scripts/perl/openbabel_perl.cpp 2008-01-07 23:30:21.000000000 +0100
@@ -812,6 +812,8 @@ extern "C" {
/* -----------------------------------------------------------------------------
* error manipulation
* ----------------------------------------------------------------------------- */
+SWIGINTERN const char*
+SWIG_Perl_ErrorType(int code) __attribute__((noinline));
SWIGINTERN const char*
SWIG_Perl_ErrorType(int code) {
diff -up openbabel-2.1.1/include/openbabel/xml.h.gcc43 openbabel-2.1.1/include/openbabel/xml.h
--- openbabel-2.1.1/include/openbabel/xml.h.gcc43 2007-02-26 17:28:03.000000000 +0100
+++ openbabel-2.1.1/include/openbabel/xml.h 2008-01-07 23:15:46.000000000 +0100
diff -up openbabel-2.2.0b3-20080215-r2249/include/openbabel/xml.h.gcc43 openbabel-2.2.0b3-20080215-r2249/include/openbabel/xml.h
--- openbabel-2.2.0b3-20080215-r2249/include/openbabel/xml.h.gcc43 2007-12-12 20:16:13.000000000 +0100
+++ openbabel-2.2.0b3-20080215-r2249/include/openbabel/xml.h 2008-02-23 20:55:49.000000000 +0100
@@ -13,6 +13,8 @@ MERCHANTABILITY or FITNESS FOR A PARTICU
GNU General Public License for more details.
***********************************************************************/
@ -115,9 +91,9 @@ diff -up openbabel-2.1.1/include/openbabel/xml.h.gcc43 openbabel-2.1.1/include/o
#include <openbabel/mol.h>
#include <openbabel/obconversion.h>
#include <openbabel/obmolecformat.h>
diff -up openbabel-2.1.1/include/openbabel/obconversion.h.gcc43 openbabel-2.1.1/include/openbabel/obconversion.h
--- openbabel-2.1.1/include/openbabel/obconversion.h.gcc43 2007-06-02 15:56:37.000000000 +0200
+++ openbabel-2.1.1/include/openbabel/obconversion.h 2008-01-07 23:15:46.000000000 +0100
diff -up openbabel-2.2.0b3-20080215-r2249/include/openbabel/obconversion.h.gcc43 openbabel-2.2.0b3-20080215-r2249/include/openbabel/obconversion.h
--- openbabel-2.2.0b3-20080215-r2249/include/openbabel/obconversion.h.gcc43 2008-01-16 19:42:43.000000000 +0100
+++ openbabel-2.2.0b3-20080215-r2249/include/openbabel/obconversion.h 2008-02-23 20:55:49.000000000 +0100
@@ -28,6 +28,7 @@ GNU General Public License for more deta
#include <string>
#include <vector>
@ -126,9 +102,9 @@ diff -up openbabel-2.1.1/include/openbabel/obconversion.h.gcc43 openbabel-2.1.1/
#include <openbabel/dlhandler.h>
#include <openbabel/oberror.h>
diff -up openbabel-2.1.1/include/openbabel/data.h.gcc43 openbabel-2.1.1/include/openbabel/data.h
--- openbabel-2.1.1/include/openbabel/data.h.gcc43 2007-04-14 02:34:14.000000000 +0200
+++ openbabel-2.1.1/include/openbabel/data.h 2008-01-07 23:15:46.000000000 +0100
diff -up openbabel-2.2.0b3-20080215-r2249/include/openbabel/data.h.gcc43 openbabel-2.2.0b3-20080215-r2249/include/openbabel/data.h
--- openbabel-2.2.0b3-20080215-r2249/include/openbabel/data.h.gcc43 2008-01-21 22:03:43.000000000 +0100
+++ openbabel-2.2.0b3-20080215-r2249/include/openbabel/data.h 2008-02-23 20:55:49.000000000 +0100
@@ -23,7 +23,7 @@ GNU General Public License for more deta
#include <openbabel/babelconfig.h>
@ -138,9 +114,9 @@ diff -up openbabel-2.1.1/include/openbabel/data.h.gcc43 openbabel-2.1.1/include/
#include <fstream>
#include <vector>
#include <string>
diff -up openbabel-2.1.1/include/openbabel/obmolecformat.h.gcc43 openbabel-2.1.1/include/openbabel/obmolecformat.h
--- openbabel-2.1.1/include/openbabel/obmolecformat.h.gcc43 2007-02-26 17:46:15.000000000 +0100
+++ openbabel-2.1.1/include/openbabel/obmolecformat.h 2008-01-07 23:15:46.000000000 +0100
diff -up openbabel-2.2.0b3-20080215-r2249/include/openbabel/obmolecformat.h.gcc43 openbabel-2.2.0b3-20080215-r2249/include/openbabel/obmolecformat.h
--- openbabel-2.2.0b3-20080215-r2249/include/openbabel/obmolecformat.h.gcc43 2007-12-12 20:16:13.000000000 +0100
+++ openbabel-2.2.0b3-20080215-r2249/include/openbabel/obmolecformat.h 2008-02-23 20:55:49.000000000 +0100
@@ -23,6 +23,8 @@ GNU General Public License for more deta
#include <hash_map>
#endif
@ -149,26 +125,16 @@ diff -up openbabel-2.1.1/include/openbabel/obmolecformat.h.gcc43 openbabel-2.1.1
+
#include <openbabel/mol.h>
#include <openbabel/obconversion.h>
diff -up openbabel-2.1.1/include/openbabel/lineend.h.gcc43 openbabel-2.1.1/include/openbabel/lineend.h
--- openbabel-2.1.1/include/openbabel/lineend.h.gcc43 2007-06-02 15:56:39.000000000 +0200
+++ openbabel-2.1.1/include/openbabel/lineend.h 2008-01-07 23:15:46.000000000 +0100
@@ -21,6 +21,7 @@ General Public License for more details.
#define OB_LINEEND_H
#include <streambuf>
+#include <climits>
#ifndef OBCONV
#define OBCONV
diff -up openbabel-2.1.1/tools/babel.cpp.gcc43 openbabel-2.1.1/tools/babel.cpp
--- openbabel-2.1.1/tools/babel.cpp.gcc43 2007-07-07 08:35:54.000000000 +0200
+++ openbabel-2.1.1/tools/babel.cpp 2008-01-07 23:15:46.000000000 +0100
@@ -35,6 +35,7 @@ GNU General Public License for more deta
#include <conio.h>
#endif
#include <typeinfo>
diff -up openbabel-2.2.0b3-20080215-r2249/include/openbabel/lineend.h.gcc43 openbabel-2.2.0b3-20080215-r2249/include/openbabel/lineend.h
diff -up openbabel-2.2.0b3-20080215-r2249/tools/babel.cpp.gcc43 openbabel-2.2.0b3-20080215-r2249/tools/babel.cpp
--- openbabel-2.2.0b3-20080215-r2249/tools/babel.cpp.gcc43 2007-12-12 20:16:13.000000000 +0100
+++ openbabel-2.2.0b3-20080215-r2249/tools/babel.cpp 2008-02-23 20:55:55.000000000 +0100
@@ -42,6 +42,7 @@ extern "C" int strncasecmp(const char *s
#include <openbabel/obconversion.h>
#include <openbabel/plugin.h>
#include <cstdlib>
+#include <cstring>
#if !HAVE_STRNCASECMP
extern "C" int strncasecmp(const char *s1, const char *s2, size_t n);
using namespace std;
using namespace OpenBabel;

30
openbabel-rpm.patch Normal file
View File

@ -0,0 +1,30 @@
diff -up openbabel-2.2.0b3-20080215-r2249/scripts/Makefile.am.r openbabel-2.2.0b3-20080215-r2249/scripts/Makefile.am
--- openbabel-2.2.0b3-20080215-r2249/scripts/Makefile.am.r 2008-01-24 21:43:42.000000000 +0100
+++ openbabel-2.2.0b3-20080215-r2249/scripts/Makefile.am 2008-02-23 15:48:26.000000000 +0100
@@ -58,8 +58,8 @@ ruby/openbabel_ruby.cpp: openbabel-ruby.
$(SWIG) -ruby -naturalvar -autorename -c++ -o $@ -I$(top_srcdir)/include \
-I$(top_builddir)/include $<;
(cd ruby; ruby extconf.rb \
- --with-openbabel-include=$(includedir)/openbabel-2.0 \
- --with-openbabel-lib=$(libdir) )
+ --with-openbabel-include=../../include/openbabel \
+ --with-openbabel-lib=../../src/.libs )
sed -e 's/rb_define_module(\"Openbabel\")/rb_define_module(\"OpenBabel\")/' -e 's/void Init_OpenBabel/void Init_openbabel/' <ruby/openbabel_ruby.cpp >ruby/openbabel_ruby.new
mv ruby/openbabel_ruby.new ruby/openbabel_ruby.cpp
endif # BUILD_RUBY
diff -up openbabel-2.2.0b3-20080215-r2249/test/cml.sh.r openbabel-2.2.0b3-20080215-r2249/test/cml.sh
--- openbabel-2.2.0b3-20080215-r2249/test/cml.sh.r 2008-01-10 18:47:23.000000000 +0100
+++ openbabel-2.2.0b3-20080215-r2249/test/cml.sh 2008-02-23 17:18:33.000000000 +0100
@@ -14,8 +14,8 @@ fi
echo
echo "# Testing CML support..."
-if [ -f $cmltestdir/test.sh ]; then
- (cd $cmltestdir; source test.sh 2>/dev/null)
-else
+#if [ -f $cmltestdir/test.sh ]; then
+# (cd $cmltestdir; source test.sh 2>/dev/null)
+#else
echo "1..0 # skipping - CML test set not found"
-fi
+#fi

View File

@ -2,16 +2,21 @@
%define perl_archlib %(eval "`perl -V:archlib`"; echo $archlib)
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
%define ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"]')
%define beta_ver b3
%define beta_str b3-20080215-r2249
Name: openbabel
Version: 2.1.1
Release: 4%{?dist}
Version: 2.2.0
Release: 0.1.%{beta_ver}%{?dist}
Summary: Chemistry software file format converter
License: GPLv2
Group: Applications/File
URL: http://openbabel.sourceforge.net/
Source: http://dl.sourceforge.net/sourceforge/openbabel/%{name}-%{version}.tar.gz
Source: http://dl.sourceforge.net/sourceforge/openbabel/%{name}-%{version}%{beta_str}.tar.gz
Patch: %{name}-gcc43.patch
Patch1: %{name}-rpm.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: inchi-devel
BuildRequires: libtool
@ -19,6 +24,9 @@ BuildRequires: libxml2-devel
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: python
BuildRequires: python-devel
BuildRequires: ruby
BuildRequires: ruby-devel
BuildRequires: swig
#TODO: enable when GUI is functional
#BuildRequires: wxGTK-devel
BuildRequires: zlib-devel
@ -51,27 +59,41 @@ If you are going to develop programs which will use this library
you should install %{name}-devel. You'll also need to have the
%{name} package installed.
%package perl
%package -n perl-%{name}
Group: System Environment/Libraries
Summary: Perl wrapper for the Open Babel library
Obsoletes: %{name}-perl < 2.2.0
Provides: %{name}-perl
%description perl
%description -n perl-%{name}
Perl wrapper for the Open Babel library.
%package python
%package -n python-%{name}
Group: System Environment/Libraries
Summary: Python wrapper for the Open Babel library
Obsoletes: %{name}-python < 2.2.0
Provides: %{name}-python
%description python
%description -n python-%{name}
Python wrapper for the Open Babel library.
%package -n ruby-%{name}
Summary: Ruby wrapper for the Open Babel library
Group: Development/Libraries
Requires: ruby(abi) = 1.8
Requires: %{name} = %{version}-%{release}
%description -n ruby-%{name}
Ruby wrapper for the Open Babel library.
%prep
%setup -q
%setup -q -n %{name}-%{version}%{beta_str}
%patch -p1 -b .gcc43
%patch1 -p1 -b .r
%build
autoreconf --force --install
%configure --enable-shared=yes --enable-static=no
%configure --enable-shared=yes --enable-static=no --enable-maintainer-mode
%{__make} %{?_smp_mflags}
pushd scripts/perl
@ -83,6 +105,10 @@ pushd scripts/python
python setup.py build
popd
pushd scripts/ruby
%{__make} %{?_smp_mflags}
popd
%install
%{__rm} -rf $RPM_BUILD_ROOT
@ -102,9 +128,12 @@ pushd scripts/python
%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
popd
pushd scripts/ruby
%{__make} install DESTDIR=$RPM_BUILD_ROOT
popd
# work around testsuite crash
%{__rm} src/formats/.libs/*.soT
%{__rm} src/formats/xml/.libs/*.soT
%clean
%{__rm} -rf $RPM_BUILD_ROOT
@ -133,20 +162,31 @@ popd
%{_libdir}/libopenbabel.so
%{_libdir}/pkgconfig/*.pc
%files perl
%files -n perl-%{name}
%defattr(-,root,root,-)
%{perl_vendorarch}/Chemistry/OpenBabel.pm
%dir %{perl_vendorarch}/*/Chemistry/OpenBabel
%{perl_vendorarch}/*/Chemistry/OpenBabel/OpenBabel.so
%files python
%files -n python-%{name}
%defattr(-,root,root,-)
%{python_sitearch}/_openbabel.so
%{python_sitearch}/openbabel.py*
%{python_sitearch}/pybel.py*
%{python_sitearch}/openbabel*.egg-info
%files -n ruby-%{name}
%defattr(-, root, root, -)
%{ruby_sitearch}/openbabel.so
%changelog
* Fri Feb 22 2008 Dominik Mierzejewski <rpm@greysector.net> 2.2.0-0.1.b3
- updated to 2.2.0 beta3
- renamed language bindings subpackages
- added ruby bindings
- fixed ruby buildings build with local shared lib
- disable CML tests (broken upstream)
* Mon Jan 07 2008 Dominik Mierzejewski <rpm@greysector.net> 2.1.1-4
- work around gcc bug: http://gcc.gnu.org/PR34708

View File

@ -1 +1 @@
a2a002c6913d6fb94fdc7dede2166194 openbabel-2.1.1.tar.gz
0d0b79d0b8c4ba83efada0d8668f63af openbabel-2.2.0b3-20080215-r2249.tar.gz