rebase openbabel-disable-tests-some-arches.patch

This commit is contained in:
Dominik Mierzejewski 2015-02-12 18:00:13 +01:00
parent 8200c87716
commit 94c7d9d3d2
1 changed files with 16 additions and 15 deletions

View File

@ -1,15 +1,16 @@
diff -up openbabel-2.3.2/test/CMakeLists.txt.ppc64 openbabel-2.3.2/test/CMakeLists.txt
--- openbabel-2.3.2/test/CMakeLists.txt.ppc64 2014-10-15 13:39:48.258473495 +0200
+++ openbabel-2.3.2/test/CMakeLists.txt 2014-10-15 13:41:01.730471702 +0200
@@ -18,7 +18,6 @@ set(tests
implicitH
lssr
isomorphism
- rotor
shuffle
smiles
spectrophore
@@ -120,7 +119,7 @@ if(WITH_INCHI)
diff -up openbabel-75414ad4e043f16ba72ae51c7ca60f448576688d/test/CMakeLists.txt.some_arches openbabel-75414ad4e043f16ba72ae51c7ca60f448576688d/test/CMakeLists.txt
--- openbabel-75414ad4e043f16ba72ae51c7ca60f448576688d/test/CMakeLists.txt.some_arches 2015-02-04 20:04:57.000000000 +0100
+++ openbabel-75414ad4e043f16ba72ae51c7ca60f448576688d/test/CMakeLists.txt 2015-02-12 15:47:20.754833641 +0100
@@ -31,7 +31,7 @@ set (graphsym_parts 1 2 3 4 5)
set (implicitH_parts 1)
set (lssr_parts 1 2 3 4 5)
set (isomorphism_parts 1 2 3 4 5 6 7 8)
-set (rotor_parts 1 2 3 4)
+set (rotor_parts 1 2 4)
set (shuffle_parts 1 2 3 4 5)
set (smiles_parts 1 2 3)
set (spectrophore_parts 1 2 3 4 5)
@@ -172,7 +172,7 @@ if(WITH_INCHI)
set_target_properties(test_inchiwrite PROPERTIES LINK_SEARCH_END_STATIC TRUE)
endif()
# files in test/inchi -- both .sdf and .txt
@ -18,12 +19,12 @@ diff -up openbabel-2.3.2/test/CMakeLists.txt.ppc64 openbabel-2.3.2/test/CMakeLis
set(inchidata ${CMAKE_SOURCE_DIR}/test/inchi)
foreach(test ${inchitests})
add_test(inchi${test}_Test
@@ -171,7 +170,7 @@ if(NOT MINGW AND NOT CYGWIN)
@@ -210,7 +210,7 @@ if(NOT MINGW AND NOT CYGWIN)
include(UsePythonTest)
if(PYTHON_EXECUTABLE)
set(pytests
- babel sym fastsearch unique kekule)
+ babel fastsearch unique kekule)
- babel sym smartssym fastsearch unique kekule)
+ babel smartssym fastsearch unique kekule)
foreach(pytest ${pytests})
SET_SOURCE_FILES_PROPERTIES(test${pytest}.py PROPERTIES
PYTHONPATH "${CMAKE_SOURCE_DIR}/scripts/python:${CMAKE_BINARY_DIR}/lib${LIB_SUFFIX}"