Update to 2.3.2 and turn off versioned data directories.

This commit is contained in:
Susi Lehtola 2013-07-18 11:54:30 +03:00
parent e17aed5d75
commit 7e9367c76e
4 changed files with 108 additions and 56 deletions

1
.gitignore vendored
View File

@ -2,3 +2,4 @@ openbabel-2.0.2.tar.gz
/openbabel-2.3.0b2-20100803-r3942.tar.gz
/openbabel-2.3.0.tar.gz
/openbabel-2.3.1.tar.gz
/openbabel-2.3.2.tar.gz

View File

@ -0,0 +1,19 @@
diff -up openbabel-2.3.2/scripts/CMakeLists.txt.cmakepol openbabel-2.3.2/scripts/CMakeLists.txt
--- openbabel-2.3.2/scripts/CMakeLists.txt.cmakepol 2012-10-03 22:08:52.000000000 +0300
+++ openbabel-2.3.2/scripts/CMakeLists.txt 2013-07-18 10:31:52.295263987 +0300
@@ -222,15 +222,6 @@ if (DO_PERL_BINDINGS)
endif (NOT WIN32)
endif (RUN_SWIG)
- add_library(bindings_perl MODULE ${openbabel_SOURCE_DIR}/scripts/perl/openbabel-perl.cpp)
- target_link_libraries(bindings_perl ${PERL_LIBRARY} ${BABEL_LIBRARY} ${PERL_EXTRA_LINK_FLAGS})
- set_target_properties(bindings_perl PROPERTIES
- PREFIX ""
- OUTPUT_NAME OpenBabel)
- add_dependencies(bindings_perl openbabel)
- install(TARGETS bindings_perl LIBRARY DESTINATION ${LIB_INSTALL_DIR})
- install(FILES ${openbabel_SOURCE_DIR}/scripts/perl/OpenBabel.pm DESTINATION ${LIB_INSTALL_DIR})
-
set(PERL_INSTALLDIRS_TEXT "")
if (OBPERL_INSTALLDIRS)
set(PERL_INSTALLDIRS_TEXT "INSTALLDIRS=${OBPERL_INSTALLDIRS}")

View File

@ -1,15 +1,16 @@
%define perl_vendorarch %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
%define perl_archlib %(eval "`perl -V:archlib`"; echo $archlib)
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
# we don't want to provide private Perl or Python extension libs
%global __provides_exclude_from ^(%{perl_vendorarch}/auto/.*\\.so|%{python_sitearch}/.*\\.so)$
%define beta_ver %{nil}
%define beta_str %{nil}
%define beta_dir %{nil}
Name: openbabel
Version: 2.3.1
Release: 9%{beta_ver}%{?dist}
Version: 2.3.2
Release: 1%{beta_ver}%{?dist}
Summary: Chemistry software file format converter
License: GPLv2
Group: Applications/File
@ -17,6 +18,9 @@ URL: http://openbabel.org/
Source0: http://downloads.sourceforge.net/sourceforge/openbabel/%{name}-%{version}%{beta_str}.tar.gz
Source1: obgui.desktop
Patch1: %{name}-rpm.patch
# http://sourceforge.net/p/openbabel/bugs/839/ perl bindings fail to build
Patch2: openbabel-2.3.2-cmake.patch
# fix plugin directory location (#680292, patch by lg)
Patch4: openbabel-2.3.0-plugindir.patch
# Patch 5-7: all ruby related
@ -29,18 +33,16 @@ Patch7: openbabel-2.3.1-ruby19-vendorarch.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: cmake
BuildRequires: desktop-file-utils
BuildRequires: eigen2-devel
BuildRequires: eigen3-devel
BuildRequires: inchi-devel >= 1.0.3
BuildRequires: libxml2-devel
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: python
BuildRequires: python-devel
BuildRequires: ruby
BuildRequires: python2-devel
BuildRequires: ruby-devel
BuildRequires: swig
BuildRequires: wxGTK-devel
BuildRequires: zlib-devel
BuildRequires: %{_bindir}/convert
BuildRequires: ImageMagick
%description
Open Babel is a free, open-source version of the Babel chemistry file
@ -55,10 +57,27 @@ between various chemical file formats as well as a wide variety of
utilities to foster development of other open source scientific
software.
%package devel
Summary: Development tools for programs which will use the Open Babel library
Group: Development/Libraries
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
Requires: pkgconfig
%description devel
The %{name}-devel package includes the header files and libraries
necessary for developing programs using the Open Babel library.
%package doc
Summary: Additional documentation for the Open Babel library
Group: Documentation
BuildArch: noarch
%description doc
This package contains additional documentation for Open Babel.
%package gui
Summary: Chemistry software file format converter - GUI version
Group: Applications/File
Requires: hicolor-icon-theme
%description gui
Open Babel is a free, open-source version of the Babel chemistry file
@ -84,26 +103,13 @@ computational chemistry, and many related areas.
This package contains the C++ library, which includes all of the
file-translation code.
%package devel
Summary: Development tools for programs which will use the Open Babel library
Group: Development/Libraries
Requires: %{name}-libs = %{version}-%{release}
Requires: pkgconfig
%description devel
The %{name}-devel package includes the header files and libraries
necessary for developing programs using the Open Babel library.
If you are going to develop programs which will use this library
you should install %{name}-devel. You'll also need to have the
%{name} package installed.
%package -n perl-%{name}
Group: System Environment/Libraries
Summary: Perl wrapper for the Open Babel library
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
Obsoletes: %{name}-perl < 2.2.0
Provides: %{name}-perl = %{version}-%{release}
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%description -n perl-%{name}
Perl wrapper for the Open Babel library.
@ -113,6 +119,7 @@ Group: System Environment/Libraries
Summary: Python wrapper for the Open Babel library
Obsoletes: %{name}-python < 2.2.0
Provides: %{name}-python = %{version}-%{release}
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%description -n python-%{name}
Python wrapper for the Open Babel library.
@ -125,14 +132,15 @@ Requires: ruby(release)
%else
Requires: ruby(abi) = 1.9.1
%endif
Requires: %{name} = %{version}-%{release}
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%description -n ruby-%{name}
Ruby wrapper for the Open Babel library.
%prep
%setup -q -n %{name}-%{version}%{beta_dir}
%patch1 -p1 -b .r
%patch1 -p1 -b .rpm
%patch2 -p1 -b .cmakepol
%patch4 -p1 -b .plugindir
%patch5 -p1 -b .gcc47
%patch6 -p1 -b .noswig_ruby
@ -142,6 +150,15 @@ chmod 644 src/math/align.cpp
chmod 644 include/openbabel/{graphsym.h,math/align.h}
convert src/GUI/babel.xpm -transparent white babel.png
# Remove duplicate html files
pushd doc
for man in *.1; do
html=`basename $man .1`.html
if [ -f $html ]; then
rm $html
fi
done
%build
%cmake \
-DCMAKE_SKIP_RPATH:BOOL=ON \
@ -150,32 +167,40 @@ convert src/GUI/babel.xpm -transparent white babel.png
-DPERL_BINDINGS:BOOL=ON \
-DRUBY_BINDINGS:BOOL=ON \
-DOPENBABEL_USE_SYSTEM_INCHI=true \
-DENABLE_VERSIONED_FORMATS=false \
-DRUN_SWIG=true \
.
make VERBOSE=1 %{?_smp_mflags}
%install
%{__rm} -rf $RPM_BUILD_ROOT
make VERBOSE=1 DESTDIR=$RPM_BUILD_ROOT ruby_headers= install
rm -rf %{buildroot}
make VERBOSE=1 DESTDIR=%{buildroot} ruby_headers= install
rm $RPM_BUILD_ROOT%{_libdir}/cmake/openbabel2/*.cmake
rm $RPM_BUILD_ROOT%{_libdir}/perl5/perllocal.pod
rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Chemistry/OpenBabel/{.packlist,OpenBabel.bs}
chmod 755 $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Chemistry/OpenBabel/OpenBabel.so
# Put Python bindings in the right place.
# See http://sourceforge.net/p/openbabel/bugs/837/
mkdir -p %{buildroot}%{python_sitearch}
mv %{buildroot}%{_libdir}/_openbabel.so \
%{buildroot}%{_libdir}/openbabel.py* \
%{buildroot}%{_libdir}/pybel.py* \
%{buildroot}%{python_sitearch}
desktop-file-install --dir=$RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE1}
install -Dpm644 babel.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/babel.png
rm %{buildroot}%{_libdir}/cmake/openbabel2/*.cmake
rm %{buildroot}%{_libdir}/perl5/perllocal.pod
rm -f %{buildroot}%{perl_vendorarch}/auto/Chemistry/OpenBabel/{.packlist,OpenBabel.bs}
chmod 755 %{buildroot}%{perl_vendorarch}/auto/Chemistry/OpenBabel/OpenBabel.so
desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE1}
install -Dpm644 babel.png %{buildroot}%{_datadir}/pixmaps/babel.png
%clean
%{__rm} -rf $RPM_BUILD_ROOT
rm -rf %{buildroot}
%if 0
%check
%{__make} test
make test
%endif
%post libs -p /sbin/ldconfig
%postun libs -p /sbin/ldconfig
%files
@ -183,22 +208,7 @@ install -Dpm644 babel.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/ba
%{_bindir}/babel
%{_bindir}/ob*
%{_bindir}/roundtrip
%{_mandir}/man1/*
%files gui
%defattr(-,root,root,-)
%{_bindir}/obgui
%{_datadir}/applications
%{_datadir}/icons/hicolor/32x32/apps/babel.png
%files libs
%defattr(-,root,root,-)
%doc AUTHORS COPYING ChangeLog README THANKS
%doc doc/*.html
%doc doc/README* doc/dioxin.*
%{_libdir}/libopenbabel.so.*
%{_libdir}/%{name}
%{_datadir}/%{name}
%{_mandir}/man1/*.1*
%files devel
%defattr(-,root,root,-)
@ -206,6 +216,22 @@ install -Dpm644 babel.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/ba
%{_libdir}/libopenbabel.so
%{_libdir}/pkgconfig/*.pc
%files doc
%defattr(-,root,root,-)
%doc doc/*.html doc/README* doc/dioxin.*
%files gui
%defattr(-,root,root,-)
%{_bindir}/obgui
%{_datadir}/applications/obgui.desktop
%{_datadir}/pixmaps/babel.png
%files libs
%defattr(-,root,root,-)
%{_datadir}/%{name}/
%{_libdir}/%{name}/
%{_libdir}/libopenbabel.so.*
%files -n perl-%{name}
%defattr(-,root,root,-)
%{perl_vendorarch}/Chemistry/OpenBabel.pm
@ -217,13 +243,19 @@ install -Dpm644 babel.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/ba
%{python_sitearch}/_openbabel.so
%{python_sitearch}/openbabel.py*
%{python_sitearch}/pybel.py*
%{python_sitearch}/openbabel*.egg-info
# Egg-info is not generated in 2.3.2, see upstream bug 837
#%{python_sitearch}/openbabel*.egg-info
%files -n ruby-%{name}
%defattr(-, root, root, -)
%defattr(-,root,root,-)
%{ruby_vendorarchdir}/openbabel.so
%changelog
* Thu Jul 18 2013 Susi Lehtola <jussilehtola@fedoraproject.org> - 2.3.2-1
- Turned off versioned formats.
- Filter out private provides.
- Update to 2.3.2.
* Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 2.3.1-9
- Perl 5.18 rebuild

View File

@ -1 +1 @@
1f029b0add12a3b55582dc2c832b04f8 openbabel-2.3.1.tar.gz
9b0007560d9d838b40ab4ad06daf5610 openbabel-2.3.2.tar.gz