Unify patches which disable tests on some arches

Affected arches: ppc64, s390(x), arm and aarch64.
rhbugs: #1108103 #1094491 #1094513

Based on a patch by Marcin Juszkiewicz <mjuszkie@redhat.com>
This commit is contained in:
Dominik 'Rathann' Mierzejewski 2015-01-27 15:28:12 +01:00
parent 7b85c1c31d
commit 7249506091
3 changed files with 13 additions and 31 deletions

View File

@ -1,21 +0,0 @@
diff -up openbabel-2.3.2/test/CMakeLists.txt.arm openbabel-2.3.2/test/CMakeLists.txt
--- openbabel-2.3.2/test/CMakeLists.txt.arm 2014-05-01 16:24:22.000000000 +0200
+++ openbabel-2.3.2/test/CMakeLists.txt 2014-05-05 21:53:02.217223215 +0200
@@ -120,7 +120,7 @@ if(WITH_INCHI)
set_target_properties(test_inchiwrite PROPERTIES LINK_SEARCH_END_STATIC TRUE)
endif()
# files in test/inchi -- both .sdf and .txt
- set(inchitests Samples.sdf SamplesTechMan.sdf Steffen_PubChem.smi)
+ set(inchitests Samples.sdf SamplesTechMan.sdf)
set(inchidata ${CMAKE_SOURCE_DIR}/test/inchi)
foreach(test ${inchitests})
add_test(inchi${test}_Test
@@ -171,7 +171,7 @@ if(NOT MINGW AND NOT CYGWIN)
include(UsePythonTest)
if(PYTHON_EXECUTABLE)
set(pytests
- babel sym fastsearch unique kekule)
+ babel fastsearch unique kekule)
foreach(pytest ${pytests})
SET_SOURCE_FILES_PROPERTIES(test${pytest}.py PROPERTIES
PYTHONPATH "${CMAKE_SOURCE_DIR}/scripts/python:${CMAKE_BINARY_DIR}/lib${LIB_SUFFIX}"

View File

@ -10,7 +10,7 @@
Name: openbabel
Version: 2.3.2
Release: 10%{beta_ver}%{?dist}
Release: 11%{beta_ver}%{?dist}
Summary: Chemistry software file format converter
License: GPLv2
Group: Applications/File
@ -31,10 +31,12 @@ Patch5: openbabel-2.3.1-gcc47-darwin.patch
Patch6: openbabel-2.3.1-noswig-rubymethod.patch
# On F-17, directory for C ruby files changed to use vendorarch directory
Patch7: openbabel-2.3.1-ruby19-vendorarch.patch
# Two tests are failing on ARM (#1094491)
Patch8: openbabel-disable-tests-arm.patch
# temporarily disable some tests on ppc64 and s390(x) to unblock other builds (#1108103)
Patch9: openbabel-disable-tests-ppc64.patch
# temporarily disable some tests on:
# - ppc64 and s390(x) to unblock other builds (#1108103)
# - ARM (#1094491)
# - aarch64 (#1094513)
# Upstream bugs: https://sourceforge.net/p/openbabel/bugs/927/ https://sourceforge.net/p/openbabel/bugs/945/
Patch8: openbabel-disable-tests-some-arches.patch
# Remove deprecated usage on ruby 22
Patch10: openbabel-2.3.1-ruby22-remove-deprecated-usage.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -148,11 +150,8 @@ Ruby wrapper for the Open Babel library.
%patch5 -p1 -b .gcc47
%patch6 -p1 -b .noswig_ruby
%patch7 -p1 -b .ruby_vendor
%ifarch armv7hl
%patch8 -p1 -b .arm
%endif
%ifarch %{power64} s390 s390x
%patch9 -p1 -b .ppc64
%ifarch %{power64} s390 s390x armv7hl aarch64
%patch8 -p1 -b .some_arches
%endif
%patch10 -p1 -b .rbconfig
chmod 644 src/formats/{fchk,genbank,mmcif}format.cpp
@ -259,6 +258,10 @@ make test
%{ruby_vendorarchdir}/openbabel.so
%changelog
* Tue Jan 27 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 2.3.2-11
- Unify patches which disable tests on ppc64, s390(x), arm and enable
result also for aarch64. rhbugs: #1108103 #1094491 #1094513
* Fri Jan 16 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.3.2-10
- Rebuild for https://fedoraproject.org/wiki/Changes/Ruby_2.2
- Remove deprecated Config:: usage