- update to 2.1.0b4 to fix building with new python
- dropped obsolete patch - ensure proper inchi versioning
This commit is contained in:
parent
3966db2eca
commit
10244b4618
@ -1 +1 @@
|
||||
openbabel-2.0.2.tar.gz
|
||||
openbabel-2.1.0b4.tar.gz
|
||||
|
@ -1,24 +1,23 @@
|
||||
--- openbabel-2.0.2/scripts/perl/Makefile.PL.chicken 2006-05-03 17:54:54.000000000 +0200
|
||||
+++ openbabel-2.0.2/scripts/perl/Makefile.PL 2006-09-20 05:55:53.000000000 +0200
|
||||
@@ -4,7 +4,8 @@
|
||||
$srcdir = '../../src';
|
||||
--- openbabel-2.1.0b4/scripts/perl/Makefile.PL.chicken 2006-12-10 13:57:57.000000000 +0100
|
||||
+++ openbabel-2.1.0b4/scripts/perl/Makefile.PL 2006-12-18 00:45:12.000000000 +0100
|
||||
@@ -5,6 +5,8 @@
|
||||
|
||||
# check if we're compiling in the source directory
|
||||
-$ldfrom = '$(OBJECT) -lopenbabel -lz';
|
||||
$ldfrom = '$(OBJECT) -lopenbabel -lz';
|
||||
+$ldfrom = "\$(OBJECT) -L$srcdir/.libs -lopenbabel -lz"
|
||||
+ if (-r "$srcdir/.libs/libopenbabel.so") and (-s _) and (-B _);
|
||||
$ldfrom = "\$(OBJECT) $srcdir/.libs/libopenbabel.a -lz"
|
||||
if (-r "$srcdir/.libs/libopenbabel.a") and (-s _) and (-B _);
|
||||
|
||||
--- openbabel-2.0.2/scripts/python/setup.py.chicken 2006-05-03 17:54:53.000000000 +0200
|
||||
+++ openbabel-2.0.2/scripts/python/setup.py 2006-09-20 05:53:33.000000000 +0200
|
||||
@@ -41,6 +41,9 @@
|
||||
"INFO: Looking for library and include files in ../../src\n")
|
||||
if os.path.isfile("../../src/atom.o"):
|
||||
return ["../../src"],["../../src"]
|
||||
+ else:
|
||||
+ if os.path.isfile("../../src/atom.lo"):
|
||||
+ return ["../../src"],["../../src/.libs"]
|
||||
|
||||
sys.stderr.write("ERROR: Cannot find Open Babel library directory\n")
|
||||
return (None,None)
|
||||
--- openbabel-2.1.0b4/scripts/python/setup.py.chicken 2006-12-10 13:58:47.000000000 +0100
|
||||
+++ openbabel-2.1.0b4/scripts/python/setup.py 2006-12-18 01:07:25.000000000 +0100
|
||||
@@ -31,6 +31,9 @@
|
||||
sys.stderr.write("INFO: Looking for library and include files in ../../src\n")
|
||||
if os.path.isfile("../../src/atom.o"):
|
||||
return ["../../include"],["../../src"]
|
||||
+ else:
|
||||
+ if os.path.isfile("../../src/atom.lo"):
|
||||
+ return ["../../include"],["../../src/.libs"]
|
||||
|
||||
for dirname in ["/usr/local","/usr"]:
|
||||
# Look for each of these directories in turn for the directory include/openbabel-2.0
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- openbabel-2.0.2/src/formats/xml/Makefile.am.r 2006-05-24 21:37:41.000000000 +0200
|
||||
+++ openbabel-2.0.2/src/formats/xml/Makefile.am 2006-08-05 22:13:11.000000000 +0200
|
||||
@@ -3,7 +3,6 @@
|
||||
INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/data
|
||||
AM_CPPFLAGS = @XML_CPPFLAGS@
|
||||
AM_LDFLAGS = @LIBS@ @XML_LIBS@
|
||||
-CXXFLAGS += -O0
|
||||
|
||||
if BUILD_SHARED
|
||||
|
@ -4,27 +4,23 @@
|
||||
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
||||
|
||||
%define inchi_ver 1.0.1
|
||||
%define inchi_rel 5
|
||||
|
||||
Name: openbabel
|
||||
Version: 2.0.2
|
||||
Release: 5%{?dist}
|
||||
Version: 2.1.0
|
||||
Release: 0.1.b4%{?dist}
|
||||
Summary: Chemistry software file format converter
|
||||
License: GPL
|
||||
Group: Applications/File
|
||||
URL: http://openbabel.sourceforge.net/
|
||||
Source: http://dl.sourceforge.net/sourceforge/openbabel/%{name}-%{version}.tar.gz
|
||||
Patch0: %{name}-cxxflags.patch
|
||||
Source: http://dl.sourceforge.net/sourceforge/openbabel/%{name}-%{version}b4.tar.gz
|
||||
Patch1: %{name}-chicken.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
#BuildRequires: doxygen
|
||||
BuildRequires: libtool
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: perl
|
||||
BuildRequires: python
|
||||
BuildRequires: python-devel
|
||||
BuildRequires: swig
|
||||
BuildRequires: zlib-devel
|
||||
|
||||
%description
|
||||
@ -60,6 +56,7 @@ Summary: The IUPAC International Chemical Identifier (InChI) library
|
||||
Group: System Environment/Libraries
|
||||
License: LGPL
|
||||
Version: %{inchi_ver}
|
||||
Release: %{inchi_rel}%{?dist}
|
||||
|
||||
%description -n inchi
|
||||
The IUPAC International Chemical Identifier (InChI) library.
|
||||
@ -69,7 +66,8 @@ Summary: Development headers for InChI library
|
||||
Group: Development/Libraries
|
||||
License: LGPL
|
||||
Version: %{inchi_ver}
|
||||
Requires: inchi = %{inchi_ver}-%{release}
|
||||
Release: %{inchi_rel}%{?dist}
|
||||
Requires: inchi = %{inchi_ver}-%{inchi_rel}%{?dist}
|
||||
|
||||
%description -n inchi-devel
|
||||
The inchi-devel package includes the header files and libraries
|
||||
@ -94,8 +92,7 @@ Summary: Python wrapper for the Open Babel library
|
||||
Python wrapper for the Open Babel library.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .cxxflags
|
||||
%setup -q -n %{name}-2.1.0b4
|
||||
%patch1 -p1 -b .chicken
|
||||
|
||||
%build
|
||||
@ -106,7 +103,6 @@ autoreconf --force --install
|
||||
pushd scripts/perl
|
||||
perl Makefile.PL INSTALLDIRS="vendor"
|
||||
%{__make} %{?_smp_mflags} OPTIMIZE="$RPM_OPT_FLAGS"
|
||||
#%{__make} test
|
||||
popd
|
||||
|
||||
pushd scripts/python
|
||||
@ -125,6 +121,7 @@ pushd scripts/perl
|
||||
popd
|
||||
%{__rm} -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
|
||||
%{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/*/Chemistry/OpenBabel/{.packlist,OpenBabel.bs}
|
||||
chmod 755 $RPM_BUILD_ROOT%{perl_vendorarch}/*/Chemistry/OpenBabel/OpenBabel.so
|
||||
|
||||
pushd scripts/python
|
||||
%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
|
||||
@ -180,8 +177,14 @@ popd
|
||||
%defattr(-,root,root,-)
|
||||
%{python_sitearch}/_openbabel.so
|
||||
%{python_sitearch}/openbabel.py*
|
||||
%{python_sitearch}/pybel.py*
|
||||
|
||||
%changelog
|
||||
* Sun Dec 17 2006 Dominik Mierzejewski <rpm@greysector.net> 2.1.0-0.1.b4
|
||||
- update to 2.1.0b4 to fix building with new python
|
||||
- dropped obsolete patch
|
||||
- ensure proper inchi versioning
|
||||
|
||||
* Tue Oct 03 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-5
|
||||
- rebuilt for unwind info generation, broken in gcc-4.1.1-21
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user