Update to 3.6.1.
This commit is contained in:
parent
b03c7174c6
commit
f4a1a1c2b6
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@ octave-3.2.4.tar.bz2
|
|||||||
/octave-3.4.2.tar.bz2
|
/octave-3.4.2.tar.bz2
|
||||||
/octave-3.4.3.tar.bz2
|
/octave-3.4.3.tar.bz2
|
||||||
/octave-3.6.0.tar.bz2
|
/octave-3.6.0.tar.bz2
|
||||||
|
/octave-3.6.1.tar.bz2
|
||||||
|
@ -1,24 +0,0 @@
|
|||||||
diff --git a/src/load-save.cc b/src/load-save.cc
|
|
||||||
--- a/src/load-save.cc
|
|
||||||
+++ b/src/load-save.cc
|
|
||||||
@@ -649,7 +649,7 @@
|
|
||||||
std::string orig_fname = "";
|
|
||||||
|
|
||||||
// Function called with Matlab-style ["filename", options] syntax
|
|
||||||
- if (argc > 1 && argv[1].at(0) != '-')
|
|
||||||
+ if (argc > 1 && ! argv[1].empty () && argv[1].at(0) != '-')
|
|
||||||
{
|
|
||||||
orig_fname = argv[1];
|
|
||||||
i++;
|
|
||||||
diff --git a/test/test_io.m b/test/test_io.m
|
|
||||||
--- a/test/test_io.m
|
|
||||||
+++ b/test/test_io.m
|
|
||||||
@@ -227,6 +227,8 @@
|
|
||||||
%!
|
|
||||||
%! delete matrix.ascii;
|
|
||||||
|
|
||||||
+%!error <unable to find file> load ("")
|
|
||||||
+
|
|
||||||
%% FIXME: This test is disabled as it writes to stdout and there is no easy
|
|
||||||
%% way to recover output. Need to spawn new octave process and pipe stdout
|
|
||||||
%% somewhere to treat this case.
|
|
10
octave.spec
10
octave.spec
@ -2,8 +2,8 @@
|
|||||||
%global octave_api api-v48+
|
%global octave_api api-v48+
|
||||||
|
|
||||||
Name: octave
|
Name: octave
|
||||||
Version: 3.6.0
|
Version: 3.6.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A high-level language for numerical computations
|
Summary: A high-level language for numerical computations
|
||||||
Epoch: 6
|
Epoch: 6
|
||||||
Group: Applications/Engineering
|
Group: Applications/Engineering
|
||||||
@ -14,8 +14,6 @@ Source1: macros.octave
|
|||||||
# https://savannah.gnu.org/bugs/index.php?32839
|
# https://savannah.gnu.org/bugs/index.php?32839
|
||||||
# Fix building packages from directories
|
# Fix building packages from directories
|
||||||
Patch2: octave-3.4.0-pkgbuilddir.patch
|
Patch2: octave-3.4.0-pkgbuilddir.patch
|
||||||
# Fix load-save
|
|
||||||
Patch3: octave-3.6.0-loadsave.patch
|
|
||||||
URL: http://www.octave.org
|
URL: http://www.octave.org
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
@ -75,7 +73,6 @@ This package contains documentation for Octave.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch2 -p1 -b .pkgbuilddir
|
%patch2 -p1 -b .pkgbuilddir
|
||||||
%patch3 -p1 -b .loadsave
|
|
||||||
|
|
||||||
# Check permissions
|
# Check permissions
|
||||||
find -name *.cc -exec chmod 644 {} \;
|
find -name *.cc -exec chmod 644 {} \;
|
||||||
@ -248,6 +245,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 22 2012 Orion Poplawski <orion[AT]cora.nwra com> - 6:3.6.1-1
|
||||||
|
- Update to 3.6.1.
|
||||||
|
|
||||||
* Thu Feb 9 2012 Orion Poplawski <orion[AT]cora.nwra com> - 6:3.6.0-2
|
* Thu Feb 9 2012 Orion Poplawski <orion[AT]cora.nwra com> - 6:3.6.0-2
|
||||||
- Rebuild with pcre 8.30
|
- Rebuild with pcre 8.30
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user