Update to 8.1.0
Build with pcre2 (bz#2128340)
This commit is contained in:
parent
36ac824c44
commit
c7d30dff4c
1
.gitignore
vendored
1
.gitignore
vendored
@ -43,3 +43,4 @@ octave-3.2.4.tar.bz2
|
||||
/octave-7.2.0.tar.lz
|
||||
/octave-7.3.0.tar.lz
|
||||
/octave-7.3.0-docs.tar.xz
|
||||
/octave-8.1.0.tar.lz
|
||||
|
43
ab6d276f6fcb
43
ab6d276f6fcb
@ -1,43 +0,0 @@
|
||||
|
||||
# HG changeset patch
|
||||
# User Rik <rik@octave.org>
|
||||
# Date 1668451079 28800
|
||||
# Node ID ab6d276f6fcb90631131eeb6668efd4f54a36204
|
||||
# Parent 662499ba0d21173006f99fc3b14b9a76a0e8670a
|
||||
build: Enable building of Qt documentation with Texinfo >= 7.0 (bug #62648).
|
||||
|
||||
* doc/interpreter/mk-qthelp.pl: Update regular expressions that find the start
|
||||
of data in index.html and Function-index.html to include additional pattern
|
||||
generated by Texinfo 7.0.
|
||||
|
||||
diff --git a/doc/interpreter/mk-qthelp.pl b/doc/interpreter/mk-qthelp.pl
|
||||
--- a/doc/interpreter/mk-qthelp.pl
|
||||
+++ b/doc/interpreter/mk-qthelp.pl
|
||||
@@ -26,8 +26,11 @@
|
||||
open (my $HTML, "<", $htmlfname) or die "Unable to open $htmlfname";
|
||||
|
||||
# Skip through preamble of file to find start of list
|
||||
-while (($_ = <$HTML>) !~ /^<div class="contents">/ ) {;}
|
||||
-while (($_ = <$HTML>) !~ /^<ul class="no-bullet">/ ) {;}
|
||||
+while (defined ($_ = <$HTML>) and ! /^<div class="contents">/ ) {;}
|
||||
+while (defined ($_ = <$HTML>)
|
||||
+ and ! /^<ul class="(?:no-bullet|toc-numbered-mark)">/ ) {;}
|
||||
+
|
||||
+die "index.html: reached EOF without finding data start pattern" if eof ($HTML);
|
||||
|
||||
$level = 0;
|
||||
while (<$HTML>)
|
||||
@@ -68,7 +71,11 @@
|
||||
open ($HTML, "<", $htmlfname) or die "Unable to open $htmlfname";
|
||||
|
||||
# Skip through preamble of file to find start of list
|
||||
-while (($_ = <$HTML>) !~ /^<table class="index-fn/ ) {;}
|
||||
+while (defined ($_ = <$HTML>)
|
||||
+ and ! /^<table class="(?:index-fn|fn-entries)/ ) {;}
|
||||
+
|
||||
+die "Function-Index.html: reached EOF without finding data start pattern"
|
||||
+ if eof ($HTML);
|
||||
|
||||
while (<$HTML>)
|
||||
{
|
||||
|
@ -66,7 +66,7 @@ fi \
|
||||
# octave can find the package, then remove 'octave_packages' again, and re-strip
|
||||
# any shared objects.
|
||||
%octave_pkg_check \
|
||||
%octave_cmd pkg("prefix","%{buildroot}%{octprefix}","%{buildroot}%{octarchprefix}");pkg("local_list",fullfile("%{buildroot}%{octshareprefix}","octave_packages"));pkg("list");pkg("install","-verbose",glob("%{_builddir}/%{buildsubdir}/build/%{octpkg}-%{version}-*.tar.gz"){1,1});pkg("load","%{octpkg}");pkg("list");runtests("%{buildroot}%{octpkgdir}");unlink(pkg("local_list")); \
|
||||
%octave_cmd pkg("prefix","%{buildroot}%{octprefix}","%{buildroot}%{octarchprefix}");pkg("local_list",fullfile("%{buildroot}%{octshareprefix}","octave_packages"));pkg("list");pkg("install","-verbose",glob("%{_builddir}/%{buildsubdir}/build/%{octpkg}-%{version}-*.tar.gz"){1,1});pkg("load","%{octpkg}");pkg("list");oruntests("%{buildroot}%{octpkgdir}");unlink(pkg("local_list")); \
|
||||
/usr/lib/rpm/brp-strip %{__strip} \
|
||||
%{nil}
|
||||
|
||||
|
21
octave.spec
21
octave.spec
@ -1,5 +1,5 @@
|
||||
# From src/version.h:#define OCTAVE_API_VERSION
|
||||
%global octave_api api-v57
|
||||
%global octave_api api-v58
|
||||
|
||||
%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
|
||||
|
||||
@ -36,8 +36,8 @@
|
||||
|
||||
Name: octave
|
||||
Epoch: 6
|
||||
Version: 7.3.0
|
||||
Release: 4%{?dist}
|
||||
Version: 8.1.0
|
||||
Release: 1%{?dist}
|
||||
Summary: A high-level language for numerical computations
|
||||
License: GPLv3+
|
||||
URL: http://www.octave.org
|
||||
@ -50,9 +50,6 @@ Source2: xorg.conf
|
||||
%if !%{builddocs}
|
||||
Source3: octave-%{version}-docs.tar.xz
|
||||
%endif
|
||||
# Infinite loop with texinfo 7
|
||||
# https://savannah.gnu.org/bugs/index.php?63810
|
||||
Patch0: https://hg.savannah.gnu.org/hgweb/octave/raw-rev/ab6d276f6fcb
|
||||
# Add needed time.h header
|
||||
Patch2: octave-time.patch
|
||||
|
||||
@ -117,7 +114,7 @@ BuildRequires: mesa-libGL-devel
|
||||
BuildRequires: mesa-libGLU-devel
|
||||
BuildRequires: mesa-libOSMesa-devel
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRequires: pcre-devel
|
||||
BuildRequires: pcre2-devel
|
||||
BuildRequires: portaudio-devel
|
||||
BuildRequires: qhull-devel
|
||||
BuildRequires: qrupdate-devel
|
||||
@ -415,9 +412,9 @@ make check
|
||||
%{_bindir}/octave*
|
||||
%dir %{_libdir}/octave/
|
||||
%dir %{_libdir}/octave/%{version}
|
||||
%{_libdir}/octave/%{version}/liboctave.so.9*
|
||||
%{_libdir}/octave/%{version}/liboctgui.so.8*
|
||||
%{_libdir}/octave/%{version}/liboctinterp.so.10*
|
||||
%{_libdir}/octave/%{version}/liboctave.so.10*
|
||||
%{_libdir}/octave/%{version}/liboctgui.so.9*
|
||||
%{_libdir}/octave/%{version}/liboctinterp.so.11*
|
||||
%{_libdir}/octave/%{version}/mkoctfile-%{version}
|
||||
%{_libdir}/octave/%{version}/oct/
|
||||
%{_libdir}/octave/%{version}/octave-config-%{version}
|
||||
@ -461,6 +458,10 @@ make check
|
||||
%{_pkgdocdir}/refcard*.pdf
|
||||
|
||||
%changelog
|
||||
* Sat Apr 08 2023 Orion Poplawski <orion@nwra.com> - 6:8.1.0-1
|
||||
- Update to 8.1.0
|
||||
- Build with pcre2 (bz#2128340)
|
||||
|
||||
* Fri Mar 17 2023 Orion Poplawski <orion@nwra.com> - 6:7.3.0-4
|
||||
- Add upstream patch to fix doc builds
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (octave-7.3.0.tar.lz) = 8448aa01fa2a0650993ff9e4a4a017c243d5bf4af17cc321458e583913f4a71c2a34d60c1f79b8fedd5f00604f0960b94a4e2c0d9b87f07b13e969afe2951aa2
|
||||
SHA512 (octave-8.1.0.tar.lz) = 0c14a9c682cc4da5b6e3c6d018d082ed53cdfd13e9f42ca5afae2d499ef6aa1a19f3fb5b5a9cc006e28f24c45e6c1df298487a7f2d37d886385e427f984e6832
|
||||
|
Loading…
Reference in New Issue
Block a user