New upstream release. Lots of spec changes--see changelog.
This commit is contained in:
parent
7e80f1cda2
commit
c6b0f7f038
@ -1 +1 @@
|
|||||||
octave-2.9.4.tar.bz2
|
octave-2.9.5.tar.bz2
|
||||||
|
@ -1,27 +0,0 @@
|
|||||||
src/ChangeLog:
|
|
||||||
|
|
||||||
2005-11-11 John W. Eaton <jwe@octave.org>
|
|
||||||
|
|
||||||
* Makefile.in (install-oct): Fix thinko in previous change.
|
|
||||||
|
|
||||||
|
|
||||||
Index: src/Makefile.in
|
|
||||||
===================================================================
|
|
||||||
RCS file: /cvs/octave/src/Makefile.in,v
|
|
||||||
retrieving revision 1.389
|
|
||||||
diff -u -r1.389 Makefile.in
|
|
||||||
--- src/Makefile.in 11 Nov 2005 17:45:51 -0000 1.389
|
|
||||||
+++ src/Makefile.in 12 Nov 2005 02:29:32 -0000
|
|
||||||
@@ -398,12 +398,12 @@
|
|
||||||
|
|
||||||
install-oct:
|
|
||||||
$(top_srcdir)/mkinstalldirs $(DESTDIR)$(octfiledir)
|
|
||||||
+ $(srcdir)/mk-pkg-add --prefix $(octfiledir) $(DLD_DEF_FILES) > $(DESTDIR)$(octfiledir)/PKG_ADD
|
|
||||||
if [ -n "$(OCT_FILES)" ]; then \
|
|
||||||
xfiles="$(OCT_FILES)"; \
|
|
||||||
for f in $$xfiles; do \
|
|
||||||
$(INSTALL_PROGRAM) $$f $(DESTDIR)$(octfiledir)/$$f; \
|
|
||||||
done; \
|
|
||||||
- $(srcdir)/mk-pkg-add --prefix $(octfiledir) $(DLD_DEF_FILES) > $(DESTDIR)$(octfiledir)/PKG_ADD
|
|
||||||
fi
|
|
||||||
.PHONY: install-oct
|
|
@ -1,14 +0,0 @@
|
|||||||
--- src/DLD-FUNCTIONS/spchol.cc.orig 2005-11-11 10:44:05.000000000 -0700
|
|
||||||
+++ src/DLD-FUNCTIONS/spchol.cc 2005-11-30 15:41:35.000000000 -0700
|
|
||||||
@@ -609,7 +609,11 @@
|
|
||||||
for (octave_idx_type k = 0 ; k < n ; k++)
|
|
||||||
{
|
|
||||||
// get the kth row of L and store in the columns of L
|
|
||||||
+#ifdef IDX_TYPE_LONG
|
|
||||||
+ cholmod_l_row_subtree (A1, A2, k, Parent, R, cm) ;
|
|
||||||
+#else
|
|
||||||
cholmod_row_subtree (A1, A2, k, Parent, R, cm) ;
|
|
||||||
+#endif
|
|
||||||
for (octave_idx_type p = 0 ; p < Rp [1] ; p++)
|
|
||||||
L.xridx (W [Ri [p]]++) = k ;
|
|
||||||
|
|
61
octave-2.9.5-sparse.patch
Normal file
61
octave-2.9.5-sparse.patch
Normal file
@ -0,0 +1,61 @@
|
|||||||
|
Index: liboctave/SparseCmplxQR.h
|
||||||
|
===================================================================
|
||||||
|
RCS file: /cvs/octave/liboctave/SparseCmplxQR.h,v
|
||||||
|
retrieving revision 1.2
|
||||||
|
diff -u -r1.2 SparseCmplxQR.h
|
||||||
|
--- liboctave/SparseCmplxQR.h 8 Mar 2006 20:17:38 -0000 1.2
|
||||||
|
+++ liboctave/SparseCmplxQR.h 23 Mar 2006 17:56:07 -0000
|
||||||
|
@@ -137,6 +137,23 @@
|
||||||
|
#endif
|
||||||
|
};
|
||||||
|
|
||||||
|
+
|
||||||
|
+// Publish externally used friend functions.
|
||||||
|
+
|
||||||
|
+extern ComplexMatrix qrsolve (const SparseComplexMatrix &a, const Matrix &b,
|
||||||
|
+ octave_idx_type &info);
|
||||||
|
+
|
||||||
|
+extern SparseComplexMatrix qrsolve (const SparseComplexMatrix &a,
|
||||||
|
+ const SparseMatrix &b,
|
||||||
|
+ octave_idx_type &info);
|
||||||
|
+
|
||||||
|
+extern ComplexMatrix qrsolve (const SparseComplexMatrix &a,
|
||||||
|
+ const ComplexMatrix &b,
|
||||||
|
+ octave_idx_type &info);
|
||||||
|
+
|
||||||
|
+extern SparseComplexMatrix qrsolve (const SparseComplexMatrix &a,
|
||||||
|
+ const SparseComplexMatrix &b,
|
||||||
|
+ octave_idx_type &info);
|
||||||
|
#endif
|
||||||
|
|
||||||
|
/*
|
||||||
|
Index: liboctave/SparseQR.h
|
||||||
|
===================================================================
|
||||||
|
RCS file: /cvs/octave/liboctave/SparseQR.h,v
|
||||||
|
retrieving revision 1.2
|
||||||
|
diff -u -r1.2 SparseQR.h
|
||||||
|
--- liboctave/SparseQR.h 8 Mar 2006 20:17:38 -0000 1.2
|
||||||
|
+++ liboctave/SparseQR.h 23 Mar 2006 17:56:07 -0000
|
||||||
|
@@ -133,6 +133,22 @@
|
||||||
|
#endif
|
||||||
|
};
|
||||||
|
|
||||||
|
+
|
||||||
|
+// Publish externally used friend functions.
|
||||||
|
+
|
||||||
|
+extern Matrix qrsolve (const SparseMatrix &a, const Matrix &b,
|
||||||
|
+ octave_idx_type &info);
|
||||||
|
+
|
||||||
|
+extern SparseMatrix qrsolve (const SparseMatrix &a, const SparseMatrix &b,
|
||||||
|
+ octave_idx_type &info);
|
||||||
|
+
|
||||||
|
+extern ComplexMatrix qrsolve (const SparseMatrix &a, const ComplexMatrix &b,
|
||||||
|
+ octave_idx_type &info);
|
||||||
|
+
|
||||||
|
+extern SparseComplexMatrix qrsolve (const SparseMatrix &a,
|
||||||
|
+ const SparseComplexMatrix &b,
|
||||||
|
+ octave_idx_type &info);
|
||||||
|
+
|
||||||
|
#endif
|
||||||
|
|
||||||
|
/*
|
64
octave.spec
64
octave.spec
@ -1,14 +1,13 @@
|
|||||||
Name: octave
|
Name: octave
|
||||||
Version: 2.9.4
|
Version: 2.9.5
|
||||||
Release: 8%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A high-level language for numerical computations
|
Summary: A high-level language for numerical computations
|
||||||
Epoch: 6
|
Epoch: 6
|
||||||
|
|
||||||
Group: Applications/Engineering
|
Group: Applications/Engineering
|
||||||
License: GPL
|
License: GPL
|
||||||
Source: ftp://ftp.octave.org/pub/octave/bleeding-edge/octave-%{version}.tar.bz2
|
Source: ftp://ftp.octave.org/pub/octave/bleeding-edge/octave-%{version}.tar.bz2
|
||||||
Patch0: octave-2.9.4-header.patch
|
Patch0: octave-2.9.5-sparse.patch
|
||||||
Patch1: octave-2.9.4-x86_64.patch
|
|
||||||
URL: http://www.octave.org
|
URL: http://www.octave.org
|
||||||
Requires: gnuplot less info texinfo
|
Requires: gnuplot less info texinfo
|
||||||
Requires(post): /sbin/install-info
|
Requires(post): /sbin/install-info
|
||||||
@ -18,7 +17,7 @@ Requires(preun): /sbin/install-info
|
|||||||
BuildRequires: bison flex less tetex gcc-gfortran lapack-devel blas-devel
|
BuildRequires: bison flex less tetex gcc-gfortran lapack-devel blas-devel
|
||||||
BuildRequires: ncurses-devel zlib-devel libtermcap-devel hdf5-devel
|
BuildRequires: ncurses-devel zlib-devel libtermcap-devel hdf5-devel
|
||||||
BuildRequires: readline-devel glibc-devel fftw-devel autoconf gperf
|
BuildRequires: readline-devel glibc-devel fftw-devel autoconf gperf
|
||||||
BuildRequires: ufsparse-devel glpk-devel gnuplot
|
BuildRequires: ufsparse-devel glpk-devel gnuplot desktop-file-utils
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
|
|
||||||
@ -42,7 +41,7 @@ Summary: Development headers and files for Octave
|
|||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name} = %{epoch}:%{version}-%{release}
|
Requires: %{name} = %{epoch}:%{version}-%{release}
|
||||||
Requires: readline-devel fftw-devel hdf5-devel zlib-devel
|
Requires: readline-devel fftw-devel hdf5-devel zlib-devel
|
||||||
Requires: lapack-devel blas-devel
|
Requires: lapack-devel blas-devel gcc-c++
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
The octave-devel package contains files needed for developing
|
The octave-devel package contains files needed for developing
|
||||||
@ -52,47 +51,53 @@ applications which use GNU Octave.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p0
|
%patch0 -p0
|
||||||
%patch1 -p0
|
|
||||||
./autogen.sh
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%ifarch x86_64
|
%ifarch x86_64
|
||||||
%define enable64 --enable-64=yes
|
%define enable64 yes
|
||||||
%else
|
%else
|
||||||
%define enable64 --enable-64=no
|
%define enable64 no
|
||||||
%endif
|
%endif
|
||||||
CPPFLAGS=-I%{_includedir}/glpk \
|
export CPPFLAGS=-I%{_includedir}/glpk
|
||||||
CXXFLAGS="$RPM_OPT_FLAGS" ./configure %enable64 \
|
%configure --enable-shared --disable-static --enable-64=%enable64
|
||||||
--enable-shared --disable-static --prefix=%{_prefix} \
|
make %{?_smp_mflags} OCTAVE_RELEASE="Fedora Extras %{version}-%{release}"
|
||||||
--infodir=%{_infodir} --libdir=%{_libdir} --mandir=%{_mandir}
|
|
||||||
make %{?_smp_mflags}
|
|
||||||
|
|
||||||
|
|
||||||
#empty
|
|
||||||
rm -f interpreter/octave.{ky,pg,tp}
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
rm -f doc/interpreter/munge-texi doc/interpreter/*.o
|
|
||||||
strip $RPM_BUILD_ROOT/usr/libexec/octave/%{version}/oct/*/*.oct
|
strip $RPM_BUILD_ROOT/usr/libexec/octave/%{version}/oct/*/*.oct
|
||||||
|
rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
|
||||||
|
|
||||||
# Make library links
|
# Make library links
|
||||||
mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
|
mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
|
||||||
echo "%{_libdir}/octave-%{version}" > $RPM_BUILD_ROOT/etc/ld.so.conf.d/octave-%{_arch}.conf
|
echo "%{_libdir}/octave-%{version}" > $RPM_BUILD_ROOT/etc/ld.so.conf.d/octave-%{_arch}.conf
|
||||||
|
|
||||||
perl -pi -e "s,$RPM_BUILD_ROOT,," $RPM_BUILD_ROOT/%{_libexecdir}/%{name}/ls-R
|
# Remove RPM_BUILD_ROOT from ls-R files
|
||||||
perl -pi -e "s,$RPM_BUILD_ROOT,," $RPM_BUILD_ROOT/%{_datadir}/%{name}/ls-R
|
perl -pi -e "s,$RPM_BUILD_ROOT,," $RPM_BUILD_ROOT%{_libexecdir}/%{name}/ls-R
|
||||||
|
perl -pi -e "s,$RPM_BUILD_ROOT,," $RPM_BUILD_ROOT%{_datadir}/%{name}/ls-R
|
||||||
|
|
||||||
|
# Clean doc directory
|
||||||
|
pushd doc
|
||||||
|
make distclean
|
||||||
|
rm -f *.in */*.in */*.cc refcard/*.tex
|
||||||
|
popd
|
||||||
|
|
||||||
|
# Create desktop file
|
||||||
|
rm $RPM_BUILD_ROOT%{_datadir}/applications/www.octave.org-octave.desktop
|
||||||
|
desktop-file-install --vendor fedora --add-category X-Fedora \
|
||||||
|
--dir $RPM_BUILD_ROOT%{_datadir}/applications examples/octave.desktop
|
||||||
|
|
||||||
|
|
||||||
rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
%post
|
%post
|
||||||
/sbin/ldconfig
|
/sbin/ldconfig
|
||||||
/sbin/install-info --info-dir=%{_infodir}/ --section="Programming:" --entry="* Octave:(octave). Interactive language for numerical computations." %{_infodir}/octave.info.gz
|
/sbin/install-info --info-dir=%{_infodir} --section="Programming:" \
|
||||||
|
--entry="* Octave:(%{name}). %{summary}." %{_infodir}/octave.info.gz
|
||||||
|
|
||||||
%preun
|
%preun
|
||||||
if [ "$1" = "0" ]; then
|
if [ "$1" = "0" ]; then
|
||||||
@ -105,8 +110,8 @@ fi
|
|||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc COPYING NEWS* PROJECTS README README.Linux README.kpathsea ROADMAP
|
%doc COPYING NEWS* PROJECTS README README.Linux README.kpathsea ROADMAP
|
||||||
%doc SENDING-PATCHES THANKS
|
%doc SENDING-PATCHES THANKS emacs examples doc/interpreter/octave.p*
|
||||||
%doc doc/faq doc/liboctave doc/refcard emacs examples
|
%doc doc/faq doc/interpreter/HTML doc/refcard
|
||||||
%{_bindir}/octave
|
%{_bindir}/octave
|
||||||
%{_bindir}/octave-%{version}
|
%{_bindir}/octave-%{version}
|
||||||
%config(noreplace) /etc/ld.so.conf.d/*
|
%config(noreplace) /etc/ld.so.conf.d/*
|
||||||
@ -115,9 +120,11 @@ fi
|
|||||||
%{_libexecdir}/octave
|
%{_libexecdir}/octave
|
||||||
%{_mandir}/man*/octave*
|
%{_mandir}/man*/octave*
|
||||||
%{_infodir}/octave.info*
|
%{_infodir}/octave.info*
|
||||||
|
%{_datadir}/applications/*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
|
%doc doc/liboctave
|
||||||
%{_bindir}/mkoctfile*
|
%{_bindir}/mkoctfile*
|
||||||
%{_bindir}/octave-bug*
|
%{_bindir}/octave-bug*
|
||||||
%{_bindir}/octave-config*
|
%{_bindir}/octave-config*
|
||||||
@ -126,6 +133,13 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 23 2006 Quentin Spencer <qspencer@users.sourceforge.net> 2.9.5-1
|
||||||
|
- New upstream release; remove old patches; add sparse patch.
|
||||||
|
- Add gcc-c++ as dependency for devel package.
|
||||||
|
- Add more docs; cleanup extra files in docs.
|
||||||
|
- Simplify configure command.
|
||||||
|
- Install desktop file.
|
||||||
|
|
||||||
* Fri Feb 24 2006 Quentin Spencer <qspencer@users.sourceforge.net> 2.9.4-8
|
* Fri Feb 24 2006 Quentin Spencer <qspencer@users.sourceforge.net> 2.9.4-8
|
||||||
- Rebuild for new hdf5.
|
- Rebuild for new hdf5.
|
||||||
- Remove obsolete configure options.
|
- Remove obsolete configure options.
|
||||||
|
Loading…
Reference in New Issue
Block a user