Update to 5.2.0
This commit is contained in:
parent
b1d97f35c3
commit
be55d20164
2
.gitignore
vendored
2
.gitignore
vendored
@ -32,3 +32,5 @@ octave-3.2.4.tar.bz2
|
||||
/octave-4.4.1-docs.tar.gz
|
||||
/octave-5.1.0.tar.lz
|
||||
/octave-5.1.0-docs.tar.lz
|
||||
/octave-5.2.0.tar.lz
|
||||
/octave-5.2.0-docs.tar.lz
|
||||
|
@ -1,28 +0,0 @@
|
||||
|
||||
# HG changeset patch
|
||||
# User Mike Miller <mtmiller@octave.org>
|
||||
# Date 1554238576 25200
|
||||
# Node ID c3716220d5b93c49e1c7cc8ebe0b76dd961f4ec7
|
||||
# Parent fc73dafece570f201c18a4eb4a8729a654cfcfbb
|
||||
fix pause and kbhit with glibc 2.28 end-of-file state behavior (bug #55029)
|
||||
|
||||
* sysdep.cc (octave::kbhit): Call "clearerr (stdin)" on end-of-file condition
|
||||
in addition to "std::cin.clear ()". In glibc 2.28, end-of-file is persistent
|
||||
and must be cleared by the application.
|
||||
|
||||
diff --git a/libinterp/corefcn/sysdep.cc b/libinterp/corefcn/sysdep.cc
|
||||
--- a/libinterp/corefcn/sysdep.cc
|
||||
+++ b/libinterp/corefcn/sysdep.cc
|
||||
@@ -566,7 +566,10 @@
|
||||
int c = std::cin.get ();
|
||||
|
||||
if (std::cin.fail () || std::cin.eof ())
|
||||
- std::cin.clear ();
|
||||
+ {
|
||||
+ std::cin.clear ();
|
||||
+ clearerr (stdin);
|
||||
+ }
|
||||
|
||||
// Restore it, enabling system call restarts (if possible).
|
||||
octave::set_interrupt_handler (saved_interrupt_handler, true);
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up octave-5.0.91/configure.ac.sundials3 octave-5.0.91/configure.ac
|
||||
--- octave-5.0.91/configure.ac.sundials3 2019-02-04 10:50:20.000000000 -0700
|
||||
+++ octave-5.0.91/configure.ac 2019-02-05 22:05:44.096260529 -0700
|
||||
diff -up octave-5.1.90/configure.ac.sundials3 octave-5.1.90/configure.ac
|
||||
--- octave-5.1.90/configure.ac.sundials3 2020-01-18 11:48:59.000074162 -0700
|
||||
+++ octave-5.1.90/configure.ac 2020-01-18 11:50:21.861966968 -0700
|
||||
@@ -2220,15 +2220,15 @@ OCTAVE_CHECK_LIB(sundials_ida, [SUNDIALS
|
||||
[], [don't use SUNDIALS IDA library, solvers ode15i and ode15s will be disabled],
|
||||
[warn_sundials_ida=
|
||||
@ -19,10 +19,10 @@ diff -up octave-5.0.91/configure.ac.sundials3 octave-5.0.91/configure.ac
|
||||
+ && test $octave_cv_sundials_sunlinsol_dense = yes \
|
||||
&& test $octave_cv_sundials_realtype_is_double = yes; then
|
||||
AC_DEFINE(HAVE_SUNDIALS, 1, [Define to 1 if SUNDIALS is available.])
|
||||
fi
|
||||
diff -up octave-5.0.91/libinterp/dldfcn/__ode15__.cc.sundials3 octave-5.0.91/libinterp/dldfcn/__ode15__.cc
|
||||
--- octave-5.0.91/libinterp/dldfcn/__ode15__.cc.sundials3 2019-02-04 10:50:20.000000000 -0700
|
||||
+++ octave-5.0.91/libinterp/dldfcn/__ode15__.cc 2019-02-05 22:06:48.074012827 -0700
|
||||
|
||||
diff -up octave-5.1.90/libinterp/dldfcn/__ode15__.cc.sundials3 octave-5.1.90/libinterp/dldfcn/__ode15__.cc
|
||||
--- octave-5.1.90/libinterp/dldfcn/__ode15__.cc.sundials3 2019-12-21 17:01:27.000000000 -0700
|
||||
+++ octave-5.1.90/libinterp/dldfcn/__ode15__.cc 2020-01-18 11:48:59.002074159 -0700
|
||||
@@ -1,6 +1,7 @@
|
||||
/*
|
||||
|
||||
@ -312,10 +312,10 @@ diff -up octave-5.0.91/libinterp/dldfcn/__ode15__.cc.sundials3 octave-5.0.91/lib
|
||||
|
||||
// Integrate
|
||||
retval = dae.integrate (numt, tspan, y0, yp0, refine,
|
||||
diff -up octave-5.0.91/m4/acinclude.m4.sundials3 octave-5.0.91/m4/acinclude.m4
|
||||
--- octave-5.0.91/m4/acinclude.m4.sundials3 2019-02-04 10:50:20.000000000 -0700
|
||||
+++ octave-5.0.91/m4/acinclude.m4 2019-02-05 22:05:44.100260576 -0700
|
||||
@@ -2210,14 +2210,11 @@ dnl Check whether SUNDIALS IDA library i
|
||||
diff -up octave-5.1.90/m4/acinclude.m4.sundials3 octave-5.1.90/m4/acinclude.m4
|
||||
--- octave-5.1.90/m4/acinclude.m4.sundials3 2019-12-21 17:01:27.000000000 -0700
|
||||
+++ octave-5.1.90/m4/acinclude.m4 2020-01-18 11:48:59.005074156 -0700
|
||||
@@ -2215,14 +2215,11 @@ dnl Check whether SUNDIALS IDA library i
|
||||
dnl precision realtype.
|
||||
dnl
|
||||
AC_DEFUN([OCTAVE_CHECK_SUNDIALS_SIZEOF_REALTYPE], [
|
||||
@ -330,7 +330,7 @@ diff -up octave-5.0.91/m4/acinclude.m4.sundials3 octave-5.0.91/m4/acinclude.m4
|
||||
#endif
|
||||
#include <assert.h>
|
||||
]], [[
|
||||
@@ -2233,61 +2230,72 @@ AC_DEFUN([OCTAVE_CHECK_SUNDIALS_SIZEOF_R
|
||||
@@ -2238,61 +2235,72 @@ AC_DEFUN([OCTAVE_CHECK_SUNDIALS_SIZEOF_R
|
||||
fi
|
||||
])
|
||||
dnl
|
||||
@ -436,9 +436,9 @@ diff -up octave-5.0.91/m4/acinclude.m4.sundials3 octave-5.0.91/m4/acinclude.m4
|
||||
fi
|
||||
])
|
||||
dnl
|
||||
diff -up octave-5.0.91/scripts/ode/ode15i.m.sundials3 octave-5.0.91/scripts/ode/ode15i.m
|
||||
--- octave-5.0.91/scripts/ode/ode15i.m.sundials3 2019-02-04 10:50:20.000000000 -0700
|
||||
+++ octave-5.0.91/scripts/ode/ode15i.m 2019-02-05 22:05:44.101260588 -0700
|
||||
diff -up octave-5.1.90/scripts/ode/ode15i.m.sundials3 octave-5.1.90/scripts/ode/ode15i.m
|
||||
--- octave-5.1.90/scripts/ode/ode15i.m.sundials3 2019-12-21 17:01:27.000000000 -0700
|
||||
+++ octave-5.1.90/scripts/ode/ode15i.m 2020-01-18 11:48:59.006074155 -0700
|
||||
@@ -452,7 +452,7 @@ endfunction
|
||||
%! assert ([t(end), y(end,:)], fref, 1e-3);
|
||||
|
||||
@ -457,9 +457,9 @@ diff -up octave-5.0.91/scripts/ode/ode15i.m.sundials3 octave-5.0.91/scripts/ode/
|
||||
%! DFDY = sparse ([-0.04, 1;
|
||||
%! 0.04, 1]);
|
||||
%! DFDYP = sparse ([-1, 0, 0;
|
||||
diff -up octave-5.0.91/scripts/ode/ode15s.m.sundials3 octave-5.0.91/scripts/ode/ode15s.m
|
||||
--- octave-5.0.91/scripts/ode/ode15s.m.sundials3 2019-02-04 10:50:20.000000000 -0700
|
||||
+++ octave-5.0.91/scripts/ode/ode15s.m 2019-02-05 22:05:44.102260599 -0700
|
||||
diff -up octave-5.1.90/scripts/ode/ode15s.m.sundials3 octave-5.1.90/scripts/ode/ode15s.m
|
||||
--- octave-5.1.90/scripts/ode/ode15s.m.sundials3 2019-12-21 17:01:27.000000000 -0700
|
||||
+++ octave-5.1.90/scripts/ode/ode15s.m 2020-01-18 11:48:59.007074154 -0700
|
||||
@@ -545,21 +545,21 @@ endfunction
|
||||
%! [t, y] = ode15s (@rob, [0, 100], [1; 0; 0], opt);
|
||||
%! assert ([t(end), y(end,:)], frefrob, 1e-3);
|
||||
|
14
octave.spec
14
octave.spec
@ -27,8 +27,8 @@
|
||||
|
||||
Name: octave
|
||||
Epoch: 6
|
||||
Version: 5.1.0
|
||||
Release: 4%{?rcver:.rc%{rcver}}%{?dist}.1
|
||||
Version: 5.2.0
|
||||
Release: 1%{?dist}
|
||||
Summary: A high-level language for numerical computations
|
||||
License: GPLv3+
|
||||
URL: http://www.octave.org
|
||||
@ -39,14 +39,10 @@ Source0: https://ftp.gnu.org/gnu/octave/octave-%{version}.tar.lz
|
||||
Source1: macros.octave
|
||||
Source2: xorg.conf
|
||||
# Prebuilt docs from Fedora for EPEL
|
||||
Source3: octave-5.1.0-docs.tar.lz
|
||||
Source3: octave-5.2.0-docs.tar.lz
|
||||
# SUNDIALS 3 support
|
||||
# https://savannah.gnu.org/bugs/?52475
|
||||
Patch1: octave-sundials3.patch
|
||||
# Proper EOF handling
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1705129
|
||||
# https://hg.savannah.gnu.org/hgweb/octave/rev/c3716220d5b9
|
||||
Patch2: octave-eof.patch
|
||||
|
||||
Provides: octave(api) = %{octave_api}
|
||||
Provides: bundled(gnulib)
|
||||
@ -213,7 +209,6 @@ This package contains documentation for Octave.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}%{?rctag}
|
||||
%patch2 -p1 -b .eof
|
||||
%if %{with blas64}
|
||||
sed -i -e 's/OCTAVE_CHECK_LIB(suitesparseconfig,/OCTAVE_CHECK_LIB(suitesparseconfig64,/' configure.ac
|
||||
%endif
|
||||
@ -428,6 +423,9 @@ make check %{?el7:|| :}
|
||||
%{_pkgdocdir}/refcard*.pdf
|
||||
|
||||
%changelog
|
||||
* Mon Feb 03 2020 Orion Poplawski <orion@nwra.com> - 6:5.2.0-1
|
||||
- Update to 5.2.0
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 6:5.1.0-4.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (octave-5.1.0.tar.lz) = 34facc20ffceaead05e62e16cc70bd603919c7e52c7489faa17b5c969a160c655f50c4aeb41ecee2e2d0a6245cc3364cf9009ddd3cecb17b9e06bbdacaa0a516
|
||||
SHA512 (octave-5.1.0-docs.tar.lz) = 6bf24ed95d5d2957271abb8902a156edc588962b95218b05936858fafe8205f4295f072388f7331ad5700946fbae701bd0c3f2a59c258f390ea92c85eb87fdd2
|
||||
SHA512 (octave-5.2.0.tar.lz) = e8f64c5703548e3f209aeaae51c3f6907db5189ec7790600be6f335d9edeb183d9dcfbf5ec711c5e30aa953877dd176a1c506ae90c505a52ed74dba6ce69c7f5
|
||||
SHA512 (octave-5.2.0-docs.tar.lz) = 7d8869aac27b51173a9060860444b95074336ada5837f0f96a4fc22c4fb942f2a0cc47d77c749b09a00fc9b3d28ad7b96aaec7ced4373e7c7d39598654f5a6cf
|
||||
|
Loading…
x
Reference in New Issue
Block a user