Add x86_64 patch.
This commit is contained in:
parent
8ea2d60b76
commit
bc442add73
14
octave-2.9.4-x86_64.patch
Normal file
14
octave-2.9.4-x86_64.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
--- octave-2.9.4/src/DLD-FUNCTIONS/spchol.cc.orig 2005-11-11 10:44:05.000000000 -0700
|
||||||
|
+++ octave-2.9.4/src/DLD-FUNCTIONS/spchol.cc 2005-11-30 15:41:35.000000000 -0700
|
||||||
|
@@ -609,7 +609,11 @@
|
||||||
|
for (octave_idx_type k = 0 ; k < n ; k++)
|
||||||
|
{
|
||||||
|
// get the kth row of L and store in the columns of L
|
||||||
|
+#ifdef IDX_TYPE_LONG
|
||||||
|
+ cholmod_l_row_subtree (A1, A2, k, Parent, R, cm) ;
|
||||||
|
+#else
|
||||||
|
cholmod_row_subtree (A1, A2, k, Parent, R, cm) ;
|
||||||
|
+#endif
|
||||||
|
for (octave_idx_type p = 0 ; p < Rp [1] ; p++)
|
||||||
|
L.xridx (W [Ri [p]]++) = k ;
|
||||||
|
|
13
octave.spec
13
octave.spec
@ -1,6 +1,6 @@
|
|||||||
Name: octave
|
Name: octave
|
||||||
Version: 2.9.4
|
Version: 2.9.4
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: A high-level language for numerical computations
|
Summary: A high-level language for numerical computations
|
||||||
Epoch: 6
|
Epoch: 6
|
||||||
|
|
||||||
@ -8,6 +8,7 @@ Group: Applications/Engineering
|
|||||||
License: GPL
|
License: GPL
|
||||||
Source: ftp://ftp.octave.org/pub/octave/bleeding-edge/octave-%{version}.tar.bz2
|
Source: ftp://ftp.octave.org/pub/octave/bleeding-edge/octave-%{version}.tar.bz2
|
||||||
Patch0: octave-2.9.4-header.patch
|
Patch0: octave-2.9.4-header.patch
|
||||||
|
Patch1: octave-2.9.4-x86_64.patch
|
||||||
URL: http://www.octave.org
|
URL: http://www.octave.org
|
||||||
Requires: gnuplot less info texinfo
|
Requires: gnuplot less info texinfo
|
||||||
Requires(post): /sbin/install-info
|
Requires(post): /sbin/install-info
|
||||||
@ -51,6 +52,7 @@ applications which use GNU Octave.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p0
|
%patch0 -p0
|
||||||
|
%patch1 -p0
|
||||||
./autogen.sh
|
./autogen.sh
|
||||||
|
|
||||||
|
|
||||||
@ -63,7 +65,8 @@ applications which use GNU Octave.
|
|||||||
CPPFLAGS=-I%{_includedir}/glpk \
|
CPPFLAGS=-I%{_includedir}/glpk \
|
||||||
CXXFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE" ./configure %enable64 \
|
CXXFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE" ./configure %enable64 \
|
||||||
--enable-shared=yes --enable-lite-kernel --enable-static=no \
|
--enable-shared=yes --enable-lite-kernel --enable-static=no \
|
||||||
--prefix=%{_prefix} --infodir=%{_infodir} --libdir=%{_libdir}
|
--prefix=%{_prefix} --infodir=%{_infodir} --libdir=%{_libdir} \
|
||||||
|
--mandir=%{_mandir}
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
@ -72,7 +75,7 @@ rm -f interpreter/octave.{ky,pg,tp}
|
|||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
%makeinstall
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
rm -f doc/interpreter/munge-texi doc/interpreter/*.o
|
rm -f doc/interpreter/munge-texi doc/interpreter/*.o
|
||||||
strip $RPM_BUILD_ROOT/usr/libexec/octave/%{version}/oct/*/*.oct
|
strip $RPM_BUILD_ROOT/usr/libexec/octave/%{version}/oct/*/*.oct
|
||||||
|
|
||||||
@ -82,7 +85,6 @@ echo "%{_libdir}/octave-%{version}" > $RPM_BUILD_ROOT/etc/ld.so.conf.d/octave-%{
|
|||||||
|
|
||||||
perl -pi -e "s,$RPM_BUILD_ROOT,," $RPM_BUILD_ROOT/%{_libexecdir}/%{name}/ls-R
|
perl -pi -e "s,$RPM_BUILD_ROOT,," $RPM_BUILD_ROOT/%{_libexecdir}/%{name}/ls-R
|
||||||
perl -pi -e "s,$RPM_BUILD_ROOT,," $RPM_BUILD_ROOT/%{_datadir}/%{name}/ls-R
|
perl -pi -e "s,$RPM_BUILD_ROOT,," $RPM_BUILD_ROOT/%{_datadir}/%{name}/ls-R
|
||||||
perl -pi -e "s,$RPM_BUILD_ROOT,," $RPM_BUILD_ROOT/%{_libexecdir}/%{name}/%{version}/oct/*/PKG_ADD
|
|
||||||
|
|
||||||
|
|
||||||
# XXX Nuke unpackaged files
|
# XXX Nuke unpackaged files
|
||||||
@ -129,6 +131,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Dec 1 2005 Quentin Spencer <qspencer@users.sourceforge.net> 2.9.4-2
|
||||||
|
- Patch to enable compilation on x86_64.
|
||||||
|
|
||||||
* Fri Nov 11 2005 Quentin Spencer <qspencer@users.sourceforge.net> 2.9.4-1
|
* Fri Nov 11 2005 Quentin Spencer <qspencer@users.sourceforge.net> 2.9.4-1
|
||||||
- New upstream release.
|
- New upstream release.
|
||||||
- Patch to make sure all headers are included in -devel.
|
- Patch to make sure all headers are included in -devel.
|
||||||
|
Loading…
Reference in New Issue
Block a user