New release, remove old patches. Misc bug fixes.
This commit is contained in:
parent
1fe63014af
commit
b3dee2c605
@ -1 +1 @@
|
||||
octave-2.9.5.tar.bz2
|
||||
octave-2.9.6.tar.bz2
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- configure.orig 2006-04-18 08:22:38.000000000 -0500
|
||||
+++ configure 2006-04-18 08:30:46.000000000 -0500
|
||||
@@ -3291,7 +3291,7 @@
|
||||
echo "$as_me:$LINENO: result: defining localfcnfiledir to be $localfcnfiledir" >&5
|
||||
echo "${ECHO_T}defining localfcnfiledir to be $localfcnfiledir" >&6
|
||||
|
||||
-: ${localapifcnfiledir='$(datadir)/octave/site/$(apiversion)/m'}
|
||||
+: ${localapifcnfiledir='$(datadir)/octave/site/$(api_version)/m'}
|
||||
echo "$as_me:$LINENO: result: defining localapifcnfiledir to be $localapifcnfiledir" >&5
|
||||
echo "${ECHO_T}defining localapifcnfiledir to be $localapifcnfiledir" >&6
|
||||
|
||||
@@ -3327,7 +3327,7 @@
|
||||
echo "$as_me:$LINENO: result: defining localoctfiledir to be $localoctfiledir" >&5
|
||||
echo "${ECHO_T}defining localoctfiledir to be $localoctfiledir" >&6
|
||||
|
||||
-: ${localapioctfiledir='$(libexecdir)/octave/site/oct/$(apiversion)/$(canonical_host_type)'}
|
||||
+: ${localapioctfiledir='$(libexecdir)/octave/site/oct/$(api_version)/$(canonical_host_type)'}
|
||||
echo "$as_me:$LINENO: result: defining localapioctfiledir to be $localapioctfiledir" >&5
|
||||
echo "${ECHO_T}defining localapioctfiledir to be $localapioctfiledir" >&6
|
||||
|
@ -1,26 +0,0 @@
|
||||
src/ChangeLog:
|
||||
|
||||
2006-05-02 John W. Eaton <jwe@octave.org>
|
||||
|
||||
* lex.l ({CCHAR}): Exit rawcommand mode if returning '\n' token.
|
||||
|
||||
|
||||
Index: src/lex.l
|
||||
===================================================================
|
||||
RCS file: /cvs/octave/src/lex.l,v
|
||||
retrieving revision 1.232
|
||||
diff -u -r1.232 lex.l
|
||||
--- src/lex.l 24 Apr 2006 19:13:08 -0000 1.232
|
||||
+++ src/lex.l 2 May 2006 23:31:14 -0000
|
||||
@@ -696,7 +696,10 @@
|
||||
BEGIN (INITIAL);
|
||||
|
||||
if (nesting_level.none ())
|
||||
- COUNT_TOK_AND_RETURN ('\n');
|
||||
+ {
|
||||
+ lexer_flags.doing_rawcommand = false;
|
||||
+ COUNT_TOK_AND_RETURN ('\n');
|
||||
+ }
|
||||
else if (nesting_level.is_bracket_or_brace ())
|
||||
COUNT_TOK_AND_RETURN (';');
|
||||
}
|
@ -1,402 +0,0 @@
|
||||
Index: liboctave/SparseCmplxQR.h
|
||||
===================================================================
|
||||
RCS file: /cvs/octave/liboctave/SparseCmplxQR.h,v
|
||||
retrieving revision 1.2
|
||||
retrieving revision 1.3
|
||||
diff -u -r1.2 -r1.3
|
||||
--- liboctave/SparseCmplxQR.h 8 Mar 2006 20:17:38 -0000 1.2
|
||||
+++ liboctave/SparseCmplxQR.h 23 Mar 2006 18:22:51 -0000 1.3
|
||||
@@ -137,6 +137,23 @@
|
||||
#endif
|
||||
};
|
||||
|
||||
+
|
||||
+// Publish externally used friend functions.
|
||||
+
|
||||
+extern ComplexMatrix qrsolve (const SparseComplexMatrix &a, const Matrix &b,
|
||||
+ octave_idx_type &info);
|
||||
+
|
||||
+extern SparseComplexMatrix qrsolve (const SparseComplexMatrix &a,
|
||||
+ const SparseMatrix &b,
|
||||
+ octave_idx_type &info);
|
||||
+
|
||||
+extern ComplexMatrix qrsolve (const SparseComplexMatrix &a,
|
||||
+ const ComplexMatrix &b,
|
||||
+ octave_idx_type &info);
|
||||
+
|
||||
+extern SparseComplexMatrix qrsolve (const SparseComplexMatrix &a,
|
||||
+ const SparseComplexMatrix &b,
|
||||
+ octave_idx_type &info);
|
||||
#endif
|
||||
|
||||
/*
|
||||
Index: liboctave/SparseQR.h
|
||||
===================================================================
|
||||
RCS file: /cvs/octave/liboctave/SparseQR.h,v
|
||||
retrieving revision 1.2
|
||||
retrieving revision 1.3
|
||||
diff -u -r1.2 -r1.3
|
||||
--- liboctave/SparseQR.h 8 Mar 2006 20:17:38 -0000 1.2
|
||||
+++ liboctave/SparseQR.h 23 Mar 2006 18:22:51 -0000 1.3
|
||||
@@ -133,6 +133,22 @@
|
||||
#endif
|
||||
};
|
||||
|
||||
+
|
||||
+// Publish externally used friend functions.
|
||||
+
|
||||
+extern Matrix qrsolve (const SparseMatrix &a, const Matrix &b,
|
||||
+ octave_idx_type &info);
|
||||
+
|
||||
+extern SparseMatrix qrsolve (const SparseMatrix &a, const SparseMatrix &b,
|
||||
+ octave_idx_type &info);
|
||||
+
|
||||
+extern ComplexMatrix qrsolve (const SparseMatrix &a, const ComplexMatrix &b,
|
||||
+ octave_idx_type &info);
|
||||
+
|
||||
+extern SparseComplexMatrix qrsolve (const SparseMatrix &a,
|
||||
+ const SparseComplexMatrix &b,
|
||||
+ octave_idx_type &info);
|
||||
+
|
||||
#endif
|
||||
|
||||
/*
|
||||
Index: liboctave/CMatrix.cc
|
||||
===================================================================
|
||||
RCS file: /cvs/octave/liboctave/CMatrix.cc,v
|
||||
retrieving revision 1.114
|
||||
diff -u -r1.114 CMatrix.cc
|
||||
--- liboctave/CMatrix.cc 2 Mar 2006 03:40:00 -0000 1.114
|
||||
+++ liboctave/CMatrix.cc 24 Mar 2006 18:53:58 -0000
|
||||
@@ -889,27 +889,6 @@
|
||||
return retval;
|
||||
}
|
||||
|
||||
-ComplexRowVector
|
||||
-ComplexMatrix::row (char *s) const
|
||||
-{
|
||||
- if (! s)
|
||||
- {
|
||||
- (*current_liboctave_error_handler) ("invalid row selection");
|
||||
- return ComplexRowVector ();
|
||||
- }
|
||||
-
|
||||
- char c = *s;
|
||||
- if (c == 'f' || c == 'F')
|
||||
- return row (static_cast<octave_idx_type>(0));
|
||||
- else if (c == 'l' || c == 'L')
|
||||
- return row (rows () - 1);
|
||||
- else
|
||||
- {
|
||||
- (*current_liboctave_error_handler) ("invalid row selection");
|
||||
- return ComplexRowVector ();
|
||||
- }
|
||||
-}
|
||||
-
|
||||
ComplexColumnVector
|
||||
ComplexMatrix::column (octave_idx_type i) const
|
||||
{
|
||||
@@ -927,27 +906,6 @@
|
||||
return retval;
|
||||
}
|
||||
|
||||
-ComplexColumnVector
|
||||
-ComplexMatrix::column (char *s) const
|
||||
-{
|
||||
- if (! s)
|
||||
- {
|
||||
- (*current_liboctave_error_handler) ("invalid column selection");
|
||||
- return ComplexColumnVector ();
|
||||
- }
|
||||
-
|
||||
- char c = *s;
|
||||
- if (c == 'f' || c == 'F')
|
||||
- return column (static_cast<octave_idx_type>(0));
|
||||
- else if (c == 'l' || c == 'L')
|
||||
- return column (cols () - 1);
|
||||
- else
|
||||
- {
|
||||
- (*current_liboctave_error_handler) ("invalid column selection");
|
||||
- return ComplexColumnVector ();
|
||||
- }
|
||||
-}
|
||||
-
|
||||
ComplexMatrix
|
||||
ComplexMatrix::inverse (void) const
|
||||
{
|
||||
Index: liboctave/CMatrix.h
|
||||
===================================================================
|
||||
RCS file: /cvs/octave/liboctave/CMatrix.h,v
|
||||
retrieving revision 1.55
|
||||
diff -u -r1.55 CMatrix.h
|
||||
--- liboctave/CMatrix.h 26 Oct 2005 15:24:08 -0000 1.55
|
||||
+++ liboctave/CMatrix.h 24 Mar 2006 18:53:58 -0000
|
||||
@@ -130,10 +130,8 @@
|
||||
// extract row or column i.
|
||||
|
||||
ComplexRowVector row (octave_idx_type i) const;
|
||||
- ComplexRowVector row (char *s) const;
|
||||
|
||||
ComplexColumnVector column (octave_idx_type i) const;
|
||||
- ComplexColumnVector column (char *s) const;
|
||||
|
||||
ComplexMatrix inverse (void) const;
|
||||
ComplexMatrix inverse (octave_idx_type& info) const;
|
||||
Index: liboctave/dMatrix.cc
|
||||
===================================================================
|
||||
RCS file: /cvs/octave/liboctave/dMatrix.cc,v
|
||||
retrieving revision 1.120
|
||||
diff -u -r1.120 dMatrix.cc
|
||||
--- liboctave/dMatrix.cc 2 Mar 2006 03:40:01 -0000 1.120
|
||||
+++ liboctave/dMatrix.cc 24 Mar 2006 18:53:59 -0000
|
||||
@@ -559,27 +559,6 @@
|
||||
return retval;
|
||||
}
|
||||
|
||||
-RowVector
|
||||
-Matrix::row (char *s) const
|
||||
-{
|
||||
- if (! s)
|
||||
- {
|
||||
- (*current_liboctave_error_handler) ("invalid row selection");
|
||||
- return RowVector ();
|
||||
- }
|
||||
-
|
||||
- char c = *s;
|
||||
- if (c == 'f' || c == 'F')
|
||||
- return row ( static_cast<octave_idx_type>(0) );
|
||||
- else if (c == 'l' || c == 'L')
|
||||
- return row (rows () - 1);
|
||||
- else
|
||||
- {
|
||||
- (*current_liboctave_error_handler) ("invalid row selection");
|
||||
- return RowVector ();
|
||||
- }
|
||||
-}
|
||||
-
|
||||
ColumnVector
|
||||
Matrix::column (octave_idx_type i) const
|
||||
{
|
||||
@@ -597,27 +576,6 @@
|
||||
return retval;
|
||||
}
|
||||
|
||||
-ColumnVector
|
||||
-Matrix::column (char *s) const
|
||||
-{
|
||||
- if (! s)
|
||||
- {
|
||||
- (*current_liboctave_error_handler) ("invalid column selection");
|
||||
- return ColumnVector ();
|
||||
- }
|
||||
-
|
||||
- char c = *s;
|
||||
- if (c == 'f' || c == 'F')
|
||||
- return column (static_cast<octave_idx_type> (0));
|
||||
- else if (c == 'l' || c == 'L')
|
||||
- return column (cols () - 1);
|
||||
- else
|
||||
- {
|
||||
- (*current_liboctave_error_handler) ("invalid column selection");
|
||||
- return ColumnVector ();
|
||||
- }
|
||||
-}
|
||||
-
|
||||
Matrix
|
||||
Matrix::inverse (void) const
|
||||
{
|
||||
Index: liboctave/dMatrix.h
|
||||
===================================================================
|
||||
RCS file: /cvs/octave/liboctave/dMatrix.h,v
|
||||
retrieving revision 1.61
|
||||
diff -u -r1.61 dMatrix.h
|
||||
--- liboctave/dMatrix.h 26 Oct 2005 15:24:08 -0000 1.61
|
||||
+++ liboctave/dMatrix.h 24 Mar 2006 18:53:59 -0000
|
||||
@@ -102,10 +102,8 @@
|
||||
// extract row or column i.
|
||||
|
||||
RowVector row (octave_idx_type i) const;
|
||||
- RowVector row (char *s) const;
|
||||
|
||||
ColumnVector column (octave_idx_type i) const;
|
||||
- ColumnVector column (char *s) const;
|
||||
|
||||
Matrix inverse (void) const;
|
||||
Matrix inverse (octave_idx_type& info) const;
|
||||
Index: liboctave/dSparse.cc
|
||||
===================================================================
|
||||
RCS file: /cvs/octave/liboctave/dSparse.cc,v
|
||||
retrieving revision 1.21
|
||||
diff -u -r1.21 dSparse.cc
|
||||
--- liboctave/dSparse.cc 22 Mar 2006 22:58:12 -0000 1.21
|
||||
+++ liboctave/dSparse.cc 24 Mar 2006 18:54:00 -0000
|
||||
@@ -4404,7 +4404,7 @@
|
||||
Array<double> z (3 * nr);
|
||||
double *pz = z.fortran_vec ();
|
||||
Array<octave_idx_type> iz (nr);
|
||||
- int *piz = iz.fortran_vec ();
|
||||
+ octave_idx_type *piz = iz.fortran_vec ();
|
||||
|
||||
F77_XFCN (dpbcon, DGBCON,
|
||||
(F77_CONST_CHAR_ARG2 (&job, 1),
|
||||
@@ -4540,7 +4540,7 @@
|
||||
Array<double> z (3 * nr);
|
||||
double *pz = z.fortran_vec ();
|
||||
Array<octave_idx_type> iz (nr);
|
||||
- int *piz = iz.fortran_vec ();
|
||||
+ octave_idx_type *piz = iz.fortran_vec ();
|
||||
|
||||
F77_XFCN (dgbcon, DGBCON,
|
||||
(F77_CONST_CHAR_ARG2 (&job, 1),
|
||||
@@ -4678,7 +4678,7 @@
|
||||
Array<double> z (3 * nr);
|
||||
double *pz = z.fortran_vec ();
|
||||
Array<octave_idx_type> iz (nr);
|
||||
- int *piz = iz.fortran_vec ();
|
||||
+ octave_idx_type *piz = iz.fortran_vec ();
|
||||
|
||||
F77_XFCN (dpbcon, DGBCON,
|
||||
(F77_CONST_CHAR_ARG2 (&job, 1),
|
||||
@@ -4851,7 +4851,7 @@
|
||||
Array<double> z (3 * nr);
|
||||
double *pz = z.fortran_vec ();
|
||||
Array<octave_idx_type> iz (nr);
|
||||
- int *piz = iz.fortran_vec ();
|
||||
+ octave_idx_type *piz = iz.fortran_vec ();
|
||||
|
||||
F77_XFCN (dgbcon, DGBCON,
|
||||
(F77_CONST_CHAR_ARG2 (&job, 1),
|
||||
@@ -5031,7 +5031,7 @@
|
||||
Array<double> z (3 * nr);
|
||||
double *pz = z.fortran_vec ();
|
||||
Array<octave_idx_type> iz (nr);
|
||||
- int *piz = iz.fortran_vec ();
|
||||
+ octave_idx_type *piz = iz.fortran_vec ();
|
||||
|
||||
F77_XFCN (dpbcon, DGBCON,
|
||||
(F77_CONST_CHAR_ARG2 (&job, 1),
|
||||
@@ -5208,7 +5208,7 @@
|
||||
Array<double> z (3 * nr);
|
||||
double *pz = z.fortran_vec ();
|
||||
Array<octave_idx_type> iz (nr);
|
||||
- int *piz = iz.fortran_vec ();
|
||||
+ octave_idx_type *piz = iz.fortran_vec ();
|
||||
|
||||
F77_XFCN (dpbcon, DGBCON,
|
||||
(F77_CONST_CHAR_ARG2 (&job, 1),
|
||||
@@ -5379,7 +5379,7 @@
|
||||
Array<double> z (3 * nr);
|
||||
double *pz = z.fortran_vec ();
|
||||
Array<octave_idx_type> iz (nr);
|
||||
- int *piz = iz.fortran_vec ();
|
||||
+ octave_idx_type *piz = iz.fortran_vec ();
|
||||
|
||||
F77_XFCN (dpbcon, DGBCON,
|
||||
(F77_CONST_CHAR_ARG2 (&job, 1),
|
||||
@@ -5586,7 +5586,7 @@
|
||||
Array<double> z (3 * nr);
|
||||
double *pz = z.fortran_vec ();
|
||||
Array<octave_idx_type> iz (nr);
|
||||
- int *piz = iz.fortran_vec ();
|
||||
+ octave_idx_type *piz = iz.fortran_vec ();
|
||||
|
||||
F77_XFCN (dgbcon, DGBCON,
|
||||
(F77_CONST_CHAR_ARG2 (&job, 1),
|
||||
Index: src/ov-cell.cc
|
||||
===================================================================
|
||||
RCS file: /cvs/octave/src/ov-cell.cc,v
|
||||
retrieving revision 1.58
|
||||
diff -u -r1.58 ov-cell.cc
|
||||
--- src/ov-cell.cc 24 Mar 2006 16:42:44 -0000 1.58
|
||||
+++ src/ov-cell.cc 24 Mar 2006 19:14:32 -0000
|
||||
@@ -783,10 +783,12 @@
|
||||
|
||||
for (octave_idx_type i = 0; i < dv.numel (); i++)
|
||||
{
|
||||
- char s[20];
|
||||
- sprintf (s, "_%d", i);
|
||||
+ OSSTREAM buf;
|
||||
+ buf << "_" << i << OSSTREAM_ENDS;
|
||||
+ std::string s = OSSTREAM_STR (buf);
|
||||
+ OSSTREAM_FREEZE (buf);
|
||||
|
||||
- if (! add_hdf5_data(data_hid, tmp.elem (i), s, "", false,
|
||||
+ if (! add_hdf5_data(data_hid, tmp.elem (i), s.c_str (), "", false,
|
||||
save_as_floats))
|
||||
{
|
||||
H5Gclose (data_hid);
|
||||
Index: src/ov-list.cc
|
||||
===================================================================
|
||||
RCS file: /cvs/octave/src/ov-list.cc,v
|
||||
retrieving revision 1.44
|
||||
diff -u -r1.44 ov-list.cc
|
||||
--- src/ov-list.cc 26 Apr 2005 19:24:33 -0000 1.44
|
||||
+++ src/ov-list.cc 24 Mar 2006 19:14:32 -0000
|
||||
@@ -536,9 +536,13 @@
|
||||
for (int i = 0; i < lst.length (); ++i)
|
||||
{
|
||||
// should we use lst.name_tags () to label the elements?
|
||||
- char s[20];
|
||||
- sprintf (s, "_%d", i);
|
||||
- bool b = save_ascii_data (os, lst (i), s, infnan_warned,
|
||||
+
|
||||
+ OSSTREAM buf;
|
||||
+ buf << "_" << i << OSSTREAM_ENDS;
|
||||
+ std::string s = OSSTREAM_STR (buf);
|
||||
+ OSSTREAM_FREEZE (buf);
|
||||
+
|
||||
+ bool b = save_ascii_data (os, lst (i), s.c_str (), infnan_warned,
|
||||
strip_nan_and_inf, 0, 0);
|
||||
|
||||
if (! b)
|
||||
@@ -607,11 +611,15 @@
|
||||
for (int i = 0; i < lst.length (); i++)
|
||||
{
|
||||
// should we use lst.name_tags () to label the elements?
|
||||
- char s[20];
|
||||
- sprintf (s, "_%d", i);
|
||||
+
|
||||
+ OSSTREAM buf;
|
||||
+ buf << "_" << i << OSSTREAM_ENDS;
|
||||
+ std::string s = OSSTREAM_STR (buf);
|
||||
+ OSSTREAM_FREEZE (buf);
|
||||
|
||||
// Recurse to print sub-value.
|
||||
- bool b = save_binary_data (os, lst(i), s, "", 0, save_as_floats);
|
||||
+ bool b = save_binary_data (os, lst(i), s.c_str (), "", 0,
|
||||
+ save_as_floats);
|
||||
|
||||
if (! b)
|
||||
return false;
|
||||
@@ -683,9 +691,13 @@
|
||||
for (octave_idx_type i = 0; i < lst.length (); ++i)
|
||||
{
|
||||
// should we use lst.name_tags () to label the elements?
|
||||
- char s[20];
|
||||
- sprintf (s, "_%d", i);
|
||||
- bool retval2 = add_hdf5_data (data_hid, lst (i), s, "",
|
||||
+
|
||||
+ OSSTREAM buf;
|
||||
+ buf << "_" << i << OSSTREAM_ENDS;
|
||||
+ std::string s = OSSTREAM_STR (buf);
|
||||
+ OSSTREAM_FREEZE (buf);
|
||||
+
|
||||
+ bool retval2 = add_hdf5_data (data_hid, lst (i), s.c_str (), "",
|
||||
false, save_as_floats);
|
||||
if (! retval2)
|
||||
break;
|
||||
Index: src/DLD-FUNCTIONS/spchol.cc
|
||||
===================================================================
|
||||
RCS file: /cvs/octave/src/DLD-FUNCTIONS/spchol.cc,v
|
||||
retrieving revision 1.7
|
||||
diff -u -r1.7 spchol.cc
|
||||
--- src/DLD-FUNCTIONS/spchol.cc 22 Mar 2006 22:58:12 -0000 1.7
|
||||
+++ src/DLD-FUNCTIONS/spchol.cc 24 Mar 2006 19:55:38 -0000
|
||||
@@ -607,7 +607,7 @@
|
||||
for (octave_idx_type k = 0 ; k < n ; k++)
|
||||
{
|
||||
// get the kth row of L and store in the columns of L
|
||||
- cholmod_row_subtree (A1, A2, k, Parent, R, cm) ;
|
||||
+ CHOLMOD_NAME (row_subtree) (A1, A2, k, Parent, R, cm) ;
|
||||
for (octave_idx_type p = 0 ; p < Rp [1] ; p++)
|
||||
L.xridx (W [Ri [p]]++) = k ;
|
38
octave.spec
38
octave.spec
@ -1,15 +1,12 @@
|
||||
Name: octave
|
||||
Version: 2.9.5
|
||||
Release: 6%{?dist}
|
||||
Version: 2.9.6
|
||||
Release: 1%{?dist}
|
||||
Summary: A high-level language for numerical computations
|
||||
Epoch: 6
|
||||
|
||||
Group: Applications/Engineering
|
||||
License: GPL
|
||||
Source: ftp://ftp.octave.org/pub/octave/bleeding-edge/octave-%{version}.tar.bz2
|
||||
Patch0: octave-2.9.5-sparse.patch
|
||||
Patch1: octave-2.9.5-config.patch
|
||||
Patch2: octave-2.9.5-lex.patch
|
||||
URL: http://www.octave.org
|
||||
Requires: gnuplot less info texinfo
|
||||
Requires(post): /sbin/install-info
|
||||
@ -18,7 +15,7 @@ Requires(post): /sbin/ldconfig
|
||||
Requires(preun): /sbin/install-info
|
||||
BuildRequires: bison flex less tetex gcc-gfortran lapack-devel blas-devel
|
||||
BuildRequires: ncurses-devel zlib-devel libtermcap-devel hdf5-devel
|
||||
BuildRequires: readline-devel glibc-devel fftw-devel autoconf gperf
|
||||
BuildRequires: readline-devel glibc-devel fftw-devel gperf
|
||||
BuildRequires: ufsparse-devel glpk-devel gnuplot desktop-file-utils
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -43,7 +40,7 @@ Summary: Development headers and files for Octave
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{epoch}:%{version}-%{release}
|
||||
Requires: readline-devel fftw-devel hdf5-devel zlib-devel
|
||||
Requires: lapack-devel blas-devel gcc-c++
|
||||
Requires: lapack-devel blas-devel gcc-c++ gcc-gfortran
|
||||
|
||||
%description devel
|
||||
The octave-devel package contains files needed for developing
|
||||
@ -52,17 +49,10 @@ applications which use GNU Octave.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p0
|
||||
%patch1 -p0
|
||||
%patch2 -p0
|
||||
|
||||
|
||||
%build
|
||||
%ifarch x86_64
|
||||
%define enable64 yes
|
||||
%else
|
||||
%define enable64 no
|
||||
%endif
|
||||
export CPPFLAGS=-I%{_includedir}/glpk
|
||||
%configure --enable-shared --disable-static --enable-64=%enable64
|
||||
make %{?_smp_mflags} OCTAVE_RELEASE="Fedora Extras %{version}-%{release}"
|
||||
@ -99,9 +89,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%post
|
||||
/sbin/ldconfig
|
||||
/sbin/install-info --info-dir=%{_infodir} --section="Programming:" \
|
||||
--entry="* Octave:(%{name}). %{summary}." %{_infodir}/octave.info.gz
|
||||
|
||||
/sbin/install-info --info-dir=%{_infodir} --section="Programming" \
|
||||
%{_infodir}/octave.info.gz
|
||||
|
||||
%preun
|
||||
if [ "$1" = "0" ]; then
|
||||
/sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/octave.info.gz
|
||||
@ -115,8 +105,7 @@ fi
|
||||
%doc COPYING NEWS* PROJECTS README README.Linux README.kpathsea ROADMAP
|
||||
%doc SENDING-PATCHES THANKS emacs examples doc/interpreter/octave.p*
|
||||
%doc doc/faq doc/interpreter/HTML doc/refcard
|
||||
%{_bindir}/octave
|
||||
%{_bindir}/octave-%{version}
|
||||
%{_bindir}/octave*
|
||||
%config(noreplace) /etc/ld.so.conf.d/*
|
||||
%{_libdir}/octave*
|
||||
%{_datadir}/octave
|
||||
@ -129,13 +118,18 @@ fi
|
||||
%defattr(-,root,root)
|
||||
%doc doc/liboctave
|
||||
%{_bindir}/mkoctfile*
|
||||
%{_bindir}/octave-bug*
|
||||
%{_bindir}/octave-config*
|
||||
%{_includedir}/octave*
|
||||
%{_includedir}/octave-%{version}
|
||||
%{_mandir}/man*/mkoctfile*
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jun 27 2006 Quentin Spencer <qspencer@users.sourceforge.net> 2.9.6-1
|
||||
- New release. Remove old patches.
|
||||
- Disable 64-bit extensions (some libraries don't support 64-bit indexing yet).
|
||||
- Add gcc-gfortran to -devel dependencies (mkoctfile fails without it).
|
||||
- Move octave-bug and octave-config from devel to main package.
|
||||
- Fix categorization of info files (bug 196760).
|
||||
|
||||
* Wed Apr 27 2006 Quentin Spencer <qspencer@users.sourceforge.net> 2.9.5-6
|
||||
- Add patch for bug #190481
|
||||
- Manual stripping of .oct files is no longer necessary.
|
||||
|
Loading…
Reference in New Issue
Block a user