Update to 3.4.3
Drop upstreamed patches
This commit is contained in:
parent
b108d3146b
commit
a4a8bae8e3
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@ octave-3.2.4.tar.bz2
|
|||||||
/octave-3.3.54.tar.bz2
|
/octave-3.3.54.tar.bz2
|
||||||
/octave-3.4.0.tar.bz2
|
/octave-3.4.0.tar.bz2
|
||||||
/octave-3.4.2.tar.bz2
|
/octave-3.4.2.tar.bz2
|
||||||
|
/octave-3.4.3.tar.bz2
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
diff -up octave-3.4.2/src/DLD-FUNCTIONS/urlwrite.cc.curl octave-3.4.2/src/DLD-FUNCTIONS/urlwrite.cc
|
|
||||||
--- octave-3.4.2/src/DLD-FUNCTIONS/urlwrite.cc.curl 2011-06-09 20:22:32.000000000 +0300
|
|
||||||
+++ octave-3.4.2/src/DLD-FUNCTIONS/urlwrite.cc 2011-08-06 11:54:58.331640323 +0300
|
|
||||||
@@ -52,7 +52,6 @@ along with Octave; see the file COPYING.
|
|
||||||
|
|
||||||
#include <curl/curl.h>
|
|
||||||
#include <curl/curlver.h>
|
|
||||||
-#include <curl/types.h>
|
|
||||||
#include <curl/easy.h>
|
|
||||||
|
|
||||||
static int
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -r d1db86336a49 scripts/miscellaneous/tar.m
|
|
||||||
--- a/scripts/miscellaneous/tar.m Thu Aug 11 02:41:36 2011 -0500
|
|
||||||
+++ b/scripts/miscellaneous/tar.m Thu Aug 11 10:56:18 2011 -0600
|
|
||||||
@@ -42,7 +42,7 @@
|
|
||||||
files = cellstr (files);
|
|
||||||
endif
|
|
||||||
|
|
||||||
- if (ischar (tarfile) && iscellstr (files) && ischar (root))
|
|
||||||
+ if !(ischar (tarfile) && iscellstr (files) && ischar (root))
|
|
||||||
error ("tar: all arguments must be character strings");
|
|
||||||
endif
|
|
||||||
|
|
@ -1,25 +0,0 @@
|
|||||||
diff -r d1db86336a49 scripts/miscellaneous/private/__xzip__.m
|
|
||||||
--- a/scripts/miscellaneous/private/__xzip__.m Thu Aug 11 02:41:36 2011 -0500
|
|
||||||
+++ b/scripts/miscellaneous/private/__xzip__.m Thu Aug 11 14:28:45 2011 -0600
|
|
||||||
@@ -80,14 +80,16 @@
|
|
||||||
commandname, status);
|
|
||||||
endif
|
|
||||||
|
|
||||||
- if (nargout > 0)
|
|
||||||
- if (nargin == 5)
|
|
||||||
+ if (nargin == 5)
|
|
||||||
+ if (nargout > 0)
|
|
||||||
entries = cellfun(
|
|
||||||
@(x) fullfile (outdir, sprintf ("%s.%s", x, extension)),
|
|
||||||
f, "uniformoutput", false);
|
|
||||||
- else
|
|
||||||
- movefile (cellfun(@(x) sprintf ("%s.%s", x, extension), f,
|
|
||||||
- "uniformoutput", false), cwd);
|
|
||||||
+ endif
|
|
||||||
+ else
|
|
||||||
+ movefile (cellfun(@(x) sprintf ("%s.%s", x, extension), f,
|
|
||||||
+ "uniformoutput", false), cwd);
|
|
||||||
+ if (nargout > 0)
|
|
||||||
## FIXME this does not work when you try to compress directories
|
|
||||||
entries = cellfun(@(x) sprintf ("%s.%s", x, extension),
|
|
||||||
files, "uniformoutput", false);
|
|
19
octave.spec
19
octave.spec
@ -2,25 +2,17 @@
|
|||||||
%global octave_api api-v45+
|
%global octave_api api-v45+
|
||||||
|
|
||||||
Name: octave
|
Name: octave
|
||||||
Version: 3.4.2
|
Version: 3.4.3
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A high-level language for numerical computations
|
Summary: A high-level language for numerical computations
|
||||||
Epoch: 6
|
Epoch: 6
|
||||||
Group: Applications/Engineering
|
Group: Applications/Engineering
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Source0: ftp://ftp.gnu.org/gnu/octave/octave-%{version}.tar.bz2
|
Source0: ftp://ftp.gnu.org/gnu/octave/octave-%{version}.tar.bz2
|
||||||
Source1: macros.octave
|
Source1: macros.octave
|
||||||
# Don't include <curl/types.h> which isn't used and is missing on newer versions of libcurl
|
|
||||||
Patch0: octave-3.4.2-curl.patch
|
|
||||||
# https://savannah.gnu.org/bugs/index.php?33988
|
|
||||||
# Fix tar argument handling
|
|
||||||
Patch1: octave-tar.patch
|
|
||||||
# https://savannah.gnu.org/bugs/index.php?32839
|
# https://savannah.gnu.org/bugs/index.php?32839
|
||||||
# Fix building packages from directories
|
# Fix building packages from directories
|
||||||
Patch2: octave-3.4.0-pkgbuilddir.patch
|
Patch2: octave-3.4.0-pkgbuilddir.patch
|
||||||
# https://savannah.gnu.org/bugs/index.php?33993
|
|
||||||
# Fix xzip
|
|
||||||
Patch3: octave-xzip.patch
|
|
||||||
URL: http://www.octave.org
|
URL: http://www.octave.org
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
@ -78,10 +70,7 @@ This package contains documentation for Octave.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .curl
|
|
||||||
%patch1 -p1 -b .tar
|
|
||||||
%patch2 -p1 -b .pkgbuilddir
|
%patch2 -p1 -b .pkgbuilddir
|
||||||
%patch3 -p1 -b .xzip
|
|
||||||
|
|
||||||
# Check permissions
|
# Check permissions
|
||||||
find -name *.cc -exec chmod 644 {} \;
|
find -name *.cc -exec chmod 644 {} \;
|
||||||
@ -253,6 +242,10 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 24 2011 Orion Poplawski <orion[AT]cora.nwra com> - 6:3.4.3-1
|
||||||
|
- Update to 3.4.3
|
||||||
|
- Drop upstreamed patches
|
||||||
|
|
||||||
* Wed Aug 24 2011 Jussi Lehtola <jussilehtola@fedoraproject.org> - 6:3.4.2-3
|
* Wed Aug 24 2011 Jussi Lehtola <jussilehtola@fedoraproject.org> - 6:3.4.2-3
|
||||||
- Place rpm macros in -devel.
|
- Place rpm macros in -devel.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user